金语言简介 - kingtrader帮助系统

金语言简介

简介

金语言KingLanguage是广州博庭计算机科技有限公司所研发的，服务于量化投资的程式化交易语言，并内建于博庭的金魔方KingTrader量化交易平台上。

金语言的设计目标是能完全的表达投资者的交易思想、实现投资者的各种策略意图。

金语言既简洁，又强大。入门简单、内涵博大。

金语言能够有效服务于传统技术分析需求。配合金魔方平台，金语言具有最强大的绘画金融图表、技术指标能力。

同时，在完美结合图表的基础上，用户能最直观、便利的研发、表达自己的量化投资思想并运行其策略交易逻辑。

金语言既兼容国内主流证券软件，如飞狐交易师、大智慧、通达信等的指标语言，又兼容技术分析和程式交易的工业标准语言Easy Language/Power Language。同时，国内其它股软，如TradeBlazer、文华、金字塔等的指标语言也能通过简单的工作转换为金语言。

金语言参考手册

一． 指标

用金语言所编写的程序称之为“指标”。

二． 金语言指标的类型

金语言能够生成五类指标。分别是：

1) 技术指标

2) 条件选股指标

3) 五彩K线指标

4) 自定义函数

5) 智能策略

技术指标：对证券数据进行计算、统计后得出的数据集合。通常需要显示在软件图表上。

条件选股：是一类特别的技术指标，其特征是只允许输出一个变量，而且这个变量必须是布尔值。

五彩K线指标：是一类特别的技术指标，它的用途很简单，就是用于控制K线的颜色。所以这类指标也只输出一个变量。这个变量存放的是K线的颜色。

自定义函数：用户把一些常用的计算提炼出来，以方便以后反复使用。

智能策略：能够直接作出交易动作的指标。

三． 金语言基础元素

3.1 数据是怎样计算的

序列

序列是很特别的一类数据。它跟数组很相像：可以通过下标访问。

序列跟数组的区别：

数组在声明时已经定义好元素数量，之后不会改变，而序列在声明时并不指明元素数量。它的数量由K线数量决定，随着行情进行，K线不断增加，序列也相应的自动增加，并且是一一对应。

序列的下标：金语言中，序列下标0代表最近的一根K线所对应的序列数据；下标1代表前一根K线所对应的数据。

单值

单值是除序列之外的所有数据类型。单值可以是数字，也可以是字符串，甚至可以是定长数组。

内置序列

金语言内置了常用的行情序列数据。包括：开、高、低、收、量、额、日期、时间、持仓等。

计算模式

金语言有两种计算模式。逐行计算和逐根计算。

逐行计算模式下，每次计算都对整个序列从头到尾重新计算其值。

逐根计算模式下，每次计算时只计算序列最新一根的值----第一次载入图表时除外，此时会从头到尾对每一根K线进行逐根计算。

其中，智能策略和用户自定义函数只能运行在逐根模式下。

3.2 变量的声明

变量通过input（输入参数）、variable进行声明。

3.3 表达式

变量通过运算组成表达式。

3.4 输出

所谓输出，是指标运行时显示数据，输出数据。

金语言有多种输出方式。

1、通过“：”操作符或Plot函数输出。

2、通过画线函数输出。

3、通过Explain、Print、Comment、声音函数、Email等函数输出。

3.5 控制语句

控制语句控制程序的执行。包括分支、循环等。

金语言有以下控制语言：

if、switch(case)、for、while、repeat

3.6 指标引用

技术指标能够通过refindi函数引用另一个指标的输出。

refindi只工作在逐行模式下。

3.7 数据引用

默认提供的高低收量额等数据对应于当前图表上的品种和周期。如果要使用非当前图表上的品种、周期的数据，可以通过refData函数取得。

3.8 自定义函数

自定义函数能够很方便的扩展金语言，既比使用DLL这样的手段简单，运行效率又比引用指标的方式高。

自定义函数只能工作在逐根模式下。

自定义函数通常这样使用：

1、计算后返回一个值

2、计算并填充引用参数。引用参数是自定义函数特殊的输入参数，能够在函数中计算，并把值带出函数。

自定义函数所声明的variable变量的值会保留，并能够在下一次计算时使用。

四． 金语言与金魔方

金语言在金魔方中编写、编译；

指标能显示在金魔方图表上或用于选股、预警。

智能策略指标编写之后，可以在金魔方中测评；

最后，智能策略可以通过金魔方实盘运行，并做出交易动作。

五． 金语言的扩展（用户DLL的接入）

金语言允许用户通过DLL增强金语言的能力。

金语言的DLL接口非常强大，相比之下，一般股软都预先限定DLL的输入参数，金语言则同时支持限定输入参数的方式，也支持用户描述的方式。

也就是说，用户只需在金语言中撰写函数描述，就能自由使用任意DLL函数包括，例如Windows Api中的函数。前提是这些函数用到的数据类型在金语言的支持之列------毕竟，金语言并未支持结构、指针等数据类型。

来自“http://www.hs633.com/kthelp/index.php?title=%E6%98%9F%E8%AF%AD%E8%A8%80%E7%AE%80%E4%BB%8B&oldid=2241”


公式系统入门

公式简述

公式系统的作用是什么呢？公式系统其实就是对一系列随时间变化的原始数据序列进行代数和逻辑计算。

为什么是数据序列呢？因为每一个时间周期都包含了一个或一组原始数据，如开高低收量额，

公式系统能对其中的任何原始数据进行操作。使用者定义出如何对原始数据进行处理得到一个新的数据，

公式系统读出原始数据并按要求计算出使用者定制的数据，并以曲线、图形、指示等形式显示出来。

例如下面的例子：

指标1:(High+Low)/2;

上面的例子，逻辑是把每个周期的最高值和最低值的平均值输出成指标1：

Fml basic helloworld.png

添加公式

要添加用户公式，一般在公式树上相关类型的目录上点击右键，选择“新建公式”。

主程序和公式编辑器都有公式树，都可以创建公式。

要打开主程序的公式树，可以通过菜单：“查看”=>“公式管理”

要打开公式编辑器上的公式树，可以通过菜单：“视图”=> “公式面板”

Fml basic new fml.png

公式分为以下几种类型：A技术指标，B条件选股，C交易系统，D五彩K线，E智能交易，F公共函数，G优化评价，

要创建相应类型的公式，直接在相关节点下创建公式即可。要详细了解公式类型，可以参考公式类型。

用户还可以创建或删除文件夹来归类和管理公式，公式和目录跟文件系统是一一对应的，位置在

安装目录的 \FML\ 文件夹下面。

运行公式

公式系统处理的原始数据的分析周期（即相邻两组数据间的时间间隔）可以从多秒线到多年线之间的任意值，

或者分笔成交数据，我们用鼠标把一个公式拖到某只证券的某个周期的图形分析窗口，

则该公式处理这个周期的原始数据,如开高低收量额，改变分析窗口显示的分析周期，则公式处理新的分析周期的数据。

要运行公式，可以通过下面三个方法：

  1. 用鼠标从公式树上拖动相应公式到主图上或副图上
  2. 在主图或副图上右键“选择公式”，然后选择相应的公式
  3. 直接用键盘敲公式的名字，从键盘精灵处选择公式

要移除公式，也是上面的三种方法，拖放相同的公式到图上时，等于是移除公式。

您也可以在公式名称的地方右键，选择“删除指标线”|“移除策略”

Fml basic remove fml.png

修改公式

公式系统的保存分为源代码的保存和编译两种

  • 源代码保存：可以保存公式的编辑内容和设置等等，并不需要编译通过也可以保存
  • 编译：编译前源代码将会自动保存，只有编译通过后公式才可以运行

主程序运行时，若编辑正在运行的公式，编译通过后程序将自动重新加载新版本运行。

若编辑正在运行的自动交易脚本，该公式的交易将会自动停止，编译后需要点击“哭脸”图标才能再次开启

若编辑公共函数，编辑器将搜索所有引用该函数的公式，并让用户挑选是否需要重新编译

来自“http://www.hs633.com/kthelp/index.php?title=%E5%85%AC%E5%BC%8F%E7%B3%BB%E7%BB%9F%E5%85%A5%E9%97%A8&oldid=752”


公式类型

公式系统可以编辑七种类型的公式，分别是技术指标，交易系统，条件选股，五彩K线，智能交易，公共函数，优化评价公式。

其中技术指标，交易系统，条件选股和五彩K线可以运行在主图或副图。技术指标可以有逐行和逐根两种运行模式，详见执行模式。

各种类型的公式可以自由叠加在同一个图形上。

智能交易公式，公共函数和优化评价是特殊的公式，只能在逐根模式下运行。智能交易公式在一个图上只能运行一个，而且只能运行在主图。

技术指标

技术指标公式是最基本的公式，它用于指标图形的绘制。

技术指标可以通过指标输出来绘制图形, 指标输出可以使用下面的形式

// 经典格式，语法：指标名 冒号 表达式 [逗号 线形描述]
指标名:close;
// Plot 函数, 语法：Plot<[Offset]>(X, Name=, Color=DEFAULT, CellBGColor=Default, LineWidth=1, LineType=LINESOLIDT)
Plot(close, '指标名');

要叠加指标公式，可以按着Ctrl键拖放公式到图上，下面是运行了抛物转向和之字转向指标公式的例子

Fml basic jszb.png

技术指标详细请参考指标输出和线形描述

条件选股

技术指标公式结合选股条件逻辑判断表达式，即得到条件选股公式，用于条件选股。

条件选股的公式只需要输出一条0和1的指标线，例如下面的公式：

open > close

你也可以给这条指标线命名

k1:open>close

指标线也不只限于0和1的序列，大于0的都视为真。条件选股公式成立时，将在K线下方标注箭头

Fml basic tjxg.png

交易系统

技术指标公式结合买卖逻辑判断表达式，得到交易系统公式，用于交易系统指示。

交易系统是条件选股的升级，条件选股只有1个信号输出，而交易系统可以有4种信号：

  • ENTERLONG 多头开仓
  • EXITLONG 多头平仓
  • ENTERSHORT 空头开仓
  • EXITSHORT 空头平仓

这4种指标必须带有上述的指标名，可以使用 tFilter 线形描述来过滤重复的信号， 例如下面布林线的例子：

MID :=  MA(CLOSE,m);
UPPER:= MID + k*STD(CLOSE,m);
LOWER:= MID - k*STD(CLOSE,m);
ENTERSHORT:CROSS(CLOSE,LOWER),TFilter;
EXITSHORT:CROSS(CLOSE,UPPER),TFilter;

运行时，满足条件时，在K线的上下方标注信号，在K线中间标注信号价位， 价位计算方式目前是 (High+Low+Close)/3;

Fml basic jyxt.png

五彩K线

技术指标公式结合色彩逻辑判断表达式，即得到K线模式公式，用于描述特定的K线模式。

五彩K线与条件选股公式的输出是一样的，都是0和1的一条指标，不同之处是绘制时，

选中的K线变成红色，非选中的变成蓝色，例如下面十字星的例子：

// 收盘价等于开盘价，最高价不等于最低价
p1:CLOSE=OPEN AND HIGH<>LOW

运行结果

Fml basic wckx.png

智能交易

智能交易公式是交易系统公式的扩展，可以直接操控买卖行为：开平仓的时机和价格，设置止盈止损，

查询账户信息，查询交易绩效等，还可以直接操作真实交易帐号，可以进行交易测评和参数优化。

智能交易公式只能运行在主图上，只能以逐根的模式运行，分为每个Bar执行一遍和每个Tick执行一遍两种类型， 详见执行模式

智能交易公式可以像一般技术指标公式那样输出技术指标，以便核对信号。

以下是一个简单的智能交易公式：

Input://公式参数
    A(5,1,30,1),
    B(15,5,100,4);
ma1:MA(CLOSE,A);
ma2:MA(CLOSE,B);
bEnterLong :=CROSS(MA(CLOSE,A),MA(CLOSE,B));
bExitLong :=CROSS(MA(CLOSE,B),MA(CLOSE,A));
If bEnterLong Then Buy;
If bExitLong Then Sell;

公式输出了两条均线，在金叉和死叉信号发出后进出场：

Fml basic znjygs.png

进出场已虚心三角型表示，并用虚线连接，鼠标移动到连线处可以查看开平仓的详细信息。

要了解更多，请查看智能交易公式。

公共函数

公共函数是公式的一种扩展，把常用的逻辑封装成公共函数后，

编写公式时就可以直接引用，这可以加速开发的效率，实现公式的模块化，方便了公式的管理和共享。

以下是对序列求和的一个公共函数：

 ////////////////////////////////
 // 公共函数 Cum
 ////////////////////////////////
 // 函数参数，序列类型
 input: numericseries PriceValue;
 // 函数返回值，上一个Bar的和加上当前的PriceValue
 Cum := Cum[1] + PriceValue ;

公共函数名为 Cum, 对Cum赋值:=表示函数返回，Cum[1]表示引用函数上一个Bar的返回值。

详细请查阅公共函数。

优化评价

在测评智能交易公式时，可以自行定义评价的目标，使用内置的评价函数来计算出用户关心的公式绩效。

评价公式需要在公式头部标明#OPT, 编译指令开关都是以#号开头的。

 #OPT

评价公式只能用于智能交易测评，只能使用专门的评价函数，数学函数和四则运算。

评价公式使用第一个指标（表达式）作为公式的输出

例如下面的评价公式使用净利润与总盈利的比率作为衡量交易脚本的指标：

#OPT
OPT_NetProfit/OPT_GrossProfit
来自“http://www.hs633.com/kthelp/index.php?title=%E5%85%AC%E5%BC%8F%E7%B1%BB%E5%9E%8B&oldid=607”


数据类型

从数据性质上看，公式只使用两种类型，一种是数值型，另一种是字符串类型。

数值类型包括整数，浮点数（小数），逻辑真和假；字符串类型使用单引号表示。

从数据组织上看，上述两种类型分别可以是单值，序列，数组或引用。

  • 单值

单值是相对序列而言的，如果变量var1是单值，在本K线对var1修改，则前一根K线运算所赋给var1的值将会被覆盖，

若var1是序列，那么，前一根K线运算所赋给var1的值可以通过var1[1]来获得，也可以修改。

  • 序列

序列是对应K线图上的K线根数而言的，100根K线时，序列变量var1就有100个值，每个值对应1根K线，

分别是 var1[0], var1[1] ... var1[99]。序列会随着K线的增加而自动增长，开销要比单值大，

所以如果不需要引用非当前根K线的值时，使用单值变量就足够了。

  • 数组

数组可以看作是固定长度的序列，有固定的大小，由用户在声明时设定。

数组不会随着K线增长而增长，跟K线没有一一对应的关系。下面的例子定义了两个数组

 variable:
   NumericArray aa[100](0),
   NumericArray bb[20, 20](0);

aa大小为100， bb大小为400。数组的读写使用下标来进行：

一维数组aa的有效下标：aa[1], aa[2], aa[3] .... aa[100]

二维数组bb的有效下标：bb[x,y]; x=1,2...20; y=1,2....20;

  • 引用

引用类型使用于函数的参数传递，一般参数传递是数据拷贝的传递。

例如把变量cc传给当函数时，只是传递cc的值，函数内部对它的修改并不会影响cc；

但当函数参数类型是引用时，是把变量cc的地址传递给函数，函数内部对它修改就是对cc的修改

要了解更多参数调用，请查看参数和变量，公共函数。

综上所述，数据类型主要有以下8种：

void

 | 单值 | 序列 | 数组 | 引用
数值 | NumericSimple | NumericSeries | NumericArray | NumericRef
字符串 | StringSimple | StringSeries | StringArray | StringRef

下面是一些特殊的常量值：

  • Invalid

数值无效值，所有于它的比较都返回假 Invalid != Invalid 返回真。 指标输出左右两端的Invalid数值都不会输出到图上，直到遇上第一个有效值为止。

  • Null

字符串空串

  • True

真，值为1

  • False

假，值为0

  • Default

用于函数调用，若函数的参数设定了默认值，函数调用时填default表示使用函数设定的默认值

公式的数据类型属于弱类型。

字符串转义字符 \, @

来自“http://www.hs633.com/kthelp/index.php?title=%E6%95%B0%E6%8D%AE%E7%B1%BB%E5%9E%8B&oldid=605”


参数和变量

什么是变量

变量的组成

变量是一个标识符，代表一个或一组数据，公式可以通过该标识符对变量进行读取或赋值。 变量的类型可以是数值类型或字符串类型；变量可以是数组，序列或单值，详细参考数据类型。

可以作为变量名的字符是 数字 0-9，字母 A-Z 特殊符号 _ % $ 和汉字，

  • 变量不能以数字开头
  • 变量的长度没有限制
  • 变量的字母不区分大小写（DLL调用的函数声明除外，此时是区分大小写的）
  • 已经作为内部函数，公共函数和关键字的标识符不能作为变量。参考保留字。

变量声明

语法：

('VARIABLE'|'VARIABLES'|'变量') ':' GLOBAL_VAR (',' GLOBAL_VAR)* ';'
GLOBAL_VAR: [TYPE] Name [ARRAY_SUBSCRIPT] [('(' 初始值 ')'| '=' 初始值)]
ARRAY_SUBSCRIPT: '['[Number] (',' Number)* ']'
TYPE: ['IntrabarPersist'] ('Numeric'|'NumericArray'|'NumericSeries'|'String'|'StringArray')

说明：

例子：

Variable: a1=1,a2=2;
Variable: IntrabarPersist NumericSimple myVar(0);

什么是参数

公式的参数是一种特殊类型的变量，用户可以外部通过界面设定该变量的值。

  • 参数个数并没有限制
  • 参数的类型只能是NumericSimple和String

语法:

说明：

  • 默认值
  • 最小值
  • 最大值
  • 步长

例子：

参数的保存和加载

函数参数

函数变量

来自“http://www.hs633.com/kthelp/index.php?title=%E5%8F%82%E6%95%B0%E5%92%8C%E5%8F%98%E9%87%8F&oldid=857”


执行模式

逐根和逐行

星语言中，公式有两种执行模式，一种叫逐行模式，一种叫逐根模式。

逐行运行 就是说根据代码，从上到下，第一行运行到最后一行：

逐根运行 就是说根据K线，从左边第一根K线，运行到右面最后一根K线：

逐根运行在运行每一根K线时，也是把代码从第一行运行到最后一行的。逐根运行与逐行运行的区别是：

每行代码只运行当前的一个值，而逐行模式是整条序列。

例如如果代码是 Close+1，那么在逐行模式下，Close 代表图上所有的收盘价，加一后，得到所有收盘价+1的一条序列；

而在逐根运行时，Close 只代表当前一根k线的收盘价，加一后，得到当前收盘价+1的一个单值，从第一根运行到最后一根，

每一根都得到1个单值，等所有K线运行完毕后，才得到完整的序列。

由此可见，逐根模式比逐行模式多运行了许多遍：如果图上有1000根K线，公式代码将会被执行1000遍，

只不过每次运算只算1个值，而不像逐行模式那样每次运算一整条序列。总的来说逐根运行要比逐行耗时，

但是逐根运算能表达逐行运算所不能完成的条件分支逻辑，这是交易脚本所必须的逻辑。

另外，逐根模式在第一次运行完毕后，后续行情到来时，只需要运算最后一根的变化，这要比逐行的开销少多了。

关于这两种模式的运行机制更多讨论：逐行和逐根。

公式是怎样选择运行模式的呢？通过编译开关来控制：

#Run_By_Bar
#Run_By_Series

其中，#Run_By_Bar表示使用逐根模式，#Run_By_Series表示使用逐行模式。

这两个开关也可以不写，在不同的指标类型中，分别有不同的默认值。

在“技术指标”、“条件选股”、“交易系统”、“五彩K线”这四种指标中，默认是逐行模式。

在“智能策略”、“公共函数”、“优化评价”这三种指标中，默认是逐根模式（而且只能是逐根，指定逐行开关无效）。

计算频率开关

对于逐根模式，我们知道，每次都是只计算一根。

现在问题来了，K线的最后一根，并非是一次成型的，是在一段时间内不断变化的。

那么，是在每次变化时，都计算，还是最后成型时才计算呢？为此，准备了开关来控制这个行为。

#Run_Every_Tick
#Run_Every_Bar
  • Run_Every_Tick 表示，最后一根K线每次变化的时候，都重新计算。
  • Run_Every_Bar，则在下一根K线产生的一瞬间，才计算当前的K线。

在 Buy Next Bar Open 这种类型的公式里，为了避免信号抖动，需要在K线完全走完时才发出信号，在下根K线中成交。

对于这种类型的公式，可以使用#Run_Every_Bar模式，减少不必要的运算。

在 Buy This Bar Market 这种类型的公式里，需要根据最新行情来计算是否交易。此时公式运行需要 #Run_Every_Tick模式

对于SetStopLoss（止损）、SetProfitTarget（止盈）、SetDollarTrailing/SetPercentTrailing(跟踪止损）、SetBreakeven(保本平仓）等等Set给后台去做的工作，不受run_every_bar指令的影响，是永远每tick计算的。

事件触发

在公式中，可以编写一小段代码，这段代码是在某些事件发生的时候才执行。

这类事件包括初始化和执行完毕

初始化

只要编写一个内置函数，并且命名为OnInit，那么它就会在初始化时执行。

fucntion OnInit
Begin
  //做一些只需要做一次，没有必要每次行情来时都做的工作。例如，设置画线的颜色，设置账号。等等。
End

那么，OnInit究竟具体在什么时候会发生呢。 包括并且不限于以下情况，例如：

1.切换成其他品种；

2.切换成其他周期；

3.服务器推送来一些旧的历史数据（某种情况下，可能客户端会先请求最新一段数据，再请求旧的数据）

初始化事件会让公式清除所有状态重新运行计算1次，后续行情到来不再计算。

执行完毕

只要编写一个内置函数，并且命名为OnExit,那么它就会在公式执行到末尾时执行。

 function OnExit
 Begin
   //做一些收尾工作
 End

为什么需要OnExit呢，是因为目前公式引擎支持“中断”。所谓中断，就是如果某些公式计算一次时间特别长，有时公式运行到一半，还没计算完，用户切换到其他品种了，那之前的计算就没有必要继续下去，这时候，系统就会强行中断计算。

但是，用户可能希望某些计算是必须要执行的，例如，这个公式可能是调用DLL的，DLL可能在开始分配了一些资源，而且必须在运算完毕后释放，这部分计算就可以写在OnExit中，正常情况下它们会在公式主体运行结束之后被执行。如果公式主体被中断，它们会在中断后执行。

公式主体

公式的主体是名为OnStart的函数，象这样：

 Function OnStart
 Begin
   mm:ma(c, close );
 End

但是，为了方便编写，上述的“Function OnStart”可以省略。 也就是可以只写

 mm: ma( c, Close );

凡是没有包在其它函数体里面的代码都被认为是 OnStart 函数的内容。除非显式声明了 OnStart 函数。如果既声明了OnStart函数，又写了一段没有被任何函数包裹的代码，那么没有被包裹的代码被直接忽略，认为是空白。

来自“http://www.hs633.com/kthelp/index.php?title=%E6%89%A7%E8%A1%8C%E6%A8%A1%E5%BC%8F&oldid=2231”


保留字

Header text | Header text | Header text
Example | Example | Example
Example | Example | Example
Example | Example | Example

USES USE DEFINE

INPUT INPUTS 输入

VARIABLE VARIABLES 变量

FUNCTION 函数

PARAM 参数

BEGIN 开始

END 结束

IF 如果

THEN 那么

ELSE 否则

WHILE 当

DO 执行

FOR 从

TO 上升到

DOWNTO 下降到

STEP 步长

REPEAT 重复

UNTIL 直到

CASE 分支

OF

RETURN 返回

BREAK 跳出循环

CONTINUE 继续循环

REFLINE

EXIT 退出

TRUE 真

FALSE 假

DEFAULT 默认值

INVALID 无效值

NULL 空串

DIV 除以

MOD 取模

AND 而且

OR 或者

NOT 非

DATA2 DATA3 DATA4 DATA5 DATA6 DATA7 DATA8 DATA9

ENTERLONG ENTERSHORT EXITLONG EXITSHORT EXTERN SWITCH FROM CONST ARRAY ARRAYS INTRABARPERSIST

BUY SELL SELLSHORT BUYTOCOVER 买入 卖出 卖开 买平

SHORT COVER THIS NEXT BAR

THISBAR NEXTBAR

本周期 次周期

FROMENTRY 从标记

LABEL 标记为

TOTAL LIMIT STOP MARKET

限价 追价 市价

AN IS THAN WAS ON DOES AT THE BASED BY PLACE SHARE SHARES 在 的 股 口

STRINGSERIES NUMERICSIMPLE NUMERICSERIES NUMERIC NUMERICREF NUMERICARRAY NUMERICARRAYREF STRING STRINGARRAY STRINGREF VOID CHAR INT WORD LONG DWORD FLOAT DOUBLE BOOL ULONG LPBYTE LPINT LPWORD LPLONG LPDWORD LPFLOAT LPDOUBLE LPCWSTR FILE

来自“http://www.hs633.com/kthelp/index.php?title=%E4%BF%9D%E7%95%99%E5%AD%97&oldid=588”


操作符

四则运算操作符

操作符 | 含义
+ | 算术相加，也可用于字符串想加，字符串+字符串=字符串，字符串+数值=字符串，数值+字符串=出错
- | 算术相减
* | 算术相乘
/ | 算术相除
** | 算术乘方
++ | 算术加1
-- | 算术减1

比较运算操作符

操作符 | 含义
> | 大于
>= | 大于等于
< | 小于
<= | 小于等于
== | 相等，也可写作 =
!= | 不相等，也可写作 <>

逻辑运算操作符

操作符 | 含义
And | 逻辑与，也可写作 &&
Or | |
Not | 逻辑非，也可写作 !

位运算操作符

操作符 | 含义
<< | 向左位移
>> | 向右位移
& | 位与
｜ | 位或
~ | 位非
^ | 位异或

赋值操作符

操作符 | 含义
= | 赋值
+= | a += b 含义是 a = a + b
-= | a -= b 含义是 a = a - b
*= | a *= b 含义是 a = a * b
/= | a /= b 含义是 a = a / b
&= | a &= b 含义是 a = a & b
｜= | a ｜= b 含义是 a = a ｜ b
^= | a ^= b 含义是 a = a ^ b
<<= | a <<= b 含义是 a = a << b
>>= | a >>= b 含义是 a = a >> b
来自“http://www.hs633.com/kthelp/index.php?title=%E6%93%8D%E4%BD%9C%E7%AC%A6&oldid=415”


表达式

表达式是变量和常量之间的某种运算或函数调用

返回值有数值和字符串两种类型

孤立表达式将作为指标输出

来自“http://www.hs633.com/kthelp/index.php?title=%E8%A1%A8%E8%BE%BE%E5%BC%8F&oldid=587”


控制语句

赋值语句

Assignment Increment

复合语句

BEGIN END 空语句

分支语句

IF

SWITCH CASE

CASE OF

循环语句

FOR

REPEAT

WHILE

BREAK CONTINUE

坐标定义语句

REFLINE

交易语句

BUY SELL SELLSHORT BUYTOCOVER

指标输出语句

指标名:表达式(,线形描述)* plot语句 print comment

来自“http://www.hs633.com/kthelp/index.php?title=%E6%8E%A7%E5%88%B6%E8%AF%AD%E5%8F%A5&oldid=582”


指标输出和线形描述

指标输出是指在画面做图形输出，指标输出主要有下面的几种类型: 经典的表达式指标输出, PLOT输出, Comment输出,

Tl_趋势线输出, Text_文字输出, 五彩K线，条件选股和交易系统等的输出，文件输出。

经典的表达式指标输出

语法：

[指标名 ':'] 表达式 (','表达式)*  ';'

例子：

我的指标: (High+Low)/2, ColorRed ;

说明：

  • [指标名 ':']

指标名可选，没有指标名时系统会默认生成'指标1'，图形台头不显示默认生成的指标名。

  • 表达式

表达式作为数值输出，也可以是Draw系列的函数。这个数值可以通过指标名来使用，例如上面的例子

‘我的指标’可以直接当作序列变量来使用，参与到别的运算。

  • ',' 表达式

表达式后面的逗号加表达式是线形描述，可以0个或1个或多个，用逗号分隔，为了兼容飞狐的语法，

逗号不写也是可以的，但是最后的分号必须写，除非是公式结束（最后一行）。

默认指标颜色： 标记

线形描述参照下一小节

线形描述

线形描述 | 数值 | 说明
ColorXXXX | RGB值 | 指定指标输出的颜色，本段下面有内置带名字的颜色列表和RGB颜色参考
Line/LineSolid | -7000 | 默认的指标类型，实线
VolStick | -6999 | 宽柱状线，区分颜色
Stick | -6998 | 窄柱状线，不区分颜色
ColorStick | -6997 | 窄柱状线，区分分颜色
CircleDot | -6996 | 小圆圈
CrossDot | -6995 | 小十字
LineDash | -6994 | 虚线 ------
LineDashDot | -6993 | 虚线 -.-.-.-.-.-
LineDot | -6992 | 虚线 .............
LineStick | -6991 | 柱状线，末端以线段相连
PointDot | -6990 | 小圆点
BARSTACK | -6989 | 柱状叠加
BARPERCENT | -6988 | 柱状叠加，标出百分号
AREACOLOR | -6987 |
AREAHATCHDOWN | -6986 |
AREAHATCHUP | -6985 |
AREAHATCHCROSS | -6984 |
AREAHATCHDIAG | -6983 |
AREAHATCHHOR | -6982 |
AREAHATCHVER | -6981 |
AREASTACK | -6981 |
PxUp | -10200 | 向上移动多少像素，最多127，例如PxUp9
PxDn | -10000 | 向下移动多少像素，最多127, 例如PxDn9
Precision | -5000 | 浮点数显示精度，取值范围是 Precision0-Precision7
LineThick | -8000 | 线形宽度，LineThick0 只显示台头，不画线，最大宽度是 LineThick200
Shift | -9000 | 指标线向后（向右）偏移x个周期，最多偏移999个周期，例如 Shift1
Align | -5200 | 画图标、文字的对齐方式 对于DRAWICON,0图标中对齐;1图标上缘;2图标中缘;3图中;4图上;5图下, 对于DRAWTEXT,DRAWNUMBER,0中对齐;1左对齐;2右对齐;3图中;4图上;5图下。对于DRAWYITEXT，3为竖排, 例如: drawicon(cross(ma(c,5),ma(c,20)),H,3),align3;
NoDrawInvalid | -6002 | 无效值时不绘制
NoAxis | -6001 | 不影响坐标最高最低值
SeparateAxis/ OwnerScale | -6000 | 独立坐标，不影响坐标最高最低值
Nothing | -10400 | 保留值
NoTitle | -10401 | 不显示指标台头（标题）
AutoTitle | -10402 | 自动隐藏指标台头（标题），当整条指标无效时隐藏
tFilter | -10403 | 过滤交易信号, 用于交易系统公式ENTERLONG, EXITLONG, ENTERSHORT, EXITSHORT后,以ENTER和EXIT为间隔，过滤连续的同种信号
tFilterX | -10404 | 保留值

内置颜色列表

内建颜色
ColorRed 红色 | ColorGreen 绿色 | ColorBlue 蓝色 | ColorBlack 黑色
ColorWhite 白色 | ColorGray 灰色 | ColorYellow 黄色 | ColorCyan 青色
ColorMagenta 晶红色 | ColorBrown 棕色 | ColorLightBlue 淡蓝色 | ColorLightGreen 淡绿色
ColorLightCyan 淡青色 | ColorLightRed 淡红色 | ColorLightMagenta 淡洋红色

[RGB颜色速查]

来自“http://www.hs633.com/kthelp/index.php?title=%E6%8C%87%E6%A0%87%E8%BE%93%E5%87%BA%E5%92%8C%E7%BA%BF%E5%BD%A2%E6%8F%8F%E8%BF%B0&oldid=748”


注释，公式描述，参数精灵

公式注释

公式编写中，往往需要插入描述性文字，这些文字在编译时是忽略的。

注释分为单行注释和整个段落注释，使用 // 注释单行，直至行末；使用{}注释整个段落

例如下面的例子：

在公式编辑器里，注释呈现绿色

公式描述

为了方便用户理解，公式可以附带一些说明性的文字。在编辑器的参数面板里面可以

点击 用法注释 按钮来添加公式描述：

编译后，当用户运行公式时，只要鼠标移动到指标名称上，软件就会浮现用户添加的用法注释：

参数精灵

参数精灵也是公式的一种说明描述，显示在调整公式参数面板上：

参数精灵通过 Param#No 或 SParam#No 来对应参数的类型和第几个参数，Param是数值型，SParam是字符串类型。

注意它们是大小写敏感的，No是数字，代表第几个参数，下面是例子：

这是第一个参数 #Param#1, 数值类型
这是第二个参数 #SParam#2, 字符串类型

全文本公式

注释，公式描述和参数精灵，包括参数设置本身都可以内嵌到公式的文本里，完全无界面化。

 #Note '公式描述
换行 '

#Template '参数精灵第一个参数 Param#1
第二个参数 SParam#2
'

input:
  aa(1.2),
  bb('test1');
来自“http://www.hs633.com/kthelp/index.php?title=%E6%B3%A8%E9%87%8A%EF%BC%8C%E5%85%AC%E5%BC%8F%E6%8F%8F%E8%BF%B0%EF%BC%8C%E5%8F%82%E6%95%B0%E7%B2%BE%E7%81%B5&oldid=1108”


编译预处理

编译预处理是指编译前对编译器的一些设定，不参与到公式的语法分析中

编译预处理有下面的种类：

#Mainchart
#Subchart
#NoDefaultOutput
#Trade
#Opt
#Note
#Template
#InvalidPeriod
#DefaultPeriod
#RunMode
#Run_By_Bar
#Run_By_Serie
#Run_Every_Tick
#Run_Every_Bar
#NoTitle
#Use
#Define
#RefLine
来自“http://www.hs633.com/kthelp/index.php?title=%E7%BC%96%E8%AF%91%E9%A2%84%E5%A4%84%E7%90%86&oldid=1110”


智能交易公式

智能交易脚本是量化交易思路的表达形式

虚盘与实盘

在交易策略里，一般的交易函数并不直接操作真实帐号。每个策略都虚拟出一个帐号，称之为虚盘。

在这个帐号上开平仓都是瞬间完成的，没有网络延时，并且保证成功。

这样做可以确保策略自身逻辑的完整性，就是说每当策略产生信号时，虚盘总是能根据信号发生交易，

并不会像真实交易那样产生滑价，延时，部分成交，甚至不成交。

实盘是指真实的交易帐号（也可以是模拟帐号），实盘是通过与虚盘的同步跟随去完成实际交易的。

请看下面的例子：

ma1:ma(close, 5);
ma2:ma(close, 10);
if cross(ma2, ma1) then sellshort;

该策略以5日均线和10日均线交叉作为开仓条件

两条均线在图中所标注处发生了交叉，则虚盘在下一根K线的开盘价卖空1手。

这个操作是不需要真实交易帐号的。虚盘的交易信号使用虚心三角形表示，鼠标在上方时飘浮详细交易信息。

虚盘的仓位会标注在策略图标的右方，此时蓝色的[-1]表示虚盘持有1手空仓，多仓以红色正数表示。

虚盘不允许双向持仓，开反向仓时自动平掉原方向的仓位。

虚盘的信号通过仓位同步反应在真实交易中。接着上面的例子，如果此时登陆了交易帐号，并点击小脸打开交易

（笑脸为交易开启，哭脸为交易关闭），并且把同步设置成“总是同步”，实盘将会在最新价处跟随虚盘开仓，

使得实盘与虚盘的仓位一致：

实盘的信号使用实心三角表示，红色多仓，蓝色空仓。鼠标在上方时漂浮详细交易信息。

同步的选项有以下几种：

  • 总是同步:任何时候都保证实盘与虚盘的持仓数量和方向一致
  • 下次持仓方向改变时同步:持仓方向有持多仓，持空仓和无持仓三种，当下次持仓方向改变时才进行同步
  • 下次持仓数量改变时同步:当虚盘持仓在数量上改变时同步。方向改变时持仓数量一定改变，但持仓数量改变时不一定持仓方向也改变
  • 市场价优于虚盘开仓均价时同步:当虚盘有持仓，实盘等待最新价低于多头虚盘开仓价（或者高于空头开仓价时），进行同步

交易指令

基本的交易可以通过 Buy/Sell/SellShort/BuyToCover 函数或语句完成。

指令 | 中文 | 含义
Buy | 买入 | 多头开仓
Sell | 卖出 | 多头平仓
SellShort | 卖开 | 空头开仓
BuyToCover | 买平 | 空头平仓

交易函数

作为函数时，与一般的函数调用一样，目前只支持逐根运行的模式。

Buy('symbol', Lots, Price=0, Slippage=0, OT=OT_Market, KT=KT_NextBar, Comment=)
SellShort('symbol', Lots, Price=0, Slippage=0, OT=OT_Market, KT=KT_NextBar, Comment=)
Sell('Symbol', lots, price, slippage, OT, KT, 'Comment') [From 'EntryName']
BuyToCover('Symbol', lots, price, slippage, OT, KT, 'Comment') [From 'EntryName']

Symbol: 下单品种

Lots: 下单数量，填Default时下单数量由界面控制

Price: 下单价格，市价单 OT_Market 时价格可以填 0

Slippage: 下单滑价，滑价是在实盘成交时起作用的，不影响虚盘的成交价格，但会影响测评报告的绩效计算。滑价填0时由界面控制滑价。

OT: Order Type 有以下的类型：

  • OT_OPEN 开盘竞价，暂不支持
  • OT_CLOSE 收盘竞价，暂不支持
  • OT_MARKET 市价单，以当前价格成交
  • OT_LIMIT 限价单，当买方向价格低于下单价格时成交（或卖方向高于此价格）
  • OT_STOP 追价单，当买方向价格高于下单价格时成交（或卖方向低于此价格）

KT: K线类型有以下几种：

  • KT_ThisBar, 当前一根K线，只能配合 OT_Market
  • KT_NextBar, 下一根K线，可以配合 OT_Market/OT_Stop/OT_Limit

Comment: 下单注释，开仓时作为仓位标记

EntryName: 平仓时可以指定只操作某个标记的仓位

返回值：这4个交易函数都是操作虚盘的，操作能保证成功，所以函数没有返回值

交易语句

作为交易语句时，功能与交易函数一样，但写法更易于理解

 ('SellShort' | 'Sell' 'Short') ['(' "EntryLabel" ')'] [TradeSize] EntryType
 'Buy' ['(' "EntryLabel" ')'] [TradeSize] EntryType
 'Sell'['(' "ExitLabel" ')'] [From Entry("EntryLabel")] [TradeSize[Total]] ExitType
 ('BuyToCover' | 'Buy' 'To' 'Cover' ) [("ExitLabel")][From Entry("EntryLabel")] [TradeSize[Total]] ExitType

 EntryType: ( This Bar[On]Close | Next Bar[At]Open or Next Bar[At]Market | Next Bar[At]Price Limit | Next Bar[At]Price  Stop )
 ExitType: ( This Bar[On]Close | Next Bar[At]Open  or Next Bar[At]Market | Next Bar[At]Price  Limit | Next Bar[At]Price  Stop )

省略字, 交易语句中可以插入一些定词，冠词，方便理解。这些单词在编译时会被忽略

A An Is Than Was On Does At The Based By Place Share Shares

交易语句例子

buy this bar Market; // 在当前K线市价买入
sell next bar open;  // 在下一根K线的开盘价卖出

// 在下一根的 2398.2 价格处限价买入2口, 把仓位标记为 myPos
buy ('myPos') 2 shares next bar  at 2398.2 limit;
// 在下一根的 2399.8 价格处追价卖出标记为'myPos'里面的2口
sell ('comment') from entry('myPos') 2 shares next bar at 2399.8 stop;

中文版本的交易语句

 ('次周期'|'本周期') [价格] [类型] ('买入'|'卖开') [数量] ['标记为' '开仓标记'];
 ('次周期'|'本周期') [价格] [类型] ['从标记' '开仓标记'] ('卖出'|'买平') [数量] ['标记为' '平仓标记'];

 类型: ('追价'|'限价'|'市价')

中文版本的省略字

在 的 股 口

中文交易语句例子

 本周期 市价 买入;
 次周期 开盘价 卖出;
 在 次周期 2398.2 限价 买入 1 口 标记为 'MyPos';
 在 次周期 2399.8 追价 从标记 'MyPos' 卖出 1 口 标记为 'comment';

限价，追价，市价单

  • 市价单 在当前价格处交易
  • 限价单 买入时不高于指定价格，卖出时不低于指定价格
  • 追价单 买入时不低于指定价格，卖出时不高于指定价格

Buy(买入) 和 BuyToCover(买平) 都属于买入方向

Sell(卖出) 和 SellShort(卖开) 都属于卖出方向

多头止损属于 Sell Stop 类型，空头止损属于 BuyToCover Stop 类型

当根开仓，下一根开仓

ThisBar 当根开仓是指当前产生信时后立刻交易，不考虑信号闪烁问题。当根开仓只能用 OT_Market 市价单，最好使用 #Run_Every_Tick模式。ThisBar 不需要接受 OT_Limit/OT_Stop单，原因是当前价格已知: Limit 单可以写成 if close < price then buy; （多头） Stop 单可以写成 if close > price then buy; (多头)

NextBar 下根开仓是指当K线走完了，确认信号，在下一根交易。或者计算买入卖出的通道，在下一根K线应用追价或限价单。下根交易可以使用 #Run_Every_Bar 模式，每根K线运行一次即可。Run_Every_Bar指定公式每根K线只运行一次，然而对于追价限价，止盈止损的判断，仍然是每个tick进行的。

止盈，止损，跟踪止损，震荡止损，保本止损

出场的指令，除了Sell(卖出)和BuyToCover(买平)，还可以有以下：

  • SetStopLoss 止损
  • SetProfitTarget 止盈
  • SetDollarTrailing 跟踪止盈（按金额计算）
  • SetPercentTrailing 跟踪止盈（按百分比计算）
  • SetBreakEven 保本止损
  • SetInactive 震荡止损 （多少个周期内没有达到一定幅度的盈利和亏损）

止盈止损的计算都分为按总盈利计算和按平均没口盈利计算，默认按整个仓位的总盈利计算。

计算方式使用以下函数指定：

  • SetStopContract 按平均没口赢利计算
  • SetStopPosition 按整个仓位计算

注意盈利的计算是考虑了单边手续费的，而止盈止损则考虑双边的手续费。

实盘函数

除了使用实盘虚盘同步的交易模式，策略还能直接操作真实帐号，进行开平仓，撤单等的操作。

  • A_SendOrder 以限价单的形式直接发送到交易通道
  • A_CancelOrder 撤销委托单
  • A_CancelAllOrders 撤销所有委托单
  • A_GetOrderCount 返回当日共有多少张委托单
  • A_GetOpenOrderCount 返回当日为成交（或部分成交）的委托单数量
  • A_GetLastOrderIndex 返回最近一次委托单的序号
  • A_GetLastOpenOrderIndex 返回最近一次为成交（或部分成交）的委托单数量
  • A_OrderStatus 委托单的状态
  • A_OpenOrderStatus 未成交（或部分成交）的委托单的状态
  • A_OrderLot 委托单的委托开仓量
  • A_OpenOrderLot 未成交（或部分成交）委托的未成交的口数
  • A_OrderPrice 委托单的委托价格
  • A_OpenOrderPrice 未成交（或部分成交）的委托价格
  • A_OrderTime 委托单的委托时间
  • A_OpenOrderTime 未成交（或部分成交）的委托单的委托时间
  • A_OrderDate 委托单的委托日期
  • A_OpenOrderDate 未成交（或部分成交）的委托单的委托日期
  • A_OrderType 委托单的类型
  • A_OpenOrderType 未成交（或部分成交）的委托单的类型
  • A_OrderContractNo 委托单的合同编号
  • A_OpenOrderContractNo 未成交（或部分成交）的委托单的合同编号
  • A_OrderFilledLot 委托单的已成交口数
  • A_OpenOrderFilledLot 未成交（或部分成交）的委托单的已成交口数
  • A_OrderFilledPrice 委托单的成交价格
  • A_OpenOrderFilledPrice 未成交（或部分成交）的委托单的已成交部分的成交价格
  • A_OrderCancelledLot 委托单撤单已撤口数
  • A_OpenOrderCancelledLot 未成交（或部分成交）的委托单的已撤口数
  • A_OrderSymbol 委托单的委托品种
  • A_OpenOrderSymbol 未成交（或部分成交）的委托单的委托品种
来自“http://www.hs633.com/kthelp/index.php?title=%E6%99%BA%E8%83%BD%E4%BA%A4%E6%98%93%E5%85%AC%E5%BC%8F&oldid=1456”


公共函数

概述

所谓函数，是一些会反复使用到的功能，封装而成的一段代码。

函数有三种类型：内置函数、局部函数和公共函数

内置函数是最常用的函数，本软件中有很多内置函数，例如ma、hhv、buy、sell等等。

当内置函数不够用，除了等待软件升级新增所需函数，还有一个途径，就是通过公式语言自行编写局部函数或公共函数。

局部函数和公共函数

通过公式语言编写的函数有两种存在形式。

第一种，内嵌在其他公式中。

例1：内嵌在其他公式中的函数
//以下函数把上次传入的点和这次传入的点用线连起来
function drawL
input:
  numericSimple var1;
variable:
  numericSimple d0(0),t0(0),v0(0);
begin
  if( d0!=0 and date>2013 )then begin
    id = tl_new( d0, t0, v0, date, time , var1);
  end;
  d0 = date;
  t0 = time;
  v0 = var1;
end

//主程序体
//每隔10根k线，就在收盘价处连一条线
#run_by_bar
#MainChart
#nodefaultoutput
if( barpos mod 10 =0 )then
  drawL( close );

这样的函数我们称为“局部函数”。

第二种，把函数独立出来，单独成为一个公式

这样的函数，在公式里不需要额外的声明就可以直接使用，跟ma等内置函数一样，我们称为“公共函数”。

适用范围

局部函数和公共函数仅工作于逐根模式下。

函数参数

调用函数时，可以通过参数给函数传入和传出值。 参数类型可以是：

 numericSimple 单值
 numericSeries 序列
 numericRef 引用参数

numericRef类型的参数可以在函数内赋值，并且把值带到主程序中去。

当参数类型是numericRef时，传入参数时必须使用序列型（不可以是numericSimple)。

例如，以下的例子是不正确的
func testFunc
input:
  numericRef n;
begin
  n = 1;
end;

//主程序
variable:
  numericSimple x(0);
testFunc(x);

函数内部变量

在函数中定义的变量只是在函数体内使用。 但是这些变量的值会一直保存，在下根k线到来时，这些变量依然保持上一根k线结算的结果。

函数返回

函数能够返回值给调用者。 语法是：

 return x;

例如：

function func
begin
  return 1;
end

直接给函数名赋值也能达到相同的目的 例如：

function func
begin
  func = 1;
end

公共函数编译

在公共函数被改变后，不但公共函数需要编译，使用了它的公式也需要重新编译。

系统会分析使用这个函数的公式的整个依赖链条。

有依赖关系的公式会自动列出，供您重新编译。

来自“http://www.hs633.com/kthelp/index.php?title=%E5%85%AC%E5%85%B1%E5%87%BD%E6%95%B0&oldid=1861”


DLL扩展

公式系统支持DLL扩展调用，用户可以用C，C++，Pascal，Delphi，.NET 等高级语言编写一段数据处理程序，然后以动态连接库的形式，嵌入到公式里面。除了用户编写的公式，系统DLL也可以调用。

有了DLL的扩展，用户可以更灵活的表达自己的算法，更可满足保密或效率方面的需求。DLL扩展主要有四种：

  • 飞狐 DLL调用
  • 新格式 DLL调用
  • 系统 DLL调用
  • .NET DLL调用

运行模式函数

//DLL公式的运行模式，系统调用该DLL时，公式系统告知该DLL公式运行在何种模式下
//0,DLL运行逐行模式 1,DLL运行逐根模式
__declspec(dllexport) void WINAPI RUNMODE(int nMode);

DLL调用常见问题

  • 无法加载DLL
  • 无法删除DLL
  • 无法找到调用函数
来自“http://www.hs633.com/kthelp/index.php?title=DLL%E6%89%A9%E5%B1%95&oldid=91”


函数索引 - kingtrader帮助系统

函数索引

  • 行情函数
  • 动态函数
  • 财务数据
  • 时间函数
  • 引用函数
  • 逻辑函数
  • 数学函数
  • 统计函数
  • 期权函数
  • 指标函数
  • 常数函数
  • 字符串函数
  • 协方差函数
  • 易理函数
  • 绘图函数
  • 解盘函数
  • 其他函数
  • 系统参数
  • 线型描述
  • 新画线函数
  • 控制语句函数
  • 投资管理帐户
  • 系统函数
  • 数据引用函数
  • 交易函数
  • 交易状态函数
  • 宏
  • 自定义评价公式
  • 扩展数据
  • 编译开关
  • 变量声明
  • 交易绩效函数
  • 属性函数
  • 交易账户函数
  • 组合测评函数
  • 应用程序接口
来自“http://www.hs633.com/kthelp/index.php?title=%E5%87%BD%E6%95%B0%E7%B4%A2%E5%BC%95&oldid=804”


飞狐 DLL调用

DLL接口说明

  1. 扩展函数可用于实现系统公式函数不能实现的特殊算法
  2. 扩展函数用windows 32位动态链接库实现,建议使用Microsoft Visual C++编程.
  3. 调用时在公式编辑器中书写"动态库名称@函数名称"(参数表)即可,例如下面函数"FOXFUNC@MYMACLOSE"(5)
  4. 动态链接库名称和函数名称可以自己定义
  5. 使用时必须将动态库文件放置在软件安装目录下的FmlDLL子目录下

DLL函数格式

DLL名称和函数名称可以自行定义，由于原飞狐公式不区分大小写，DLL的函数名最好使用全大写， 避免某些环境下无法加载，新版本的DLL则无此限制。 下面的例子定义了一个 MYMACLOSE 的函数，函数的实现下面具体分析。

extern "C" __declspec(dllexport) int WINAPI MYMACLOSE(CALCINFO* pData)

DLL函数返回值

首先注意上述函数的返回值是int,这个返回值表示在pData的m_pResultBuf里面有效位置的起始位， m_pResultBuf是DLL返回的数值序列的存放位置,0表示从第1位起有效，2表示从第3位起有效， 返回-1表示全部无效，公式将没有输出。m_pResultBuf和CALCINFO的类型下面讲述

DLL的参数类型

DLL的参数是一个结构体CALCINFO的指针，下面是定义

////////////////////////////////////////////////////
//调用接口信息数据结构
////////////////////////////////////////////////////
typedef struct tagCALCINFO
{
    //结构大小
    DWORD m_dwSize;
    //调用软件版本(V3.00 : 0x300)
    DWORD m_dwVersion;
    //调用软件序列号
    DWORD m_dwSerial;
    //软件用户名
    //char* m_strUserName;
    //股票代码
    char* m_strStkLabel;
    //大盘
    BOOL m_bIndex;
    //数据数量(pData,pDataEx,pResultBuf数据数量)
    int m_nNumData;
    //常规数据,注意:当m_nNumData==0时可能为 NULL
    STKDATA* m_pData;
    //扩展数据,分笔成交买卖盘,注意:可能为 NULL
    STKDATAEx* m_pDataEx;
    //参数1有效位置
    int m_nParam1Start;
    //调用参数1
    float*	 m_pfParam1;
    //调用参数2
    float*	 m_pfParam2;
    //调用参数3
    float*	 m_pfParam3;
    //调用参数4
    float*	 m_pfParam4;
    //结果缓冲区
    float* m_pResultBuf;
    //数据类型
    int m_dataType;
    //财务数据
    float* m_pfFinData;
    //以上与分析家兼容，所以沿用其结构和名称

    //以下为 FoxTrader 扩展
    // function type
    DWORD m_nFncType;
    // 调用参数数量
    int m_nNumParam;
    // 调用参数数组
    CALCPARAM* m_pCalcParam;
    //扩展结果缓冲区
    float* m_pResultBufExt[8];
    //扩展结果有效位置
    int m_nResultStart[8];
    // 用户数据(102400字节)
    void* m_pUserData;

    //内部函数计算用
    //参数2有效位置
    int m_nParam2Start;
    //参数3有效位置
    int m_nParam3Start;
    //参数4有效位置
    int m_nParam4Start;
    //股票名称
    char* m_strStkName;
    //除权数据
    SPLITDATA* m_pSplitData;
    //除权次数
    int m_nNumSplitData;
    //计算当前下标数据
    int m_iCurIndex;

    void* m_pReserved1;
    void* m_pReserved2;
    void* m_pReserved3;
    void* m_pReserved4;

} CALCINFO;

注意里面的float* m_pResultBuf;就是函数返回数值序列的存放位置，序列的类型是float, 长度是int m_nNumData;

DLL参数传递

传入DLL的参数是CALCINFO结构体里面的m_pfParam1，m_pfParam2，m_pfParam3，m_pfParam4; 最多可传4个序列。当m_pfParam1为NULL时，表示无参数；当m_pfParam1不为空而m_pfParam2为空表示有1个参数； 当m_pfParam1和m_pfParam2不为空但m_pfParam3为空则表示有两个参数，以此类推。 序列的有效起始位是m_nParam1Start，m_nParam2Start，m_nParam3Start，m_nParam4Start， 起始位小于0表示是单值(用 *m_pfParam1 来获取)。起始位大于等于0时，有效数据为: m_pfParam1[m_nParam1Start]，m_pfParam1[m_nParam1Start+1],m_pfParam1[m_nParam1Start+2]...m_pfParam1[m_nNumData-1] 第2，3，4条序列也是同样的结构。

基本数据结构

公式调用DLL时会把当前图形上的信息传入DLL，这些信息包括开高低收量额等， 定义在STKDATA* m_pData这个指针里，长度是m_nNumData， STKDATA结构体的定义如下：

////////////////////////////////////////////////////
//基本数据
////////////////////////////////////////////////////
typedef struct tagSTKDATA
{
    TimeType m_time;		//时间,UCT
    float	m_fOpen;		//开盘
    float	m_fHigh;		//最高
    float	m_fLow;			//最低
    float	m_fClose;		//收盘
    float	m_fVolume;		//成交量(手)
    float	m_fAmount;		//成交额(元)/持仓(未平仓合约，仅期货有效)
    WORD	m_wAdvance;		//上涨家数(仅大盘有效)
    WORD	m_wDecline;		//下跌家数(仅大盘有效)
} STKDATA;

兼容时间格式

注意上述结构的m_time是TimeType类型，老版本的格式是time_t，由于新版本的time_t是64位的，老飞狐是32位， 所有原来time_t的字段，现在都用TimeType来表示。 使用vc6编译dll的，如果需要用到时间的，时间字段是vc6的time_t类型即可 使用vc2008以上版本的，time_t就是__int64，为了兼容老版本的DLL, 需要使用额外定义下面的TimeType类型（实际上就是int,32位的）

#define TimeType int

扩展数据格式

////////////////////////////////////////////////////
//扩展数据,用于描述分笔成交数据的买卖盘
////////////////////////////////////////////////////
typedef union tagSTKDATAEx
{
    struct
    {
        float m_fBuyPrice[3];		//买1--买3价
        float m_fBuyVol[3];			//买1--买3量
        float m_fSellPrice[3];		//卖1--卖3价
        float m_fSellVol[3];		//卖1--卖3量
        DWORD m_dwToken;			//成交方向
    };
    float m_fDataEx[13];
} STKDATAEx;

除权数据

////////////////////////////////////////////////////
//除权数据
////////////////////////////////////////////////////
typedef struct tagSPLITDATA
{
    TimeType	m_time;			//时间,UCT
    float		m_fHg;			//红股
    float		m_fPg;			//配股
    float		m_fPgj;			//配股价
    float		m_fHl;			//红利
} SPLITDATA;

扩展调用参数

////////////////////////////////////////////////////
//调用参数项结构
////////////////////////////////////////////////////
typedef struct tagCALCPARAM
{
    union
    {
        const float m_fParam; //数值参数
        const float* m_pfParam; //序列参数，指向一个浮点型数组
        const char* m_szParam; //字符串参数
    };
    //序列参数有效起始位置
    const int	m_nParamStart;
}CALCPARAM;

公式调用例子

公式里使用双引号来调用DLL, 例如下面的例子是调用MyDll.dll里面的MYMACLOSE函数，参数是5， 返回值输出成指标线k1。 下一节有建立DLL工程及调用公式的详细例子。

k1:"MyDll@MYMACLOSE"(5);

开发DLL的详细例子

这里例子是使用VS2012制作的，VS2010,VS2008,VC6也类似。

1. 首先创建Win32的工程项目,项目名称是MyDll

Fml dll create project.png

2. 项目设置成DLL

Fml dll project settings.png

3. 把TimeType, STKDATA, STKDATAEx，等等上述数据结构拷贝到MyDll.cpp

Fml dll edit src.png

4. 添加用户函数MYMACLOSE, 计算 N 日均线

//计算收盘价的均价,一个常数参数,表示计算周期
//调用方法:
//	"FOXFUNC@MYMACLOSE"(5)
extern "C" __declspec(dllexport) int WINAPI MYMACLOSE(CALCINFO* pData)
{

    if ( pData->m_pfParam1 &&				//参数1有效
         pData->m_nParam1Start<0 &&			//参数1为常数
         pData->m_pfParam2==NULL )			//仅有一个参数
    {
        float fParam = *pData->m_pfParam1;
        int nPeriod = (int)fParam;			//参数1
        if(nPeriod>0)
        {
            float fTotal;
            int i, j;
            for ( i = nPeriod-1; i < pData->m_nNumData; i++ )//计算nPeriod周期的均线,数据从nPeriod-1开始有效
            {
                fTotal = 0.0f;
                for ( j = 0; j < nPeriod; j++ )				//累加
                    fTotal += pData->m_pData[i-j].m_fClose;
                pData->m_pResultBuf[i] = fTotal/nPeriod;	//平均
            }
            return nPeriod-1;
        }
    }
    return -1;
}

5. 设置项目的输出路径为软件安装目录下的 FmlDll 下，输出名称为 MyDll.dll。 这一步可以省略，编译后手动拷贝dll到软件的FmlDll目录也可以

Fml dll linker output.png

6. 编译后，直接运行软件，或者在Debugging调试Command处添加软件的启动路径

7. 创建公式 测试DLL，并编译

Fml dll create fml.png

8. 拖放到图上运行

Fml dll run dll.png

示例DLL工程文件下载

文件:MyDll.zip

返回DLL扩展页

来自“http://www.hs633.com/kthelp/index.php?title=%E9%A3%9E%E7%8B%90_DLL%E8%B0%83%E7%94%A8&oldid=93”


新格式 DLL调用

新的公式逐根运行模式每次只计算新增数据，不需要整条序列重新运算，这样可以大大提升效率。 有鉴于此，DLL调用也有了新的格式。

逐根模式DLL接口说明

  1. 扩展函数用windows 32位动态链接库实现,建议使用Microsoft Visual C++编程
  2. 只能用于逐根运行模式#Run_By_Bar, 参考执行模式
  3. 调用前需要声明 extern 返回值类型 函数名(参数类型 参数,...);
  4. 调用时直接调用函数名，与普通函数调用方式一样
  5. DLL名称和函数名可以自己定义
  6. 使用时必须将DLL放在软件安装目录下的FmlDll子目录下

DLL函数格式

  1. DLL名称和函数名都是大小写敏感的，代码声明和公式调用时需要匹配。
  2. 参数的个数和名称都没有限制，支持基础的数据类型float, double, int,BOOL, LONG, DWORD, float*, LPCWSTR等,注意序列类型只能是 float*, 单值类型则是通用的
// C 代码里的声明
extern "C" __declspec(dllexport) void WINAPI my_ma2(float* pResultBuffer, float* pDataBuffer, int n, int barpos)

公式里面的声明

 // 公式里面的声明
 extern 'MyDll2.dll' void  my_ma2(NumericSeries ResultBuffer, NumericSeries DataBuffer, int n, int barpos);

DLL的返回值

新格式DLL可返回单值，序列和数组。单值类型大致分为两种：数值类型和字符串类型，可以通过函数返回值直接返回。

  • 返回单值类型的例子
//返回整数
extern "C" __declspec(dllexport) int WINAPI my_test1()
{
    return 1;
}
//返回浮点
extern "C" __declspec(dllexport) float WINAPI my_test2()
{
    return 2.0f;
}
//返回字符串
extern "C" __declspec(dllexport) LPCWSTR WINAPI my_test3()
{
    return L"TEST STRING";
}

相应的公式调用例子

#MAINCHART
#Run_By_Bar
extern 'MyDll2.dll' int my_test1();
extern 'MyDll2.dll' float my_test2();
extern 'MyDll2.dll' LPCWSTR my_test3();
k1: my_test1;
k2: my_test2;
comment(my_test3);

若要返回序列或数组，则把需要返回的序列赋值目标当作参数传递给DLL，在DLL内部直接修改已达到赋值。 注意逐根运行模式下，每一根K线都会调用dll，所以通常每次调用只需要赋值比上一根K线新增加的类型， 例如计算收盘价均值时，每次在BarPos位置填入当根K线的均值即可。由此可见，这种应用下通常需要把 BarPos(当前是第几根K线)作为参数传入Dll中。

  • 返回序列和数组的例子
extern "C" __declspec(dllexport) void WINAPI my_test4(float*pReturn, int nIndex)
{
    pReturn[nIndex-1] = 123;
}

extern "C" __declspec(dllexport) void WINAPI my_test5(float*pReturn, int nLen)
{
    for(int i=0;i<nLen;i++)
        pReturn[i] = 0;
}

相应的公式调用例子

#MAINCHART
#Run_By_Bar
variable:
  NumericSeries mySequence(0);
array:
  myArray[100](1);

extern 'MyDll2.dll' void my_test4(NumericSeries mySequence, int nIndex);
extern 'MyDll2.dll' void my_test5(NumericArray myArray, int nLen);
my_test4(mySequence, BarPos);
my_test5(myArray, 100);

DLL的参数类型

- | 单值 | 序列 | 数组 | 引用
数值 | NumericSimple | NumericSeries | NumericArray | NumericRef
字符串 | String | - | StringArray | StringRef

无效数据表示

公式系统使用std的无效浮点数表示无效值，浮点无效值的一个重要特征是 f != f 为真，可作为判断依据， 其它运算皆输出无效值，其它比较皆输出假。当序列作为指标输出时，开始和结束两段的无效值自动截除，不作为指标输出。 例如要输出5日均线，序列的前4个值可填充无效值（填充0时会使指标线变形）

#include <limits>
#define INVALID_NUMERIC std::numeric_limits<float>::quiet_NaN()

无效值在公式里可以用 Invalid 关键字指定，例如

k1:Invalid;

则k1指标线不会输出

来自“http://www.hs633.com/kthelp/index.php?title=%E6%96%B0%E6%A0%BC%E5%BC%8F_DLL%E8%B0%83%E7%94%A8&oldid=2038”


系统 DLL调用

调用win32提供的系统DLL，与调用自己编写的DLL是一样的。

只要知道windows系统函数所属的DLL和函数名，参数等信息就可以直接使用，例如

extern 'kernel32.dll' int GetTickCount();
tickcount:GetTickCount();

同样地，这种用法只能工作于逐根模式下。

来自“http://www.hs633.com/kthelp/index.php?title=%E7%B3%BB%E7%BB%9F_DLL%E8%B0%83%E7%94%A8&oldid=2061”


.NET DLL调用

只能在逐根模式中使用.net DLL

跟一般DLL不同的是，.net DLL在声明时，除了函数名信息，还要提供命名空间、类名的信息，例如：

 extern 'RzRq.dll' void RzRq.Grabber.GetFinance( LPCWSTR stockCode);

这里的RzRq就是命名空间，而Grabber则是类的名称，GetFinance是函数名

来自“http://www.hs633.com/kthelp/index.php?title=.NET_DLL%E8%B0%83%E7%94%A8&oldid=2080”


DefaultPeriod

函数 | DefaultPeriod
别名 | 无
所属类别 | 编译开关
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统在条件选股和探索交易系统最佳参数时自动计算该周期的数据
用法 | #defaultPeriod P_DAY 可选周期包括: P_TICK,P_MIN1,P_MIN5,P_MIN15,P_MIN30,P_MIN60,P_HOUR1,P_HOUR4,P_DAY,P_WEEK,P_MONTH,P_QUARTER,P_HALFYEAR,P_YEAR。 例如：#defaultPeriod P_DAY。”
来自“http://www.hs633.com/kthelp/index.php?title=DefaultPeriod&oldid=1884”


Define 预定义

函数 | Define
别名 | 预定义
所属类别 | 编译开关
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 预定义某个标识符为其后的表达式
用法 | #define Name something。用一个简单的词代替一串复杂的文字，让代码更简洁。Name是你自己定的一个简短的名字，something通常是一个比较长的表达式。 例如：#define PI 3.14159266”
来自“http://www.hs633.com/kthelp/index.php?title=Define_%E9%A2%84%E5%AE%9A%E4%B9%89&oldid=1887”


IntraBarOrder 开启Bar内下单

函数 | IntraBarOrder
别名 | 开启Bar内下单
所属类别 | 编译开关
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 开启Bar内下单
用法 | #IntrabarOrder
来自“http://www.hs633.com/kthelp/index.php?title=IntraBarOrder_%E5%BC%80%E5%90%AFBar%E5%86%85%E4%B8%8B%E5%8D%95&oldid=1891”


MainChart

函数 | MainChart
别名 | 无
所属类别 | 编译开关
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 该指标被双击时默认显示到主图上
用法 #mainchart

例如:

  1. mainChart

ma(c,5);

输出就会放到主图上

来自“http://www.hs633.com/kthelp/index.php?title=MainChart&oldid=1885”


ParamWizard 参数精灵

函数 | ParamWizard
别名 | 参数精灵
所属类别 | 编译开关
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 定义参数精灵
用法 | #define ParamWizard 定义参数精灵。设置调整公式参数时所用的模板，将来调整参数时，param1、param2...的地方被参数编辑框取代。具体可参考ma指标的参数精灵
来自“http://www.hs633.com/kthelp/index.php?title=ParamWizard_%E5%8F%82%E6%95%B0%E7%B2%BE%E7%81%B5&oldid=1888”


RefLine 指定在哪些位置画水平坐标线

函数 | RefLine
别名 | 指定在哪些位置画水平坐标线
所属类别 | 编译开关
参数数量 | 7
运行模式 | 逐根/逐行
说明 | 指定在哪些位置画水平坐标线
用法 | RefLine:l1,l2,l3...指定在哪些位置画水平坐标线，最多可设置7个,用分号分隔。 例如对MTM，可以输入'#RefLine:-0.6,0,0.6'。系统将显示在这三个数值的水平坐标线。 仅对副图指标有效。 如果没有指定RefLine，那么缺省时系统按实际值设定最佳显示的水平坐标线。”
来自“http://www.hs633.com/kthelp/index.php?title=RefLine_%E6%8C%87%E5%AE%9A%E5%9C%A8%E5%93%AA%E4%BA%9B%E4%BD%8D%E7%BD%AE%E7%94%BB%E6%B0%B4%E5%B9%B3%E5%9D%90%E6%A0%87%E7%BA%BF&oldid=1890”


SubChart

函数 | SubChart
别名 | 无
所属类别 | 编译开关
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 该指标被双击时默认显示到副图上
用法 #subChart

例如:

  1. subChart

ma(c,5);

输出就会放到副图上

来自“http://www.hs633.com/kthelp/index.php?title=SubChart&oldid=1886”


UserGuide 指标使用说明

函数 | UserGuide
别名 | 指标使用说明
所属类别 | 编译开关
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 定义指标使用说明
用法 | #define USERGUIDE 定义指标使用说明。例如指标算法思想、用法、参数意义等
来自“http://www.hs633.com/kthelp/index.php?title=UserGuide_%E6%8C%87%E6%A0%87%E4%BD%BF%E7%94%A8%E8%AF%B4%E6%98%8E&oldid=1889”


Array 数组

函数 | Array
别名 | 数组
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 数组
用法 | 语法: Array:〈IntraBarPersist〉ArrayName1[D1,D2,D3,etc.](InitialValue1〈,DataN〉), 〈IntraBarPersist〉ArrayName2[D1,D2,D3,etc.](InitialValue2〈,DataN〉),etc.Arrays 1、array：A[10](0); 或VARIABLE（或VARIABLES)：A[10](0); 2种定义相同，第2种定义是为了兼容飞狐。 A[10] 是整个K线序列只有一个11个元素的数组，下标从0-10
来自“http://www.hs633.com/kthelp/index.php?title=Array_%E6%95%B0%E7%BB%84&oldid=1897”


Arrays 数组

函数 | Arrays
别名 | 数组
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 数组
用法 | 语法: Arrays:〈IntraBarPersist〉ArrayName1[D1,D2,D3,etc.](InitialValue1〈,DataN〉), 〈IntraBarPersist〉ArrayName2[D1,D2,D3,etc.](InitialValue2〈,DataN〉),etc.Arrays
来自“http://www.hs633.com/kthelp/index.php?title=Arrays_%E6%95%B0%E7%BB%84&oldid=1898”


Char 声明DLL函数字符型变量

函数 | Char
别名 | 声明DLL函数字符型变量
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数字符型变量。
用法 | 语法: 例：extern 'FoxFunc.dll' double myfunc(char d1, int d2, long d3, DWORD d4, float d5, double d6, bool d7, ulong d8);
来自“http://www.hs633.com/kthelp/index.php?title=Char_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0%E5%AD%97%E7%AC%A6%E5%9E%8B%E5%8F%98%E9%87%8F&oldid=1906”


Const 常数

函数 | Const
别名 | 常数
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 常数
用法 | 语法: const:ConstName1(InitialValue1), ConstName2(InitialValue2),.....;
来自“http://www.hs633.com/kthelp/index.php?title=Const_%E5%B8%B8%E6%95%B0&oldid=1896”


Double 声明DLL函数双精度浮点型变量

函数 | Double
别名 | 声明DLL函数双精度浮点型变量
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数双精度浮点型变量。
用法 | 语法: const:ConstName1(InitialValue1), ConstName2(InitialValue2),.....;
来自“http://www.hs633.com/kthelp/index.php?title=Double_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0%E5%8F%8C%E7%B2%BE%E5%BA%A6%E6%B5%AE%E7%82%B9%E5%9E%8B%E5%8F%98%E9%87%8F&oldid=1907”


Dword 声明DLL函数双字无符号整型变量

函数 | Dword
别名 | 声明DLL函数双字无符号整型变量
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数双字无符号整型变量。
用法 | 语法: 例：extern 'FoxFunc.dll' double myfunc(char d1, int d2, long d3, DWORD d4, float d5, double d6, bool d7, ulong d8);
来自“http://www.hs633.com/kthelp/index.php?title=Dword_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0%E5%8F%8C%E5%AD%97%E6%97%A0%E7%AC%A6%E5%8F%B7%E6%95%B4%E5%9E%8B%E5%8F%98%E9%87%8F&oldid=1909”


Extern 声明DLL函数

函数 | Extern
别名 | 声明DLL函数
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数。
用法 | 语法: 例：extern 'foxfunc.dll' void myfunc( NumericSeries resultArray, NumericSeries array, int n); extern 'dllname' ,此处的dllname，可以是一个url地址(可以是dll或zip压缩文件)，例如 extern 'http://www.hs633.com/fmldll/Position.zip' 或extern 'http://www.hs633.com/fmldll/Position.dll'
来自“http://www.hs633.com/kthelp/index.php?title=Extern_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0&oldid=1904”


Float 声明DLL函数浮点型变量

函数 | Float
别名 | 声明DLL函数浮点型变量
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数浮点型变量。
用法 | 语法: 例：extern 'FoxFunc.dll' double myfunc(char d1, int d2, long d3, DWORD d4, float d5, double d6, bool d7, ulong d8);
来自“http://www.hs633.com/kthelp/index.php?title=Float_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0%E6%B5%AE%E7%82%B9%E5%9E%8B%E5%8F%98%E9%87%8F&oldid=1910”


Input

函数 | Input
别名 | 无
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 申明并设置参数
用法 | 语法: INPUT:pname1(dft,min,max,step),pname2(dft,min,max,step)...; pname表示参数名, dft表示缺省值 min表示最小值,max表示最大值 step表示优化步长,除default外都可省略 例如: INPUT:N(5), M(10,1,100,2); 表示定义参数N,缺省值为5 定义参数M,缺省值为10,最小值为1,最大值为100,优化步长为2
来自“http://www.hs633.com/kthelp/index.php?title=Input&oldid=1893”


Int 声明DLL函数整型变量

函数 | Int
别名 | 声明DLL函数整型变量
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数整型变量。
用法 | 语法: 例：extern 'FoxFunc.dll' double myfunc(char d1, int d2, long d3, DWORD d4, float d5, double d6, bool d7, ulong d8);
来自“http://www.hs633.com/kthelp/index.php?title=Int_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0%E6%95%B4%E5%9E%8B%E5%8F%98%E9%87%8F&oldid=1905”


IntraBarPersist 记住每笔

函数 | ntraBarPersist
别名 | 记住每笔
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 变量修饰符，必须配合run_every_tick开关使用。没有指定run_every_tick时，则intrabarPersist的修饰不会生效
用法 语法:

作用：指定了这个修饰的变量，会记住上一个tick的值。没有指定，则记住上一个bar的值。

  1. run_every_tick

variable:

intrabarPersist numericSimple x(0), intrabarPersis y(0);

来自“http://www.hs633.com/kthelp/index.php?title=IntraBarPersist_%E8%AE%B0%E4%BD%8F%E6%AF%8F%E7%AC%94&oldid=1915”


Long 声明DLL函数长整型变量

函数 | Long
别名 | 声明DLL函数长整型变量
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数长整型变量。
用法 | 语法: 例：extern 'FoxFunc.dll' double myfunc(char d1, int d2, long d3, DWORD d4, float d5, double d6, bool d7, ulong d8);
来自“http://www.hs633.com/kthelp/index.php?title=Long_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0%E9%95%BF%E6%95%B4%E5%9E%8B%E5%8F%98%E9%87%8F&oldid=1908”


LpcStr 声明DLL函数字符串指针

函数 | LpcStr
别名 | 声明DLL函数字符串指针
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数字符串指针。
用法 | 语法: 例：extern 'FoxFunc.dll' void myStrFunc(LPCSTR str1);
来自“http://www.hs633.com/kthelp/index.php?title=LpcStr_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%8C%87%E9%92%88&oldid=1912”


LpcwStr 声明DLL函数unicode字符串指针

函数 | LpcwStr
别名 | 声明DLL函数unicode字符串指针
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL函数unicode字符串指针。
用法 | 语法: 例：extern 'FoxFunc.dll' void myStrFunc(LPCWSTR str1);
来自“http://www.hs633.com/kthelp/index.php?title=LpcwStr_%E5%A3%B0%E6%98%8EDLL%E5%87%BD%E6%95%B0unicode%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%8C%87%E9%92%88&oldid=1911”


Numeric 声明公共函数的输入参数为数值型

函数 | Numeric
别名 | 声明公共函数的输入参数为数值型
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 声明公共函数的输入参数为数值型。用于传入单值。
用法 | 语法: Input: Numerice P1;
来自“http://www.hs633.com/kthelp/index.php?title=Numeric_%E5%A3%B0%E6%98%8E%E5%85%AC%E5%85%B1%E5%87%BD%E6%95%B0%E7%9A%84%E8%BE%93%E5%85%A5%E5%8F%82%E6%95%B0%E4%B8%BA%E6%95%B0%E5%80%BC%E5%9E%8B&oldid=1899”


NumericRef 声明公共函数的输入参数为引用序列

函数 | NumericRef
别名 | 声明公共函数的输入参数为引用序列
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 声明公共函数的输入参数为引用序列。引用序列可以任意改变其中的单个值，并且把改变带到函数之外。
用法 | 语法: 例如，函数myFunc是这样的 Input: NumericRef P1; P1:=c; 调用函数myFunc(x)之后，x变成跟c一样
来自“http://www.hs633.com/kthelp/index.php?title=NumericRef_%E5%A3%B0%E6%98%8E%E5%85%AC%E5%85%B1%E5%87%BD%E6%95%B0%E7%9A%84%E8%BE%93%E5%85%A5%E5%8F%82%E6%95%B0%E4%B8%BA%E5%BC%95%E7%94%A8%E5%BA%8F%E5%88%97&oldid=1901”


NumericSeries 声明公共函数的输入参数为序列

函数 | NumericSeries
别名 | 声明公共函数的输入参数为序列
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 声明公共函数的输入参数为序列。序列能够通过下标访问其中单个元素。
用法 | 语法: Input: NumericSeries P1;
来自“http://www.hs633.com/kthelp/index.php?title=NumericSeries_%E5%A3%B0%E6%98%8E%E5%85%AC%E5%85%B1%E5%87%BD%E6%95%B0%E7%9A%84%E8%BE%93%E5%85%A5%E5%8F%82%E6%95%B0%E4%B8%BA%E5%BA%8F%E5%88%97&oldid=1900”


NumericSimple 单值变量

函数 | NumericSimple
别名 | 单值变量
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明变量为单值变量
用法 | 语法: variable: NumericSimple SN(90), V1(0), V2(0); 则SN是单值变量，不占内存，而V1、V2是序列变量。 NumericSimple的优势是资源占用小，效率高。 而序列变量多数情况下可兼容单值型变量，所以默认是序列变量.
来自“http://www.hs633.com/kthelp/index.php?title=NumericSimple_%E5%8D%95%E5%80%BC%E5%8F%98%E9%87%8F&oldid=1914”


String 声明公共函数的输入参数为字符串

函数 | String
别名 | 声明公共函数的输入参数为字符串
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 声明公共函数的输入参数为字符串。
用法 | 语法: Input: String P1;
来自“http://www.hs633.com/kthelp/index.php?title=String_%E5%A3%B0%E6%98%8E%E5%85%AC%E5%85%B1%E5%87%BD%E6%95%B0%E7%9A%84%E8%BE%93%E5%85%A5%E5%8F%82%E6%95%B0%E4%B8%BA%E5%AD%97%E7%AC%A6%E4%B8%B2&oldid=1902”


StringRef 声明公共函数的输入参数为引用字符串

函数 | StringRef
别名 | 声明公共函数的输入参数为引用字符串
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 声明公共函数的输入参数为引用字符串。可以在函数中改变引用字符串的值，并把改变带到函数之外。
用法 | 语法: 例如，函数myFunc是这样的 Input: StringRef P1; P1:='haha'; 调用函数myFunc(x)之后，x的值变成'haha'
来自“http://www.hs633.com/kthelp/index.php?title=StringRef_%E5%A3%B0%E6%98%8E%E5%85%AC%E5%85%B1%E5%87%BD%E6%95%B0%E7%9A%84%E8%BE%93%E5%85%A5%E5%8F%82%E6%95%B0%E4%B8%BA%E5%BC%95%E7%94%A8%E5%AD%97%E7%AC%A6%E4%B8%B2&oldid=1903”


Variable

函数 | Variable
别名 | 无
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 申明并初始化变量
用法 | 语法: VARIABLE:varname1(initValue1),varname2(initValue2),.....; initValue，该变量的初始值 例如: variable: numericSimple x(1)”,y(CLOSE),ARR[10](0),SARR[5]('str'); 表示定义单值变量x并初始化为1, 申明序列变量y并初始化为收盘价, 申明含10个浮点数的数组并全部初始化为0 申明含5个字符串的数组并都初始化为'str'
来自“http://www.hs633.com/kthelp/index.php?title=Variable&oldid=1894”


Variables

函数 | Variables
别名 | 无
所属类别 | 变量声明
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 申明并初始化变量
用法 | 语法: VARIABLES:varname1(initValue1),varname2(initValue2),.....; initValue，该变量的初始值 例如: VARIABLES:x(1),y(CLOSE),ARR[10](0),SARR[5]('str'); 表示定义常数变量x并初始化为1, 申明序列变量y并初始化为收盘价, 申明含10个浮点数的数组并全部初始化为0 申明含5个字符串的数组并都初始化为'str'
来自“http://www.hs633.com/kthelp/index.php?title=Variables&oldid=1895”


Void 声明DLL无返回值函数

函数 | Void
别名 | 声明DLL无返回值函数
所属类别 | 变量声明
参数数量 | 多个
运行模式 | 逐根/逐行
说明 | 声明DLL无返回值函数。
用法 | 语法: 例：extern 'FoxFunc.dll' void myStrFunc(LPCSTR str1);
来自“http://www.hs633.com/kthelp/index.php?title=Void_%E5%A3%B0%E6%98%8EDLL%E6%97%A0%E8%BF%94%E5%9B%9E%E5%80%BC%E5%87%BD%E6%95%B0&oldid=1913”


DynaInfo

函数 | DynaInfo
别名 | 动态行情
所属类别 | 财务数据
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 动态行情
用法 | DYNAINFO(Q_DATE)
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo&oldid=1088”


DynaInfo02

函数 | DynaInfo02
别名 | 品种动态行情
所属类别 | 财务数据
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 品种动态行情
用法 | DYNAINFO2(Q_DATE, )
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo02&oldid=1089”


Finance

函数 | Finance
别名 | 财务数据
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据函数
用法 | FINANCE(0);
来自“http://www.hs633.com/kthelp/index.php?title=Finance&oldid=1087”


Finance(0)

函数 | Finance(0)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:更新日期
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(0)&oldid=1021”


Finance(1)

函数 | Finance(1)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:总股本(万股)
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(1)&oldid=1023”


Finance(10)

函数 | Finance(10)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:总资产(千元)
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(10)&oldid=1000”


Finance(11)

函数 | Finance(11)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:流动资产
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(11)&oldid=1031”


Finance(12)

函数 | Finance(12)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:固定资产
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(12)&oldid=1032”


Finance(13)

函数 | Finance(13)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:无形资产
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(13)&oldid=1033”


Finance(14)

函数 | Finance(14)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:长期投资
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(14)&oldid=1034”


Finance(15)

函数 | Finance(15)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:流动负债
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(15)&oldid=1035”


Finance(16)

函数 | Finance(16)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:长期负债
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(16)&oldid=1036”


Finance(17)

函数 | Finance(17)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:资本公积金
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(17)&oldid=1037”


Finance(18)

函数 | Finance(18)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:每股公积金
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(18)&oldid=1038”


Finance(19)

函数 | Finance(19)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:股东权益
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(19)&oldid=1039”


Finance(2)

函数 | Finance(2)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:国家股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(2)&oldid=1022”


Finance(20)

函数 | Finance(20)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:主营收入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(20)&oldid=1040”


Finance(21)

函数 | Finance(21)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:主营利润
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(21)&oldid=1041”


Finance(22)

函数 | Finance(22)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:其他利润
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(22)&oldid=1042”


Finance(23)

函数 | Finance(23)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:营业利润
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(23)&oldid=1043”


Finance(24)

函数 | Finance(24)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:投资收益
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(24)&oldid=1044”


Finance(25)

函数 | Finance(25)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:补贴收入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(25)&oldid=1045”


Finance(26)

函数 | Finance(26)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:营业外收支
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(26)&oldid=1046”


Finance(27)

函数 | Finance(27)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:损益调整
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(27)&oldid=1047”


Finance(28)

函数 | Finance(28)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:利润总额
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(28)&oldid=1048”


Finance(29)

函数 | Finance(29)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:税后利润
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(29)&oldid=1049”


Finance(3)

函数 | Finance(3)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:发起法人股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(3)&oldid=1024”


Finance(30)

函数 | Finance(30)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:净利润
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(30)&oldid=1050”


Finance(31)

函数 | Finance(31)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:未分配利润
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(31)&oldid=1051”


Finance(32)

函数 | Finance(32)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:每股未分配
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(32)&oldid=1052”


Finance(33)

函数 | Finance(33)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:每股收益
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(33)&oldid=1053”


Finance(34)

函数 | Finance(34)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:每股净资
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(34)&oldid=1054”


Finance(35)

函数 | Finance(35)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:调整每股净资
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(35)&oldid=1055”


Finance(36)

函数 | Finance(36)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:股东权益比率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(36)&oldid=1056”


Finance(37)

函数 | Finance(37)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:净资收益率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(37)&oldid=1057”


Finance(38)

函数 | Finance(38)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:经营现金流入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(38)&oldid=1058”


Finance(39)

函数 | Finance(39)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:经营现金流出
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(39)&oldid=1059”


Finance(4)

函数 | Finance(4)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:法人股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(4)&oldid=1025”


Finance(40)

函数 | Finance(40)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:经营现金流量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(40)&oldid=1060”


Finance(41)

函数 | Finance(41)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:投资现金流入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(41)&oldid=1061”


Finance(42)

函数 | Finance(42)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:投资现金流出
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(42)&oldid=1063”


Finance(43)

函数 | Finance(43)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:投资现金流量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(43)&oldid=1064”


Finance(44)

函数 | Finance(44)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:筹资现金流入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(44)&oldid=1065”


Finance(45)

函数 | Finance(45)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:筹资现金流出
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(45)&oldid=1066”


Finance(46)

函数 | Finance(46)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:筹资现金流量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(46)&oldid=1069”


Finance(47)

函数 | Finance(47)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:现金及等价物
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(47)&oldid=1071”


Finance(48)

函数 | Finance(48)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:应收帐款周转率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(48)&oldid=1074”


Finance(49)

函数 | Finance(49)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:存货周转率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(49)&oldid=1075”


Finance(5)

函数 | Finance(5)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:B股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(5)&oldid=1026”


Finance(50)

函数 | Finance(50)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:股东总数
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(50)&oldid=1076”


Finance(51)

函数 | Finance(51)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:发行价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(51)&oldid=1077”


Finance(52)

函数 | Finance(52)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:发行量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(52)&oldid=1078”


Finance(53)

函数 | Finance(53)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:主营业务增长率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(53)&oldid=1079”


Finance(54)

函数 | Finance(54)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:税后利润增长率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(54)&oldid=1080”


Finance(55)

函数 | Finance(55)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:净资产增长率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(55)&oldid=1081”


Finance(56)

函数 | Finance(56)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:总资产增长率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(56)&oldid=1082”


Finance(6)

函数 | Finance(6)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:Ｈ股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(6)&oldid=1027”


Finance(7)

函数 | Finance(7)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:流通A股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(7)&oldid=1028”


Finance(8)

函数 | Finance(8)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:职工股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(8)&oldid=1029”


Finance(9)

函数 | Finance(9)
别名 | 无
所属类别 | 财务数据
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 财务数据:A2转配股
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=Finance(9)&oldid=1030”


Finance2

函数 | Finance2
别名 | 品种财务数据
所属类别 | 财务数据
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 指定品种财务数据函数
用法 | FINANCE2(N, STKLABEL) 取得品种代码STKLABEL的对应财务数据 例如: FINANCE2(1, '600000') 表示取得600000的总股本 注意: 该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=Finance2&oldid=1084”


Capital 流通盘大小

函数 | Capital
别名 | 流通盘大小
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 流通盘大小。
用法 | CAPITAL，返回流通盘大小，单位为手。 对于A股得到流通A股，B股得到B股总股本，指数为0 注意：该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=Capital_%E6%B5%81%E9%80%9A%E7%9B%98%E5%A4%A7%E5%B0%8F&oldid=1297”


DataCount 序列数据量

函数 | DataCount
别名 | 序列数据量
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 序列数据量。
用法 | DATACOUNT，返回序列数据数量 注意：该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=DataCount_%E5%BA%8F%E5%88%97%E6%95%B0%E6%8D%AE%E9%87%8F&oldid=1298”


DataPeriod 当前数据周期

函数 | DataPeriod
别名 | 当前数据周期
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 当前数据周期。
用法 | DATAPERIOD 返回以下枚举值 P_TICK, 分笔 P_MIN1, 1分钟 P_MIN5, 5分钟 P_MIN15, 15分钟 P_MIN30, 30分钟 P_MIN60, 60分钟 P_HOUR1, 1小时 P_HOUR4, 4小时 P_DAY, 日线 P_WEEK, 周线 P_MONTH, 月线 P_QUARTER, 季线 P_HALFYEAR, 半年线 P_YEAR, 年线
来自“http://www.hs633.com/kthelp/index.php?title=DataPeriod_%E5%BD%93%E5%89%8D%E6%95%B0%E6%8D%AE%E5%91%A8%E6%9C%9F&oldid=1300”


DataType 数据周期类型

函数 | DataType
别名 | 数据周期类型
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 当前数据周期类型。
用法 | DATATYPE 返回值范围为-1-12，分别表示 即时图、分笔成交、1分钟、5分钟、15分钟、30分钟、 60分钟、日、周、月、年、多日、多分钟、多秒
来自“http://www.hs633.com/kthelp/index.php?title=DataType_%E6%95%B0%E6%8D%AE%E5%91%A8%E6%9C%9F%E7%B1%BB%E5%9E%8B&oldid=1299”


DataTypeM DATAPERIODM, 数据周期设定值

函数 | DataTypeM
别名 | DATAPERIODM, 数据周期设定值
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 当前数据周期设定值。
用法 | DATATYPEM 于当前多分、多日、多秒周期，取得其周期的设定值。 若不是多分、多日、多秒周期则返回零值。 但若为季度线返回-1，半年线返回-2，节气线返回-3。 例如：3日、3分、3秒之DATATYPEM=3，6日、6分、6秒之DATATYPEM=6 组合DATATYPE=11 and DATATYPEM=3 可判断当前周期是否为3分钟线
来自“http://www.hs633.com/kthelp/index.php?title=DataTypeM_DATAPERIODM,_%E6%95%B0%E6%8D%AE%E5%91%A8%E6%9C%9F%E8%AE%BE%E5%AE%9A%E5%80%BC&oldid=1301”


FindIndexByTime 按时间寻找K线

函数 | FindIndexByTime
别名 | 按时间寻找K线
所属类别 | 常数函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 特定时间的K线位置。
用法 | FINDINDEXBYTIME(Y),返回当时间为Y时，K线的序列索引 时间格式:'yymmdd HHMMSS' 或'HHMMSS' 例如: FINDINDEXBYTIME('20060601 093001')或FINDINDEXBYTIME('093001')
来自“http://www.hs633.com/kthelp/index.php?title=FindIndexByTime_%E6%8C%89%E6%97%B6%E9%97%B4%E5%AF%BB%E6%89%BEK%E7%BA%BF&oldid=1302”


Invalid 无效数据

函数 | Invalid
别名 | 无效数据
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 代表无效数据。当一个数被赋值为无效时，图上将不会显示它的值。
用法 | c1:if(c>o,c,invalid); 那些为invalid的点不画，并且有效的点会连起来。 c1:if(c>o,c,invalid),NoDrawInvalid; 那些为invalid的点不画，有效的点碰到无效点不连起来 对无效数据的判断： 当某个值，假设是x，为无效时，x 不等于 x 。 也就是说 x != x 为真 例子： bb:RefData( , D_CLOSE, P_DAY, 0 ); if(bb[DataCount-1]!=bb[DataCount-1] )then Comment('yes'); else Comment('no'); 无效值在dll中如何表示： 通过 std::numeric_limits::quiet_nan() 来表示
来自“http://www.hs633.com/kthelp/index.php?title=Invalid_%E6%97%A0%E6%95%88%E6%95%B0%E6%8D%AE&oldid=1308”


IsSplit 复权处理

函数 | IsSplit
别名 | 复权处理
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 是否复权处理
用法 | ISSPLIT 复权处理返回>0,数值随复权方式不同而不同，否则为0 注意：该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=IsSplit_%E5%A4%8D%E6%9D%83%E5%A4%84%E7%90%86&oldid=1303”


LBound 序列下界

函数 | LBound
别名 | 序列下界
所属类别 | 常数函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 序列最小下标。
用法 | LBOUND(X) 返回序列X的下界(最小下标),即为第一个有效数据下标,若无有效数据返回0 可通过SETLBOUND(X,N)函数设置序列变量X的下界(最小下标)
来自“http://www.hs633.com/kthelp/index.php?title=LBound_%E5%BA%8F%E5%88%97%E4%B8%8B%E7%95%8C&oldid=1304”


MinDiff minmovevalue,最小变动价位

函数 | MinDiff
别名 | minmovevalue,最小变动价位
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回当前品种最小变动价位。
用法 | MINDIFF 对于深沪股票为0.01，深沪基金为0.001 注意：该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=MinDiff_minmovevalue,%E6%9C%80%E5%B0%8F%E5%8F%98%E5%8A%A8%E4%BB%B7%E4%BD%8D&oldid=1305”


UBound 序列上界

函数 | UBound
别名 | 序列上界
所属类别 | 常数函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 序列最大下标。
用法 | UBOUND(X) 返回序列的上界(最大下标)
来自“http://www.hs633.com/kthelp/index.php?title=UBound_%E5%BA%8F%E5%88%97%E4%B8%8A%E7%95%8C&oldid=1306”


VolUnit 每手股数

函数 | VolUnit
别名 | 每手股数
所属类别 | 常数函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 每手股数。
用法 | VOLUNIT 返回每手股数(可在市场管理中设置)，对于深沪股票为100，深沪债券为10 注意：该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=VolUnit_%E6%AF%8F%E6%89%8B%E8%82%A1%E6%95%B0&oldid=1307”


DynaInfo 动态行情函数

函数 | DynaInfo
别名 | 动态行情
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 动态行情函数
用法 DynaInfo(TYPE) 取得对应的动态行情数据, 如DynaInfo(Q_PREVCLOSE) ,获取动态行情前收;

同时也支持DynaInfo(N)写法， ,如DynaInfo(3)获取动态行情前收，详细说明请参考函数字典; 注意：该函数返回常数。 TYPE 类型如下 3 Q_PRECLOSE 前收 4 Q_OPEN 今开 5 Q_HIGH 最高 6 Q_LOW 最低 7 Q_LAST 最新 8 Q_VOL 总手 9 Q_LASTVOL 现手 10 Q_AMOUNT 总额（持仓） 11 Q_AVGPRICE 均价 12 Q_NETCHG 涨跌 13 Q_OSCILLATION 振幅 14 Q_CHG 涨幅 15 Q_ABRATE 委比 16 Q_ABDIFF 委差 17 Q_VOLRATE 量比 18 Q_BIDVOL 委买量 19 Q_ASKVOL 委卖量 20 Q_BID 委买价 21 Q_ASK 委卖价 22 Q_BVOL 内盘 23 Q_BVOL 外盘 24 Q_CHGSPEED 涨速 25 Q_BIDVOL1 买一量 26 Q_BIDVOL2 买二量 27 Q_BIDVOL3 买三量 28 Q_BIDPX1 买一价 29 Q_BIDPX2(Q_BID2) 买二价 30 Q_BIDPX3(Q_BID3) 买三价 31 Q_ASKVOL1 卖一量 32 Q_ASKVOL2 卖二量 33 Q_ASKVOL3 卖三量 34 Q_ASKPX1(Q_ASK1) 卖一价 35 Q_ASKPX2(Q_ASK2) 卖二价 36 Q_ASKPX3(Q_ASK3) 卖三价 37 Q_TURNOVER 换手率（仓差） 38 Q_5DAVGVOL 5日均量 39 Q_PE 市盈率 40 Q_BUYSELL 成交方向 41 Q_LASTINT 总市值(昨持仓) 42 Q_MARKETVAL 流通市值 43 Q_BIDVOL4 买四量 44 Q_BIDVOL5 买五量 45 Q_BIDPX4(Q_BID4) 买四价 46 Q_BIDPX5(Q_BID5) 买五价 47 Q_ASKVOL4 卖四量 48 Q_ASKVOL5 卖五量 49 Q_ASKPX4(Q_ASK4) 卖四价 50 Q_ASKPX5(Q_ASK5) 卖五价 51 Q_TICKCOUNT 成交笔数 52 Q_AVGVOL 每笔均量 53 Q_UPPERLIMIT 涨停价 54 Q_LOWERLIMIT 跌停价 55 Q_DATETIME 最终行情时间

来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo_%E5%8A%A8%E6%80%81%E8%A1%8C%E6%83%85%E5%87%BD%E6%95%B0&oldid=913”


DynaInfo(10)

函数 | DynaInfo(10)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:总额(持仓)
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(10)&oldid=922”


DynaInfo(100)

函数 | DynaInfo(100)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构吃货量
用法 | 注意：该函数返回常数，仅适用于L2行情。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(100)&oldid=923”


DynaInfo(101)

函数 | DynaInfo(101)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构吐货量
用法 | 注意：该函数返回常数，仅适用于L2行情。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(101)&oldid=924”


DynaInfo(102)

函数 | DynaInfo(102)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构吃货均额
用法 | 注意：该函数返回常数，仅适用于L2行情。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(102)&oldid=925”


DynaInfo(103)

函数 | DynaInfo(103)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构吐货均额
用法 | 注意：该函数返回常数，仅适用于L2行情。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(103)&oldid=926”


DynaInfo(11)

函数 | DynaInfo(11)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:均价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(11)&oldid=927”


DynaInfo(12)

函数 | DynaInfo(12)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:涨跌
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(12)&oldid=933”


DynaInfo(13)

函数 | DynaInfo(13)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:振幅
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(13)&oldid=929”


DynaInfo(14)

函数 | DynaInfo(14)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:涨幅
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(14)&oldid=930”


DynaInfo(15)

函数 | DynaInfo(15)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:委比
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(15)&oldid=931”


DynaInfo(16)

函数 | DynaInfo(16)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:委差
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(16)&oldid=935”


DynaInfo(17)

函数 | DynaInfo(17)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:量比
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(17)&oldid=936”


DynaInfo(18)

函数 | DynaInfo(18)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:委买量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(18)&oldid=937”


DynaInfo(19)

函数 | DynaInfo(19)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:委卖量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(19)&oldid=938”


DynaInfo(20)

函数 | DynaInfo(20)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:委买价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(20)&oldid=939”


DynaInfo(21)

函数 | DynaInfo(21)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:委卖价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(21)&oldid=940”


DynaInfo(22)

函数 | DynaInfo(22)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:内盘
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(22)&oldid=941”


DynaInfo(23)

函数 | DynaInfo(23)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:外盘
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(23)&oldid=942”


DynaInfo(24)

函数 | DynaInfo(24)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:涨速
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(24)&oldid=943”


DynaInfo(25)

函数 | DynaInfo(25)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买一量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(25)&oldid=944”


DynaInfo(26)

函数 | DynaInfo(26)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买二量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(26)&oldid=945”


DynaInfo(27)

函数 | DynaInfo(27)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买三量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(27)&oldid=946”


DynaInfo(28)

函数 | DynaInfo(28)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买一价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(28)&oldid=947”


DynaInfo(29)

函数 | DynaInfo(29)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买二价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(29)&oldid=948”


DynaInfo(3)

函数 | DynaInfo(3)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:前收
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(3)&oldid=934”


DynaInfo(30)

函数 | DynaInfo(30)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买三价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(30)&oldid=949”


DynaInfo(31)

函数 | DynaInfo(31)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖一量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(31)&oldid=950”


DynaInfo(32)

函数 | DynaInfo(32)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖二量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(32)&oldid=951”


DynaInfo(33)

函数 | DynaInfo(33)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖三量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(33)&oldid=952”


DynaInfo(34)

函数 | DynaInfo(34)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖一价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(34)&oldid=953”


DynaInfo(35)

函数 | DynaInfo(35)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖二价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(35)&oldid=954”


DynaInfo(36)

函数 | DynaInfo(36)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖三价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(36)&oldid=955”


DynaInfo(37)

函数 | DynaInfo(37)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:换手率(仓差)
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(37)&oldid=956”


DynaInfo(38)

函数 | DynaInfo(38)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:5日均量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(38)&oldid=957”


DynaInfo(39)

函数 | DynaInfo(39)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:市盈率
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(39)&oldid=958”


DynaInfo(4)

函数 | DynaInfo(4)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:今开
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(4)&oldid=915”


DynaInfo(40)

函数 | DynaInfo(40)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:成交方向
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(40)&oldid=959”


DynaInfo(41)

函数 | DynaInfo(41)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:总市值(昨持仓)
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(41)&oldid=960”


DynaInfo(42)

函数 | DynaInfo(42)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:流通市值
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(42)&oldid=961”


DynaInfo(43)

函数 | DynaInfo(43)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买四量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(43)&oldid=962”


DynaInfo(44)

函数 | DynaInfo(44)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买五量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(44)&oldid=963”


DynaInfo(45)

函数 | DynaInfo(45)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买四价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(45)&oldid=964”


DynaInfo(46)

函数 | DynaInfo(46)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:买五价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(46)&oldid=965”


DynaInfo(47)

函数 | DynaInfo(47)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖四量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(47)&oldid=966”


DynaInfo(48)

函数 | DynaInfo(48)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖五量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(48)&oldid=967”


DynaInfo(49)

函数 | DynaInfo(49)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖四价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(49)&oldid=968”


DynaInfo(5)

函数 | DynaInfo(5)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:最高
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(5)&oldid=916”


DynaInfo(50)

函数 | DynaInfo(50)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:卖五价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(50)&oldid=969”


DynaInfo(51)

函数 | DynaInfo(51)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:成交笔数
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(51)&oldid=970”


DynaInfo(52)

函数 | DynaInfo(52)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:每笔均量
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(52)&oldid=971”


DynaInfo(53)

函数 | DynaInfo(53)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:涨停价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(53)&oldid=972”


DynaInfo(54)

函数 | DynaInfo(54)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:跌停价
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(54)&oldid=973”


DynaInfo(55)

函数 | DynaInfo(55)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:最终行情时间
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(55)&oldid=974”


DynaInfo(6)

函数 | DynaInfo(6)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:最低
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(6)&oldid=917”


DynaInfo(7)

函数 | DynaInfo(7)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:最新
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(7)&oldid=918”


DynaInfo(8)

函数 | DynaInfo(8)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:总手
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(8)&oldid=919”


DynaInfo(87)

函数 | DynaInfo(87)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 买入单
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(87)&oldid=975”


DynaInfo(88)

函数 | DynaInfo(88)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 卖出单数
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(88)&oldid=976”


DynaInfo(89)

函数 | DynaInfo(89)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 中单买入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(89)&oldid=977”


DynaInfo(9)

函数 | DynaInfo(8)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:现手
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(9)&oldid=921”


DynaInfo(90)

函数 | DynaInfo(90)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 大单买入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(90)&oldid=978”


DynaInfo(91)

函数 | DynaInfo(91)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 特大买入
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(91)&oldid=979”


DynaInfo(92)

函数 | DynaInfo(92)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 中单卖出
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(92)&oldid=980”


DynaInfo(93)

函数 | DynaInfo(93)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 大单卖出
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(93)&oldid=981”


DynaInfo(94)

函数 | DynaInfo(94)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 特大卖出
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(94)&oldid=982”


DynaInfo(95)

函数 | DynaInfo(95)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构买单
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(95)&oldid=983”


DynaInfo(96)

函数 | DynaInfo(96)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构卖单
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(96)&oldid=984”


DynaInfo(97)

函数 | DynaInfo(97)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构单数差
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(97)&oldid=985”


DynaInfo(98)

函数 | DynaInfo(98)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构吃货数
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(98)&oldid=986”


DynaInfo(99)

函数 | DynaInfo(99)
别名 | 无
所属类别 | 动态行情
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 动态行情:取得最新动态行情: 机构吐货数
用法 | 注意：该函数返回常数。
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo(99)&oldid=987”


DynaInfo02 品种动态行情

函数 | DynaInfo02
别名 | 品种动态行情
所属类别 | 动态行情
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 指定品种动态行情函数
用法 | DYNAINFO2(N, STKLABEL) 取得品种代码STKLABEL的对应动态行情数据 例如: DYNAINFO2(20, 'cu09') 表示取得cu09的委买价 注意: 该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=DynaInfo02_%E5%93%81%E7%A7%8D%E5%8A%A8%E6%80%81%E8%A1%8C%E6%83%85&oldid=988”


Ai_BuyFreeze

函数 | Ai_BuyFreeze
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的买入委托冻结
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_BuyFreeze&oldid=1785”


Ai_BuyMargin

函数 | Ai_BuyMargin
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的买入保证金
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_BuyMargin&oldid=1783”


Ai_CurrenteQuity

函数 | Ai_CurrenteQuity
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的动态权益
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_CurrenteQuity&oldid=1780”


Ai_OpenProfit

函数 | Ai_OpenProfit
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的浮动盈亏
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_OpenProfit&oldid=1782”


Ai_PreviouseQuity

函数 | Ai_PreviouseQuity
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的昨日结存
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_PreviouseQuity&oldid=1781”


Ai_SellFreeze

函数 | Ai_SellFreeze
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的卖出委托冻结
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_SellFreeze&oldid=1786”


Ai_SellMargin

函数 | Ai_SellMargin
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的卖出保证金
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_SellMargin&oldid=1784”


Ai_TodayDePosit

函数 | Ai_TodayDePosit
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的当日入金
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_TodayDePosit&oldid=1787”


Ai_TodayDrawing

函数 | Ai_TodayDrawing
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回指定的账户的当日出金
用法 | 参考 AccountInfo(Attribute)
来自“http://www.hs633.com/kthelp/index.php?title=Ai_TodayDrawing&oldid=1788”


C_Blk_Index

函数 | C_Blk_Index
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 板块指数
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Blk_Index&oldid=1805”


C_Bonds

函数 | C_Bonds
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 债券
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Bonds&oldid=1798”


C_Conertible Bonds

函数 | C_Conertible_Bonds
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 可转换债券
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Conertible_Bonds&oldid=1807”


C_CurrencyOption

函数 | C_CurrencyOption
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 货币期权
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_CurrencyOption&oldid=1818”


C_Enterprise_Bonds

函数 | C_Enterprise_Bonds
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 企业债
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Enterprise_Bonds&oldid=1808”


C_Fe

函数 | C_Fe
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 外汇
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Fe&oldid=1799”


C_Fund

函数 | C_Fund
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 基金
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Fund&oldid=1797”


C_Fut_Option

函数 | C_Fut_Option
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 选择权
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Fut_Option&oldid=1801”


C_Futures

函数 | C_Futures
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 期货
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Futures&oldid=1796”


C_Gem

函数 | C_Gem
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 创业板
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Gem&oldid=1794”


C_Index

函数 | C_Index
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 指数
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Index&oldid=1789”


C_IndexOption

函数 | C_IndexOption
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 指数期权
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_IndexOption&oldid=1817”


C_Ins_Index

函数 | C_Ins_Index
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 投资指数
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Ins_Index&oldid=1804”


C_Lending

函数 | C_Lending
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 拆解
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Lending&oldid=1811”


C_Long_Contrace

函数 | C_Long_Contrace
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 长远期合约
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Long_Contrace&oldid=1810”


C_Mas

函数 | C_Mas
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 中小板
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Mas&oldid=1795”


C_MoneyMarketFund

函数 | C_MoneyMarketFund
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 货币基金
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_MoneyMarketFund&oldid=1816”


C_MutualFund

函数 | C_MutualFund
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 开放基金
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_MutualFund&oldid=1814”


C_Now_Bonds

函数 | C_Now_Bonds
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 现券
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Now_Bonds&oldid=1809”


C_Other

函数 | C_Other
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 其他证券
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Other&oldid=1813”


C_Repurchase

函数 | C_Repurchase
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 回购
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Repurchase&oldid=1803”


C_Spot

函数 | C_Spot
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 现货
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Spot&oldid=1800”


C_Spread

函数 | C_Spread
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 价差(台湾市场有)
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Spread&oldid=1820”


C_Stock_A

函数 | C_Stock_A
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | A股
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Stock_A&oldid=1790”


C_Stock_B

函数 | C_Stock_B
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | B股
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Stock_B&oldid=1791”


C_Stock_H

函数 | C_Stock_H
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | H股
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Stock_H&oldid=1792”


C_Stock_N

函数 | C_Stock_N
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | N股
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Stock_N&oldid=1793”


C_Tl_Index

函数 | C_Tl_Index
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 套利指数
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Tl_Index&oldid=1812”


C_Treasury_Bonds

函数 | C_Treasury_Bonds
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 国债
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Treasury_Bonds&oldid=1806”


C_Warrant

函数 | C_Warrant
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 权证
用法 | 参考 Category
来自“http://www.hs633.com/kthelp/index.php?title=C_Warrant&oldid=1802”


D_Amount 成交额

函数 | D_Amount
别名 | 成交额
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 成交额
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_Amount_%E6%88%90%E4%BA%A4%E9%A2%9D&oldid=1737”


D_Capital 流通股

函数 | D_Capital
别名 | 流通股
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 流通股
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_Capital_%E6%B5%81%E9%80%9A%E8%82%A1&oldid=1740”


D_Close 收盘价

函数 | D_Close
别名 | 收盘价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 收盘价
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_Close_%E6%94%B6%E7%9B%98%E4%BB%B7&oldid=1733”


D High 最高价

函数 | D_High
别名 | 最高价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最高价
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_High_%E6%9C%80%E9%AB%98%E4%BB%B7&oldid=1732”


D_Low 最低价

函数 | D_Low
别名 | 最低价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最低价
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_Low_%E6%9C%80%E4%BD%8E%E4%BB%B7&oldid=1735”


D Open 开盘价

函数 | D_Open
别名 | 开盘价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 开盘价
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_Open_%E5%BC%80%E7%9B%98%E4%BB%B7&oldid=1734”


D_OpenInt 持仓量

函数 | D_OpenInt
别名 | 持仓量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 持仓量
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_OpenInt_%E6%8C%81%E4%BB%93%E9%87%8F&oldid=1738”


D_Volume 成交量

函数 | D_Volume
别名 | 成交量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 成交量
用法 | 详见RefData用法
来自“http://www.hs633.com/kthelp/index.php?title=D_Volume_%E6%88%90%E4%BA%A4%E9%87%8F&oldid=1736”


False

函数 | False
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | FALSE = 0
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=False&oldid=1744”


Mp_Long

函数 | Mp_Long
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | MP_LONG = 1
用法 | MP_LONG 表示多头
来自“http://www.hs633.com/kthelp/index.php?title=Mp_Long&oldid=1741”


Mp_Short

函数 | Mp_Short
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | MP_Short = 1
用法 | MP_Short 表示空头
来自“http://www.hs633.com/kthelp/index.php?title=Mp_Short&oldid=1742”


Ob_ThisBar 本周期

函数 | Ot_ThisBar
别名 | 本周期
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 本周期
用法 | 详见BUY用法
来自“http://www.hs633.com/kthelp/index.php?title=Ob_ThisBar_%E6%9C%AC%E5%91%A8%E6%9C%9F&oldid=1729”


Ot_Close 收盘单

函数 | Ot_Close
别名 | 收盘单
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 收盘单
用法 | 详见BUY用法
来自“http://www.hs633.com/kthelp/index.php?title=Ot_Close_%E6%94%B6%E7%9B%98%E5%8D%95&oldid=1727”


Ot_Limit 限价单

函数 | Ot_Limit
别名 | 限价单
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 限价单
用法 | 详见BUY用法
来自“http://www.hs633.com/kthelp/index.php?title=Ot_Limit_%E9%99%90%E4%BB%B7%E5%8D%95&oldid=1724”


Ot_Market 市价单

函数 | Ot_Market
别名 | 市价单
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 市价单
用法 | 详见BUY用法
来自“http://www.hs633.com/kthelp/index.php?title=Ot_Market_%E5%B8%82%E4%BB%B7%E5%8D%95&oldid=1723”


Ot_NextBar 次周期

函数 | Ot_NextBar
别名 | 次周期
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 次周期
用法 | 详见BUY用法
来自“http://www.hs633.com/kthelp/index.php?title=Ot_NextBar_%E6%AC%A1%E5%91%A8%E6%9C%9F&oldid=1728”


Ot_Open 开盘单

函数 | Ot_Open
别名 | 开盘单
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 开盘单
用法 | 详见BUY用法
来自“http://www.hs633.com/kthelp/index.php?title=Ot_Open_%E5%BC%80%E7%9B%98%E5%8D%95&oldid=1726”


Ot_Stop STOP单、停损单

函数 | Ot_Stop
别名 | STOP单、停损单
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | STOP单、停损单
用法 | 详见BUY用法
来自“http://www.hs633.com/kthelp/index.php?title=Ot_Stop_STOP%E5%8D%95%E3%80%81%E5%81%9C%E6%8D%9F%E5%8D%95&oldid=1725”


P_Day 日线

函数 | P_Day
别名 | 日线
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 日线
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Day_%E6%97%A5%E7%BA%BF&oldid=1830”


P HalfYear 半年线

函数 | P_HalfYear
别名 | 半年线
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 半年线
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_HalfYear_%E5%8D%8A%E5%B9%B4%E7%BA%BF&oldid=1834”


P_Hour1 1小时

函数 | P_Hour1
别名 | 1小时
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 1小时
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Hour1_1%E5%B0%8F%E6%97%B6&oldid=1828”


P_Hour4 4小时

函数 | P_Hour4
别名 | 4小时
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 4小时
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Hour4_4%E5%B0%8F%E6%97%B6&oldid=1829”


P_Min1 1分钟

函数 | P_Min1
别名 | 1分钟
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 1分钟
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Min1_1%E5%88%86%E9%92%9F&oldid=1823”


P Min15 15分钟

函数 | P_Min15
别名 | 15分钟
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 15分钟
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Min15_15%E5%88%86%E9%92%9F&oldid=1825”


P_Min30 30分钟

函数 | P_Min30
别名 | 30分钟
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 30分钟
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Min30_30%E5%88%86%E9%92%9F&oldid=1826”


P_Min5 5分钟

函数 | P_Min5
别名 | 5分钟
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 5分钟
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Min5_5%E5%88%86%E9%92%9F&oldid=1824”


P_Min60 60分钟

函数 | P_Min60
别名 | 60分钟
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 60分钟
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Min60_60%E5%88%86%E9%92%9F&oldid=1827”


P_Month 月线

函数 | P_Month
别名 | 月线
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 月线
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Month_%E6%9C%88%E7%BA%BF&oldid=1832”


P_Quarter 季线

函数 | P_Quarter
别名 | 季线
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 季线
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Quarter_%E5%AD%A3%E7%BA%BF&oldid=1833”


P_Tick 分笔

函数 | P_Tick
别名 | 分笔
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 分笔
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Tick_%E5%88%86%E7%AC%94&oldid=1822”


P_Week 周线

函数 | P_Week
别名 | 周线
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 周线
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Week_%E5%91%A8%E7%BA%BF&oldid=1831”


P_Year 年线

函数 | P_Year
别名 | 年线
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 年线
用法 | 参考 RefData
来自“http://www.hs633.com/kthelp/index.php?title=P_Year_%E5%B9%B4%E7%BA%BF&oldid=1835”


Pi_AutoTrade

函数 | P_AutoTrade
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 自动交易
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_AutoTrade&oldid=1836”


Pi_AutoTradeConf

函数 | P_AutoTradeConf
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 自动交易下单需要手工确认
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_AutoTradeConf&oldid=1837”


Pi_LeftDispDateTime

函数 | P_LeftDispDateTime
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 主图最左边K线时间
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_LeftDispDateTime&oldid=1842”


Pi_Optimization

函数 | P_Optimization
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 参数优化
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_Optimization&oldid=1840”


Pi_RealTimeCalc

函数 | P_RealTimeCalc
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 基于实时数据
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_RealTimeCalc&oldid=1838”


Pi_RightDispDateTime

函数 | P_RightDispDateTime
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 主图最右边K线时间
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_RightDispDateTime&oldid=1843”


Pi_SpaceToRight

函数 | P_SpaceToRight
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 主图右边留空K线数
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Pi_SpaceToRight&oldid=1844”


Pi_StrategyTesting

函数 | P_StrategyTesting
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 历史测试
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_StrategyTesting&oldid=1839”


Pi_VisualMode

函数 | P_VisualMode
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 可视模式
用法 | 参考 AppInfo
来自“http://www.hs633.com/kthelp/index.php?title=Pi_VisualMode&oldid=1841”


Q_Amount 总额

函数 | Q_Amount
别名 | 总额
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 总额
用法 | DynaInfo(Q_Amount)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Amount_%E6%80%BB%E9%A2%9D&oldid=1755”


Q_Ask 委卖价

函数 | Q_Ask
别名 | 委卖价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 委卖价
用法 | DynaInfo(Q_ASK)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Ask_%E5%A7%94%E5%8D%96%E4%BB%B7&oldid=1779”


Q_Ask1 卖一价

函数 | Q_Ask1
别名 | 卖一价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 卖一价
用法 | DynaInfo(Q_Ask1)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Ask1_%E5%8D%96%E4%B8%80%E4%BB%B7&oldid=1764”


Q Ask4 卖四价

函数 | Q_Ask4
别名 | 卖四价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 卖四价
用法 | DynaInfo(Q_Ask4)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Ask4_%E5%8D%96%E5%9B%9B%E4%BB%B7&oldid=1768”


Q_AskVol 委卖量

函数 | Q_AskVol
别名 | 委卖量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 委卖量
用法 | DynaInfo(Q_ASKVOL)
来自“http://www.hs633.com/kthelp/index.php?title=Q_AskVol_%E5%A7%94%E5%8D%96%E9%87%8F&oldid=1776”


Q_AskVol1 卖一量

函数 | Q_AskVol1
别名 | 卖一量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 卖一量
用法 | DynaInfo(Q_AskVol1)
来自“http://www.hs633.com/kthelp/index.php?title=Q_AskVol1_%E5%8D%96%E4%B8%80%E9%87%8F&oldid=1772”


Q_AskVol4 卖四量

函数 | Q_AskVol4
别名 | 卖四量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 卖四量
用法 | DynaInfo(Q_AskVol4)
来自“http://www.hs633.com/kthelp/index.php?title=Q_AskVol4_%E5%8D%96%E5%9B%9B%E9%87%8F&oldid=1759”


Q_AvgPrice 均价

函数 | Q_AvgPrice
别名 | 均价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 涨跌
用法 | DynaInfo(Q_AvgPrice)
来自“http://www.hs633.com/kthelp/index.php?title=Q_AvgPrice_%E5%9D%87%E4%BB%B7&oldid=1757”


Q_Bid 委买价

函数 | Q_Bid
别名 | 委买价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 委买价
用法 | DynaInfo(Q_BID)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Bid_%E5%A7%94%E4%B9%B0%E4%BB%B7&oldid=1778”


Q_Bid1 买一价

函数 | Q_Bid1
别名 | 买一价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 买一价
用法 | DynaInfo(Q_BID1)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Bid1_%E4%B9%B0%E4%B8%80%E4%BB%B7&oldid=1777”


Q_Bid4 买四价

函数 | Q_Bid4
别名 | 买四价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 买四价
用法 | DynaInfo(Q_Bid4)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Bid4_%E4%B9%B0%E5%9B%9B%E4%BB%B7&oldid=1765”


Q_BidVol 委买量

函数 | Q_BidVol
别名 | 委买量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 委买量
用法 | DynaInfo(Q_BidVol)
来自“http://www.hs633.com/kthelp/index.php?title=Q_BidVol_%E5%A7%94%E4%B9%B0%E9%87%8F&oldid=1774”


Q_BidVol1 买一量

函数 | Q_BidVol1
别名 | 买一量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 买一量
用法 | DynaInfo(Q_BidVol1)
来自“http://www.hs633.com/kthelp/index.php?title=Q_BidVol1_%E4%B9%B0%E4%B8%80%E9%87%8F&oldid=1767”


Q_BidVol4 买四量

函数 | Q_BidVol4
别名 | 买四量
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 买四量
用法 | DynaInfo(Q_BidVol4)
来自“http://www.hs633.com/kthelp/index.php?title=Q_BidVol4_%E4%B9%B0%E5%9B%9B%E9%87%8F&oldid=1756”


Q_Date

函数 | Q_Date
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | Q_Date = 1
用法 | DynaInfo(Q_DATE) 返回最新报价的日期
来自“http://www.hs633.com/kthelp/index.php?title=Q_Date&oldid=1745”


Q_High 最高

函数 | Q_High
别名 | 最高
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最高
用法 | DynaInfo(Q_HIGH))
来自“http://www.hs633.com/kthelp/index.php?title=Q_High_%E6%9C%80%E9%AB%98&oldid=1749”


Q_InsideVol 内盘

函数 | Q_InsideVol
别名 | 内盘
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 内盘
用法 | DynaInfo(Q_INSIDEVOL)
来自“http://www.hs633.com/kthelp/index.php?title=Q_InsideVol_%E5%86%85%E7%9B%98&oldid=1775”


Q_Last 最新

函数 | Q_Last
别名 | 最新
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最新
用法 | DynaInfo(Q_Last)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Last_%E6%9C%80%E6%96%B0&oldid=1752”


Q_LastTime 最终行情时间

函数 | Q_LastTime
别名 | 最终行情时间
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最终行情时间
用法 | DynaInfo(Q_LastTime)
来自“http://www.hs633.com/kthelp/index.php?title=Q_LastTime_%E6%9C%80%E7%BB%88%E8%A1%8C%E6%83%85%E6%97%B6%E9%97%B4&oldid=1762”


Q_LastVol 现手

函数 | Q_LastVol
别名 | 现手
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 总手
用法 | DynaInfo(Q_LastVol)
来自“http://www.hs633.com/kthelp/index.php?title=Q_LastVol_%E7%8E%B0%E6%89%8B&oldid=1753”


Q_Low 最低

函数 | Q_Low
别名 | 最低
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最低
用法 | DynaInfo(Q_Low)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Low_%E6%9C%80%E4%BD%8E&oldid=1750”


Q_LowerLimit 跌停价

函数 | Q_LowerLimit
别名 | 跌停价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 跌停价
用法 | DynaInfo(Q_LowerLimit)
来自“http://www.hs633.com/kthelp/index.php?title=Q_LowerLimit_%E8%B7%8C%E5%81%9C%E4%BB%B7&oldid=1761”


Q_Open 今开

函数 | Q_Open
别名 | 今开
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 今开
用法 | DynaInfo(Q_OPEN)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Open_%E4%BB%8A%E5%BC%80&oldid=1748”


Q_OpenInt 持仓

函数 | Q_OpenInt
别名 | 持仓
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 持仓
用法 | DynaInfo(Q_OpenInt)
来自“http://www.hs633.com/kthelp/index.php?title=Q_OpenInt_%E6%8C%81%E4%BB%93&oldid=1754”


Q_Oscillation 振幅

函数 | Q_Oscillation
别名 | 振幅
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 振幅
用法 | DynaInfo(Q_Oscillation)
来自“http://www.hs633.com/kthelp/index.php?title=Q_Oscillation_%E6%8C%AF%E5%B9%85&oldid=1769”


Q_OutsideVol 外盘

函数 | Q_OutsideVol
别名 | 外盘
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 外盘
用法 | DynaInfo(Q_OutsideVol)
来自“http://www.hs633.com/kthelp/index.php?title=Q_OutsideVol_%E5%A4%96%E7%9B%98&oldid=1773”


Q_PrevClose 前收

函数 | Q_PrevClose
别名 | 前收
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 前收
用法 | DynaInfo(Q_PREVCLOSE)
来自“http://www.hs633.com/kthelp/index.php?title=Q_PrevClose_%E5%89%8D%E6%94%B6&oldid=1747”


Q_PriceChg 涨跌

函数 | Q_PriceChg
别名 | 涨跌
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 均价
用法 | DynaInfo(Q_PriceChg)
来自“http://www.hs633.com/kthelp/index.php?title=Q_PriceChg_%E6%B6%A8%E8%B7%8C&oldid=1758”


Q_PriceChgRatio 涨幅

函数 | Q_PriceChgRatio
别名 | 涨幅
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 涨幅
用法 | DynaInfo(Q_PriceChgRatio)
来自“http://www.hs633.com/kthelp/index.php?title=Q_PriceChgRatio_%E6%B6%A8%E5%B9%85&oldid=1771”


Q_Time

函数 | Q_Time
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | Q_Time = 2
用法 | DynaInfo(Q_TIME) 返回最新报价的时间
来自“http://www.hs633.com/kthelp/index.php?title=Q_Time&oldid=1746”


Q_TotalVol 总手

函数 | Q_TotalVol
别名 | 总手
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 总手
用法 | DynaInfo(Q_TotalVol)
来自“http://www.hs633.com/kthelp/index.php?title=Q_TotalVol_%E6%80%BB%E6%89%8B&oldid=1751”


Q_UpperLimit 涨停价

函数 | Q_UpperLimit
别名 | 涨停价
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 涨停价
用法 | DynaInfo(Q_UpperLimit)
来自“http://www.hs633.com/kthelp/index.php?title=Q_UpperLimit_%E6%B6%A8%E5%81%9C%E4%BB%B7&oldid=1760”


Run_By_Bar 逐根模式

函数 | Run_By_Bar
别名 | 逐根模式
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根
说明 | 逐根模式
用法 | #RUN_BY_BAR'时，公式以逐根模式执行，对K线序列逐根执行整个公式； 说明：1.run_every_bar和run_every_tick，都是针对逐根模式的开关，逐行不支持这两种模式。所以逐行下写这两个开关实际上会被忽略。 2.智能交易类公式，系统自动强制run_by_bar模式执行，即使写run_by_serie也会被忽略。 3.技术指标里，如果指定run_by_bar模式，那么默认run_every_tick。 run_every_bar，需要指定。
来自“http://www.hs633.com/kthelp/index.php?title=Run_By_Bar_%E9%80%90%E6%A0%B9%E6%A8%A1%E5%BC%8F&oldid=1719”


Run_By_Serie 逐行模式

函数 | Run_By_Serie
别名 | 逐根模式
所属类别 | 宏
参数数量 | 0
运行模式 | 逐行
说明 | 逐行模式
用法 | #RUN_BY_SERIE时，公式以逐行(序列)模式执行，对整个K线序列逐行执行语句。
来自“http://www.hs633.com/kthelp/index.php?title=Run_By_Serie_%E9%80%90%E8%A1%8C%E6%A8%A1%E5%BC%8F&oldid=1720”


Run_Every_Bar

函数 | Run_By_Serie
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 每根K线只运行公式一次，运行时间是下一根K线的第一笔Tick到来时，交易脚本默认的运行方式；
用法 | #Run_Every_Bar'时，每根K线只运行公式一次，运行时间是下一根K线的第一笔Tick到来时，交易脚本默认的运行方式；
来自“http://www.hs633.com/kthelp/index.php?title=Run_Every_Bar&oldid=1721”


Run_Every_Tick

函数 | Run_By_Tick
别名 | 逐根模式
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 每个Tick都会触发公式运行，指标类公式的默认运行方式；
用法 | #Run_Every_Tick'时，每个Tick都会触发公式运行，指标类公式的默认运行方式； 说明：1.run_every_bar和run_every_tick，都是针对逐根模式的开关，逐行不支持这两种模式。所以逐行下写这两个开关实际上会被忽略。 2.智能交易类公式，系统自动强制run_by_bar模式执行，即使写run_by_serie也会被忽略。 3.技术指标里，如果指定run_by_bar模式，那么默认run_every_tick。 run_every_bar，需要指定。
来自“http://www.hs633.com/kthelp/index.php?title=Run_Every_Tick&oldid=1722”


True

函数 | True
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | TRUE = 1
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=True&oldid=1743”


BgColor 背景色

函数 | BgColor
别名 | 背景色
所属类别 | 绘图函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得指标窗口底色，例如可以根据不同底色设置不同的绘制颜色
用法 | BGColor 例如： If BGColor = COLORWHITE then clr := COLORBLACK; ELSE clr := COLORWHITE; Plot(X,'INDIN',LINE, clr);
来自“http://www.hs633.com/kthelp/index.php?title=BgColor_%E8%83%8C%E6%99%AF%E8%89%B2&oldid=1385”


DrawBand 画带子

函数 | DrawBand
别名 | 画带子
所属类别 | 绘图函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 在图形上绘制颜色带子。
用法 | DRAWICON(COND,PRICE,TYPE) DRAWBAND(VAL1,COLOR1,VAL2,COLOR2),当VAL1>VAL2时,在VAL1和VAL2之间填充COLOR1;当VAL1 例如:DRAWBAND(OPEN,RGB(0,224,224),CLOSE,RGB(255,96,96));
来自“http://www.hs633.com/kthelp/index.php?title=DrawBand_%E7%94%BB%E5%B8%A6%E5%AD%90&oldid=1367”


DrawBkBmp 画背景图

函数 | DrawBkBmp
别名 | 画背景图
所属类别 | 绘图函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 根据条件设置背景图。
用法 | DRAWBKBMP(COND,BMP); 当图形上最后一组COND条件满足时,以MyBMP做背景例如:DRAWBKBMP(C>O, 'MyBMP'); 表示图形上最后一组C>O时背景显示子FmlDLL目录下的MyBMP.bmp图。
来自“http://www.hs633.com/kthelp/index.php?title=DrawBkBmp_%E7%94%BB%E8%83%8C%E6%99%AF%E5%9B%BE&oldid=1364”


DrawGbk 画渐变背景色

函数 | DrawGbk
别名 | 画渐变背景色
所属类别 | 绘图函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 绘制渐变背景色。
用法 | DRAWGBK(COND,COLOR1, COLOR2,D); 当COND条件满足时,以COLOR1到COLOR2渐变色填充子图区域, D=0表示从左到右,D=1表示从上到下 例如: DRAWGBK(C>O, COLORRGB(255,0,0), COLORRGB(255,255,0),0); 表示图形上最后一组C>O时从左到右从红色到黄色渐变填充子图。
来自“http://www.hs633.com/kthelp/index.php?title=DrawGbk_%E7%94%BB%E6%B8%90%E5%8F%98%E8%83%8C%E6%99%AF%E8%89%B2&oldid=1365”


DrawIcon 画图标

函数 | DrawIcon
别名 | 画图标
所属类别 | 绘图函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 在图形上绘制小图标。
用法 | DRAWICON(COND,PRICE,TYPE) 当COND条件满足时,在PRICE位置画TYPE号图标。 15种图标编码为1-15（1-3为小脸,4-5为上下箭头,6-7为红绿小旗, 8-9为三角形,10-12为信号灯,13-15为O、X、四方形）。 TYPE为字符串时可显示用户自制BMP图或GIF图(预设为BMP)， GIF格式可支持背景透明 例如: DRAWICON(CLOSE>OPEN,LOW,4) 表示当收阳时在最低价位置画4号图标。 DRAWICON(C>O, L, 'MyICON') 表示当收阳时在最低价位置画FmlDLL子目录下的自制图标MyICON.BMP DRAWICON(C>O, L, 'MyICON.GIF') 表示当收阳时在最低价位置画FmlDLL子目录下的自制图标MyICON.GIF
来自“http://www.hs633.com/kthelp/index.php?title=DrawIcon_%E7%94%BB%E5%9B%BE%E6%A0%87&oldid=1366”


DrawLine 画直线

函数 | DrawLine
别名 | 画直线
所属类别 | 绘图函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 在图形上绘制直线段。
用法 | DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND) 当COND1条件满足时,在PRICE1位置画直线起点， 当COND2条件满足时,在PRICE2位置画直线终点， EXPAND为延长类型,0不延长,1延长。 例如: DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,10),LOW,1) 表示在创10天新高与创10天新低之间画直线并且向右延长。
来自“http://www.hs633.com/kthelp/index.php?title=DrawLine_%E7%94%BB%E7%9B%B4%E7%BA%BF&oldid=1368”


DrawNumber 显示数字

函数 | DrawNumber
别名 | 显示数字
所属类别 | 绘图函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 在图形上显示数字。
用法 | DRAWNUMBER(COND,PRICE,NUMBER,PRECISION) 当COND条件满足时,在PRICE位置书写数字NUMBER（可以为常数或数组序列） PRECISION为小数显示位数(取值范围0-7)。可ALIGN0-5定义对齐方式r 例如:DRAWNUMBER(CLOSE/OPEN>1.08,HIGH,(CLOSE-REF(C,1))/REF(C,1)*100,2) 表示当日涨幅大于8%时在最高价位置显示涨幅(相对开盘价的百分比)。
来自“http://www.hs633.com/kthelp/index.php?title=DrawNumber_%E6%98%BE%E7%A4%BA%E6%95%B0%E5%AD%97&oldid=1369”


DrawSl 画斜线

函数 | DrawSl
别名 | 画斜线
所属类别 | 绘图函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 在图形上绘制指定斜率、长度和方向的直线。
用法 | DRAWSL(COND,PRICE,SLOPE,LEN,D) 当COND条件满足时,以PRICE位置为起点绘制斜率为每个周期价差SLOPE, 长度为LEN周期的直线,LEN为0则无限延伸,D为1、2分别表示从起点向左、双 向绘制,其余表示向右绘制。 例如: DRAWSL(low=llv(low,50),low,(refx(low,5)-low)/5,5,1)
来自“http://www.hs633.com/kthelp/index.php?title=DrawSl_%E7%94%BB%E6%96%9C%E7%BA%BF&oldid=1370”


DrawText 显示文字

函数 | DrawText
别名 | 显示文字
所属类别 | 绘图函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 在图形上显示文字。
用法 | DRAWTEXT(COND,PRICE,TEXT) 当COND条件满足时,在PRICE位置书写文字TEXT,可用'\n'换行,可ALIGN0-5定义对齐方式。 例如: DRAWTEXT(CLOSE/OPEN>1.08,LOW,'大阳线') 表示当日涨幅大于8%时在最低价位置显示'大阳线'字样
来自“http://www.hs633.com/kthelp/index.php?title=DrawText_%E6%98%BE%E7%A4%BA%E6%96%87%E5%AD%97&oldid=1371”


DrawTextEx 指定位置显示文字

函数 | DrawTextEx
别名 | 指定位置显示文字
所属类别 | 绘图函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 在图形指定位置上显示文字。
用法 | DRAWTEXTEX(COND,TYPE,X,Y,TEXT) 当COND条件(COND为序列时取最后值)满足时,在图形窗口(X,Y)坐标位置书写文字TEXT， 当TYPE为0时坐标单位是像素,图形窗口左上角坐标为(0,0)。当TYPE为1时，坐标单位 是窗口沿水平和垂直方向的1/1000，X,Y取值范围是0—999,超出范围则可能显示在图形窗口外。 例如: DRAWTEXTEX(1,0,0,0,'金融板块') 表示在图形最左上角位置显示'金融板块'字样 例如: DRAWTEXTEX(C>O,1,500,500,'买进') 表示最后K线阳线时在图形中间位置显示'买进'字样
来自“http://www.hs633.com/kthelp/index.php?title=DrawTextEx_%E6%8C%87%E5%AE%9A%E4%BD%8D%E7%BD%AE%E6%98%BE%E7%A4%BA%E6%96%87%E5%AD%97&oldid=1372”


DrawYiText 显示易学文字

函数 | DrawYiText
别名 | 显示易学文字
所属类别 | 绘图函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 在图形上显示易学文字,可ALIGN0-3定义对齐方式。
用法 | DRAWYITEXT(COND,PRICE,CODE,TYPE) 当COND条件满足时,在PRICE位置书写TYPE类型的CODE的对应文字 TYPE为常数，取0--1，分别表示计算的是干支、64卦，CODE为对应的代码 例如: DRAWYITEXT(CLOSE/OPEN>1.05,LOW, GANZHI(DATE*100, 2),0) 表示当日涨幅大于5%时在最低价位置显示日干支； DRAWYITEXT(REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN, LOW, KGUA(1, 1), 1 ) 表示连二阳时在最低价位置显示K线卦象
来自“http://www.hs633.com/kthelp/index.php?title=DrawYiText_%E6%98%BE%E7%A4%BA%E6%98%93%E5%AD%A6%E6%96%87%E5%AD%97&oldid=1373”


FillRgn 画区间彩带

函数 | FillRgn
别名 | 画区间彩带
所属类别 | 绘图函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 绘制指标区间彩带。
用法 | FILLRGN(COND,PRICE1,PRICE2) 当COND条件满足时,以COLOR填充PRICE1和PRICE2的区间 例如: FILLRGN(MA1>MA2, MA1,MA2),colorred 表示MA1>MA2时以红色填充MA1和MA2之间的区域。
来自“http://www.hs633.com/kthelp/index.php?title=FillRgn_%E7%94%BB%E5%8C%BA%E9%97%B4%E5%BD%A9%E5%B8%A6&oldid=1374”


KLine 画K线

函数 | KLine
别名 | 画K线
所属类别 | 绘图函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 在图形上绘制K线。
用法 | KLINE(O,H,L,C,T) O,H,L,C分别为开高低收 T为绘制类型,0表示与主图K线画法相同,1表示不影响坐标高低值,可用于叠加在其它指标上 例如: KLINE(O,H,L,C,0) 又如: 在KDJ公式中叠加 KLINE(O,H,L,C,1)
来自“http://www.hs633.com/kthelp/index.php?title=KLine_%E7%94%BBK%E7%BA%BF&oldid=1375”


PartLine 画分段线

函数 | PartLine
别名 | 画分段线
所属类别 | 绘图函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 分段绘制指标线。
用法 | PARTLINE(COND,PRICE),满足COND条件绘制PRICE连线。 例如: PARTLINE(C>REF(C,1),C),colorred 表示收盘大于前收以红色绘制收盘价连线。
来自“http://www.hs633.com/kthelp/index.php?title=PartLine_%E7%94%BB%E5%88%86%E6%AE%B5%E7%BA%BF&oldid=1376”


PlaneLineEx 指定X轴范围画水平线

函数 | PlaneLineEx
别名 | 指定X轴范围画水平线
所属类别 | 绘图函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 指定X轴范围画水平线
用法 | PLANELINEEX(Cond,X1,X2,Y) 当Cond条件满足时(Cond为序列时取最后的值),在Y的高度位置画一根水平线(水平宽度X1~X2) 坐标单位是视图沿水平和垂直方向的1/1000,图形视图自左往右算和自底往顶算为0-999。 例如: PLANELINEEX(1,0,500,500) colorred linethick3; 表示在图形视图Y轴中央位置，画一根红色水平线(自图形视图左边画到中央)
来自“http://www.hs633.com/kthelp/index.php?title=PlaneLineEx_%E6%8C%87%E5%AE%9AX%E8%BD%B4%E8%8C%83%E5%9B%B4%E7%94%BB%E6%B0%B4%E5%B9%B3%E7%BA%BF&oldid=1377”


Plot 输出

函数 | Plot
别名 | 输出
所属类别 | 绘图函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 根据设置参数输出、绘制指标值
用法 Plot[Offset](X, Name=, Color=DEFAULT, CellBGColor=Default, LineWidth=1, LineType=LINESOLIDT)

PlotN[Offset](X, Name=, Color=DEFAULT, CellBGColor=Default, LineWidth=1, LineType=LINESOLIDT)

N - 用于识别该输出的数字，之后可通过NoPlot独立控制在某根K线上是否输出，取值范围1-99；

X：输出的序列变量或数值

Name：输出名，用于指定、显示

LineType：画线类型，可以为以下枚举值：

LINESOLID 0 //实线

LINEDASH 1 //虚线

LINEDOT 2 //点线

LINEDASHDOT 3 //虚线与点线交替

STICK 4 //柱状线

COLORSTICK 5 //以零轴为中心画彩色柱状线，零轴下为阴线颜色，零轴上为阳线颜色

VOLSTICK 6 //成交量棒状线,当股价上涨时阳线,反之阴线

LINESTICK 7 //同时画出柱状线和连线

CROSSDOT 8 //小叉

CIRCLEDOT 9 //小圆圈

POINTDOT 10 //小圆点

Color/CellBGColor: 颜色，可以为以下宏：或RGB(r,g,b) //RGB函数

COLORRED //RGB(255,0,0)

COLORGREEN //RGB(0,255,0)

COLORBLUE //RGB(0,0,255)

COLORBLACK //RGB(0,0,0)

COLORWHITE //RGB(255,255,255)

COLORGRAY

COLORYELLOW

COLORCYAN //青色

COLORMAGENTA //洋红色

COLORBROWN

COLORLIGHTBLUE //淡蓝色

COLORLIGHTGREEN //淡绿色

COLORLIGHTCYAN //淡青色

COLORLIGHTRED //淡红色

COLORLIGHTMAGENTA //淡洋红色

LineWidth：线宽, 对应原 LINETHICKx

[Offset] 可选参数。指定K线位置偏移。正值时，以当前K线为起点向左偏移，负值时，向右偏移。

例子： Plot( c, 'theclose' , COLORBLACK, ColorYellow, 3, circleDot)

Plot[30](c); //画一条收盘线并向左偏移30根K线

Plot2('上升！')

来自“http://www.hs633.com/kthelp/index.php?title=Plot_%E8%BE%93%E5%87%BA&oldid=1383”


PolyLine 画折线

函数 | PolyLine
别名 | 画折线
所属类别 | 绘图函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 在图形上绘制折线段。
用法 | POLYLINE(COND,PRICE) 当COND条件满足时,以PRICE位置为顶点画折线连接。 例如: POLYLINE(HIGH>=HHV(HIGH,10),HIGH)表示在创10天新高点之间画折线。
来自“http://www.hs633.com/kthelp/index.php?title=PolyLine_%E7%94%BB%E6%8A%98%E7%BA%BF&oldid=1378”


Rgb COLORRGB

函数 | Rgb
别名 | COLORRGB
所属类别 | 绘图函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 三原色红(R)绿(G)蓝(B)组成指定颜色
用法 | RGB(R,G,B) R,G,B：红、绿、蓝颜色分量,每种颜色值取值0-255 例如： RGB(0,255,0)为绿色,RGB(255,255,255)为白色
来自“http://www.hs633.com/kthelp/index.php?title=Rgb_COLORRGB&oldid=1384”


ShowTips 显示提示信息

函数 | ShowTips
别名 | 显示提示信息
所属类别 | 绘图函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 长时间运行的公式可以在图形中心显示提示信息
用法 | #Run_By_Bar for i=1 to 10000 do k2:ma(close,20); ShowTips('本公式运行时间比较长，当前正在计算的是第'+ BarPos + '根K线');
来自“http://www.hs633.com/kthelp/index.php?title=ShowTips_%E6%98%BE%E7%A4%BA%E6%8F%90%E7%A4%BA%E4%BF%A1%E6%81%AF&oldid=1386”


StickLine 画柱线

函数 | StickLine
别名 | 画柱线
所属类别 | 绘图函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 在图形上绘制柱线。
用法 | STICKLINE(COND,PRICE1,PRICE2,WIDTH,EMPTY) 当COND条件满足时,在PRICE1和PRICE2位置之间画柱状线 宽度为WIDTH(10为标准间距),EMPTY大于1则画空心柱。 例如: STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,1)表示画K线中阳线的空心柱体部分。 STICKLINE(CLOSE>OPEN,HIGH,LOW,0.8,1)表示画K线中阳线的高低线部分。
来自“http://www.hs633.com/kthelp/index.php?title=StickLine_%E7%94%BB%E6%9F%B1%E7%BA%BF&oldid=1379”


StickLineEx 指定Y轴范围画柱线

函数 | StickLineEx
别名 | 指定Y轴范围画柱线
所属类别 | 绘图函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 在条件成立的位置指定范围画柱线。
用法 | STICKLINEEX(Cond,Y1,Y2,WIDTH,EMPTY) 当Cond条件满足时,在对应的K线位置画柱状线(柱线高度Y1~Y2) Y1和Y2的坐标单位是视图沿垂直方向的1/1000,图形视图自底往顶算为0-999。 WIDTH为宽度(10为标准间距),EMPTY大于0则画空心柱。 例如: STICKLINEEX(ISUP,500,999,8,1)colorred; 表示若对应K线为阳线时，在对应的K线位置的视图上半部分画红色柱体。
来自“http://www.hs633.com/kthelp/index.php?title=StickLineEx_%E6%8C%87%E5%AE%9AY%E8%BD%B4%E8%8C%83%E5%9B%B4%E7%94%BB%E6%9F%B1%E7%BA%BF&oldid=1380”


StickLineUd 画柱状延伸线

函数 | StickLineUd
别名 | 画柱状延伸线
所属类别 | 绘图函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 条件成立时，以指定的价格为起点，向上或向下画柱状延伸线
用法 | STICKLINEUD(COND,PRICE,DIR,WIDTH,EMPTY) 当COND条件满足时,以PRICE位置为起点，DIR为方向(0.向上，1.向下)，EMPTY大于0则画实体柱状。 例如: STICKLINEUD(1,C,1,10,1) colorred 收盘价之上，画红色柱状延伸线
来自“http://www.hs633.com/kthelp/index.php?title=StickLineUd_%E7%94%BB%E6%9F%B1%E7%8A%B6%E5%BB%B6%E4%BC%B8%E7%BA%BF&oldid=1381”


VertLine 画垂直线

函数 | VertLine
别名 | 画垂直线
所属类别 | 绘图函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 在图形上绘制垂直线段。
用法 | VERTLINE(COND) 在COND条件满足的周期处画垂直线。 例如: VERTLINE(HIGH>=HHV(HIGH,20))表示在创20天新高时画垂直线。
来自“http://www.hs633.com/kthelp/index.php?title=VertLine_%E7%94%BB%E5%9E%82%E7%9B%B4%E7%BA%BF&oldid=1382”


A_AvgPrice 持仓开仓均价

函数 | A_AvgPrice
别名 | 持仓开仓均价
所属类别 | 交易函数
参数数量 | 3
运行模式 | 逐根
说明 | 查询当前持仓的开仓均价
用法 | 语法: A_AvgPrice(MP_LONG, 'IF99', ); MP: 持仓方向，取 MP_LONG/MP_SHORT/MP_ALL symbol: 持仓品种，'all'表示全部，空串表示当前品种 Pos: 仓位名, 'all'表示全部，空串表示当前公式 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行 4. 没有持仓时返回0
来自“http://www.hs633.com/kthelp/index.php?title=A_AvgPrice_%E6%8C%81%E4%BB%93%E5%BC%80%E4%BB%93%E5%9D%87%E4%BB%B7&oldid=2059”


A_CancelAllOrders

函数 | A_CancelAllOrders
别名 | 无
所属类别 | 交易函数
参数数量 | 2
运行模式 | 逐根
说明 | 撤销所有
用法 | 语法： A_CancelAllOrders(strSymbol, strPos); strSymbol 品种名称，写'all'表示撤销所有品种，空串表示当前品种 strPos 公式名称，写'all'表示撤销所有公式的委托单，包括人工，'人工'表示手工单，空串表示当前公式
来自“http://www.hs633.com/kthelp/index.php?title=A_CancelAllOrders&oldid=2088”


A_CancelOrder 撤单

函数 | A_CancelOrder
别名 | 撤单
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 撤单
用法 | 语法： A_CANCELORDER(orderIndex); 撤销当前策略的一条或所有委托单 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示撤销所有未成交的 返回值: 成功返回1，失败返回0 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_CancelOrder_%E6%92%A4%E5%8D%95&oldid=2087”


A_CurrentContracts 账户当前权益

函数 | A_CurrentContracts
别名 | 账户当前权益
所属类别 | 交易函数
参数数量 | 3
运行模式 | 逐根
说明 | 账户当前权益
用法 | 语法： A_CurrentContracts(MP, strSymbol, strPos); MP: 持仓方向，取 MP_LONG/MP_SHORT/MP_ALL strSymbol: 持仓品种，'all'表示全部，空串表示当前品种 strPos: 仓位名, 'all'表示全部，空串表示当前公式 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_CurrentContracts_%E8%B4%A6%E6%88%B7%E5%BD%93%E5%89%8D%E6%9D%83%E7%9B%8A&oldid=2084”


A_CurrentEquity 账户当前权益

函数 | A_CurrentEquity
别名 | 账户当前权益
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 账户当前权益
用法 | 语法： A_CurrentEquity() 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_CurrentEquity_%E8%B4%A6%E6%88%B7%E5%BD%93%E5%89%8D%E6%9D%83%E7%9B%8A&oldid=2083”


A_FreeCapital 可用资金

函数 | A_FreeCapital
别名 | 可用资金
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前账户的可用资金
用法 | A_FreeCapital
来自“http://www.hs633.com/kthelp/index.php?title=A_FreeCapital_%E5%8F%AF%E7%94%A8%E8%B5%84%E9%87%91&oldid=2054”


A_GetLastOpenOrderIndex

函数 | A_GetLastOpenOrderIndex
别名 | 无
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 取得最近一个未成交的委托单的单号
用法 | 语法： A_GetLastOpenOrderIndex(SendOrderType) SendOrderType: SO_BUY/SO_SELL/SO_SELLSHORT/SO_BUYTOCOVER 若不需要区分委托单类型，GetOpenOrderCount() 返回的就是最近一个未成交的委托单号 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_GetLastOpenOrderIndex&oldid=2090”


A_GetLastOrderIndex

函数 | A_GetLastOrderIndex
别名 | 无
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 取得最近一个委托单的单号
用法 | 语法： A_GetLastOrderIndex(SendOrderType) SendOrderType: SO_BUY/SO_SELL/SO_SELLSHORT/SO_BUYTOCOVER 若不需要区分委托单类型，GetOrderCount() 返回的就是最近一个委托单号 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_GetLastOrderIndex&oldid=2089”


A_GetOpenOrderCount 未成交委托单数量

函数 | A_GetOpenOrderCount
别名 | 未成交委托单数量
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 未成交和部分成交的委托单数量
用法 | 语法： A_GetOpenOrderCount 取得当前策略当天所有未成交，部分成交的委托单。有别于A_GetOrderCount, 返回当天所有委托单。 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_GetOpenOrderCount_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E6%95%B0%E9%87%8F&oldid=2057”


A_GetOrderCount 委托单数量

函数 | A_GetOrderCount
别名 | 委托单数量
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 委托单数量
用法 | 语法： A_GetOrderCount 取得当前策略当天所有委托单，包括未成交，部分成交，已成交，已撤单等所有状态。有别于A_GetOpenOrderCount, 只返回未成交和部分成交的单。 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_GetOrderCount_%E5%A7%94%E6%89%98%E5%8D%95%E6%95%B0%E9%87%8F&oldid=2058”


A_OpenOrderCancelledLot 未成交委托单已撤口数

函数 | A_OpenOrderCancelledLot
别名 | 未成交委托单已撤口数
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单已撤口数
用法 | 语法： A_OpenOrderCancelledLot(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderCancelledLot_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%B7%B2%E6%92%A4%E5%8F%A3%E6%95%B0&oldid=2079”


A_OpenOrderContractNo 未成交委托单委托单号

函数 | A_OpenOrderContractNo
别名 | 未成交委托单委托单号
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单委托单号
用法 | 语法： A_OpenOrderContractNo(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderContractNo_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E5%8D%95%E5%8F%B7&oldid=2073”


A_OpenOrderDate 未成交委托单委托日期

函数 | A_OpenOrderDate
别名 | 未成交委托单委托日期
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单委托日期
用法 | 语法： A_OpenOrderDate(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 返回值：年月日，YYYYMMDD，时间请使用 A_OpenOrderTime 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderDate_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E6%97%A5%E6%9C%9F&oldid=2065”


A_OpenOrderFilledLot 未成交委托单已成交口数

函数 | A_OpenOrderFilledLot
别名 | 未成交委托单已成交口数
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单已成交口数
用法 | 语法： A_OpenOrderFilledLot(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderFilledLot_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%B7%B2%E6%88%90%E4%BA%A4%E5%8F%A3%E6%95%B0&oldid=2075”


A_OpenOrderFilledPrice 未成交委托单已成交价格

函数 | A_OpenOrderFilledPrice
别名 | 未成交委托单已成交价格
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单已成交价格
用法 | 语法： A_OpenOrderFilledPrice(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderFilledPrice_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%B7%B2%E6%88%90%E4%BA%A4%E4%BB%B7%E6%A0%BC&oldid=2077”


A_OpenOrderLot 未成交委托单开仓量

函数 | A_OpenOrderLot
别名 | 未成交委托单开仓量
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单开仓量
用法 | 语法: A_OPENORDERLOT(orderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个委托单 返回值: 委托单的委托开仓数量 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderLot_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%BC%80%E4%BB%93%E9%87%8F&oldid=2067”


A_OpenOrderPrice 未成交委托单价格

函数 | A_OpenOrderPrice
别名 | 未成交委托单价格
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单价格
用法 | 语法: A_OPENORDERPRICE(orderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个委托单 返回值: 委托单的委托开仓数量 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderPrice_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E4%BB%B7%E6%A0%BC&oldid=2069”


A_OpenOrderStatus 未成交委托单状态

函数 | A_OpenOrderStatus
别名 | 未成交委托单状态
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单状态
用法 | 语法： n1 = A_GetOpenOrderCount; for ii=1 to n1 do begin if(A_OpenOrderStatus(ii) == OS_PARTFILLED) then begin end end 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个委托单 返回值: OS_EMPTY 委托单为空 OS_PARTFILLED 部分成交 OS_DECLARED 已挂单 OS_DECLARING 正在挂单 OS_UNKOWN 未知类型 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderStatus_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E7%8A%B6%E6%80%81&oldid=2086”


A_OpenOrderSymbol 未成交委托单委托品种

函数 | A_OpenOrderSymbol
别名 | 未成交委托单委托品种
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单委托品种
用法 | 语法： A_OpenOrderSymbol(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderSymbol_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E5%93%81%E7%A7%8D&oldid=2082”


A_OpenOrderTime 未成交委托单委托时间

函数 | A_OpenOrderTime
别名 | 未成交委托单委托时间
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单委托时间
用法 | 语法： A_OpenOrderTime(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 返回值：时分秒，HHMMSS，日期请使用 A_OpenOrderDate 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderTime_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E6%97%B6%E9%97%B4&oldid=2063”


A_OpenOrderType 未成交委托单委托类型

函数 | A_OpenOrderType
别名 | 未成交委托单委托类型
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 未成交委托单委托类型
用法 | 语法： A_OpenOrderType(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOpenOrderCount, 0 表示最近一个未成交的委托单 返回值: SO_BUY/SO_SELL/SO_SELLSHORT/SO_BUYTOCOVER 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OpenOrderType_%E6%9C%AA%E6%88%90%E4%BA%A4%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E7%B1%BB%E5%9E%8B&oldid=2071”


A_OrderCancelledLot 委托单已撤口数

函数 | A_OrderCancelledLot
别名 | 委托单已撤口数
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单已撤口数
用法 | 语法： A_OrderCancelledLot(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderCancelledLot_%E5%A7%94%E6%89%98%E5%8D%95%E5%B7%B2%E6%92%A4%E5%8F%A3%E6%95%B0&oldid=2078”


A_OrdercontractNo 委托单委托单号

函数 | A_OrdercontractNo
别名 | 委托单委托单号
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单委托单号
用法 | 语法： A_OrderContractNo(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrdercontractNo_%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E5%8D%95%E5%8F%B7&oldid=2072”


A_OrderDate 委托单委托日期

函数 | A_OrderDate
别名 | 委托单委托日期
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单委托日期
用法 | 语法： A_OrderDate(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 返回值：年月日，YYYYMMDD, 时间请使用 A_OrderTime 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderDate_%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E6%97%A5%E6%9C%9F&oldid=2064”


A_OrderFilledLot 委托单已成交口数

函数 | A_OrderFilledLot
别名 | 委托单已成交口数
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单已成交口数
用法 | 语法： A_OrderFilledLot(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderFilledLot_%E5%A7%94%E6%89%98%E5%8D%95%E5%B7%B2%E6%88%90%E4%BA%A4%E5%8F%A3%E6%95%B0&oldid=2074”


A_OrderFilledPrice 委托单已成交价格

函数 | A_OrderFilledPrice
别名 | 委托单已成交价格
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单已成交价格
用法 | 语法： A_OrderFilledPrice(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderFilledPrice_%E5%A7%94%E6%89%98%E5%8D%95%E5%B7%B2%E6%88%90%E4%BA%A4%E4%BB%B7%E6%A0%BC&oldid=2076”


A_OrderLot 委托单开仓量

函数 | A_OrderLot
别名 | 委托单开仓量
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单开仓量
用法 | 语法: A_ORDERLOT(orderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 返回值: 委托单的委托开仓数量 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderLot_%E5%A7%94%E6%89%98%E5%8D%95%E5%BC%80%E4%BB%93%E9%87%8F&oldid=2066”


A_OrderPrice 委托单价格

函数 | A_OrderPrice
别名 | 委托单价格
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单委托价格
用法 | 语法: A_ORDERPRICE(orderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 返回值: 委托单的委托价格 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderPrice_%E5%A7%94%E6%89%98%E5%8D%95%E4%BB%B7%E6%A0%BC&oldid=2068”


A_OrderStatus 委托单状态

函数 | A_OrderStatus
别名 | 委托单状态
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单状态
用法 | 语法： n1 = A_GetOrderCount; for ii=1 to n1 do begin if(A_OrderStatus(ii) == OS_FILLED) then begin end end 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 返回值: OS_EMPTY 委托单为空 OS_FILLED 已成交 OS_PARTFILLED 部分成交 OS_DECLARED 已挂单 OS_DECLARING 正在挂单 OS_CANCELLED 已撤单 OS_UNKOWN 未知类型 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderStatus_%E5%A7%94%E6%89%98%E5%8D%95%E7%8A%B6%E6%80%81&oldid=2085”


A_OrderSymbol 委托单委托品种

函数 | A_OrderSymbol
别名 | 委托单委托品种
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单委托品种
用法 | 语法： A_OrderSymbol(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderSymbol_%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E5%93%81%E7%A7%8D&oldid=2081”


A OrderTime 委托单委托时间

函数 | A_OrderTime
别名 | 委托单委托时间
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单委托时间
用法 | 语法： A_OrderTime(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 返回值：时分秒，HHMMSS，日期请使用 A_OrderDate 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderTime_%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E6%97%B6%E9%97%B4&oldid=2062”


A_OrderType 委托单委托类型

函数 | A_OrderType
别名 | 委托单委托类型
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 委托单委托类型
用法 | 语法： A_OrderType(nOrderIndex); 参数: orderIndex 委托单的序号，从 1 到 A_GetOrderCount, 0 表示最近一个委托单 返回值: SO_BUY/SO_SELL/SO_SELLSHORT/SO_BUYTOCOVER 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行
来自“http://www.hs633.com/kthelp/index.php?title=A_OrderType_%E5%A7%94%E6%89%98%E5%8D%95%E5%A7%94%E6%89%98%E7%B1%BB%E5%9E%8B&oldid=2070”


A_ProfitLoss 持仓盈亏

函数 | A_ProfitLoss
别名 | 持仓盈亏
所属类别 | 交易函数
参数数量 | 3
运行模式 | 逐根
说明 | 查询当前持仓的盈亏
用法 | 语法: A_ProfitLoss(MP_LONG, 'IF99', ); MP: 持仓方向，取 MP_LONG/MP_SHORT/MP_ALL symbol: 持仓品种，'all'表示全部，空串表示当前品种 Pos: 仓位名, 'all'表示全部，空串表示当前公式 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 配合 #Run_Every_Tick 逐笔行情运行 4. 没有持仓时返回0
来自“http://www.hs633.com/kthelp/index.php?title=A_ProfitLoss_%E6%8C%81%E4%BB%93%E7%9B%88%E4%BA%8F&oldid=2060”


A_SendOrder 发送委托单

函数 | A_SendOrder
别名 | 发送委托单
所属类别 | 交易函数
参数数量 | 7
运行模式 | 逐根
说明 | 后台交易函数，发送委托单
用法 | 语法： A_SendOrder('Symbol', SendOrderType, lots, price, stopLoss, profitTarget, 'comment'); Symbol 品种代码， 空串表示当前品种 SendOrderType 有以下4种: SO_BUY 多头开 SO_SELL 多头平 SO_SELLSHORT 空头开 SO_BUYTOCOVER 空头平 Lots 委托开仓数量 Price 委托开仓价格 stopLoss 止损价格，为0时无止损 profitTarget 止盈价格，为0时无止盈 Comment 用户注释 注意： 1. 只能用于实时行情，不能用于历史回测 2. 使用时不能打开实盘同步 3. 最好配合 #Run_Every_Tick 逐笔行情运行，否则每根K线只能执行一次 4. 可以双向持仓，开仓不会自动平反向仓
来自“http://www.hs633.com/kthelp/index.php?title=A_SendOrder_%E5%8F%91%E9%80%81%E5%A7%94%E6%89%98%E5%8D%95&oldid=2056”


A_UsedMargin 持仓保证金

函数 | A_UsedMargin
别名 | 持仓保证金
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前账户的持仓保证金
用法 | A_UsedMargin
来自“http://www.hs633.com/kthelp/index.php?title=A_UsedMargin_%E6%8C%81%E4%BB%93%E4%BF%9D%E8%AF%81%E9%87%91&oldid=2055”


AccountId 交易帐户

函数 | AccountId
别名 | 交易帐户
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回当前应用的交易帐户号
用法 | AccountID
来自“http://www.hs633.com/kthelp/index.php?title=AccountId_%E4%BA%A4%E6%98%93%E5%B8%90%E6%88%B7&oldid=2051”


AccountInfo 账户信息

函数 | AccountInfo
别名 | 账户信息
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回指定的账户属性或信息
用法 | AccountInfo(attribute) 例如： AccountInfo(Attribute) Attribute：信息类型，以下枚举值 AI_CurrentEquity //动态权益 AI_PreviousEquity //昨日结存 AI_OpenProfit //浮动盈亏 AI_BuyMargin //买入保证金 AI_SellMargin //卖出保证金 AI_BuyFreeze //买入委托冻结 AI_SellFreeze //卖出委托冻结 AI_TodayDeposit //当日入金 AI_TodayDrawing //当日出金
来自“http://www.hs633.com/kthelp/index.php?title=AccountInfo_%E8%B4%A6%E6%88%B7%E4%BF%A1%E6%81%AF&oldid=2053”


AccountSelect 账户选取

函数 | AccountSelect
别名 | 账户选取
所属类别 | 交易函数
参数数量 | 2
运行模式 | 逐根
说明 | 多账户选取，选取后有关操作针对此AccountID账户
用法 | AccountSelect(AccountID, BrokerID);//选取后所有交易有关函数针对ACCOUNTID账户 例如： AccountSelect('87111', '3030')
来自“http://www.hs633.com/kthelp/index.php?title=AccountSelect_%E8%B4%A6%E6%88%B7%E9%80%89%E5%8F%96&oldid=2050”


AllowSameEntries 允许连续同向开仓次数

函数 | AllowSameEntries
别名 | 允许连续同向开仓次数
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 允许连续同向开仓次数
用法 | AllowSameEntries(N) 例如： AllowSameEntries(3); If C>O Then Buy; //阳线买入，可连续开多仓3次 If O>C Then Sell;//阴线全部平仓
来自“http://www.hs633.com/kthelp/index.php?title=AllowSameEntries_%E5%85%81%E8%AE%B8%E8%BF%9E%E7%BB%AD%E5%90%8C%E5%90%91%E5%BC%80%E4%BB%93%E6%AC%A1%E6%95%B0&oldid=2105”


BigPointValue 整数点值

函数 | BigPointValue
别名 | 整数点值
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前商品报价的一个整数点对应一个合约的价值
用法 | BigPointValue 例如： A股一个整数点的价值为1元，BigPointValue返回1 沪深300指数期货一个整数点对应一个合约的价值为300元，BigPointValue返回300 大恒指BigPointValue返回50，小恒指BigPointValue返回10
来自“http://www.hs633.com/kthelp/index.php?title=BigPointValue_%E6%95%B4%E6%95%B0%E7%82%B9%E5%80%BC&oldid=2044”


BrokerId 交易商

函数 | BrokerId
别名 | 交易商
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回当前应用的交易帐户对应的交易经纪商ID
用法 | BrokerID
来自“http://www.hs633.com/kthelp/index.php?title=BrokerId_%E4%BA%A4%E6%98%93%E5%95%86&oldid=2052”


Buy 开多、多头开仓

函数 | Buy
别名 | 开多、多头开仓
所属类别 | 交易函数
参数数量 | 7
运行模式 | 逐根
说明 | 开多、多头开仓
用法 Buy('Symbol'=, Lots=DEFAULT, Price=0, Slippage=0,OT=OT_Market, OB=OB_NextBar, EntryName=)

参数： Symbol：品种代码，指定委托的品种，空串表示当前品种

Lots：委托量，取值DEFAULT时，对于开仓指令，实际委托量在[策略设置]中设置；对于平仓指令，表示全部平仓

Price：委托价，对于限价单、停损单需要指定的委托价格

Slippage：允许滑价，几跳报价最小变动单位，取值-1表示不限滑价，取值0时，实际允许滑价可在[策略设置]中设置。

实际发送委托价为Price+Slippage*MinDiff.对于OT_Stop单，可用该参数进行限价。

OT：委托类型，取值可为以下枚举类型

OT_Market: 市价单

OT_Limit: 限价单

OT_Stop : STOP单、停损单

OT_Open : 开盘单

OT_Close: 收盘单

OB：委托时机及有效时期，取值可为以下枚举类型

OB_NextBar: 次周期

OB_ThisBar: 本周期

EntryName：开仓命名，可用于区分开仓信号，分批开仓取用不同名后，平仓可指定EntryName只平该笔持仓

多头开仓的OT+OB组合：

OT_Market,OB_NextBar：次周期一开盘即发市价单

OT_Limit,OB_NextBar：市场价下跌达到或低于Price时开仓，次周期内有效

OT_Stop,OB_NextBar：市场价上涨达到或超过Price时开仓，次周期内有效

OT_Open,OB_NextBar：对于日线，表示集合竞价开盘单。日线以下周期，次周期开盘时下市价单。

OT_Close,OB_ThisBar：对于日线或日线以下收市前最后1个周期，[策略设置]中设置收市前若干秒下单，或进行收盘集合竞价。

日线以下周期日内，次周期开始时下市价单。

例1：

If Cross(C,MA(C,5)) Then Buy;

本周期结束时若价格金叉均线，则次周期市价（测评时等于开盘价）买入开仓

例2： ?日志3;Buy(,5,100,0,OT_Limit);

下一个周期内，当市价小于等于100时，以100加上[策略设置]中的允许滑价委托买入5口

例3：

Buy(,2,100,5,OT_Stop);

下一个周期内，当市价上升突破100，且不高于100加上5个价格最小变动单位时委托买入2口

这实际上是限价停损单，避免第2天跳空开盘追得太高

例4：

Buy(,Default,100,-1,OT_Stop,OB_NextBar,'突破买开');

下一个周期内，若价格大于等于100，以【策略设置】中的下单量买入开仓，且这次开仓命名为'突破买开'

例5：

If bEnterLong Then Buy(,1,0,0,OT_Close,OB_ThisBar);

日线周期，或者日线以下周期的当天最后1个周期，若收市前若干秒（在【策略设置】中设置）满足条件，则市价买入1口

日线以下周期的其余时期，在下一周期开始时市价买入

来自“http://www.hs633.com/kthelp/index.php?title=Buy_%E5%BC%80%E5%A4%9A%E3%80%81%E5%A4%9A%E5%A4%B4%E5%BC%80%E4%BB%93&oldid=2091”


BuyToCover 平空、空头平仓

函数 | BuyToCover
别名 | 平空、空头平仓
所属类别 | 交易函数
参数数量 | 7
运行模式 | 逐根
说明 | 平空、空头平仓
用法 | BuyToCover('Symbol'=, Lots=DEFAULT, Price=0, Slippage=-1,OT=OT_Market, OB=OB_NextBar, ExitName=) 〈From 'EntryName'〉 参数： Symbol：品种代码，指定委托的品种，空串表示当前品种 Lots：委托量，取值DEFAULT时，表示全部平仓，指定From 'EntryName'时，表示平掉以EntryName开仓的全部仓位 Price：委托价，对于限价单、停损单需要指定的委托价格 Slippage：允许滑价，几跳报价最小变动单位，取值-1表示不限滑价，取值0时，实际允许滑价可在[策略设置]中设置。 实际发送委托价为Price+Slippage*MinDiff. OT：委托类型，取值可为以下枚举类型 OT_Market: 市价单 OT_Limit: 限价单 OT_Stop : STOP单、停损单 OT_Open : 开盘单 OT_Close: 收盘单 OB：委托时机及有效时期，取值可为以下枚举类型 OB_NextBar: 次周期 OB_ThisBar: 本周期 ExitName：平仓命名，可用于区分平仓信号 From 'EntryName'：对以EntryName开仓的仓位进行平仓
来自“http://www.hs633.com/kthelp/index.php?title=BuyToCover_%E5%B9%B3%E7%A9%BA%E3%80%81%E7%A9%BA%E5%A4%B4%E5%B9%B3%E4%BB%93&oldid=2094”


CanTrade 可交易

函数 | CanTrade
别名 | 可交易
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前策略是否处于可交易状态
用法 | CanTrade 具体的判断条件是：如果处于测评下，那么直接返回1。 如果不是测评，那么，需要同时满足以下条件才返回1：已经登录、图上控制图标为笑脸、数据是完整的。 例如： If CanTrade=0 then RETURN;
来自“http://www.hs633.com/kthelp/index.php?title=CanTrade_%E5%8F%AF%E4%BA%A4%E6%98%93&oldid=2039”


Category 商品类别

函数 | Category
别名 | 商品类别
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前商品的类别
用法 | CATEGORY STKTYPE 返回以下枚举值 C_INDEX, // 指数 C_STOCK_A, // A股 C_STOCK_B, // B股 C_STOCK_H, // H股 C_STOCK_N, // N股 C_GEM, //创业板 C_MAS, //中小板 C_FUTURES, // 期货 C_FUND , // 基金 C_BONDS, // 债券 C_FE, //外汇 C_SPOT , //现货 C_FUT_OPTION, // 选择权 C_WARRANT, // 权证 C_REPURCHASE, //回购 C_INS_INDEX, //投资指数 C_BLK_INDEX, //板块指数 C_TREASURY_BONDS = 'TB', //国债 C_CONVERTIBLE_BONDS = 'CB', //可转换债券 C_ENTERPRISE_BONDS, //企业债 C_NOW_BONDS , // 现券 C_LONG_CONTRACT, // 长远期合约 C_LENDING , //拆解 C_TL_INDEX , // 套利指数 C_OTHER, // 其他证券 C_MUTUALFUND, //开放基金 C_MONEYMARKETFUND, //货币基金 C_INDEXOPTION , //指数期权 C_CURRENCYOPTION, //货币期权 C_SPREAD, //价差(台湾市场有) 注意：老飞狐只有14种类型，而现在类型更多。
来自“http://www.hs633.com/kthelp/index.php?title=Category_%E5%95%86%E5%93%81%E7%B1%BB%E5%88%AB&oldid=2045”


CurrentContracts 持仓数量

函数 | CurrentContracts
别名 | 持仓数量
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 持仓数量
用法 | Lots = CurrentContracts; 若本策略目前有5口空头仓，函数返回5 若本策略目前持有200股股票，函数返回200
来自“http://www.hs633.com/kthelp/index.php?title=CurrentContracts_%E6%8C%81%E4%BB%93%E6%95%B0%E9%87%8F&oldid=2096”


EntryPrice 开仓价格

函数 | EntryPrice
别名 | 开仓价格
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回指定持仓的第一次开仓的价格
用法 | EntryPrice(PosBack=0) 返回指定持仓的第一次开仓的价格
来自“http://www.hs633.com/kthelp/index.php?title=EntryPrice_%E5%BC%80%E4%BB%93%E4%BB%B7%E6%A0%BC&oldid=2097”


InitialMargin 每口初始保证金

函数 | InitialMargin
别名 | 每口初始保证金
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回每口合约开仓时需冻结的初始保证金，适用于国外期货
用法 | InitialMargin('Symbol'=) 例如： InitialMargin() 获取当前界面证券的每口初始保证金
来自“http://www.hs633.com/kthelp/index.php?title=InitialMargin_%E6%AF%8F%E5%8F%A3%E5%88%9D%E5%A7%8B%E4%BF%9D%E8%AF%81%E9%87%91&oldid=2048”


IsTradeAllowed 允许交易

函数 | IsTradeAllowed
别名 | 允许交易
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 如果在设置中允许自动交易，返回1。否则返回0
用法 | IsTradeAllowed 例如： If IsTradeAllowed=0 then Alert('不允许自动交易');
来自“http://www.hs633.com/kthelp/index.php?title=IsTradeAllowed_%E5%85%81%E8%AE%B8%E4%BA%A4%E6%98%93&oldid=2036”


IsTradeContextBusy 交易忙

函数 | IsTradeContextBusy
别名 | 交易忙
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 如果其他交易进程还没结束或其它原因导致无法发单，返回1。否则返回0
用法 | IsTradeContextBusy 例如： For n = 1 to 20 do Begin If IsTradeContextBusy = 0 then Break; Sleep(15); End If n >= 20 AND PrintLog then Print('交易忙，请稍等');
来自“http://www.hs633.com/kthelp/index.php?title=IsTradeContextBusy_%E4%BA%A4%E6%98%93%E5%BF%99&oldid=2037”


MainTenanceMargin 每口维持保证金

函数 | MainTenanceMargin
别名 | 每口维持保证金
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回每口合约持仓时需冻结的维持保证金，适用于国外期货
用法 | MaintenanceMargin('Symbol'=) 例如： MaintenanceMargin() 获取当前界面证券的每口维持保证金
来自“http://www.hs633.com/kthelp/index.php?title=MainTenanceMargin_%E6%AF%8F%E5%8F%A3%E7%BB%B4%E6%8C%81%E4%BF%9D%E8%AF%81%E9%87%91&oldid=2049”


MarginRatio 保证金比率

函数 | MarginRatio
别名 | 保证金比率
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 默认保证金比率，适用于国内期货
用法 | MarginRatio('Symbol'=) 例如： MarginRatio(al12.sq) 获取上期沪铝1212的保证金比率 MarginRatio() 获取当前界面证券的保证金比率
来自“http://www.hs633.com/kthelp/index.php?title=MarginRatio_%E4%BF%9D%E8%AF%81%E9%87%91%E6%AF%94%E7%8E%87&oldid=2047”


MarketPosition 持仓状态

函数 | MarketPosition
别名 | 持仓状态
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 持仓状态
用法 | MarketPosition(PosBack=0) 返回指定持仓的交易方向,1表示持多头仓，-1表示持空头仓，PosBack=0时返回0表示当前无持仓； 参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等 例1： If MarketPosition〈1 Then Buy; 若当前无持仓或者持空头仓，则买入开仓 例2： MarketPosition(1) 返回上一次已平仓头寸的持仓方向
来自“http://www.hs633.com/kthelp/index.php?title=MarketPosition_%E6%8C%81%E4%BB%93%E7%8A%B6%E6%80%81&oldid=2098”


MinMove 最小变动量

函数 | MinMove
别名 | 最小变动量
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前商品报价的最小变动量
用法 | MinMove MinMove = 最小变动值/Point 注意，最小变动值(mindiff)是金额，而最小变动量(minmove)是量 例如： 上海A股的最小变动值0.01元，其Point为0.01，MinMove返回1; 沪胶的最小变动值为5元，其Point为1，MinMove返回5
来自“http://www.hs633.com/kthelp/index.php?title=MinMove_%E6%9C%80%E5%B0%8F%E5%8F%98%E5%8A%A8%E9%87%8F&oldid=2043”


Point 点位

函数 | Point
别名 | 点位
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前商品的计价的最小单位
用法 | Point 例如： 深圳A股报价精确到小数点2位，Point 返回 0.01; 上海B股报价精确到小数点3位，Point 返回 0.001
来自“http://www.hs633.com/kthelp/index.php?title=Point_%E7%82%B9%E4%BD%8D&oldid=2040”


PointValue 点值

函数 | PointValue
别名 | 点值
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 点值
用法 | PointValue 返回当前品种单点对应的价值 PointValue = BigPointValue/PriceScale 例如： IF股指期货返回30
来自“http://www.hs633.com/kthelp/index.php?title=PointValue_%E7%82%B9%E5%80%BC&oldid=2041”


Sell 平多、多头平仓

函数 | Sell
别名 | 平多、多头平仓
所属类别 | 交易函数
参数数量 | 7
运行模式 | 逐根
说明 | 平多、多头平仓
用法 | Sell('Symbol'=, Lots=DEFAULT, Price=0, Slippage=-1,OT=OT_Market, OB=OB_NextBar, ExitName=) 〈From 'EntryName'〉 参数： Symbol：品种代码，指定委托的品种，空串表示当前品种 Lots：委托量，取值DEFAULT时，表示全部平仓，指定From 'EntryName'时，表示平掉以EntryName开仓的全部仓位 Price：委托价，对于限价单、停损单需要指定的委托价格 Slippage：允许滑价，几跳报价最小变动单位，取值-1表示不限滑价，取值0时，实际允许滑价可在[策略设置]中设置。 实际发送委托价为Price+Slippage*MinDiff. OT：委托类型，取值可为以下枚举类型 OT_Market: 市价单 OT_Limit: 限价单 OT_Stop : STOP单、停损单 OT_Open : 开盘单 OT_Close: 收盘单 OB：委托时机及有效时期，取值可为以下枚举类型 OB_NextBar: 次周期 OB_ThisBar: 本周期 ExitName：平仓命名，可用于区分平仓信号 From 'EntryName'：对以EntryName开仓的仓位进行平仓
来自“http://www.hs633.com/kthelp/index.php?title=Sell_%E5%B9%B3%E5%A4%9A%E3%80%81%E5%A4%9A%E5%A4%B4%E5%B9%B3%E4%BB%93&oldid=2092”


SellShort 开空、空头开仓

函数 | SellShort
别名 | 开空、空头开仓
所属类别 | 交易函数
参数数量 | 9
运行模式 | 逐根
说明 | 开空、空头开仓
用法 | SellShort('Symbol'=, Lots=DEFAULT, Price=0, Slippage=0,OT=OT_Market, OB=OB_NextBar, EntryName=) 参数： Symbol：品种代码，指定委托的品种，空串表示当前品种 Lots：委托量，取值DEFAULT时，对于开仓指令，实际委托量在[策略设置]中设置；对于平仓指令，表示全部平仓 Price：委托价，对于限价单、停损单需要指定的委托价格 Slippage：允许滑价，几跳报价最小变动单位，取值-1表示不限滑价，取值0时，实际允许滑价可在[策略设置]中设置。 实际发送委托价为Price-Slippage*MinDiff. OT：委托类型，取值可为以下枚举类型 OT_Market: 市价单 OT_Limit: 限价单 OT_Stop : STOP单、停损单 OT_Open : 开盘单 OT_Close: 收盘单 OB：委托时机及有效时期，取值可为以下枚举类型 OB_NextBar: 次周期 OB_ThisBar: 本周期 EntryName：开仓命名，可用于区分开仓信号，分批开仓取用不同名后，平仓可指定EntryName只平该笔持仓
来自“http://www.hs633.com/kthelp/index.php?title=SellShort_%E5%BC%80%E7%A9%BA%E3%80%81%E7%A9%BA%E5%A4%B4%E5%BC%80%E4%BB%93&oldid=2093”


SetBreakEven 设置保本平仓

函数 | SetBreakEven
别名 | 设置保本平仓
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 设置保本平仓
用法 | SetBreakEven(Profit) 单口或整个持仓的浮盈金额达到Profit后，启用保本平仓，若价格回撤到盈亏平衡点时，则全部平仓出场 例如： SetBreakEven(2000); 整个持仓的浮盈金额达到2000后，保本出场
来自“http://www.hs633.com/kthelp/index.php?title=SetBreakEven_%E8%AE%BE%E7%BD%AE%E4%BF%9D%E6%9C%AC%E5%B9%B3%E4%BB%93&oldid=2042”


SetDollarTrailing 设置金额跟踪平仓

函数 | SetDollarTrailing
别名 | 设置金额跟踪平仓
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 设置金额跟踪平仓
用法 SetDollarTrailing(Amount,Profit=0)

单口或整个持仓的浮盈金额达到Profit后，启动跟踪止损，若从最大浮盈回撤了Amount，则全部平仓出场

例1：

SetDollarTrailing(100);

整个持仓的浮盈金额回落100元时平仓

例2：

SetStopContract;

SetDollarTrailing(100,200);

单口持仓的浮盈金额达到200元后，启动跟踪止损，若从最大浮盈回撤了100元，则全部平仓出场

来自“http://www.hs633.com/kthelp/index.php?title=SetDollarTrailing_%E8%AE%BE%E7%BD%AE%E9%87%91%E9%A2%9D%E8%B7%9F%E8%B8%AA%E5%B9%B3%E4%BB%93&oldid=2103”


SetExitOnClose 收市时平仓

函数 | SetExitOnClose
别名 | 收市时平仓
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 收市时平仓
用法 | SetExitOnClose 日内交易在收市前全部平仓，平仓时机在【策略设置】中设置“日收盘交易在(n)秒前下单” 测评时以收市价作为交易价格 一旦到达设定时间，自动平仓之后，策略所发出的开仓信号将全部截留， 当天不再执行，等到第二天的开盘第一根执行
来自“http://www.hs633.com/kthelp/index.php?title=SetExitOnClose_%E6%94%B6%E5%B8%82%E6%97%B6%E5%B9%B3%E4%BB%93&oldid=2095”


SetPercentTrailing 设置百分比跟踪平仓

函数 | SetPercentTrailing
别名 | 设置百分比跟踪平仓
所属类别 | 交易函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置百分比跟踪平仓
用法 | SetPercentTrailing(Profit,Percentage) 单口或整个持仓的浮盈金额达到Profit后，启动跟踪止损，若从最大浮盈回撤了Percentage%，则全部平仓出场 例如： SetPercentTrailing(500,20) 整个持仓的浮盈金额达到500元后，启动跟踪止损，若从最大浮盈回撤了20%，假设最大浮盈曾为1000元，则浮盈回落到800元时，平仓出场
来自“http://www.hs633.com/kthelp/index.php?title=SetPercentTrailing_%E8%AE%BE%E7%BD%AE%E7%99%BE%E5%88%86%E6%AF%94%E8%B7%9F%E8%B8%AA%E5%B9%B3%E4%BB%93&oldid=2104”


SetProfitTarget 设置止盈平仓

函数 | SetProfitTarget
别名 | 设置止盈平仓
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 设置止盈平仓
用法 | SetProfitTarget(Amount) 单口或整个持仓的盈利金额达到Amount时全部止盈平仓 例如： SetProfitTarget(1000); 整个持仓的盈利金额达到1000时止盈平仓
来自“http://www.hs633.com/kthelp/index.php?title=SetProfitTarget_%E8%AE%BE%E7%BD%AE%E6%AD%A2%E7%9B%88%E5%B9%B3%E4%BB%93&oldid=2101”


SetStopContract 设置基于单口持仓

函数 | SetStopContract
别名 | 设置基于单口持仓
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 设置基于单口持仓
用法 | SetStopContract 使内建平仓出场函数的参数基于单口持仓 内建出场函数包括：SetStopLoss，SetProfitTarget，SetBreakEven，SetDollarTrailing，SetPercentTrailing 例如： SetStopContract; SetStopLoss(100); 单口持仓亏损金额达到100元时平仓出场
来自“http://www.hs633.com/kthelp/index.php?title=SetStopContract_%E8%AE%BE%E7%BD%AE%E5%9F%BA%E4%BA%8E%E5%8D%95%E5%8F%A3%E6%8C%81%E4%BB%93&oldid=2100”


SetStopLoss 设置止损平仓

函数 | SetStopLoss
别名 | 设置止损平仓
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 设置止损平仓
用法 | SetStopLoss(Amount) 单口或整个持仓的亏损金额达到Amount时全部止损平仓 若公式中没有SetStopPosition或SetStopContract，默认是以整个持仓计 该函数作用于周期内，有可能与对应的开仓位于同一周期 例如： SetStopContract SetStopLoss(20*BigPointValue); 单口持仓亏损金额达到20*BigPointValue元（与开仓价差20个点）时平仓出场
来自“http://www.hs633.com/kthelp/index.php?title=SetStopLoss_%E8%AE%BE%E7%BD%AE%E6%AD%A2%E6%8D%9F%E5%B9%B3%E4%BB%93&oldid=2102”


SetStopPosition 设置基于整个持仓

函数 | SetStopPosition
别名 | 设置基于整个持仓
所属类别 | 交易函数
参数数量 | 1
运行模式 | 逐根
说明 | 使内建平仓出场函数的参数基于整个持仓
用法 | SetStopPosition 使内建平仓出场函数的参数基于整个持仓。 例如： SetStopPosition SetStopLoss(100); 整个持仓亏损金额达到100元时平仓出场
来自“http://www.hs633.com/kthelp/index.php?title=SetStopPosition_%E8%AE%BE%E7%BD%AE%E5%9F%BA%E4%BA%8E%E6%95%B4%E4%B8%AA%E6%8C%81%E4%BB%93&oldid=2099”


StkType 商品类别

函数 | StkType
别名 | 商品类别
所属类别 | 交易函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前商品的类别
用法 | STKTYPE CATEGORY 返回以下枚举值 C_INDEX, // 指数 C_STOCK_A, // A股 C_STOCK_B, // B股 C_STOCK_H, // H股 C_STOCK_N, // N股 C_GEM, //创业板 C_MAS, //中小板 C_FUTURES, // 期货 C_FUND , // 基金 C_BONDS, // 债券 C_FE, //外汇 C_SPOT , //现货 C_FUT_OPTION, // 选择权 C_WARRANT, // 权证 C_REPURCHASE, //回购 C_INS_INDEX, //投资指数 C_BLK_INDEX, //板块指数 C_TREASURY_BONDS = 'TB', //国债 C_CONVERTIBLE_BONDS = 'CB', //可转换债券 C_ENTERPRISE_BONDS, //企业债 C_NOW_BONDS , // 现券 C_LONG_CONTRACT, // 长远期合约 C_LENDING , //拆解 C_TL_INDEX , // 套利指数 C_OTHER, // 其他证券 C_MUTUALFUND, //开放基金 C_MONEYMARKETFUND, //货币基金 C_INDEXOPTION , //指数期权 C_CURRENCYOPTION, //货币期权 C_SPREAD, //价差(台湾市场有) 注意：老飞狐只有14种类型，而现在类型更多。
来自“http://www.hs633.com/kthelp/index.php?title=StkType_%E5%95%86%E5%93%81%E7%B1%BB%E5%88%AB&oldid=2046”


AvgBarsEvenTrade 保本交易平均持仓周期数

函数 | AvgBarsEvenTrade
别名 | 保本交易平均持仓周期数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 保本交易平均持仓周期数
用法 | AvgBarsEvenTrade 返回开平仓价格相同的交易的平均持仓周期数
来自“http://www.hs633.com/kthelp/index.php?title=AvgBarsEvenTrade_%E4%BF%9D%E6%9C%AC%E4%BA%A4%E6%98%93%E5%B9%B3%E5%9D%87%E6%8C%81%E4%BB%93%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1936”


AvgBarsLosTrade 亏损交易平均持仓周期数

函数 | AvgBarsLosTrade
别名 | 亏损交易平均持仓周期数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 亏损交易平均持仓周期数
用法 | AvgBarsLosTrade
来自“http://www.hs633.com/kthelp/index.php?title=AvgBarsLosTrade_%E4%BA%8F%E6%8D%9F%E4%BA%A4%E6%98%93%E5%B9%B3%E5%9D%87%E6%8C%81%E4%BB%93%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1937”


AvgBarsWinTrade 盈利交易平均持仓周期数

函数 | AvgBarsWinTrade
别名 | 盈利交易平均持仓周期数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 盈利交易平均持仓周期数
用法 | AvgBarsWinTrade
来自“http://www.hs633.com/kthelp/index.php?title=AvgBarsWinTrade_%E7%9B%88%E5%88%A9%E4%BA%A4%E6%98%93%E5%B9%B3%E5%9D%87%E6%8C%81%E4%BB%93%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1938”


Equity asset

函数 | Equity
别名 | asset
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 资产
用法 | Equity
来自“http://www.hs633.com/kthelp/index.php?title=Equity_asset&oldid=1939”


GetRtAcountEquity 实时权益

函数 | GetRtAcountEquity
别名 | 实时权益
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 实时账户的权益
用法 | GetRtAcountEquity
来自“http://www.hs633.com/kthelp/index.php?title=GetRtAcountEquity_%E5%AE%9E%E6%97%B6%E6%9D%83%E7%9B%8A&oldid=1940”


GrossLoss 总亏损

函数 | GrossLoss
别名 | 总亏损
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 总亏损
用法 | GrossLoss 返回之前累计的总亏损，该值为负数
来自“http://www.hs633.com/kthelp/index.php?title=GrossLoss_%E6%80%BB%E4%BA%8F%E6%8D%9F&oldid=1917”


GrossProfit 总盈利

函数 | GrossProfit
别名 | 总盈利
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 总盈利
用法 | GrossProfit 返回之前累计的总盈利
来自“http://www.hs633.com/kthelp/index.php?title=GrossProfit_%E6%80%BB%E7%9B%88%E5%88%A9&oldid=1918”


LargestLosTrade 最大单次亏损

函数 | LargestLosTrade
别名 | 最大单次亏损
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大单次亏损
用法 | LargestLosTrade 返回最大单次交易亏损金额
来自“http://www.hs633.com/kthelp/index.php?title=LargestLosTrade_%E6%9C%80%E5%A4%A7%E5%8D%95%E6%AC%A1%E4%BA%8F%E6%8D%9F&oldid=1920”


LargestWinTrade 最大单次盈利

函数 | LargestWinTrade
别名 | 最大单次盈利
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大单次盈利
用法 | LargestWinTrade 返回最大单次交易盈利金额
来自“http://www.hs633.com/kthelp/index.php?title=LargestWinTrade_%E6%9C%80%E5%A4%A7%E5%8D%95%E6%AC%A1%E7%9B%88%E5%88%A9&oldid=1921”


MaxConsecLosers 最大连亏次数

函数 | MaxConsecLosers
别名 | 最大连亏次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大连亏次数
用法 | MaxConsecLosers 返回最大连续亏损交易次数
来自“http://www.hs633.com/kthelp/index.php?title=MaxConsecLosers_%E6%9C%80%E5%A4%A7%E8%BF%9E%E4%BA%8F%E6%AC%A1%E6%95%B0&oldid=1928”


MaxConsecWinners 最大连盈次数

函数 | MaxConsecWinners
别名 | 最大连盈次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大连盈次数
用法 | MaxConsecWinners 返回最大连续亏损交易次数
来自“http://www.hs633.com/kthelp/index.php?title=MaxConsecWinners_%E6%9C%80%E5%A4%A7%E8%BF%9E%E7%9B%88%E6%AC%A1%E6%95%B0&oldid=1929”


MaxContractsHeld 最大持仓数

函数 | MaxContractsHeld
别名 | 最大持仓数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大持仓数
用法 | MaxContractsHeld 返回曾经达到的最大持仓数
来自“http://www.hs633.com/kthelp/index.php?title=MaxContractsHeld_%E6%9C%80%E5%A4%A7%E6%8C%81%E4%BB%93%E6%95%B0&oldid=1932”


MaxIdDrawdown 最大资产回撤

函数 | MaxIdDrawdown
别名 | 最大资产回撤
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大资产回撤
用法 | MaxIdDrawdown
来自“http://www.hs633.com/kthelp/index.php?title=MaxIdDrawdown_%E6%9C%80%E5%A4%A7%E8%B5%84%E4%BA%A7%E5%9B%9E%E6%92%A4&oldid=1922”


NetProfit 净利润

函数 | NetProfit
别名 | 净利润
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 净利润
用法 | NetProfit 返回累计的净利润
来自“http://www.hs633.com/kthelp/index.php?title=NetProfit_%E5%87%80%E5%88%A9%E6%B6%A6&oldid=1919”


NumConsecLosers 连亏次数

函数 | NumConsecLosers
别名 | 连亏次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 连亏次数
用法 | NumConsecLosers 返回当前位置之前已连续有多少次亏损交易 例如： If NumConsecLosers >= 5 Then Buy(,Lots*1.2); 连续亏损5次后，增加下单量
来自“http://www.hs633.com/kthelp/index.php?title=NumConsecLosers_%E8%BF%9E%E4%BA%8F%E6%AC%A1%E6%95%B0&oldid=1930”


NumConsecWinners 连盈次数

函数 | NumConsecWinners
别名 | 连盈次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 连盈次数
用法 | NumConsecWinners 返回当前位置之前已连续有多少次盈利交易
来自“http://www.hs633.com/kthelp/index.php?title=NumConsecWinners_%E8%BF%9E%E7%9B%88%E6%AC%A1%E6%95%B0&oldid=1931”


NumEvenTrades 保本交易总次数

函数 | NumEvenTrades
别名 | 保本交易总次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 保本交易总次数
用法 | NumEvenTrades
来自“http://www.hs633.com/kthelp/index.php?title=NumEvenTrades_%E4%BF%9D%E6%9C%AC%E4%BA%A4%E6%98%93%E6%80%BB%E6%AC%A1%E6%95%B0&oldid=1925”


NumLosTrades 亏损交易总次数

函数 | NumLosTrades
别名 | 亏损交易总次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 亏损交易总次数
用法 | NumLosTrades
来自“http://www.hs633.com/kthelp/index.php?title=NumLosTrades_%E4%BA%8F%E6%8D%9F%E4%BA%A4%E6%98%93%E6%80%BB%E6%AC%A1%E6%95%B0&oldid=1926”


NumWinTrades 盈利交易总次数

函数 | NumWinTrades
别名 | 盈利交易总次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 盈利交易总次数
用法 | NumWinTrades 返回盈利交易的总次数
来自“http://www.hs633.com/kthelp/index.php?title=NumWinTrades_%E7%9B%88%E5%88%A9%E4%BA%A4%E6%98%93%E6%80%BB%E6%AC%A1%E6%95%B0&oldid=1924”


PercentProfit 胜率

函数 | PercentProfit
别名 | 胜率
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 胜率
用法 | PercentProfit 返回盈利交易占总交易的百分比 PercentProfit = (NumWinTrades / TotalTrades) *100%
来自“http://www.hs633.com/kthelp/index.php?title=PercentProfit_%E8%83%9C%E7%8E%87&oldid=1927”


TotalBarsEvenTrades 保本交易总持仓周期数

函数 | TotalBarsEvenTrades
别名 | 保本交易总持仓周期数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 保本交易总持仓周期数
用法 | TotalBarsEvenTrades 返回开平仓价格相同的交易的累计的总持仓周期数
来自“http://www.hs633.com/kthelp/index.php?title=TotalBarsEvenTrades_%E4%BF%9D%E6%9C%AC%E4%BA%A4%E6%98%93%E6%80%BB%E6%8C%81%E4%BB%93%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1933”


TotalBarsLosTrades 亏损交易总持仓周期数

函数 | TotalBarsLosTrades
别名 | 亏损交易总持仓周期数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 亏损交易总持仓周期数
用法 | TotalBarsLosTrades
来自“http://www.hs633.com/kthelp/index.php?title=TotalBarsLosTrades_%E4%BA%8F%E6%8D%9F%E4%BA%A4%E6%98%93%E6%80%BB%E6%8C%81%E4%BB%93%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1934”


TotalBarsWinTrades 盈利交易总持仓周期数

函数 | TotalBarsWinTrades
别名 | 盈利交易总持仓周期数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 盈利交易总持仓周期数
用法 | TotalBarsWinTrades
来自“http://www.hs633.com/kthelp/index.php?title=TotalBarsWinTrades_%E7%9B%88%E5%88%A9%E4%BA%A4%E6%98%93%E6%80%BB%E6%8C%81%E4%BB%93%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1935”


TotalTrades 交易总次数

函数 | TotalTrades
别名 | 交易总次数
所属类别 | 交易绩效函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 交易总次数
用法 | TotalTrades
来自“http://www.hs633.com/kthelp/index.php?title=TotalTrades_%E4%BA%A4%E6%98%93%E6%80%BB%E6%AC%A1%E6%95%B0&oldid=1923”


GetAccount 取账户名

函数 | GetAccoun
别名 | 取账户名
所属类别 | 交易账户函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回账户列表中指定位置的某个账户名
用法 | GetAccount(AccountLoc) 返回账户列表中指定位置的某个账户名 该函数可与GetNumAccounts函数一起用于遍历账户 AccountLoc是介于1和GetNumAccounts之间的整数 该函数不能用于测评 例如： variable: str(); for i:=1 to GetNumAccounts do begin str := GetAccount(i); end;
来自“http://www.hs633.com/kthelp/index.php?title=GetAccount_%E5%8F%96%E8%B4%A6%E6%88%B7%E5%90%8D&oldid=1960”


GetAccountId 当前账户

函数 | GetAccountId
别名 | 当前账户
所属类别 | 交易账户函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回当前策略关联的账户名
用法 | variable: str(); str := GetAccountID;
来自“http://www.hs633.com/kthelp/index.php?title=GetAccountId_%E5%BD%93%E5%89%8D%E8%B4%A6%E6%88%B7&oldid=1962”


GetAccountStatus 账户状态

函数 | GetAccountStatus
别名 | 账户状态
所属类别 | 交易账户函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回指定账户的状态
用法 | GetAccountStatus(Account=) 参数：Account为账户名，为空字串或无此参数表示当前账户 返回值定义如下： 0 = asInvalid //无该账户 1 = asActibe //可交易 2 = asInactive //不可交易 例如： //返回当前策略关联的账户的状态 value1 := GetAccountStatus(GetAccountID);
来自“http://www.hs633.com/kthelp/index.php?title=GetAccountStatus_%E8%B4%A6%E6%88%B7%E7%8A%B6%E6%80%81&oldid=1963”


GetNumAccounts 账户数量

函数 | GetNumAccounts
别名 | 账户数量
所属类别 | 交易账户函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回可用账户数量
用法 | 该函数不能用于测评 例如： Value1 := GetNumAccounts;
来自“http://www.hs633.com/kthelp/index.php?title=GetNumAccounts_%E8%B4%A6%E6%88%B7%E6%95%B0%E9%87%8F&oldid=1957”


GetnumPositions 账户持仓商品个数

函数 | GetnumPositions
别名 | 账户持仓商品个数
所属类别 | 交易账户函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回指定账户的持仓商品数，无效账户返回0
用法 | GetNumPositions(Account=) 与GetPositionSymbol配合使用可遍历账户持仓的品种。 参数：Account为账户名，为空字串或无此参数表示当前账户 例如： Value1 := GetNumPositions;
来自“http://www.hs633.com/kthelp/index.php?title=GetnumPositions_%E8%B4%A6%E6%88%B7%E6%8C%81%E4%BB%93%E5%95%86%E5%93%81%E4%B8%AA%E6%95%B0&oldid=1970”


GetOpenOrderInitialMargin 账户冻结保证金

函数 | GetOpenOrderInitialMargin
别名 | 账户冻结保证金
所属类别 | 交易账户函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回期货账户实时的冻结保证金，无效账户返回0
用法 | GetOpenOrderInitialMargin(Account=) 参数：Account为账户名，为空字串或无此参数表示当前账户 该冻结保证金是指已发出、未成交的开仓委托所对应的冻结保证金 例如： value1 := GetOpenOrderInitialMargin;
来自“http://www.hs633.com/kthelp/index.php?title=GetOpenOrderInitialMargin_%E8%B4%A6%E6%88%B7%E5%86%BB%E7%BB%93%E4%BF%9D%E8%AF%81%E9%87%91&oldid=1969”


GetPositionAveragePrice 账户持仓商品均价

函数 | GetPositionAveragePrice
别名 | 账户持仓商品均价
所属类别 | 交易账户函数
参数数量 | 2
运行模式 | 逐根
说明 | 返回指定账户的指定商品的开仓均价
用法 | GetPositionAveragePrice(MP,Symbol=,Account=) 参数： MP为持仓方向，1为买仓，-1为卖仓 Symbol为商品代码，为空字串或无此参数表示当前商品 Account为账户名，为空字串或无此参数表示当前账户 例如： Value1 := GetPositionAveragePrice(1);
来自“http://www.hs633.com/kthelp/index.php?title=GetPositionAveragePrice_%E8%B4%A6%E6%88%B7%E6%8C%81%E4%BB%93%E5%95%86%E5%93%81%E5%9D%87%E4%BB%B7&oldid=1973”


GetPositionMarketValue 账户持仓商品市值

函数 | GetPositionMarketValue
别名 | 账户持仓商品市值
所属类别 | 交易账户函数
参数数量 | 2
运行模式 | 逐根
说明 | 返回指定账户的指定商品的市值，对于期货，为 价格*持仓数量
用法 | GetPositionMarketValue (MP,Symbol=,Account=) 参数： MP为持仓方向，1为买仓，-1为卖仓 Symbol为商品代码，为空字串或无此参数表示当前商品 Account为账户名，为空字串或无此参数表示当前账户 例如： //取得策略关联的当前账户中当前商品的买仓的市值 Value1 := GetPositionMarketValue (1);
来自“http://www.hs633.com/kthelp/index.php?title=GetPositionMarketValue_%E8%B4%A6%E6%88%B7%E6%8C%81%E4%BB%93%E5%95%86%E5%93%81%E5%B8%82%E5%80%BC&oldid=1974”


GetPositionOpenPl 账户持仓商品浮动盈亏

函数 | GetPositionOpenPl
别名 | 账户持仓商品浮动盈亏
所属类别 | 交易账户函数
参数数量 | 2
运行模式 | 逐根
说明 | 返回指定账户的指定商品的浮动盈亏
用法 | GetPositionOpenPL (MP,Symbol=,Account=) 参数： MP为持仓方向，1为买仓，-1为卖仓 Symbol为商品代码，为空字串或无此参数表示当前商品 Account为账户名，为空字串或无此参数表示当前账户 例如： Value1 := GetPositionOpenPL (1);
来自“http://www.hs633.com/kthelp/index.php?title=GetPositionOpenPl_%E8%B4%A6%E6%88%B7%E6%8C%81%E4%BB%93%E5%95%86%E5%93%81%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F&oldid=1975”


GetPositionQuantity 账户持仓商品净仓

函数 | GetPositionQuantity
别名 | 账户持仓商品净仓
所属类别 | 交易账户函数
参数数量 | 2
运行模式 | 逐根
说明 | 返回指定账户的持仓商品的净头寸，正数表示净买仓，负数表示净卖仓，0表示买仓与卖仓数量相等，无持仓或无效账户也返回0
用法 GetPositionQuantity(Symbol=,Account=)

参数：

Symbol为商品代码，为空字串或无此参数表示当前商品

Account为账户名，为空字串或无此参数表示当前账户

例如：

//取得策略关联的当前账户中当前商品的净持仓数量

Value1 := GetPositionQuantity;

来自“http://www.hs633.com/kthelp/index.php?title=GetPositionQuantity_%E8%B4%A6%E6%88%B7%E6%8C%81%E4%BB%93%E5%95%86%E5%93%81%E5%87%80%E4%BB%93&oldid=1972”


GetPositionSymbol 账户持仓商品代码

函数 | GetPositionSymbol
别名 | 账户持仓商品代码
所属类别 | 交易账户函数
参数数量 | 1
运行模式 | 逐根
说明 | 返回指定账户持仓中指定位置的商品代码
用法 GetPositionSymbol(PosID, Account=)

该函数配合 GetNumPositions 函数可用于遍历持仓商品

参数：

PosID 是介于1和 GetNumPositions 之间的整数

Account 为账户名，为空字串或无此参数表示当前账户

例如：

variable: str();

for i:=1 to GetNumPositions do begin

str := GetPositionSymbol(i);

end;

来自“http://www.hs633.com/kthelp/index.php?title=GetPositionSymbol_%E8%B4%A6%E6%88%B7%E6%8C%81%E4%BB%93%E5%95%86%E5%93%81%E4%BB%A3%E7%A0%81&oldid=1971”


GetRtAccountEquity 账户实时权益

函数 | GetRtAccountEquity
别名 | 账户实时权益
所属类别 | 交易账户函数
参数数量 | 10
运行模式 | 逐根
说明 | 返回账户实时的市值，无效账户返回0
用法 | GetRTAccountEquity(Account=) 参数：Account为账户名，为空字串或无此参数表示当前账户 例如： value1 := GetRTAccountEquity(GetAccountID); value2 := GetRTAccountEquity('168168'); value3 := GetRTAccountEquity(); value4 := GetRTAccountEquity; 若当前策略关联的账户是'168168'，以上四条语句是一样的
来自“http://www.hs633.com/kthelp/index.php?title=GetRtAccountEquity_%E8%B4%A6%E6%88%B7%E5%AE%9E%E6%97%B6%E6%9D%83%E7%9B%8A&oldid=1965”


GetRtMaintMargin 账户占用保证金

函数 | GetRtMaintMargin
别名 | 账户占用保证金
所属类别 | 交易账户函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回期货账户实时的占用保证金，无效账户返回0
用法 | GetRTMaintMargin(Account=) 参数：Account为账户名，为空字串或无此参数表示当前账户 例如： value1 := GetRTMaintMargin;
来自“http://www.hs633.com/kthelp/index.php?title=GetRtMaintMargin_%E8%B4%A6%E6%88%B7%E5%8D%A0%E7%94%A8%E4%BF%9D%E8%AF%81%E9%87%91&oldid=1966”


GetRtRealizedPl 账户平仓盈亏

函数 | GetRtRealizedPl
别名 | 账户平仓盈亏
所属类别 | 交易账户函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回期货账户当日已实现的平仓盈亏，无效账户返回0
用法 | GetRTRealizedPL(Account=) 参数：Account为账户名，为空字串或无此参数表示当前账户 例如： value1 := GetRTRealizedPL;
来自“http://www.hs633.com/kthelp/index.php?title=GetRtRealizedPl_%E8%B4%A6%E6%88%B7%E5%B9%B3%E4%BB%93%E7%9B%88%E4%BA%8F&oldid=1967”


GetRtUnrealizedPl 账户浮动盈亏

函数 | GetRtUnrealizedPl
别名 | 账户浮动盈亏
所属类别 | 交易账户函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回期货账户实时的持仓浮动盈亏，无效账户返回0
用法 | GetRTUnrealizedPL(Account=) 参数：Account为账户名，为空字串或无此参数表示当前账户 例如： value1 := GetRTUnrealizedPL;
来自“http://www.hs633.com/kthelp/index.php?title=GetRtUnrealizedPl_%E8%B4%A6%E6%88%B7%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F&oldid=1968”


AvgEntryPrice 平均开仓价格

函数 | AvgEntryPrice
别名 | 平均开仓价格
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前持仓的平均开仓价格
用法 | AvgEntryPrice
来自“http://www.hs633.com/kthelp/index.php?title=AvgEntryPrice_%E5%B9%B3%E5%9D%87%E5%BC%80%E4%BB%93%E4%BB%B7%E6%A0%BC&oldid=2160”


BarsEntry 开仓位置

函数 | BarsEntry
别名 | 开仓位置
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前持仓的第一个开仓位置到当前位置的Bar计数，在开仓Bar上为0，无持仓返回-1
用法 | BarsEntry
来自“http://www.hs633.com/kthelp/index.php?title=BarsEntry_%E5%BC%80%E4%BB%93%E4%BD%8D%E7%BD%AE&oldid=2162”


BarsLastEntry 最后开仓位置

函数 | BarsLastEntry
别名 | 最后开仓位置
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前持仓的最后一个开仓位置到当前位置的Bar计数
用法 | BarsLastEntry
来自“http://www.hs633.com/kthelp/index.php?title=BarsLastEntry_%E6%9C%80%E5%90%8E%E5%BC%80%E4%BB%93%E4%BD%8D%E7%BD%AE&oldid=2163”


BarsSinceEntry 开仓位置

函数 | BarsSinceEntry
别名 | 开仓位置
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 开仓位置
用法 | BarsSinceEntry(PosBack=0) 返回指定持仓的第一次开仓到当前周期数
来自“http://www.hs633.com/kthelp/index.php?title=BarsSinceEntry_%E5%BC%80%E4%BB%93%E4%BD%8D%E7%BD%AE&oldid=2167”


BarsSinceExit 平仓位置

函数 | BarsSinceExit
别名 | 平仓位置
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 平仓位置
用法 | BarsSinceExit(PosBack=0) 返回指定持仓的最近一次平仓到当前周期数 If bEnterLong and BarsSinceExit > 5 then Buy(...); //平仓后至少过了5个K线才开新仓
来自“http://www.hs633.com/kthelp/index.php?title=BarsSinceExit_%E5%B9%B3%E4%BB%93%E4%BD%8D%E7%BD%AE&oldid=2171”


BarsSinceLastEntry 最近开仓位置

函数 | BarsSinceLastEntry
别名 | 最近开仓位置
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 最近开仓位置
用法 | BarsSinceLastEntry(PosBack=0) 返回指定持仓的最近一次开仓到当前周期数
来自“http://www.hs633.com/kthelp/index.php?title=BarsSinceLastEntry_%E6%9C%80%E8%BF%91%E5%BC%80%E4%BB%93%E4%BD%8D%E7%BD%AE&oldid=2174”


ComMission 单口手续费

函数 | ComMission
别名 | 单口手续费
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 返回手续费估算
用法 | Commission() 例如： Commission 返回【策略设置】或【测评平台】中设置的以单口计手续费金额
来自“http://www.hs633.com/kthelp/index.php?title=ComMission_%E5%8D%95%E5%8F%A3%E6%89%8B%E7%BB%AD%E8%B4%B9&oldid=2155”


ContractProfit 每手浮动盈亏

函数 | ContractProfit
别名 | 每手浮动盈亏
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前持仓的每手浮动盈亏，已考虑交易费用（开仓及平仓的交易费用）
用法 | ContractProfit
来自“http://www.hs633.com/kthelp/index.php?title=ContractProfit_%E6%AF%8F%E6%89%8B%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F&oldid=1681”


ContractProfitAt 在 fPrice 平仓时的平均每口利润

函数 | ContractProfitAt
别名 | 在 fPrice 平仓时的平均每口利润
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 当前持仓如果在 fPrice 平仓时的平均每口利润， 不考虑手续费
用法 | ContractProfitAt(fPrice)
来自“http://www.hs633.com/kthelp/index.php?title=ContractProfitAt_%E5%9C%A8_fPrice_%E5%B9%B3%E4%BB%93%E6%97%B6%E7%9A%84%E5%B9%B3%E5%9D%87%E6%AF%8F%E5%8F%A3%E5%88%A9%E6%B6%A6&oldid=1686”


CurrentEntries 开仓次数

函数 | CurrentEntries
别名 | 开仓次数
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 当前持仓的开仓次数
用法 | CurrentEntries
来自“http://www.hs633.com/kthelp/index.php?title=CurrentEntries_%E5%BC%80%E4%BB%93%E6%AC%A1%E6%95%B0&oldid=1682”


DailyLosers 日亏损次数

函数 | DailyLosers
别名 | 日亏损次数
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取日亏损次数
用法 | DailyLosers(D,MP=0) 返回日期D的方向为MP的亏损交易次数，MP为1表示多头，-1表示空头，0表示双向统计 例如： If DailyLosers(Date,-1) 〈 2 Then SellShort; 当天空头亏损交易少于2次，才做新的空头交易
来自“http://www.hs633.com/kthelp/index.php?title=DailyLosers_%E6%97%A5%E4%BA%8F%E6%8D%9F%E6%AC%A1%E6%95%B0&oldid=2198”


DailyWinners 日盈利次数

函数 | DailyWinners
别名 | 日盈利次数
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 日盈利次数
用法 | DailyWinners(D,MP=0) 返回日期D的方向为MP的盈利交易次数，MP为1表示多头，-1表示空头，0表示双向统计 例如： DailyWinners(Date) 返回当天所有交易的盈利次数
来自“http://www.hs633.com/kthelp/index.php?title=DailyWinners_%E6%97%A5%E7%9B%88%E5%88%A9%E6%AC%A1%E6%95%B0&oldid=2199”


EntriesThisBar 周期开仓次数

函数 | EntriesThisBar
别名 | 周期开仓次数
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 周期开仓次数
用法 | EntriesThisBar(Bar=0,MP=0) 返回Bar位置周期的方向为MP的开仓次数。 参数：Bar为0表示当前周期，为1表示上一周期...；MP为1表示多头，-1表 示空头，0表示双向统计 例如： If EntriesThisBar(0,1) 〈 1 Then Buy; 当前周期没做过多头交易，才多头买入
来自“http://www.hs633.com/kthelp/index.php?title=EntriesThisBar_%E5%91%A8%E6%9C%9F%E5%BC%80%E4%BB%93%E6%AC%A1%E6%95%B0&oldid=2202”


EntriesToday 日开仓次数

函数 | EntriesToday
别名 | 日开仓次数
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 日开仓次数
用法 | EntriesToday(D,MP=0) 返回日期D的方向为MP的开仓次数，MP为1表示多头，-1表示空头，0表示双向统计 例如： If EntriesToday(Date,1) 〈1 Then Buy; 当天没做过多头交易，才多头买入
来自“http://www.hs633.com/kthelp/index.php?title=EntriesToday_%E6%97%A5%E5%BC%80%E4%BB%93%E6%AC%A1%E6%95%B0&oldid=2200”


EntryDate 开仓日期

函数 | EntryDate
别名 | 开仓日期
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 开仓日期
用法 | EntryDate(PosBack=0) 返回指定持仓的第一次开仓的日期，格式为YYYMMDD
来自“http://www.hs633.com/kthelp/index.php?title=EntryDate_%E5%BC%80%E4%BB%93%E6%97%A5%E6%9C%9F&oldid=2166”


EntryName 开仓名

函数 | EntryName
别名 | 开仓名
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 开仓标识名
用法 | EntryName(PosBack=0)
来自“http://www.hs633.com/kthelp/index.php?title=EntryName_%E5%BC%80%E4%BB%93%E5%90%8D&oldid=2161”


EntrySize 开仓数量

函数 | EntrySize
别名 | 开仓数量
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 开仓数量
用法 | EntrySize(nPos=0) // 别名:EntryLots
来自“http://www.hs633.com/kthelp/index.php?title=EntrySize_%E5%BC%80%E4%BB%93%E6%95%B0%E9%87%8F&oldid=2164”


EntryTime 开仓时间

函数 | EntryTime
别名 | 开仓时间
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前持仓的第一个开仓位置的日期和时间
用法 | EntryTime
来自“http://www.hs633.com/kthelp/index.php?title=EntryTime_%E5%BC%80%E4%BB%93%E6%97%B6%E9%97%B4&oldid=1663”


ExitDate 平仓日期

函数 | ExitDate
别名 | 平仓日期
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 平仓日期
用法 | ExitDate(PosBack=0) 返回指定持仓的最近一次平仓的日期，格式为YYYMMDD
来自“http://www.hs633.com/kthelp/index.php?title=ExitDate_%E5%B9%B3%E4%BB%93%E6%97%A5%E6%9C%9F&oldid=2168”


ExitName 平仓名

函数 | ExitName
别名 | 平仓名
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 平仓标识名
用法 | ExitName(PosBack=0)
来自“http://www.hs633.com/kthelp/index.php?title=ExitName_%E5%B9%B3%E4%BB%93%E5%90%8D&oldid=2170”


ExitPrice 平仓价格

函数 | ExitPrice
别名 | 平仓价格
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 最近一次平仓的平仓价格
用法 | ExitPrice
来自“http://www.hs633.com/kthelp/index.php?title=ExitPrice_%E5%B9%B3%E4%BB%93%E4%BB%B7%E6%A0%BC&oldid=1668”


ExitSize 平仓数量

函数 | ExitSize
别名 | 平仓数量
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 平仓数量
用法 | ExitSize(nPos=1) // 别名:ExitLots
来自“http://www.hs633.com/kthelp/index.php?title=ExitSize_%E5%B9%B3%E4%BB%93%E6%95%B0%E9%87%8F&oldid=2169”


ExitsThisBar 周期平仓次数

函数 | ExitsThisBar
别名 | 周期平仓次数
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 周期平仓次数
用法 | ExitsThisBar(Bar = 0,MP=0) 返回Bar位置周期的方向为MP的平仓次数。 参数：Bar为0表示当前周期，为1表示上一周期...；MP为1表示多头，-1表 示空头，0表示双向统计
来自“http://www.hs633.com/kthelp/index.php?title=ExitsThisBar_%E5%91%A8%E6%9C%9F%E5%B9%B3%E4%BB%93%E6%AC%A1%E6%95%B0&oldid=2203”


ExitsToday 日平仓次数

函数 | ExitsToday
别名 | 日平仓次数
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 日平仓次数
用法 | ExitsToday(D,MP=0) 返回日期D的方向为MP的平仓次数，MP为1表示多头，-1表示空头，0表示双向统计
来自“http://www.hs633.com/kthelp/index.php?title=ExitsToday_%E6%97%A5%E5%B9%B3%E4%BB%93%E6%AC%A1%E6%95%B0&oldid=2201”


ExitTime 平仓时间

函数 | ExitTime
别名 | 平仓时间
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 最近平仓时间
用法 | ExitTime
来自“http://www.hs633.com/kthelp/index.php?title=ExitTime_%E5%B9%B3%E4%BB%93%E6%97%B6%E9%97%B4&oldid=1669”


LastEntryDate 最近开仓日期

函数 | LastEntryDate
别名 | 最近开仓日期
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 最近开仓日期
用法 | LastEntryDate 返回当前持仓的最近一次开仓日期
来自“http://www.hs633.com/kthelp/index.php?title=LastEntryDate_%E6%9C%80%E8%BF%91%E5%BC%80%E4%BB%93%E6%97%A5%E6%9C%9F&oldid=2172”


LastEntryPrice 最后开仓价格

函数 | LastEntryPrice
别名 | 最后开仓价格
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前持仓的最后一个开仓价格
用法 | LastEntryPrice 例如： If LastEntryPrice - ASKPRICE > 2 then Buy(...); //网格交易，摊低成本
来自“http://www.hs633.com/kthelp/index.php?title=LastEntryPrice_%E6%9C%80%E5%90%8E%E5%BC%80%E4%BB%93%E4%BB%B7%E6%A0%BC&oldid=2156”


LastEntrySize 最近开仓数量

函数 | LastEntrySize
别名 | 最近开仓数量
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 最近开仓数量
用法 | LastEntrySize // 别名:LastEntryLots 返回当前持仓的最近一次开仓数量
来自“http://www.hs633.com/kthelp/index.php?title=LastEntrySize_%E6%9C%80%E8%BF%91%E5%BC%80%E4%BB%93%E6%95%B0%E9%87%8F&oldid=2173”


LastEntryTime 最后开仓时间

函数 | LastEntryTime
别名 | 最后开仓时间
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 当前持仓的最后开仓位置的日期和时间
用法 | LastEntryTime
来自“http://www.hs633.com/kthelp/index.php?title=LastEntryTime_%E6%9C%80%E5%90%8E%E5%BC%80%E4%BB%93%E6%97%B6%E9%97%B4&oldid=1665”


MaxContractLoss 最大浮亏

函数 | MaxContractLoss
别名 | 最大浮亏
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 最大浮亏
用法 | MaxpContractLoss 当前单口持仓曾经达到的最大浮亏
来自“http://www.hs633.com/kthelp/index.php?title=MaxContractLoss_%E6%9C%80%E5%A4%A7%E6%B5%AE%E4%BA%8F&oldid=2159”


MaxContractProfit 最大浮盈

函数 | MaxContractProfit
别名 | 最大浮盈
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 最大浮盈
用法 | MaxContractProfit 当前单口持仓曾经达到的最大浮盈
来自“http://www.hs633.com/kthelp/index.php?title=MaxContractProfit_%E6%9C%80%E5%A4%A7%E6%B5%AE%E7%9B%88&oldid=2157”


MaxPositionLoss 最大浮亏

函数 | MaxPositionLoss
别名 | 最大浮亏
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 当前持仓曾经最大浮动亏损数，已考虑交易费用
用法 | MaxPositionLoss(PosBack)
来自“http://www.hs633.com/kthelp/index.php?title=MaxPositionLoss_%E6%9C%80%E5%A4%A7%E6%B5%AE%E4%BA%8F&oldid=2175”


MaxPositionProfit 最大浮盈

函数 | MaxPositionProfit
别名 | 最大浮盈
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 当前持仓的最大浮动盈利数，已考虑交易费用
用法 | MaxPositionProfit(PosBack)
来自“http://www.hs633.com/kthelp/index.php?title=MaxPositionProfit_%E6%9C%80%E5%A4%A7%E6%B5%AE%E7%9B%88&oldid=2176”


MaxPostionProfit 整体最大浮盈

函数 | MaxPostionProfit
别名 | 整体最大浮盈
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 整体最大浮盈
用法 | MaxpPostionrofit 当前整体持仓曾达到的最大浮盈
来自“http://www.hs633.com/kthelp/index.php?title=MaxPostionProfit_%E6%95%B4%E4%BD%93%E6%9C%80%E5%A4%A7%E6%B5%AE%E7%9B%88&oldid=2158”


OpenEntryMaxProfit 指定头寸浮动盈亏最大值

函数 | OpenEntryMaxProfit
别名 | 指定头寸浮动盈亏最大值
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 取当前持仓的某一次开仓的头寸信息，参数TradeNumber=0表示第1次交易，1表示第2次交易...
用法 | OpenEntryMaxProfit(TradeNumber=0) 返回TradeNumber开仓的指定头寸的浮动盈亏的最大值
来自“http://www.hs633.com/kthelp/index.php?title=OpenEntryMaxProfit_%E6%8C%87%E5%AE%9A%E5%A4%B4%E5%AF%B8%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F%E6%9C%80%E5%A4%A7%E5%80%BC&oldid=2177”


OpenEntryMaxProfitPerContract 指定头寸单口浮动盈亏最大值

函数 | OpenEntryMaxProfitPerContract
别名 | 指定头寸单口浮动盈亏最大值
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 取当前持仓的某一次开仓的头寸信息，参数TradeNumber=0表示第1次交易，1表示第2次交易...
用法 | OpenEntryMaxProfitPerContract(TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=OpenEntryMaxProfitPerContract_%E6%8C%87%E5%AE%9A%E5%A4%B4%E5%AF%B8%E5%8D%95%E5%8F%A3%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F%E6%9C%80%E5%A4%A7%E5%80%BC&oldid=2178”


OpenEntryMinProfit 指定头寸浮动盈亏最小值

函数 | OpenEntryMinProfit
别名 | 指定头寸浮动盈亏最小值
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 取当前持仓的某一次开仓的头寸信息，参数TradeNumber=0表示第1次交易，1表示第2次交易...
用法 | OpenEntryMinProfit(TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=OpenEntryMinProfit_%E6%8C%87%E5%AE%9A%E5%A4%B4%E5%AF%B8%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F%E6%9C%80%E5%B0%8F%E5%80%BC&oldid=2179”


OpenEntryMinProfitPerContract 指定头寸单口浮动盈亏最小值

函数 | OpenEntryMinProfitPerContract
别名 | 指定头寸单口浮动盈亏最小值
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 取当前持仓的某一次开仓的头寸信息，参数TradeNumber=0表示第1次交易，1表示第2次交易...
用法 | OpenEntryMinProfitPerContract(TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=OpenEntryMinProfitPerContract_%E6%8C%87%E5%AE%9A%E5%A4%B4%E5%AF%B8%E5%8D%95%E5%8F%A3%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F%E6%9C%80%E5%B0%8F%E5%80%BC&oldid=2180”


OpenEntryProfit 指定头寸浮动盈亏

函数 | OpenEntryProfit
别名 | 指定头寸浮动盈亏
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 取当前持仓的某一次开仓的头寸信息，参数TradeNumber=0表示第1次交易，1表示第2次交易...
用法 | OpenEntryProfit(TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=OpenEntryProfit_%E6%8C%87%E5%AE%9A%E5%A4%B4%E5%AF%B8%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F&oldid=2181”


OpenEntryProfitPerContract 指定头寸单口浮动盈亏

函数 | OpenEntryProfitPerContract
别名 | 指定头寸单口浮动盈亏
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 取当前持仓的某一次开仓的头寸信息，参数TradeNumber=0表示第1次交易，1表示第2次交易...
用法 | OpenEntryProfitPerContract(TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=OpenEntryProfitPerContract_%E6%8C%87%E5%AE%9A%E5%A4%B4%E5%AF%B8%E5%8D%95%E5%8F%A3%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F&oldid=2182”


PositionProfit 浮动盈亏

函数 | PositionProfit
别名 | 浮动盈亏
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 当前持仓的浮动盈亏，已考虑交易费用
用法 | PositionProfit(PosBack)
来自“http://www.hs633.com/kthelp/index.php?title=PositionProfit_%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F&oldid=1683”


PositionProfitAt 在 fPrice 平仓时整个仓位的利润

函数 | PositionProfitAt
别名 | 在 fPrice 平仓时整个仓位的利润
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 当前持仓如果在 fPrice 平仓时整个仓位的利润， 不考虑手续费
用法 | PositionProfitAt(fPrice)
来自“http://www.hs633.com/kthelp/index.php?title=PositionProfitAt_%E5%9C%A8_fPrice_%E5%B9%B3%E4%BB%93%E6%97%B6%E6%95%B4%E4%B8%AA%E4%BB%93%E4%BD%8D%E7%9A%84%E5%88%A9%E6%B6%A6&oldid=1687”


PostRadeCount 指定持仓交易次数

函数 | PostRadeCount
别名 | 指定持仓交易次数
所属类别 | 交易状态函数
参数数量 | 1
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeCount(PosBack=0) 返回PosBack指定持仓的交易次数
来自“http://www.hs633.com/kthelp/index.php?title=PostRadeCount_%E6%8C%87%E5%AE%9A%E6%8C%81%E4%BB%93%E4%BA%A4%E6%98%93%E6%AC%A1%E6%95%B0&oldid=2183”


PosTradeEntryBar 指定交易开仓位置

函数 | PosTradeEntryBar
别名 | 指定交易开仓位置
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeEntryBar(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeEntryBar_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%BC%80%E4%BB%93%E4%BD%8D%E7%BD%AE&oldid=2192”


PostRadeEntryCategory 开仓指令类型

函数 | PostRadeEntryCategory
别名 | 开仓指令类型
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeEntryCategory(PosBack=0,TradeNumber=0) 1 = 停损单 (slippage=-1,OT_Stop) 2 = 限价单 (OT_Limit) 3 = 市价单 (OT_Market) 4 = 收盘单 (OT_Close) 5 = 开盘单 (OT_Buy) 6 = 保留 7 = 保留 8 = 停损限价单 (slippage>=0,OT_Stop)
来自“http://www.hs633.com/kthelp/index.php?title=PostRadeEntryCategory_%E5%BC%80%E4%BB%93%E6%8C%87%E4%BB%A4%E7%B1%BB%E5%9E%8B&oldid=2184”


PosTradeEntryDateTime 指定交易开仓时间

函数 | PosTradeEntryDateTime
别名 | 指定交易开仓时间
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeEntryDateTime(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeEntryDateTime_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%BC%80%E4%BB%93%E6%97%B6%E9%97%B4&oldid=2190”


PosTradeEntryName 指定交易开仓名

函数 | PosTradeEntryName
别名 | 指定交易开仓名
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeEntryName(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeEntryName_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%BC%80%E4%BB%93%E5%90%8D&oldid=2191”


PosTradeEntryPrice 指定交易开仓价格

函数 | PosTradeEntryPrice
别名 | 指定交易开仓价格
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeEntryPrice(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeEntryPrice_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%BC%80%E4%BB%93%E4%BB%B7%E6%A0%BC&oldid=2193”


PosTradeExitBar 指定交易平仓位置

函数 | PosTradeExitBar
别名 | 指定交易平仓位置
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeExitBar(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeExitBar_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%B9%B3%E4%BB%93%E4%BD%8D%E7%BD%AE&oldid=2196”


PostRadeExitCategory 平仓指令类型

函数 | PostRadeExitCategory
别名 | 平仓指令类型
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeExitCategory(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PostRadeExitCategory_%E5%B9%B3%E4%BB%93%E6%8C%87%E4%BB%A4%E7%B1%BB%E5%9E%8B&oldid=2185”


PosTradeExitDateTime 指定交易平仓时间

函数 | PosTradeExitDateTime
别名 | 指定交易平仓时间
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeExitDateTime(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeExitDateTime_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%B9%B3%E4%BB%93%E6%97%B6%E9%97%B4&oldid=2194”


PosTradeExitName 指定交易平仓名

函数 | PosTradeExitName
别名 | 指定交易平仓名
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeExitName(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeExitName_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%B9%B3%E4%BB%93%E5%90%8D&oldid=2195”


PosTradeExitPrice 指定交易平仓价格

函数 | PosTradeExitPrice
别名 | 指定交易平仓价格
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeExitPrice(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeExitPrice_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E5%B9%B3%E4%BB%93%E4%BB%B7%E6%A0%BC&oldid=2197”


PosTradeIsLong 是否多头交易

函数 | PosTradeIsLong
别名 | 是否多头交易
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeIsLong(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeIsLong_%E6%98%AF%E5%90%A6%E5%A4%9A%E5%A4%B4%E4%BA%A4%E6%98%93&oldid=2186”


PosTradeIsOpen 是否未被平仓

函数 | PosTradeIsOpen
别名 | 是否未被平仓
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeIsOpen(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeIsOpen_%E6%98%AF%E5%90%A6%E6%9C%AA%E8%A2%AB%E5%B9%B3%E4%BB%93&oldid=2187”


PosTradeProfit 指定交易盈亏

函数 | PosTradeProfit
别名 | 指定交易盈亏
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeProfit(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeProfit_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E7%9B%88%E4%BA%8F&oldid=2188”


PosTradeSize 指定交易数量

函数 | PosTradeSize
别名 | 指定交易数量
所属类别 | 交易状态函数
参数数量 | 2
运行模式 | 逐根
说明 | 取指定持仓的指定某次开平仓的信息，参数TradeNumber=0表示第1次交易，1表示第2次交易。参数PosBack指定之前第几次持仓,开仓后全部平掉算作1次持仓，0表示当前持仓，1表示上一次已出场的持仓，等等
用法 | PosTradeSize(PosBack=0,TradeNumber=0)
来自“http://www.hs633.com/kthelp/index.php?title=PosTradeSize_%E6%8C%87%E5%AE%9A%E4%BA%A4%E6%98%93%E6%95%B0%E9%87%8F&oldid=2189”


SetInActive 时间止损

函数 | SetInActive
别名 | 时间止损
所属类别 | 交易状态函数
参数数量 | 0
运行模式 | 逐根
说明 | 时间止损
用法 | SetInActive( profit, period ) Period个周期后，获利没到Profit则出场。 获利是单口还是整体由SetStopContract和SetStopPostion控制 例子：SetInActive( 9999999, 10); //10个周期后无论如何都出场(因为利润不可能到9999999)
来自“http://www.hs633.com/kthelp/index.php?title=SetInActive_%E6%97%B6%E9%97%B4%E6%AD%A2%E6%8D%9F&oldid=2165”


Explain 显示解盘文字

函数 | Explain
别名 | 显示解盘文字
所属类别 | 解盘函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 在[解]中输出解盘文字。
用法 | EXPLAIN(COND,TEXT) 在COND条件满足时在[解]中输出解盘文字,可以用'\n'空一行。 例如: EXPLAIN(HIGH>=HHV(HIGH,20), '创20天新高\n') 表示在创20天新高时在[解]中输出解说并空1行显示下条解盘文字。
来自“http://www.hs633.com/kthelp/index.php?title=Explain_%E6%98%BE%E7%A4%BA%E8%A7%A3%E7%9B%98%E6%96%87%E5%AD%97&oldid=1388”


ExplainEx 显示解盘数值

函数 | ExplainEx
别名 | 显示解盘数值
所属类别 | 解盘函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 在[解]中输出带数值的解盘。
用法 | EXPLAINEX(COND,TEXT,NUMBER,PRECISION,SKIPLINES) 在COND条件满足时在[解]中输出数值解说。 PRECISION为小数显示位数,SKIPLINES为空出几行显示下一个解盘 例如: EXPLAINEX(HIGH>=HHV(HIGH,20), '20天新高价:',HIGH,2,1) 表示在创20天新高时在[解]中输出数值解说。
来自“http://www.hs633.com/kthelp/index.php?title=ExplainEx_%E6%98%BE%E7%A4%BA%E8%A7%A3%E7%9B%98%E6%95%B0%E5%80%BC&oldid=1389”


ExplainIcon 画解盘图标

函数 | ExplainIcon
别名 | 画解盘图标
所属类别 | 解盘函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 在[解]中绘制解盘图标。
用法 | EXPLAINICON(COND,ICON) 在COND条件满足时在[解]中绘制解盘图标 ICON为数字时4种图标编码为1-4(阴雨、初彩、中彩、彩虹)。为字符串表示自制图标 例如: EXPLAINICON(HIGH>=HHV(HIGH,20), 2) 表示在创20天新高时在[解]中画2号图标（雨后初彩虹）。 EXPLAINICON(HIGH>=HHV(HIGH,20), 'MyBMP') 表示在创20天新高时在[解]中画FmlDLL子目录下的自制图标MyBMP.BMP。 可用ALIGN0中对齐,ALIGN1左对齐,ALIGN2右对齐
来自“http://www.hs633.com/kthelp/index.php?title=ExplainIcon_%E7%94%BB%E8%A7%A3%E7%9B%98%E5%9B%BE%E6%A0%87&oldid=1390”


And 与

函数 | And
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 逻辑与运算
用法 | A AND B 表示条件A与条件B同时成立
来自“http://www.hs633.com/kthelp/index.php?title=And_%E4%B8%8E&oldid=2009”


Begin 把多条语句看成一条语句

函数 | Begin
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 逻辑与运算
用法 | 把多条语句看作一条语句 语法:BEGIN...END
来自“http://www.hs633.com/kthelp/index.php?title=Begin_%E6%8A%8A%E5%A4%9A%E6%9D%A1%E8%AF%AD%E5%8F%A5%E7%9C%8B%E6%88%90%E4%B8%80%E6%9D%A1%E8%AF%AD%E5%8F%A5&oldid=2008”


Break 跳出循环

函数 | Break
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 跳出循环
用法 | 语法:BREAK;
来自“http://www.hs633.com/kthelp/index.php?title=Break_%E8%B7%B3%E5%87%BA%E5%BE%AA%E7%8E%AF&oldid=2010”


Case 多分支条件语句

函数 | Case
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 多分支条件语句
用法 | 语法: switch ( expression ) begin case constant-expression : statement case constant-expression : statement ... [default : statement] end 当express等于不同的case值时，执行不同的动作” 用法：“例: switch( x ) begin case 1: a:=20; case 3: a:=50; case 100: a:=H; default: a:=c; end 当x等于1时a赋值20，当x等于3时a赋值50；当x等于100时a赋值最高价，其他的a赋值收盘价
来自“http://www.hs633.com/kthelp/index.php?title=Case_%E5%A4%9A%E5%88%86%E6%94%AF%E6%9D%A1%E4%BB%B6%E8%AF%AD%E5%8F%A5&oldid=2011”


Do 执行语句

函数 | Do
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 执行语句
用法 | 语法: FOR var=n1 TO n2 DO expr; WHILE cond DO expr
来自“http://www.hs633.com/kthelp/index.php?title=Do_%E6%89%A7%E8%A1%8C%E8%AF%AD%E5%8F%A5&oldid=2012”


Else IF条件语句

函数 | Else
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | IF条件语句
用法 | 语法:IF cond THEN expr1 ELSE expr2 当满足 cond 条件的时候，执行语句 expr1，否则执行 expr2 语句
来自“http://www.hs633.com/kthelp/index.php?title=Else_IF%E6%9D%A1%E4%BB%B6%E8%AF%AD%E5%8F%A5&oldid=2013”


End 把多条语句看成一条语句

函数 | End
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 跳出循环
用法 | 把多条语句看作一条语句 语法:BEGIN...END
来自“http://www.hs633.com/kthelp/index.php?title=End_%E6%8A%8A%E5%A4%9A%E6%9D%A1%E8%AF%AD%E5%8F%A5%E7%9C%8B%E6%88%90%E4%B8%80%E6%9D%A1%E8%AF%AD%E5%8F%A5&oldid=2014”


EnterLong 多头买入

函数 | EnterLong
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 交易系统之多头买入信号
用法 | 例如: ENTERLONG:CROSS(VAR1,VAR2)
来自“http://www.hs633.com/kthelp/index.php?title=EnterLong_%E5%A4%9A%E5%A4%B4%E4%B9%B0%E5%85%A5&oldid=2015”


EnterShort 空头买入

函数 | EnterShort
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 交易系统之空头买入信号
用法 | 例如: ENTERSHORT:CROSS(VAR1,VAR2)
来自“http://www.hs633.com/kthelp/index.php?title=EnterShort_%E7%A9%BA%E5%A4%B4%E4%B9%B0%E5%85%A5&oldid=2016”


Exit 终止执行

函数 | Exit
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 终止公式执行
用法 | //第5根k线开始才执行公式 if barpos < 5 then exit;
来自“http://www.hs633.com/kthelp/index.php?title=Exit_%E7%BB%88%E6%AD%A2%E6%89%A7%E8%A1%8C&oldid=2206”


ExitLong 多头卖出

函数 | ExitLong
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 交易系统之多头卖出信号
用法 | EXITLONG:CROSS(VAR1,VAR2)
来自“http://www.hs633.com/kthelp/index.php?title=ExitLong_%E5%A4%9A%E5%A4%B4%E5%8D%96%E5%87%BA&oldid=2018”


ExitShort 空头卖出

函数 | ExitShort
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 交易系统之空头卖出信号
用法 | 例如: EXITSHORT:CROSS(VAR1,VAR2)
来自“http://www.hs633.com/kthelp/index.php?title=ExitShort_%E7%A9%BA%E5%A4%B4%E5%8D%96%E5%87%BA&oldid=2019”


For 循环语句

函数 | For
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | FOR循环语句
用法 | 语法: FOR var=n1 TO n2 DO expr; 从 var=n1 开始到 var=n2 开始循环执行 expr 语句，每执行一次var加1 FOR var=n1 DOWNTO n2 DO expr2; 从 var=n1 开始到 var=n2 开始循环执行 expr 语句，每执行一次var减1 for i = 1 to 100 step 10 do begin x := x + 5; end
来自“http://www.hs633.com/kthelp/index.php?title=For_%E5%BE%AA%E7%8E%AF%E8%AF%AD%E5%8F%A5&oldid=2020”


If 条件语句

函数 | If
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | IF条件语句
用法 | 语法:IF cond THEN expr1 ELSE expr2 当满足 cond 条件的时候，执行语句 expr1，否则执行 expr2 语句 请把序列相关运算写在条件判断的前面，除非您确信它们可以在所有的分支都被赋值。 例如，以下写法是不对的。 if(not 交易联通()) then 退出; 买信号 :=cross( ma(c,5),ma(c10); Buy(...); 请改为： 买信号:=cross( ma(c,5),ma(c10); if(not 交易联通()) then 退出; Buy(...);
来自“http://www.hs633.com/kthelp/index.php?title=If_%E6%9D%A1%E4%BB%B6%E8%AF%AD%E5%8F%A5&oldid=2021”


Or 或

函数 | Or
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 逻辑或运算
用法 | A OR B 表示条件A与条件B只要有一个成立即可
来自“http://www.hs633.com/kthelp/index.php?title=Or_%E6%88%96&oldid=2022”


Repeat 循环语句

函数 | Repeat
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | REPEAT循环语句
用法 | 语法:REPEAT expr1 UNTIL cond 循环执行语句 expr1直到cond 条件满足
来自“http://www.hs633.com/kthelp/index.php?title=Repeat_%E5%BE%AA%E7%8E%AF%E8%AF%AD%E5%8F%A5&oldid=2023”


Return 结束此函数的执行并将它的参数作为函数的值返回

函数 | Return
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回语句
用法 | 语法:return expr1 立即结束此函数的执行并将它的参数作为函数的值返回 expr1
来自“http://www.hs633.com/kthelp/index.php?title=Return_%E7%BB%93%E6%9D%9F%E6%AD%A4%E5%87%BD%E6%95%B0%E7%9A%84%E6%89%A7%E8%A1%8C%E5%B9%B6%E5%B0%86%E5%AE%83%E7%9A%84%E5%8F%82%E6%95%B0%E4%BD%9C%E4%B8%BA%E5%87%BD%E6%95%B0%E7%9A%84%E5%80%BC%E8%BF%94%E5%9B%9E&oldid=2026”


ScriptType 脚本类型

函数 | ScriptType
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设置脚本类型
用法 | 例如: t1:=SCRIPTTYPE(0);设置VBScript脚本 t1:=SCRIPTTYPE(1);设置JScript脚本
来自“http://www.hs633.com/kthelp/index.php?title=ScriptType_%E8%84%9A%E6%9C%AC%E7%B1%BB%E5%9E%8B&oldid=2027”


SetLBound 设置下界

函数 | SetLBound
别名 | 无
所属类别 | 控制语句
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 设置序列变量下界(有效数据起始下标)，函数返回序列下界
用法 | SETLBOUND(X,N) 设置序列变量X的下界(最小下标),N为0或N超过上界则整个序列数据都无效 例如: VAR1:C;n1:=SETLBOUND(VAR1,10);
来自“http://www.hs633.com/kthelp/index.php?title=SetLBound_%E8%AE%BE%E7%BD%AE%E4%B8%8B%E7%95%8C&oldid=2028”


Step FOR循环语句步长

函数 | Step
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | FOR循环语句步长
用法 | 语法: step 默认为1 for i = 1 to 100 step 10 do begin x := x + 5; end
来自“http://www.hs633.com/kthelp/index.php?title=Step_FOR%E5%BE%AA%E7%8E%AF%E8%AF%AD%E5%8F%A5%E6%AD%A5%E9%95%BF&oldid=2029”


Switch 多分支条件语句

函数 | Switch
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 多分支条件语句
用法 | 语法: switch ( expression ) begin case constant-expression : statement case constant-expression : statement ... [default : statement] end 当express等于不同的case值时，执行不同的动作” 用法：“例: switch( x ) begin case 1: a:=20; case 3: a:=50; case 100: a:=H; default: a:=c; end 当x等于1时a赋值20，当x等于3时a赋值50；当x等于100时a赋值最高价，其他的a赋值收盘价
来自“http://www.hs633.com/kthelp/index.php?title=Switch_%E5%A4%9A%E5%88%86%E6%94%AF%E6%9D%A1%E4%BB%B6%E8%AF%AD%E5%8F%A5&oldid=2030”


Then IF条件语句

函数 | Then
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | IF条件语句
用法 | 语法:IF cond THEN expr1 ELSE expr2 当满足 cond 条件的时候，执行语句 expr1，否则执行 expr2 语句
来自“http://www.hs633.com/kthelp/index.php?title=Then_IF%E6%9D%A1%E4%BB%B6%E8%AF%AD%E5%8F%A5&oldid=2031”


Until REPEAT循环语句

函数 | Until
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | REPEAT循环语句
用法 | 语法:REPEAT expr1 UNTIL cond 循环执行语句 expr1直到cond 条件满足
来自“http://www.hs633.com/kthelp/index.php?title=Until_REPEAT%E5%BE%AA%E7%8E%AF%E8%AF%AD%E5%8F%A5&oldid=2032”


While 循环语句

函数 | While
别名 | 无
所属类别 | 控制语句
参数数量 | 0
运行模式 | 逐根/逐行
说明 | WHILE循环语句
用法 | 语法: WHILE cond DO expr 当满足 cond 条件的时候，循环执行语句 expr
来自“http://www.hs633.com/kthelp/index.php?title=While_%E5%BE%AA%E7%8E%AF%E8%AF%AD%E5%8F%A5&oldid=2033”


EstData 横向统计数据

函数 | EstData
别名 | 横向统计数据
所属类别 | 扩展数据
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得横向统计日线数据。
用法 | ESTDATA(N),N取1--N 或者 ESTDATA(S),S为数据名称 在[横向统计管理]中定义并计算数据(仅为日线周期)。
来自“http://www.hs633.com/kthelp/index.php?title=EstData_%E6%A8%AA%E5%90%91%E7%BB%9F%E8%AE%A1%E6%95%B0%E6%8D%AE&oldid=1882”


SelfData 自定义数据

函数 | SelfData
别名 | 自定义数据
所属类别 | 扩展数据
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 自定义数据
用法 | SELFDATA( s),s为数据名称或序号 例如 SELFDATA('发行价'),返回自定义的'发行价'数据
来自“http://www.hs633.com/kthelp/index.php?title=SelfData_%E8%87%AA%E5%AE%9A%E4%B9%89%E6%95%B0%E6%8D%AE&oldid=1881”


All EVERY, 一直存在

函数 | All
别名 | EVERY, 一直存在
所属类别 | 逻辑函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 一直存在
用法 | EVERY (X,N)返回N周期内一直满足条件X,N可为常数或变量, 若N=0则从第一个有效值开始 例如: EVERY (C>O,10)表示10个周期内一直是阳线
来自“http://www.hs633.com/kthelp/index.php?title=All_EVERY,_%E4%B8%80%E7%9B%B4%E5%AD%98%E5%9C%A8&oldid=1204”


Any EXIST, 存在

函数 | Any
别名 | EXIST, 存在
所属类别 | 逻辑函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 是否存在
用法 | EXIST(X,N)返回N周期内是否存在满足条件X,N可为常数或变量, 若N=0则从第一个有效值开始 例如: EXIST(C>O,10)表示10个周期中存在阳线
来自“http://www.hs633.com/kthelp/index.php?title=Any_EXIST,_%E5%AD%98%E5%9C%A8&oldid=1205”


Between 介于

函数 | Between
别名 | 介于
所属类别 | 逻辑函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 介于两个数之间。
用法 | BETWEEN(A,B,C)表示A处于B和C之间时返回1，否则返回0 例如: BETWEEN(CLOSE,MA(CLOSE,10),MA(CLOSE,20)) 表示收盘价介于10日均线和20日均线之间
来自“http://www.hs633.com/kthelp/index.php?title=Between_%E4%BB%8B%E4%BA%8E&oldid=1203”


Cross 交叉函数

函数 | Cross
别名 | 交叉函数
所属类别 | 逻辑函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 两条线交叉。
用法 | CROSS(A,B)表示当A从下方向上穿过B时返回1，否则返回0 例如: CROSS(MA(CLOSE,10),MA(CLOSE,20))表示10日均线与20日均线交金叉 逐行逻辑跟逐根略有不同。 逐行下逻辑：前一根小于(〈)指定值，且本根大于等于(〉=)指定值 或者，前一根等于(=)指定值，且本根大于(>)指定值；则满足条件。 逐根下逻辑：前一根小于指定值，且本根大于指定值 或者，前N根等于指定值，且前N+1根小于指定值，且本根大于指定值；则满足条件
来自“http://www.hs633.com/kthelp/index.php?title=Cross_%E4%BA%A4%E5%8F%89%E5%87%BD%E6%95%B0&oldid=1206”


CrossOver 交叉函数

函数 | CrossOver
别名 | 交叉函数
所属类别 | 逻辑函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 两条线交叉。
用法 | CrossOver(A,B)表示当A从下方向上穿过B时返回1，否则返回0 例如: CrossOver(MA(CLOSE,10),MA(CLOSE,20))表示10日均线与20日均线交金叉
来自“http://www.hs633.com/kthelp/index.php?title=CrossOver_%E4%BA%A4%E5%8F%89%E5%87%BD%E6%95%B0&oldid=1207”


CrossUnder 交叉函数

函数 | CrossUnder
别名 | 交叉函数
所属类别 | 逻辑函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 两条线交叉。
用法 | CrossUnder(A,B)表示当A从上方向下穿过B时返回1，否则返回0 例如: CrossUnder(MA(CLOSE,10),MA(CLOSE,20))表示10日均线与20日均线交死叉
来自“http://www.hs633.com/kthelp/index.php?title=CrossUnder_%E4%BA%A4%E5%8F%89%E5%87%BD%E6%95%B0&oldid=1208”


Iif 条件函数

函数 | Iif
别名 | 条件函数
所属类别 | 逻辑函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 根据条件取不同的值。
用法 | IIF(X,A,B)若X不为0则返回A,否则返回B 例如: IIF(CLOSE>OPEN,LOW,HIGH) 表示该周期收阴则返回最低价，否则返回最高价
来自“http://www.hs633.com/kthelp/index.php?title=Iif_%E6%9D%A1%E4%BB%B6%E5%87%BD%E6%95%B0&oldid=1209”


IsDown 当日收阴

函数 | IsDown
别名 | 当日收阴
所属类别 | 逻辑函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 该周期是否收阴。
用法 | ISDOWN 当收盘<开盘时，返回值为1，否则为0
来自“http://www.hs633.com/kthelp/index.php?title=IsDown_%E5%BD%93%E6%97%A5%E6%94%B6%E9%98%B4&oldid=1210”


IsEqual 当日收平

函数 | IsEqual
别名 | 当日收平
所属类别 | 逻辑函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 该周期是否平盘。
用法 | ISEQUAL 当收盘=开盘时，返回值为1，否则为0
来自“http://www.hs633.com/kthelp/index.php?title=IsEqual_%E5%BD%93%E6%97%A5%E6%94%B6%E5%B9%B3&oldid=1211”


IsLastBar 是否最后周期

函数 | IsLastBar
别名 | 是否最后周期
所属类别 | 逻辑函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 该周期是否为最后一个周期。
用法 | ISLASTBAR,IsLastPeriod 最后一个周期返回值为1，其余为0
来自“http://www.hs633.com/kthelp/index.php?title=IsLastBar_%E6%98%AF%E5%90%A6%E6%9C%80%E5%90%8E%E5%91%A8%E6%9C%9F&oldid=1212”


IsLastPeriod 是否最后周期

函数 | IsLastPeriod
别名 | 是否最后周期
所属类别 | 逻辑函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 该周期是否为最后一个周期。
用法 | ISLASTBAR,IsLastPeriod 最后一个周期返回值为1，其余为0
来自“http://www.hs633.com/kthelp/index.php?title=IsLastPeriod_%E6%98%AF%E5%90%A6%E6%9C%80%E5%90%8E%E5%91%A8%E6%9C%9F&oldid=1213”


IsUp 当日收阳

函数 | IsUp
别名 | 当日收阳
所属类别 | 逻辑函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 该周期是否收阳。
用法 | ISUP 当收盘>开盘时，返回值为1，否则为0
来自“http://www.hs633.com/kthelp/index.php?title=IsUp_%E5%BD%93%E6%97%A5%E6%94%B6%E9%98%B3&oldid=1214”


Last 持续存在

函数 | Last
别名 | 持续存在
所属类别 | 逻辑函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 持续存在
用法 | LAST(X,A,B)返回第前A周期到第前B周期是否一直满足条件X 若A为0，表示从第一天开始，B为0，表示到最后日止 例如: LAST(C>O,10,5)表示从第前10个周期到第前5个周期内一直是阳线
来自“http://www.hs633.com/kthelp/index.php?title=Last_%E6%8C%81%E7%BB%AD%E5%AD%98%E5%9C%A8&oldid=1215”


LongCross

函数 | LongCross
别名 | 无
所属类别 | 逻辑函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 两条线维持一定周期后交叉。
用法 | LONGCROSS(A,B,N) 表示A在N周期内都小于B，本周期从下方向上穿过B时返回1，否则返回0 例如: LONGCROSS(MA(CLOSE,10),MA(CLOSE,20),5) 表示10日均线维持5周期后与20日均线交金叉
来自“http://www.hs633.com/kthelp/index.php?title=LongCross&oldid=1216”


Not 求逻辑非

函数 | Not
别名 | 求逻辑非
所属类别 | 逻辑函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求逻辑非。
用法 | NOT(X)返回非X,即当X=0时返回1，否则返回0 例如: NOT(ISDOWN)表示平盘或收阳
来自“http://www.hs633.com/kthelp/index.php?title=Not_%E6%B1%82%E9%80%BB%E8%BE%91%E9%9D%9E&oldid=1217”


Range 范围

函数 | Range
别名 | 范围
所属类别 | 逻辑函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 介于某个范围之间。
用法 | RANGE(A,B,C) 表示A大于B同时小于C时返回1，否则返回0 例如: RANGE(CLOSE,MA(CLOSE,10),MA(CLOSE,20)) 表示收盘价大于10日均线并且小于20日均线
来自“http://www.hs633.com/kthelp/index.php?title=Range_%E8%8C%83%E5%9B%B4&oldid=1218”


Delta DELTA指标

函数 | Delta
别名 | DELTA指标
所属类别 | 期权函数
参数数量 | 7
运行模式 | 逐根/逐行
说明 | DELTA指标(期权价格变动对其标的物价格变动的比率)
用法 | DELTA(O, T, P, X, I, V, D) O为期权类型,T为到期天数(自然日),P为标的物价, X为履约价格,I为年利率,V为历史年波动率,D为年现金股利率. 请参见OPTION函数
来自“http://www.hs633.com/kthelp/index.php?title=Delta_DELTA%E6%8C%87%E6%A0%87&oldid=1257”


Gamma GAMMA指标

函数 | Gamma
别名 | GAMMA指标
所属类别 | 期权函数
参数数量 | 7
运行模式 | 逐根/逐行
说明 | GAMMA指标(DELTA指标变动对其标的物价格变动的比率)
用法 | GAMMA(O, T, P, X, I, V, D) O为期权类型,T为到期天数(自然日),P为标的物价, X为履约价格,I为年利率,V为历史年波动率,D为年现金股利率. 请参见OPTION函数
来自“http://www.hs633.com/kthelp/index.php?title=Gamma_GAMMA%E6%8C%87%E6%A0%87&oldid=1258”


Imv 隐含波动率

函数 | Imv
别名 | 隐含波动率
所属类别 | 期权函数
参数数量 | 7
运行模式 | 逐根/逐行
说明 | 期权隐含波动率
用法 | IMV(O, T, P, X, I, C, D) O为期权类型,0表示看涨期权,1表示看跌期权 T为到期天数,P为标的物现价,X为履约价格,I为年利率,C为期权价格,D为年现金股利率 T/P/X/C可以为序列或常数，其余参数为常数 例如: IMV(0, 60, 110, 100, 6, 12, 0) 求标的物现价为110，履约价格为100，年利率为6%，60天后到期的看涨期权价格为12时的隐含波动率 IMV(1, DATEDIFF(DATE,1060615), TC, 20, 6, CLOSE, 0) 标的物价格序列为TC,求履约期满日为2006年6月15日的看跌期权价格序列为CLOSE时的隐含波动率
来自“http://www.hs633.com/kthelp/index.php?title=Imv_%E9%9A%90%E5%90%AB%E6%B3%A2%E5%8A%A8%E7%8E%87&oldid=1259”


Option 期权定价

函数 | Option
别名 | 期权定价
所属类别 | 期权函数
参数数量 | 7
运行模式 | 逐根/逐行
说明 | 期权定价
用法 | OPTION(O, T, P, X, I, V, D) O为期权类型,0表示看涨期权,1表示看跌期权 T为到期天数(自然日),P为标的物价,X为履约价格,I为年利率,V为历史年波动率,D为年现金股利率 T/P/X/V可以为序列或常数，其余参数为常数 例如: OPTION(0, 100, 22, 20, 6, 15, 0) 求标的物现价为22，履约价格为20，年利率为6%，波动率为12%的100天后到期的看涨期权定价 OPTION(1, DATEDIFF(DATE,1060615), CLOSE, 20, 6, 15, 0) 求履约期满日为2006年6月15日的看跌期权定价
来自“http://www.hs633.com/kthelp/index.php?title=Option_%E6%9C%9F%E6%9D%83%E5%AE%9A%E4%BB%B7&oldid=1260”


OptionLastDay 结算日

函数 | OptionLastDay
别名 | 结算日
所属类别 | 期权函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 期权结算日
用法 | OPTIONLASTDAY(STKLABEL) 取得代码为STKLABEL的期权的结算日
来自“http://www.hs633.com/kthelp/index.php?title=OptionLastDay_%E7%BB%93%E7%AE%97%E6%97%A5&oldid=1261”


Rho RHO指标

函数 | Rho
别名 | RHO指标
所属类别 | 期权函数
参数数量 | 7
运行模式 | 逐根/逐行
说明 | RHO指标(期权价格变动对利率变动的比率)
用法 | RHO(O, T, P, X, I, V, D) O为期权类型,T为到期天数(自然日),P为标的物价,X为履约价格, I为年利率,V为历史年波动率,D为年现金股利率. 请参见OPTION函数
来自“http://www.hs633.com/kthelp/index.php?title=Rho_RHO%E6%8C%87%E6%A0%87&oldid=1262”


Theta THETA指标

函数 | Theta
别名 | THETA指标
所属类别 | 期权函数
参数数量 | 7
运行模式 | 逐根/逐行
说明 | THETA指标(期权价格变动对时间变动的比率)
用法 | THETA(O, T, P, X, I, V, D) O为期权类型,T为到期天数(自然日),P为标的物价,X为履约价格, I为年利率,V为历史年波动率,D为年现金股利率. 请参见OPTION函数
来自“http://www.hs633.com/kthelp/index.php?title=Theta_THETA%E6%8C%87%E6%A0%87&oldid=1263”


Vega VEGA指标

函数 | Vega
别名 | VEGA指标
所属类别 | 期权函数
参数数量 | 7
运行模式 | 逐根/逐行
说明 | VEGA指标(期权价格变动对其标的物价格波动率变动的比率)
用法 | VEGA(O, T, P, X, I, V, D) O为期权类型,T为到期天数(自然日),P为标的物价,X为履约价格, I为年利率,V为历史年波动率,D为年现金股利率. 请参见OPTION函数
来自“http://www.hs633.com/kthelp/index.php?title=Vega_VEGA%E6%8C%87%E6%A0%87&oldid=1264”


Volo 波动率

函数 | Volo
别名 | 波动率
所属类别 | 期权函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 波动率
用法 | VOLO(X, N, M) 样本数为N的X序列的波动率,M为交易周期数 例如: VOLO(CLOSE,90,250) 表示计算90个样本收盘价数据的年波动率 (输出以百分比为单位),以年250交易日计算
来自“http://www.hs633.com/kthelp/index.php?title=Volo_%E6%B3%A2%E5%8A%A8%E7%8E%87&oldid=1265”


Fft 傅立叶变换

函数 | Fft
别名 | 傅立叶变换
所属类别 | 其他函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 傅立叶变换。
用法 | FFT(X,N) 对序列X进行傅立叶变换或变换处理后反变换. 例如: FFT(CLOSE,30) 当N=0时对序列X进行傅立叶变换 当N=1时对序列X进行傅立叶变换并反变换回来，与原X一致 当N>1时对序列X进行傅立叶变换并略去周期小于N的成分再反变换回来
来自“http://www.hs633.com/kthelp/index.php?title=Fft_%E5%82%85%E7%AB%8B%E5%8F%B6%E5%8F%98%E6%8D%A2&oldid=1393”


Function

函数 | Function
别名 | 无
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 自定义函数
用法 | 需要先定义才能使用 例如: Function ShowMsg Input: condition(0); Begin If condition > 0 then print('高开'); else if condition 〈 0 print('低开'); End show(OPEN > close[1]);
来自“http://www.hs633.com/kthelp/index.php?title=Function&oldid=1409”


GetAppMainDir 主路径

函数 | GetAppMainDir
别名 | 主路径
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取程序主执行路径。
用法 | GetAppMainDir check:=STRCMP(GetAppMainDir, 'c:\fox') 为0表示主程序所在路径为'c:\fox
来自“http://www.hs633.com/kthelp/index.php?title=GetAppMainDir_%E4%B8%BB%E8%B7%AF%E5%BE%84&oldid=1394”


GetAppSubName 专版名

函数 | GetAppSubName
别名 | 专版名
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取专版名。
用法 | GetAppSubName check:=STRCMP(GetAppSubName, '火狐') 为0表示专版的ID为火狐
来自“http://www.hs633.com/kthelp/index.php?title=GetAppSubName_%E4%B8%93%E7%89%88%E5%90%8D&oldid=1395”


HardwareId 取硬件号

函数 | HardwareId
别名 | 取硬件号
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取机器硬件标识号。
用法 | HARDWAREID check:=STRCMP(HARDWAREID, 'ABCDEFG-XXX') 为0表示标识号为ABCDEFG-XXX
来自“http://www.hs633.com/kthelp/index.php?title=HardwareId_%E5%8F%96%E7%A1%AC%E4%BB%B6%E5%8F%B7&oldid=1396”


IndiNote 引用指标说明

函数 | IndiNote
别名 | 引用指标说明
所属类别 | 其他函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得指定指标之指标说明。
用法 | INDINOTE(INDINAME) INDINAME 为指标名称 依次表示技术指标、条件选股、交易系统指标公式 例如： INDINOTE( 'MA') 代表取得MA指标之说明，返回'均价'
来自“http://www.hs633.com/kthelp/index.php?title=IndiNote_%E5%BC%95%E7%94%A8%E6%8C%87%E6%A0%87%E8%AF%B4%E6%98%8E&oldid=1397”


InvalidPeriod

函数 | InvalidPeriod
别名 | 无
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 无效周期
用法 | #INVALIDPERIOD P_DAY P_MIN1 可选周期： {P_TICK, 0, TOKEN_NUMBER}, {P_MIN1, 60, TOKEN_NUMBER}, {P_MIN5, 300, TOKEN_NUMBER}, {P_MIN15, 900, TOKEN_NUMBER}, {P_MIN30, 1800, TOKEN_NUMBER}, {P_MIN60, 3600, TOKEN_NUMBER}, {P_HOUR1, 3601, TOKEN_NUMBER}, {P_HOUR4, 14400, TOKEN_NUMBER}, {P_DAY, 86400, TOKEN_NUMBER}, {P_WEEK, 604800, TOKEN_NUMBER}, {P_MONTH, 2592000, TOKEN_NUMBER}, {P_QUARTER, 10368000, TOKEN_NUMBER}, {P_HALFYEAR, 20736000, TOKEN_NUMBER}, {P_YEAR, 41472000, TOKEN_NUMBER},
来自“http://www.hs633.com/kthelp/index.php?title=InvalidPeriod&oldid=1407”


LineValue 趋势线数值

函数 | LineValue
别名 | 趋势线数值
所属类别 | 其他函数
参数数量 | 6
运行模式 | 逐根/逐行
说明 | 计算趋势线数值。
用法 | LINEVALUE(COND1,PRICE1,COND2,PRICE2,EXPAND,LOG) 计算(COND1,PRICE1)和(COND2,PRICE2)2点决定的直线的数值 COND为数组,PRICE为数组或常数,LOG为1表示按对数计算,EXPAND为1表示向左延长.可用于趋势线预警、选股等 计算方式:先得到COND2条件满足的后点,再向左求COND1条件满足的前点,仅根据此2点计算 例如: LINEVALUE(DATE=1020129,LOW,DATE=1020606,LOW,0,1) 表示计算连接2002年1月29日低点和2002年6月6日低点的以对数方式计算的趋势线
来自“http://www.hs633.com/kthelp/index.php?title=LineValue_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E6%95%B0%E5%80%BC&oldid=1398”


LoginId 登录名

函数 | LoginId
别名 | 登录名
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取登录名。
用法 | LOGINID check:=STRCMP(LOGINID, 'FH0088') 为0表示用户登录服务器的ID为FH0088
来自“http://www.hs633.com/kthelp/index.php?title=LoginId_%E7%99%BB%E5%BD%95%E5%90%8D&oldid=1399”


Note

函数 | Note
别名 | 无
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 指标用法说明
用法 #NOTE

例如:

  1. NOTE '输出5日均价'

ma(c,5);

来自“http://www.hs633.com/kthelp/index.php?title=Note&oldid=1405”


Opt

函数 | Opt
别名 | 无
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | #OPT关键字, 出现时公式是参数优化的自定义评价函数
用法 #OPT

例如:

  1. OPT

OPT_PAYOFFRATE;

来自“http://www.hs633.com/kthelp/index.php?title=Opt&oldid=1406”


PlaySound 播放声音

函数 | PlaySound
别名 | 播放声音
所属类别 | 其他函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 播放声音。
用法 | PLAYSOUND(COND,TYPE,SOUND) 当COND条件满足时,播放SOUND声,可指定绝对路径。 例如: PLAYSOUND(CLOSE>=HHV(HIGH,5),0,'alarm') 表示最新价创5天新高时播放FmlDLL子目录下的alarm.wav。 PLAYSOUND(CLOSE>=HHV(HIGH,5),0,'c:\alarm.wav')
来自“http://www.hs633.com/kthelp/index.php?title=PlaySound_%E6%92%AD%E6%94%BE%E5%A3%B0%E9%9F%B3&oldid=1400”


Sort 排序

函数 | Sort
别名 | 排序
所属类别 | 其他函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 对序列或数组进行排序。
用法 | SORT(X,D,N1,N2) 对X序列或数组从序号N1到N2进行排序,D为0升序，D为1降序。返回N1到N2的数据数量 例如: VARIABLE:X[10]=0;VAR1:C;n1:=SORT(VAR1,0,1,DATACOUNT);n2:=SORT(X,0,1,10);
来自“http://www.hs633.com/kthelp/index.php?title=Sort_%E6%8E%92%E5%BA%8F&oldid=1401”


SortPos 排序位置

函数 | SortPos
别名 | 排序位置
所属类别 | 其他函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 对序列或数组进行排序后的原本位置
用法 | SORTPOS(X,D,N1,N2) 对X序列或数组从序号N1到N2进行排序后X存放原数值对应的位置， D为0升序，D为1降序。返回N1到N2的数据数量 例如: VARIABLE:X[10]=0;VAR1:C;n1:=SORTPOS(VAR1,0,1,DATACOUNT);n2:=SORTPOS(X,0,1,10);
来自“http://www.hs633.com/kthelp/index.php?title=SortPos_%E6%8E%92%E5%BA%8F%E4%BD%8D%E7%BD%AE&oldid=1402”


StkIndi 引用指标

函数 | StkIndi
别名 | 引用指标
所属类别 | 其他函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 引用任意品种任意周期的任意指标输出。
用法 | 本函数仅为兼容理由保留。请尽量使用功能更强大的RefIndi函数，或者通过自定义function的方式实现您的意图
来自“http://www.hs633.com/kthelp/index.php?title=StkIndi_%E5%BC%95%E7%94%A8%E6%8C%87%E6%A0%87&oldid=1403”


Template

函数 | Template
别名 | 无
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 参数精灵设置
用法 #TEMPLATE

例如:

  1. TEMPLATE

'统计主动性卖盘成交量大于Param#1股的成交量总和'

INPUT:

M(10000,1,100000);

SUM(IF(SELLVOL>=m,VOL,0),0)

来自“http://www.hs633.com/kthelp/index.php?title=Template&oldid=1408”


UserName 用户注册名

函数 | UserName
别名 | 用户注册名
所属类别 | 其他函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取用户注册名。
用法 | USERNAME check:=STRCMP(USERNAME, 'userid') 为0表示用户注册名为userid
来自“http://www.hs633.com/kthelp/index.php?title=UserName_%E7%94%A8%E6%88%B7%E6%B3%A8%E5%86%8C%E5%90%8D&oldid=1404”


BarPos 数据位置

函数 | BarPos
别名 | 数据位置
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 函数返回当前是第几根K线。 对于日线数据就表示从上市到现在总共有多少交易日。
用法 | BARPOS
来自“http://www.hs633.com/kthelp/index.php?title=BarPos_%E6%95%B0%E6%8D%AE%E4%BD%8D%E7%BD%AE&oldid=1113”


BarStatus 数据位置状态

函数 | BarStatus
别名 | 数据位置状态
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 函数返回数据位置状态。 1表示第1根K线，2表示最后1根K线，0表示中间的K线。
用法 | BARSTATUS
来自“http://www.hs633.com/kthelp/index.php?title=BarStatus_%E6%95%B0%E6%8D%AE%E4%BD%8D%E7%BD%AE%E7%8A%B6%E6%80%81&oldid=1122”


CalcDate 计算日期

函数 | CalcDate
别名 | 计算日期
所属类别 | 时间函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 计算日期
用法 | CalcDate(Date, Days) 返回日期Date加上天数Days后的日期 例如： CalcDate(1120829, 8) 返回1120906，2012年8月29日加上8天是2012年9月6日 CalcDate(1120906, -8) 返回1120829，2012年9月6日 减去8天是 2012年8月29日
来自“http://www.hs633.com/kthelp/index.php?title=CalcDate_%E8%AE%A1%E7%AE%97%E6%97%A5%E6%9C%9F&oldid=1149”


CalcTime 计算时间

函数 | CalcTime
别名 | 计算时间
所属类别 | 时间函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 计算时间
用法 | CalcTime(Time, Seconds) 返回时间Time加上秒数Seconds后的时间 例如： CalcTime(100000, -5*60) 返回95500，10:00减去5分钟为9:55 CalcTime(95500, 10*60) 返回100500，9:55 加上10分钟是10:05
来自“http://www.hs633.com/kthelp/index.php?title=CalcTime_%E8%AE%A1%E7%AE%97%E6%97%B6%E9%97%B4&oldid=1150”


CurrentDate 当前日期

函数 | CurrentDate
别名 | 当前日期
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 计算时的当前日期。
用法 | CURRENTDATE 函数返回计算时的日期,有效值范围为(700101-1341231), 表示1970/01/01-2034/12/31 注意：该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=CurrentDate_%E5%BD%93%E5%89%8D%E6%97%A5%E6%9C%9F&oldid=1123”


CurrentTime 当前时间

函数 | CURRENTTIME
别名 | 当前时间
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 计算时的当前时间。
用法 | CURRENTTIME 函数返回计算时的时间(时分秒),有效值范围为(000000-235959) 注意：该函数返回常数
来自“http://www.hs633.com/kthelp/index.php?title=CurrentTime_%E5%BD%93%E5%89%8D%E6%97%B6%E9%97%B4&oldid=1116”


D1970ToDate

函数 | D1970TODATE
别名 | 无
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得1970日期X的日期值。
用法 | D1970TODATE(X)
来自“http://www.hs633.com/kthelp/index.php?title=D1970ToDate&oldid=1117”


Date 年月日

函数 | DATE
别名 | 年月日
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期从1900以来的的年月日。
用法 | DATE 函数返回有效值范围为(700101-1341231), 表示19700101-20341231
来自“http://www.hs633.com/kthelp/index.php?title=Date_%E5%B9%B4%E6%9C%88%E6%97%A5&oldid=1118”


Datec 年月日

函数 | Datec
别名 | 年月日
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期结束时，从1900以来的年月日。
用法 | DATEC 函数返回有效值范围为(700101-1341231), 表示19700101-20341231
来自“http://www.hs633.com/kthelp/index.php?title=Datec_%E5%B9%B4%E6%9C%88%E6%97%A5&oldid=1121”


DateDiff 间隔天数

函数 | DateDiff
别名 | 间隔天数
所属类别 | 时间函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得日期之间的时间间隔天数。
用法 | DATEDIFF(DATE1,DATE2) DATE1,DATE2为序列变量或常数，格式与DATE同， 有效值范围为(800101-1301231),表示19800101-20301231 返回DATE1、DATE2两个日期之间的相差的天数， 如果 DATE1晚于 DATE2，则 DATEDIFF函数返回负数 例如: DATEDIFF(LSOLARTERMDATE(1),DATE) 表示求当年小寒到当前周期相差的天数
来自“http://www.hs633.com/kthelp/index.php?title=DateDiff_%E9%97%B4%E9%9A%94%E5%A4%A9%E6%95%B0&oldid=1125”


DateToD1970

函数 | DateToD1970
别名 | 无
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得日期X距离1970年1月1日以来的天数。
用法 | DATETOD1970(X) 例如: Datetod1970(DATE) 返回当天距离1970年1月1日的天数。
来自“http://www.hs633.com/kthelp/index.php?title=DateToD1970&oldid=1126”


Day 日期

函数 | Day
别名 | 日期
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的日期。
用法 | DAY 函数返回有效值范围为(1-31)
来自“http://www.hs633.com/kthelp/index.php?title=Day_%E6%97%A5%E6%9C%9F&oldid=1127”


DayOfDate 返回特定日期的“日”部分

函数 | DayOfDate
别名 | 返回特定日期的“日”部分
所属类别 | 时间函数
参数数量 |
运行模式 | 逐根/逐行
说明 | 返回特定日期的“日”部分
用法 | DayOfDate ( cDate ) ; cDate: 格式为YYYMMDD 的日期.YYY是自1900年以来的年数。MM是月份。dd是日期。 例如: Value1 = DayOfDate (991004) 返回 4 Value2 = DayOfDate( 1010120) 返回 20
来自“http://www.hs633.com/kthelp/index.php?title=DayOfDate_%E8%BF%94%E5%9B%9E%E7%89%B9%E5%AE%9A%E6%97%A5%E6%9C%9F%E7%9A%84%E2%80%9C%E6%97%A5%E2%80%9D%E9%83%A8%E5%88%86&oldid=1157”


Days1970 天数

函数 | Days1970
别名 | 天数
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期从1970以来的天数。 返回自从1970年1月1日以来的天数， 例如: 在1971年1月1日返回365。
用法 | DAYS1970
来自“http://www.hs633.com/kthelp/index.php?title=Days1970_%E5%A4%A9%E6%95%B0&oldid=1128”


EndDate 结束年月日

函数 | EndDate
别名 | 结束年月日
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期结束日期从1900以来的的年月日。
用法 | ENDDATE 函数返回有效值范围为(700101-1341231), 表示19700101-20341231
来自“http://www.hs633.com/kthelp/index.php?title=EndDate_%E7%BB%93%E6%9D%9F%E5%B9%B4%E6%9C%88%E6%97%A5&oldid=1124”


EndTime 结束时分秒

函数 | EndTime
别名 | 结束时分秒
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期结束的时分秒。
用法 | ENDTIME 函数返回有效值范围为(000000-235959)
来自“http://www.hs633.com/kthelp/index.php?title=EndTime_%E7%BB%93%E6%9D%9F%E6%97%B6%E5%88%86%E7%A7%92&oldid=1144”


Hour 小时

函数 | Hour
别名 | 小时
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的小时数。
用法 | HOUR 函数返回有效值范围为(0-23)， 对于日线及更长的分析周期值为0
来自“http://www.hs633.com/kthelp/index.php?title=Hour_%E5%B0%8F%E6%97%B6&oldid=1129”


LDay 农历日期

函数 | LDay
别名 | 农历日期
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的农历日期。
用法 | LDAY 函数返回有效值范围为(1-30)
来自“http://www.hs633.com/kthelp/index.php?title=LDay_%E5%86%9C%E5%8E%86%E6%97%A5%E6%9C%9F&oldid=1132”


LMonth 农历月份

函数 | LMonth
别名 | 农历月份
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的农历月份。
用法 | LMONTH 函数返回有效值范围为(1-12)
来自“http://www.hs633.com/kthelp/index.php?title=LMonth_%E5%86%9C%E5%8E%86%E6%9C%88%E4%BB%BD&oldid=1133”


LsoLarTerm 节气

函数 | LsoLarTerm
别名 | 节气
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得日期所在的二十四节气。
用法 | LSOLARTERM(X) X为序列变量或常数，格式与DATE同， 有效值范围为(700101-1341231),表示19700101-20341231 返回有效值范围为(0-24).0表示该周期不在节气日中，1-24分别表示小寒、大寒、立春、雨水、惊蛰、春分、清明、谷雨、立夏、小满、芒种、 夏至 、小暑、大暑、立秋、处暑、白露、秋分、寒露、霜降、立冬、 小雪、大雪、冬至 例如: LSOLARTERM(DATE)表示求当前周期节气
来自“http://www.hs633.com/kthelp/index.php?title=LsoLarTerm_%E8%8A%82%E6%B0%94&oldid=1134”


LsoLarTermDate 节气日期

函数 | LsoLarTermDate
别名 | 节气日期
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得当年的节气日期。
用法 | LSOLARTERMDATE(X) X为序列变量或常数，有效值范围为(1-24)分别表示小寒、大寒...冬至返回当年的节气日期,格式与DATE同， 有效值范围为(700101-1341231),表示19700101-20341231 例如: LSOLARTERMDATE(1)，求当年的小寒日期， 返回的序列中2001年之内的都为1010105
来自“http://www.hs633.com/kthelp/index.php?title=LsoLarTermDate_%E8%8A%82%E6%B0%94%E6%97%A5%E6%9C%9F&oldid=1135”


LsoLarTermDay 节气后天数

函数 | LsoLarTermDay
别名 | 节气后天数
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得节气后的第几日。
用法 | LSOLARTERMDAY(X) X为序列变量或常数，格式与DATE同， 有效值范围为(800101-1301231),表示19800101-20301231 返回序列日期是前一节气后的第几日 例如: LSOLARTERMDAY(DATE)表示求当前周期是前一节气后的第几日
来自“http://www.hs633.com/kthelp/index.php?title=LsoLarTermDay_%E8%8A%82%E6%B0%94%E5%90%8E%E5%A4%A9%E6%95%B0&oldid=1136”


LYear 农历年份

函数 | LYear
别名 | 农历年份
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的农历年份。
用法 | LYEAR 函数返回有效值范围为(1980-2030)
来自“http://www.hs633.com/kthelp/index.php?title=LYear_%E5%86%9C%E5%8E%86%E5%B9%B4%E4%BB%BD&oldid=1137”


Minute 分钟

函数 | Minute
别名 | 分钟
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的分钟数。
用法 | MINUTE 函数返回有效值范围为(0-59)，对于日线及更长的分析周期值为0
来自“http://www.hs633.com/kthelp/index.php?title=Minute_%E5%88%86%E9%92%9F&oldid=1138”


Month 月份

函数 | Month
别名 | 月份
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的月份。
用法 | MONTH 函数返回有效值范围为(1-12)
来自“http://www.hs633.com/kthelp/index.php?title=Month_%E6%9C%88%E4%BB%BD&oldid=1139”


MonthOfDate 返回特定日期的“月”部分

函数 | MonthOfDate
别名 | 返回特定日期的“月”部分
所属类别 | 时间函数
参数数量 |
运行模式 | 逐根/逐行
说明 | 返回特定日期的“月”部分
用法 | MonthOfDate ( cDate ) ; cDate: 格式为YYYMMDD 的日期.YYY是自1900年以来的年数。MM是月份。dd是日期。 例如: Value1 = MonthOfDate (991004) 返回 10 Value2 = MonthOfDate( 1010120) 返回 1
来自“http://www.hs633.com/kthelp/index.php?title=MonthOfDate_%E8%BF%94%E5%9B%9E%E7%89%B9%E5%AE%9A%E6%97%A5%E6%9C%9F%E7%9A%84%E2%80%9C%E6%9C%88%E2%80%9D%E9%83%A8%E5%88%86&oldid=1158”


OpenMinutes 开盘分钟数

函数 | OpenMinutes
别名 | 开盘分钟数
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得开盘分钟数。
用法 | OpenMinutes(TIME) 返回已开盘分钟数(1-总开盘分钟数), 当参数为-1时，返回一天的总开市分钟数 开盘前的都为1,收盘后都为总开盘分钟数 例如: OpenMinutes(CURRENTTIME)，在日线上可得到现在已开盘分钟数 OpenMinutes(TIME)，在分钟线上可得到当时已开盘分钟数
来自“http://www.hs633.com/kthelp/index.php?title=OpenMinutes_%E5%BC%80%E7%9B%98%E5%88%86%E9%92%9F%E6%95%B0&oldid=1140”


Second 秒数

函数 | Second
别名 | 秒数
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的秒数。
用法 | SECOND 函数返回有效值范围为(0-59)， 对于日线及更长的分析周期值为0
来自“http://www.hs633.com/kthelp/index.php?title=Second_%E7%A7%92%E6%95%B0&oldid=1130”


SessEndBarTime 收市周期时间

函数 | SessEndBarTime
别名 | 收市周期时间
所属类别 | 时间函数
参数数量 |
运行模式 | 逐根/逐行
说明 | 收市周期时间
用法 | SessEndBarTime 收市前最后1个周期对应的时间，格式为HHMMSS
来自“http://www.hs633.com/kthelp/index.php?title=SessEndBarTime_%E6%94%B6%E5%B8%82%E5%91%A8%E6%9C%9F%E6%97%B6%E9%97%B4&oldid=1155”


SessFirstBarTime 开市周期时间

函数 | SessFirstBarTime
别名 | 开市周期时间
参数数量 |
运行模式 | 逐根/逐行
说明 | 开市周期时间
用法 | SessFirstBarTime 开市第1个Bar对应的时间，格式为HHMMSS
来自“http://www.hs633.com/kthelp/index.php?title=SessFirstBarTime_%E5%BC%80%E5%B8%82%E5%91%A8%E6%9C%9F%E6%97%B6%E9%97%B4&oldid=1154”


SessionCount 交易时段数量

函数 | SessionCount
别名 | 交易时段数量
所属类别 | 时间函数
参数数量 |
运行模式 | 逐根/逐行
说明 | 交易时段数量
用法 | SessionCount 国内股票2段，期货3-4段
来自“http://www.hs633.com/kthelp/index.php?title=SessionCount_%E4%BA%A4%E6%98%93%E6%97%B6%E6%AE%B5%E6%95%B0%E9%87%8F&oldid=1151”


SessionEndTime 交易段收市时间

函数 | SessionEndTime
别名 | 交易段收市时间
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 交易段收市时间
用法 | SessionEndTime(SessionNum)
来自“http://www.hs633.com/kthelp/index.php?title=SessionEndTime_%E4%BA%A4%E6%98%93%E6%AE%B5%E6%94%B6%E5%B8%82%E6%97%B6%E9%97%B4&oldid=1153”


SessionLastBar 是否第N个交易时段的最后一根K线

函数 | SessionLastBar
别名 | 是否第N个交易时段的最后一根K线
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 判断是不是第N个交易时段的最后一根K线，是则返回1，否则返回0
用法 | SessionLastBar(n) N表示第几个交易时段 SessionLastBar(1) 如果是股票，表示该K线是否为上午交易时段内最后一根K线
来自“http://www.hs633.com/kthelp/index.php?title=SessionLastBar_%E6%98%AF%E5%90%A6%E7%AC%ACN%E4%B8%AA%E4%BA%A4%E6%98%93%E6%97%B6%E6%AE%B5%E7%9A%84%E6%9C%80%E5%90%8E%E4%B8%80%E6%A0%B9K%E7%BA%BF&oldid=1156”


SessionStartTime 交易段开市时间

函数 | SessionStartTime
别名 | 交易段开市时间
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 交易段开市时间
用法 | SessionStartTime(SessionNum)
来自“http://www.hs633.com/kthelp/index.php?title=SessionStartTime_%E4%BA%A4%E6%98%93%E6%AE%B5%E5%BC%80%E5%B8%82%E6%97%B6%E9%97%B4&oldid=1152”


Time 时分秒

函数 | Time
别名 | 时分秒
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 时分秒
用法 | TIME 函数返回有效值范围为(000000-235959)
来自“http://www.hs633.com/kthelp/index.php?title=Time_%E6%97%B6%E5%88%86%E7%A7%92&oldid=1142”


Time0 秒数

函数 | Time0
别名 | 秒数
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期从当日0点以来的秒数。 返回自从当日0点以来的秒数， 对于日线以上的分析周期返回0
用法 | TIME0
来自“http://www.hs633.com/kthelp/index.php?title=Time0_%E7%A7%92%E6%95%B0&oldid=1145”


Timec 时分秒

函数 | Timec
别名 | 时分秒
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期结束时的时分秒。
用法 | TIMEC 函数返回有效值范围为(000000-235959)
来自“http://www.hs633.com/kthelp/index.php?title=Timec_%E6%97%B6%E5%88%86%E7%A7%92&oldid=1143”


TimeToTo 时间转化为秒数

函数 | TimeToTo
别名 | 时间转化为秒数
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得时间X距离当日0点的秒数。
用法 | TIMETOT0(X)
来自“http://www.hs633.com/kthelp/index.php?title=TimeToTo_%E6%97%B6%E9%97%B4%E8%BD%AC%E5%8C%96%E4%B8%BA%E7%A7%92%E6%95%B0&oldid=1146”


ToToTime 秒数转换为时间

函数 | ToToTime
别名 | 秒数转换为时间
所属类别 | 时间函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得从0点开始X秒后的时间值。
用法 | T0TOTIME(X)
来自“http://www.hs633.com/kthelp/index.php?title=ToToTime_%E7%A7%92%E6%95%B0%E8%BD%AC%E6%8D%A2%E4%B8%BA%E6%97%B6%E9%97%B4&oldid=1141”


WeekDay 星期

函数 | WeekDay
别名 | 星期
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的星期数。
用法 | WEEKDAY 函数返回有效值范围为(0-6)，0表示星期天
来自“http://www.hs633.com/kthelp/index.php?title=WeekDay_%E6%98%9F%E6%9C%9F&oldid=1147”


WeekDayOfDate 返回特定日期是星期几

函数 | WeekDayOfDate
别名 | 返回特定日期是星期几
所属类别 | 时间函数
参数数量 |
运行模式 | 逐根/逐行
说明 | 返回特定日期是星期几
用法 | WeekDayOfDate ( cDate ) ; cDate: 格式为YYYMMDD 的日期.YYY是自1900年以来的年数。MM是月份。dd是日期。 其中，0代表星期天，1代表星期一，.....，6代表星期六 例如: Value1 = WeekDayOfDate (1011024) 返回 3
来自“http://www.hs633.com/kthelp/index.php?title=WeekDayOfDate_%E8%BF%94%E5%9B%9E%E7%89%B9%E5%AE%9A%E6%97%A5%E6%9C%9F%E6%98%AF%E6%98%9F%E6%9C%9F%E5%87%A0&oldid=1160”


Year 年份

函数 | Year
别名 | 年份
所属类别 | 时间函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期的年份。
用法 | YEAR 函数返回有效值范围为(1970-2038)
来自“http://www.hs633.com/kthelp/index.php?title=Year_%E5%B9%B4%E4%BB%BD&oldid=1148”


YearOfDate 返回特定日期的“年”部分

函数 | YearOfDate
别名 | 返回特定日期的“年”部分
所属类别 | 时间函数
参数数量 |
运行模式 | 逐根/逐行
说明 | 返回特定日期的“年”部分
用法 | YearOfDate ( cDate ) ; cDate: 格式为YYYMMDD 的日期.YYY是自1900年以来的年数。MM是月份。dd是日期。 例如: Value1 = YearOfDate (991004) 返回 1999 Value2 = YearOfDate( 1080120) 返回 2008
来自“http://www.hs633.com/kthelp/index.php?title=YearOfDate_%E8%BF%94%E5%9B%9E%E7%89%B9%E5%AE%9A%E6%97%A5%E6%9C%9F%E7%9A%84%E2%80%9C%E5%B9%B4%E2%80%9D%E9%83%A8%E5%88%86&oldid=1159”


Commission 单口手续费

函数 | Commission
别名 | 单口手续费
所属类别 | 属性函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 单口手续费
用法 | Commission 返回【策略设置】或【测评平台】中设置的手续费金额,以单口计
来自“http://www.hs633.com/kthelp/index.php?title=Commission_%E5%8D%95%E5%8F%A3%E6%89%8B%E7%BB%AD%E8%B4%B9&oldid=1947”


CurrentBar 有效周期数

函数 | CurrentBar
别名 | 有效周期数
所属类别 | 属性函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 有效周期数
用法 | CurrentBar 返回“公式计算需引用之前数据最大周期数”之后的周期的连续计数 注解：在公式计算时，需要引用到当前周期之前的数据，例如MA(C,5),需要用到之前4个周期的数据 例如： CurrentBar 若“公式计算需引用之前数据最大周期数”为50，则第51周期返回1，第52周期返回2
来自“http://www.hs633.com/kthelp/index.php?title=CurrentBar_%E6%9C%89%E6%95%88%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1953”


CurrentCapital 可用资金

函数 | CurrentCapital
别名 | 可用资金
所属类别 | 属性函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 可用资金
用法 | CurrentCapital 返回按当前周期开盘价计算的的可用资金
来自“http://www.hs633.com/kthelp/index.php?title=CurrentCapital_%E5%8F%AF%E7%94%A8%E8%B5%84%E9%87%91&oldid=1945”


InitialCapital 初始资金

函数 | InitialCapital
别名 | 初始资金
所属类别 | 属性函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 初始资金
用法 | InitialCapital 返回【策略设置】或【测评平台】中设置的初始资金
来自“http://www.hs633.com/kthelp/index.php?title=InitialCapital_%E5%88%9D%E5%A7%8B%E8%B5%84%E9%87%91&oldid=1943”


MaxBarsBack 最大引用周期数

函数 | MaxBarsBack
别名 | 最大引用周期数
所属类别 | 属性函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大引用周期数
用法 | MaxBarsBack 返回“公式计算需回溯（引用）之前数据最大周期数(K线根数)” 例如： If MaxBarsBack 〈 200 Then MessageBox('......') 如果公式需要强制引用若干K线，但外部设置不够，可以让公式出个提示， 把回溯根数调大
来自“http://www.hs633.com/kthelp/index.php?title=MaxBarsBack_%E6%9C%80%E5%A4%A7%E5%BC%95%E7%94%A8%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1951”


PriceScale 价格标度

函数 | PriceScale
别名 | 价格标度
所属类别 | 属性函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 价格标度
用法 | PriceScale PriceScale = BigPointValue/PointValue 例如： A股返回100 橡胶期货返回1 IF股指期货返回10
来自“http://www.hs633.com/kthelp/index.php?title=PriceScale_%E4%BB%B7%E6%A0%BC%E6%A0%87%E5%BA%A6&oldid=1942”


Slippage 单口滑移金额

函数 | Slippage
别名 | 单口滑移金额
所属类别 | 属性函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 单口滑移金额
用法 | Slippage 返回返回【策略设置】或【测评平台】中设置的以单口计算的滑移金额 外部设置为几跳的要转换成等值的金额，与MC的一致 例如：IF股指期货，设置2跳，则 Slippage = 2*0.2(MinDiff)*300(BigPointValue) = 120
来自“http://www.hs633.com/kthelp/index.php?title=Slippage_%E5%8D%95%E5%8F%A3%E6%BB%91%E7%A7%BB%E9%87%91%E9%A2%9D&oldid=1949”


RefData 返回引用数据

函数 | RefData
别名 | 返回引用数据
所属类别 | 数据引用函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 引用指定商品的指定周期的行情历史数据。
用法 | RefData(Symbol, DataType, Period, bAlign , nCount) 返回引用数据 参数： Symbol：品种代码 格式为'000001'或者'000001.SZ' DataType: 引用的数据类型 取以下值之一 D_CLOSE, 收盘价 D_OPEN, 开盘价 D_HIGH, 最高价 D_LOW, 最低价 D_VOLUME, 成交量 D_AMOUNT, 成交额 D_OPENINT, 持仓量 Period：引用数据的周期类型 Default,当前周期 P_TICK, 分笔 P_MIN1, 1分钟 P_MIN5, 5分钟 P_MIN15, 15分钟 P_MIN30, 30分钟 P_MIN60, 60分钟 P_HOUR1, 1小时 P_HOUR4, 4小时 P_DAY, 日线 P_WEEK, 周线 P_MONTH, 月线 P_QUARTER, 季线 P_HALFYEAR, 半年线 P_YEAR, 年线 nCount 是用于逐根并且不对齐模式下的填写数据数量，用于优化执行效率，默认300， 该参数不影响逐行模式和对齐的逐根模式 . Align：对齐。1表示对齐，0表示不对齐。当对齐时，长周期数据扩展其数量与短周期一致。 例如：在1分钟引用5分钟数据，则每根5分钟数据都复制4份，共5份，以便与1分钟K线时间对齐。 应用实例： RefData('600001', D_CLOSE, P_MONTH); //引用邯郸钢铁的月线收盘价
来自“http://www.hs633.com/kthelp/index.php?title=RefData_%E8%BF%94%E5%9B%9E%E5%BC%95%E7%94%A8%E6%95%B0%E6%8D%AE&oldid=1585”


RefDll 引用DLL

函数 | RefDll
别名 | 引用DLL
所属类别 | 数据引用函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 引用DLL计算
用法 | RefDLL('DLLNAME', 'FUNCNAME', PARAMs...) PARAMs... 为DLL函数的参数 例如： RefDLL('MYDLL','MYMA', C, 5);
来自“http://www.hs633.com/kthelp/index.php?title=RefDll_%E5%BC%95%E7%94%A8DLL&oldid=1586”


RefIndi 引用指标

函数 | RefIndi
别名 | 引用指标
所属类别 | 数据引用函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 引用指定商品的指定周期的指定指标输出。
用法 | RefIndi(Symbol, 'INDINAME', Period=DEFAULT, nCount=DEFAULT，PARAMs...) 返回序列 Symbol: 指定商品代码(STKLABEL.MARKETLABEL)，如为空表示当前商品,与当前商品同交易所可省略市场代码 INDINAME：指标及其输出名 Period： 周期类型，枚举有效值范围为(sec*n) DEFAULT //当前周期 P_TICK 0 //分笔成交 P_MIN1 60 P_MIN5 5*60 P_MIN15 15*60 P_MIN30 30*60 P_Hour1 60*60 P_Hour4 4*60*60 P_DAY 24*60*60 P_WEEK 7*24*60*60 P_MONTH 30*7*24*60*60 P_YEAR 365*7*24*60*60 nCount ：该参数指定每次返回多少个数值，default默认全部，只在逐根模式下生效。 PARAMs... 为被引用指标的参数,其数量应当小于等于被应用指标的参数数量,小于则将使用缺省参数数值 例如： RefIndi(, 'RSI.RSI1'); //计算RSI RefIndi('000001.SZ', 'RSI.RSI1', DEFAULT, 1, 20); //计算深发展的参数为20的RSI
来自“http://www.hs633.com/kthelp/index.php?title=RefIndi_%E5%BC%95%E7%94%A8%E6%8C%87%E6%A0%87&oldid=1584”


Abs 绝对值

函数 | Abs
别名 | 绝对值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求绝对值。
用法 | ABS(X)返回X的绝对值例如: ABS(-23)返回23
来自“http://www.hs633.com/kthelp/index.php?title=Abs_%E7%BB%9D%E5%AF%B9%E5%80%BC&oldid=1220”


Acos 反余弦值

函数 | Acos
别名 | 反余弦值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 反余弦值
用法 | ACOS(X) 返回X的反余弦值
来自“http://www.hs633.com/kthelp/index.php?title=Acos_%E5%8F%8D%E4%BD%99%E5%BC%A6%E5%80%BC&oldid=1221”


Asin 反正弦值

函数 | Asin
别名 | 反正弦值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 反正弦值。
用法 | ASIN(X) 返回X的反正弦值
来自“http://www.hs633.com/kthelp/index.php?title=Asin_%E5%8F%8D%E6%AD%A3%E5%BC%A6%E5%80%BC&oldid=1222”


Atan 反正切值

函数 | Atan
别名 | 反正切值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 反正切值。
用法 | ATAN(X) 返回X的反正切值
来自“http://www.hs633.com/kthelp/index.php?title=Atan_%E5%8F%8D%E6%AD%A3%E5%88%87%E5%80%BC&oldid=1223”


Ceiling 向上舍入

函数 | Ceiling
别名 | 向上舍入
所属类别 | 数学函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 向数值增大方向舍入。
用法 | CEILING(X,S=1)返回沿X数值增大方向最接近的S的倍数 例如: CEILING(3.3)求得4 CEILING(62，5)求得65
来自“http://www.hs633.com/kthelp/index.php?title=Ceiling_%E5%90%91%E4%B8%8A%E8%88%8D%E5%85%A5&oldid=1224”


Cos 余弦值

函数 | Cos
别名 | 余弦值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 余弦值。
用法 | COS(X) 返回X的余弦值
来自“http://www.hs633.com/kthelp/index.php?title=Cos_%E4%BD%99%E5%BC%A6%E5%80%BC&oldid=1225”


Exp 指数

函数 | Exp
别名 | 指数
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 指数。
用法 | EXP(X)为e的X次幂 例如: EXP(CLOSE)返回e的CLOSE次幂
来自“http://www.hs633.com/kthelp/index.php?title=Exp_%E6%8C%87%E6%95%B0&oldid=1226”


Floor 向下舍入

函数 | Floor
别名 | 向下舍入
所属类别 | 数学函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 向数值减小方向舍入。
用法 | FLOOR(X,S=1)返回沿X数值减小方向最接近的S的倍数 例如: FLOOR(3.3)求得3 FLOOR(62，5)求得60 向下舍入
来自“http://www.hs633.com/kthelp/index.php?title=Floor_%E5%90%91%E4%B8%8B%E8%88%8D%E5%85%A5&oldid=1227”


FracPart 取小数部分

函数 | FracPart
别名 | 取小数部分
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得数据的小数部分。
用法 | FRACPART(X)返回数值的小数部分 例如: FRACPART(12.3)求得0.3 FRACPART(-3.5)求得-0.5
来自“http://www.hs633.com/kthelp/index.php?title=FracPart_%E5%8F%96%E5%B0%8F%E6%95%B0%E9%83%A8%E5%88%86&oldid=1228”


IniPart 取整

函数 | IniPart
别名 | 取整
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得数据的整数部分。
用法 | INTPART(X)返回沿X绝对值减小方向最接近的整数 例如: INTPART(12.3)求得12 INTPART(-3.5)求得-3
来自“http://www.hs633.com/kthelp/index.php?title=IniPart_%E5%8F%96%E6%95%B4&oldid=1229”


Ln 自然对数

函数 | Ln
别名 | 自然对数
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求自然对数。
用法 | LN(X)以e为底的对数 例如: LN(CLOSE)求收盘价的对数
来自“http://www.hs633.com/kthelp/index.php?title=Ln_%E8%87%AA%E7%84%B6%E5%AF%B9%E6%95%B0&oldid=1230”


Log

函数 | Log
别名 | 无
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求10为底的对数。
用法 | LOG(X)取得X的对数 例如: LOG(1000)等于3
来自“http://www.hs633.com/kthelp/index.php?title=Log&oldid=1231”


Max 最大值

函数 | Max
别名 | 最大值
所属类别 | 数学函数
参数数量 | 两个以上
运行模式 | 逐根/逐行
说明 | 求最大值。
用法 | MAX(A,B,C...)返回A和B、C等多个值中的最大值 例如: MAX(CLOSE-OPEN,0，OPEN-CLOSE) 取三个数值中的最大值，返回该最大值
来自“http://www.hs633.com/kthelp/index.php?title=Max_%E6%9C%80%E5%A4%A7%E5%80%BC&oldid=1232”


MaxList 最大值

函数 | MaxList
别名 | 最大值
所属类别 | 数学函数
参数数量 | 两个以上
运行模式 | 逐根/逐行
说明 | 求最大值。
用法 | MaxList(A,B,C...)返回A和B、C等多个值中的最大值 例如: MaxList(CLOSE-OPEN,0，OPEN-CLOSE) 取三个数值中的最大值，返回该最大值
来自“http://www.hs633.com/kthelp/index.php?title=MaxList_%E6%9C%80%E5%A4%A7%E5%80%BC&oldid=1234”


Min 最小值

函数 | Min
别名 | 最小值
所属类别 | 数学函数
参数数量 | 两个以上
运行模式 | 逐根/逐行
说明 | 求最小值。
用法 | Min(A,B,C...)返回A和B、C等多个值中的最小值 例如: Min(CLOSE-OPEN,0，OPEN-CLOSE) 取三个数值中的最小值，返回该最小值
来自“http://www.hs633.com/kthelp/index.php?title=Min_%E6%9C%80%E5%B0%8F%E5%80%BC&oldid=1233”


MinList 最小值

函数 | MinList
别名 | 最小值
所属类别 | 数学函数
参数数量 | 两个以上
运行模式 | 逐根/逐行
说明 | 求最小值。
用法 | MinList(A,B,C...)返回A和B、C等多个值中的最小值 例如: MinList(CLOSE-OPEN,0，OPEN-CLOSE) 取三个数值中的最小值，返回该最小值
来自“http://www.hs633.com/kthelp/index.php?title=MinList_%E6%9C%80%E5%B0%8F%E5%80%BC&oldid=1235”


Mod 求模运算

函数 | Mod
别名 | 求模运算
所属类别 | 数学函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求模运算。
用法 | MOD(A,B)返回A对B求模 例如: MOD(18,10)返回8
来自“http://www.hs633.com/kthelp/index.php?title=Mod_%E6%B1%82%E6%A8%A1%E8%BF%90%E7%AE%97&oldid=1236”


NthMaxList 第N大值

函数 | NthMaxList
别名 | 第N大值
所属类别 | 数学函数
参数数量 | 两个以上
运行模式 | 逐根/逐行
说明 | 第N大值。
用法 | NthMaxList 返回参数中第N大的值。 用法 NthMaxList(N,Value1,Value2,Value3,...) 例如： NthMaxList(4,-15,-5,0,6,12) 返回 -5 NthMaxList(3、Open、HH、MA(C，5)、CloseD(1)) 在指定的4个值中计算出第3大的值。
来自“http://www.hs633.com/kthelp/index.php?title=NthMaxList_%E7%AC%ACN%E5%A4%A7%E5%80%BC&oldid=1245”


NthMinList 第N小值

函数 | NthMinList
别名 | 第N小值
所属类别 | 数学函数
参数数量 | 两个以上
运行模式 | 逐根/逐行
说明 | 第N小值。
用法 NthMinList

返回参数中第N小的值。

用法：

NthMinList(N,Value1,Value2,Value3,...)

例如：

NthMinList(3、10、20、30、40)

返还30

NthMinList(3、Open、HH、MA(C，5)、CloseD(1))

在指定的4个值中计算出第3小的值。

来自“http://www.hs633.com/kthelp/index.php?title=NthMinList_%E7%AC%ACN%E5%B0%8F%E5%80%BC&oldid=1246”


Pow 乘幂

函数 | Pow
别名 | 乘幂
所属类别 | 数学函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 乘幂。
用法 | POW(A,B)返回A的B次幂 例如: POW(CLOSE,2)求得收盘价的2次方
来自“http://www.hs633.com/kthelp/index.php?title=Pow_%E4%B9%98%E5%B9%82&oldid=1237”


Rand 随机数

函数 | Rand
别名 | 随机数
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 随机整数。
用法 | RAND(N) 返回一个范围在1-N的随机整数 例如: CLOSE*(RAND(10)/10+0.4) 输出收盘价乘以[0.5-1.4]的随机系数
来自“http://www.hs633.com/kthelp/index.php?title=Rand_%E9%9A%8F%E6%9C%BA%E6%95%B0&oldid=1238”


ReVerse 求相反数

函数 | ReVers
别名 | 求相反数
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求相反数。
用法 | REVERSE(X)返回-X 例如： REVERSE(OPEN)返回-OPEN
来自“http://www.hs633.com/kthelp/index.php?title=ReVerse_%E6%B1%82%E7%9B%B8%E5%8F%8D%E6%95%B0&oldid=1239”


Round 四舍五入

函数 | Round
别名 | 四舍五入
所属类别 | 数学函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 将Value四舍五入为Digits指定小数位数的数
用法 四舍五入

Round(Value,Digits=0)

将Value四舍五入为Digits指定小数位数的数

例如：

Round(1.268) 返回 1

Round(1.268,2) 返回 1.27

Round(-1.2683,3) 返回-1.268

来自“http://www.hs633.com/kthelp/index.php?title=Round_%E5%9B%9B%E8%88%8D%E4%BA%94%E5%85%A5&oldid=1240”


Sgn 符号值

函数 | Sgn
别名 | 符号值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求符号值。
用法 | SGN(X)，当X>0,X=0,X<0分别返回1,0,-1
来自“http://www.hs633.com/kthelp/index.php?title=Sgn_%E7%AC%A6%E5%8F%B7%E5%80%BC&oldid=1241”


Sin 正弦值

函数 | Sin
别名 | 正弦值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 正弦值。
用法 | SIN(X) 返回X的正弦值
来自“http://www.hs633.com/kthelp/index.php?title=Sin_%E6%AD%A3%E5%BC%A6%E5%80%BC&oldid=1242”


Sqrt 开平方

函数 | Sqrt
别名 | 开平方
所属类别 | 数学函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 开平方。
用法 | SQRT(X)为X的平方根 例如: SQRT(CLOSE)收盘价的平方根
来自“http://www.hs633.com/kthelp/index.php?title=Sqrt_%E5%BC%80%E5%B9%B3%E6%96%B9&oldid=1243”


Tan 正切值

函数 | Tan
别名 | 正切值
所属类别 | 数学函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 正切值。
用法 | TAN(X) 返回X的正切值
来自“http://www.hs633.com/kthelp/index.php?title=Tan_%E6%AD%A3%E5%88%87%E5%80%BC&oldid=1244”


AveDev 平均绝对偏差

函数 | AveDev
别名 | 平均绝对偏差
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 平均绝对偏差。
用法 | AVEDEV(X,N)
来自“http://www.hs633.com/kthelp/index.php?title=AveDev_%E5%B9%B3%E5%9D%87%E7%BB%9D%E5%AF%B9%E5%81%8F%E5%B7%AE&oldid=1248”


DevSq 数据偏差平方和

函数 | DevSq
别名 | 数据偏差平方和
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 数据偏差平方和。
用法 | DEVSQ(X,N)
来自“http://www.hs633.com/kthelp/index.php?title=DevSq_%E6%95%B0%E6%8D%AE%E5%81%8F%E5%B7%AE%E5%B9%B3%E6%96%B9%E5%92%8C&oldid=1249”


ForCast 线性回归预测值

函数 | ForCast
别名 | 线性回归预测值
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 线性回归预测值。
用法 | FORCAST(X,N)为X的N周期线性回归预测值 例如: FORCAST(CLOSE,20)表示求20周期线性回归预测
来自“http://www.hs633.com/kthelp/index.php?title=ForCast_%E7%BA%BF%E6%80%A7%E5%9B%9E%E5%BD%92%E9%A2%84%E6%B5%8B%E5%80%BC&oldid=1250”


Slope 线性回归斜率

函数 | Slope
别名 | 线性回归斜率
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 线性回归斜率。
用法 | SLOPE(X,N)为X的N周期线性回归线的斜率 例如: SLOPE(CLOSE,20)表示求20周期线性回归线的斜率
来自“http://www.hs633.com/kthelp/index.php?title=Slope_%E7%BA%BF%E6%80%A7%E5%9B%9E%E5%BD%92%E6%96%9C%E7%8E%87&oldid=1251”


Std 估算标准差

函数 | Std
别名 | 估算标准差
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 估算标准差。
用法 | STD(X,N)为X的N日估算标准差
来自“http://www.hs633.com/kthelp/index.php?title=Std_%E4%BC%B0%E7%AE%97%E6%A0%87%E5%87%86%E5%B7%AE&oldid=1252”


Stdp 总体标准差

函数 | Stdp
别名 | 总体标准差
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 总体标准差。
用法 | STDP(X,N)为X的N日总体标准差
来自“http://www.hs633.com/kthelp/index.php?title=Stdp_%E6%80%BB%E4%BD%93%E6%A0%87%E5%87%86%E5%B7%AE&oldid=1253”


Ver 估算样本方差

函数 | Ver
别名 | 估算样本方差
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 估算样本方差。
用法 | VAR(X,N)为X的N日估算样本方差
来自“http://www.hs633.com/kthelp/index.php?title=Ver_%E4%BC%B0%E7%AE%97%E6%A0%B7%E6%9C%AC%E6%96%B9%E5%B7%AE&oldid=1254”


VerP 总体样本方差

函数 | VerP
别名 | 总体样本方差
所属类别 | 统计函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 总体样本方差。
用法 | VARP(X,N)为X的N日总体样本方差
来自“http://www.hs633.com/kthelp/index.php?title=VerP_%E6%80%BB%E4%BD%93%E6%A0%B7%E6%9C%AC%E6%96%B9%E5%B7%AE&oldid=1255”


FreeMargin 可用资金

函数 | FreeMargin
别名 | 可用资金
所属类别 | 投资管理帐户
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 投资账户的可用资金
用法 | FREEMARGIN(ZHMC) 表示取得名称为ZHMC的帐户的可用资金 例如: FREEMARGIN('模拟训练') 表示[模拟训练]的可用资金
来自“http://www.hs633.com/kthelp/index.php?title=FreeMargin_%E5%8F%AF%E7%94%A8%E8%B5%84%E9%87%91&oldid=1553”


IvsBs 交易类型

函数 | IvsBs
别名 | 交易类型
所属类别 | 投资管理帐户
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 投资记录买卖情况
用法 | IVSBS(ZHMC,ZQDM,T) 表示取得名称为ZHMC的帐户中对证券代码为ZQDM的历史投资记录买卖情况,ZQDM为空字符串则为当前证券 参数T为交易类型, 0:任意交易 1:多头买入 2:多头卖出 3:空头买入 4:空头卖出 返回序列中0表示无此类交易，1表示有 例如: IVSBS('模拟训练',, 0) 表示[模拟训练]帐户中当前证券的任意交易情况
来自“http://www.hs633.com/kthelp/index.php?title=IvsBs_%E4%BA%A4%E6%98%93%E7%B1%BB%E5%9E%8B&oldid=1554”


IvsPrice 交易价格

函数 | IvsPrice
别名 | 交易价格
所属类别 | 投资管理帐户
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 投资记录买卖价格
用法 | IVSPRICE(ZHMC,ZQDM,T) 表示取得名称为ZHMC的帐户中对证券代码为ZQDM的历史投资记录买卖价格,ZQDM为空字符串则为当前证券 参数T为交易类型, 0:任意交易 1:多头买入 2:多头卖出 3:空头买入 4:空头卖出 例如: IVSPRICE('模拟训练',,1) 表示[模拟训练]帐户中当前证券的历史交易中多头买入价格
来自“http://www.hs633.com/kthelp/index.php?title=IvsPrice_%E4%BA%A4%E6%98%93%E4%BB%B7%E6%A0%BC&oldid=1555”


IvsVol 交易量

函数 | IvsVol
别名 | 交易量
所属类别 | 投资管理帐户
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 投资记录买卖量
用法 | IVSVOL(ZHMC,ZQDM,T) 表示取得名称为ZHMC的帐户中对证券代码为ZQDM的历史投资记录买卖量,ZQDM为空字符串则为当前证券 参数T为交易类型, 0:任意交易 1:多头买入 2:多头卖出 3:空头买入 4:空头卖出 例如: IVSVOL('模拟训练','SH600001',2) 表示[模拟训练]帐户中SH600001的历史交易中多头卖出量
来自“http://www.hs633.com/kthelp/index.php?title=IvsVol_%E4%BA%A4%E6%98%93%E9%87%8F&oldid=1556”


SysParam 系统参数

函数 | SysParam
别名 | 系统参数
所属类别 | 系统参数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统参数,详见Sysparam(1)-Sysparam(6)
用法 | Sysparam(1);
来自“http://www.hs633.com/kthelp/index.php?title=SysParam_%E7%B3%BB%E7%BB%9F%E5%8F%82%E6%95%B0&oldid=1411”


SysParam(1)

函数 | SysParam(1)
别名 | 无
所属类别 | 系统参数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统参数:画面上光标位置(K线序号)
用法 | 注意：该函数仅K线图形分析时有效。 跟十字光标有关的要打开十字光标,否则返回值不确定
来自“http://www.hs633.com/kthelp/index.php?title=SysParam(1)&oldid=1412”


SysParam(2)

函数 | SysParam(2)
别名 | 无
所属类别 | 系统参数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统参数:主图可见K线最初位置
用法 | 注意：该函数仅K线图形分析时有效。 跟十字光标有关的要打开十字光标,否则返回值不确定
来自“http://www.hs633.com/kthelp/index.php?title=SysParam(2)&oldid=1413”


SysParam(3)

函数 | SysParam(3)
别名 | 无
所属类别 | 系统参数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统参数:主图可见K线最后位置
用法 | 注意：该函数仅K线图形分析时有效。 跟十字光标有关的要打开十字光标,否则返回值不确定
来自“http://www.hs633.com/kthelp/index.php?title=SysParam(3)&oldid=1414”


SysParam(4)

函数 | SysParam(4)
别名 | 无
所属类别 | 系统参数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统参数:主图可见K线最高价
用法 | 注意：该函数仅K线图形分析时有效。 跟十字光标有关的要打开十字光标,否则返回值不确定
来自“http://www.hs633.com/kthelp/index.php?title=SysParam(4)&oldid=1415”


SysParam(5)

函数 | SysParam(5)
别名 | 无
所属类别 | 系统参数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统参数:主图可见K线最低价
用法 | 注意：该函数仅K线图形分析时有效。 跟十字光标有关的要打开十字光标,否则返回值不确定
来自“http://www.hs633.com/kthelp/index.php?title=SysParam(5)&oldid=1416”


SysParam(6)

函数 | SysParam(6)
别名 | 无
所属类别 | 系统参数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 系统参数:画面上光标数值
用法 | 注意：该函数仅K线图形分析时有效。 跟十字光标有关的要打开十字光标,否则返回值不确定
来自“http://www.hs633.com/kthelp/index.php?title=SysParam(6)&oldid=1417”


Alert 报警

函数 | Alert
别名 | 报警
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 弹出一个报警窗口, 增加一行报警信息。 参量可以是任意类型
用法 | 参数数量:1个以上。 Alert(PARAMs...) 例如： If Close[0]>SignalLevel then Alert('收盘价 ', Close[0], '超过', SignalLevel, '!!!');
来自“http://www.hs633.com/kthelp/index.php?title=Alert_%E6%8A%A5%E8%AD%A6&oldid=1561”


AppInfo 应用信息

函数 | AppInfo
别名 | 应用信息
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 返回指定的应用属性或信息
用法 | AppInfo(Attribute) Attribute：信息类型，以下枚举值 PI_AutoTrade //自动交易 PI_AutoTradeConf //自动交易下单需要手工确认 PI_RealTimeCalc //基于实时数据 PI_StrategyTesting //历史测试 PI_Optimization //参数优化 PI_VisualMode //可视模式 PI_LeftDispDateTime //主图最左边K线时间 PI_RightDispDateTime //主图最右边K线时间 PI_SpaceToRight //主图右边留空K线数
来自“http://www.hs633.com/kthelp/index.php?title=AppInfo_%E5%BA%94%E7%94%A8%E4%BF%A1%E6%81%AF&oldid=1575”


Comment 主图信息

函数 | Comment
别名 | 主图信息
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 显示一行信息在走势图左上角
用法 | Comment(PARAMs...)
来自“http://www.hs633.com/kthelp/index.php?title=Comment_%E4%B8%BB%E5%9B%BE%E4%BF%A1%E6%81%AF&oldid=1565”


CommentClear 清除主图信息

函数 | CommentClear
别名 | 清除主图信息
所属类别 | 系统函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 将之前输出到运行分析窗口的信息清除
用法 | COMMENTCLEAR()
来自“http://www.hs633.com/kthelp/index.php?title=CommentClear_%E6%B8%85%E9%99%A4%E4%B8%BB%E5%9B%BE%E4%BF%A1%E6%81%AF&oldid=1564”


FileAppend 写文件

函数 | FileAppend
别名 | 写文件
所属类别 | 系统函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 在指定文件中追加一行，成功返回1,失败返回0. 文件在 ..\Files 目录下
用法 | FileAppend('FileName', PARAMs...) 例如： FileAppend('EA_LOG.txt', '成交滑价 ', CJJ-WTJ); FileAppend('c:\\temp\\EA_LOG.txt', '成交滑价 ', CJJ-WTJ);
来自“http://www.hs633.com/kthelp/index.php?title=FileAppend_%E5%86%99%E6%96%87%E4%BB%B6&oldid=1567”


FileDelete 删除文件

函数 | FileDelete
别名 | 删除文件
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 删除指定文件. 成功返回1,失败返回0. 文件在 ..\Files 目录下
用法 | FileDelete(FileName)
来自“http://www.hs633.com/kthelp/index.php?title=FileDelete_%E5%88%A0%E9%99%A4%E6%96%87%E4%BB%B6&oldid=1568”


FormulaName 公式名

函数 | FormulaName
别名 | 公式名
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 公式名
用法 | FormulaName(N=0) N备用 获得当前执行的公式名、脚本名称
来自“http://www.hs633.com/kthelp/index.php?title=FormulaName_%E5%85%AC%E5%BC%8F%E5%90%8D&oldid=1559”


GetErrorMsg 错误信息

函数 | GetErrorMsg
别名 | 错误信息
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 返回错误码对应的错误信息
用法 | GetErrorMsg(GetLastError())
来自“http://www.hs633.com/kthelp/index.php?title=GetErrorMsg_%E9%94%99%E8%AF%AF%E4%BF%A1%E6%81%AF&oldid=1570”


GetGlobalVer 全局变量

函数 | GetGlobalVer
别名 | 全局变量
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 获取指定名称的全局变量值。
用法 | GetGlobalVar('VarName') 例如： AllowTrade := GetGlobalVar('EA_AllowTrade'); 当查询的条目不存在时，返回0
来自“http://www.hs633.com/kthelp/index.php?title=GetGlobalVer_%E5%85%A8%E5%B1%80%E5%8F%98%E9%87%8F&oldid=1573”


GetLastError 错误码

函数 | GetLastError
别名 | 错误码
所属类别 | 系统函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回最近的错误码
用法 | GetLastError
来自“http://www.hs633.com/kthelp/index.php?title=GetLastError_%E9%94%99%E8%AF%AF%E7%A0%81&oldid=1569”


GetLastErrorMsg 错误信息

函数 | GetLastErrorMsg
别名 | 错误信息
所属类别 | 系统函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回错误码对应的错误信息
用法 | GETLASTERRORMSG() 例如： GETLASTERRORMSG()
来自“http://www.hs633.com/kthelp/index.php?title=GetLastErrorMsg_%E9%94%99%E8%AF%AF%E4%BF%A1%E6%81%AF&oldid=1571”


HistoryDataExist 历史数据有效

函数 | HistoryDataExist
别名 | 历史数据有效
所属类别 | 系统函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 如果数据已经准备好，返回1，否则返回0
用法 | HistoryDataExist('Symbol', Period) 若数据中间有缺，不能正确计算，则返回0
来自“http://www.hs633.com/kthelp/index.php?title=HistoryDataExist_%E5%8E%86%E5%8F%B2%E6%95%B0%E6%8D%AE%E6%9C%89%E6%95%88&oldid=1558”


IsOptimization 参数优化

函数 | IsOptimization
别名 | 参数优化
所属类别 | 系统函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 如果在策略测试中为参数优化模式，返回1。否则返回0
用法 | IsOptimization
来自“http://www.hs633.com/kthelp/index.php?title=IsOptimization_%E5%8F%82%E6%95%B0%E4%BC%98%E5%8C%96&oldid=1579”


IsTesting 历史测试

函数 | IsTesting
别名 | 历史测试
所属类别 | 系统函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 是否运行在历史测试
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=IsTesting_%E5%8E%86%E5%8F%B2%E6%B5%8B%E8%AF%95&oldid=1578”


IsVisualMode 可视模式

函数 | IsVisualMode
别名 | 可视模式
所属类别 | 系统函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 用“可视模式”测试返回1 。否则返回0
用法 | IsVisualMode
来自“http://www.hs633.com/kthelp/index.php?title=IsVisualMode_%E5%8F%AF%E8%A7%86%E6%A8%A1%E5%BC%8F&oldid=1580”


Now 系统当前时间

函数 | Now
别名 | 系统当前时间
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得系统当前时间
用法 | Now(Format=0) Format: 0 //自系统启动以来的毫秒数,用于测试运行效率 1 //返回 1970.01.01 00:00:00开始秒数 2 //current DAY (1..31) 3 //MONTH (1..12) 4 //YEAR (four digit) 5 //DAY OF WEEK (0..6), 1=Monday 6 //DAY OF YEAR (1..366) 7 //第一次调用是一个随机数，以后每次调用都是跟上一次的时间差。单位是毫秒
来自“http://www.hs633.com/kthelp/index.php?title=Now_%E7%B3%BB%E7%BB%9F%E5%BD%93%E5%89%8D%E6%97%B6%E9%97%B4&oldid=1582”


Print 输出日志

函数 | Print
别名 | 输出日志
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 输出文本. 当第一个参数以File()括起来时，输出到该文件，否则输出到日志窗口,通过点选菜单'量化交易'->'公式日志'，打开print的观察窗口查看
用法 print(File('C:\\test\mylog.txt'), year(date[1])+1900:4:0, var1[1]:6:2, var1[2]:6:2);

表示输出到c:\test\mylog.txt文件，而内容则是 year(date[1]) + 1900和var1[1]、var1[2]

并且，var1[1]被格式化为4个有效数字，0个小数位；var1[2]格式化为6个有效数字，2个小数位。

print('year=' , year(date[1])+1900:4:0, var1[1]:6:2, var1[2]:6:2);

则输出以year=打头的一串日期到日志窗口

来自“http://www.hs633.com/kthelp/index.php?title=Print_%E8%BE%93%E5%87%BA%E6%97%A5%E5%BF%97&oldid=1562”


QuoteConneted 行情服务器连通

函数 | QuoteConneted
别名 | 行情服务器连通
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 检查该股票有没有点播行情
用法 | 例如： QuoteConnected( ‘000001.SZ’ ); //检查深发展是否有行情 QuoteConnected( ‘’ ); //检查当前股票有没有行情
来自“http://www.hs633.com/kthelp/index.php?title=QuoteConneted_%E8%A1%8C%E6%83%85%E6%9C%8D%E5%8A%A1%E5%99%A8%E8%BF%9E%E9%80%9A&oldid=1577”


ScriptName 脚本名

函数 | ScriptName
别名 | 脚本名
所属类别 | 系统函数
参数数量 |
运行模式 | 逐根/逐行
说明 |
用法 | ScriptName
来自“http://www.hs633.com/kthelp/index.php?title=ScriptName_%E8%84%9A%E6%9C%AC%E5%90%8D&oldid=1572”


SendMail 发送邮件

函数 | SendMail
别名 | 发送邮件
所属类别 | 系统函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 发送电子邮件，邮件服务器和账号在[选项]中设置,错误信息可通过GetLastError获取
用法 | SendMail('Subject', 'Content') 例如： If Close[0] SendMail('价格暴跌', '价格跌破'+NUMTOSTR(SignalLevel));
来自“http://www.hs633.com/kthelp/index.php?title=SendMail_%E5%8F%91%E9%80%81%E9%82%AE%E4%BB%B6&oldid=1566”


SetGlobalVar 设全局变量

函数 | SetGlobalVar
别名 | 设全局变量
所属类别 | 系统函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 设置指定名称的全局变量值，成功返回1,失败返回0。
用法 | SetGlobalVar('VarName',Value)
来自“http://www.hs633.com/kthelp/index.php?title=SetGlobalVar_%E8%AE%BE%E5%85%A8%E5%B1%80%E5%8F%98%E9%87%8F&oldid=1574”


Sleep 暂停

函数 | Sleep
别名 | 暂停
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 暂停运行脚本一段时间
用法 | Sleep(Milliseconds) MilliSeconds: 暂停运行 Milliseconds 毫秒 例如： Sleep(10000); //等待10秒
来自“http://www.hs633.com/kthelp/index.php?title=Sleep_%E6%9A%82%E5%81%9C&oldid=1581”


SymbolType 返回期货的品种代码

函数 | SymbolType
别名 | 返回期货的品种代码
所属类别 | 系统函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回期货的品种代码,例如Cu,Ru,SR,IF等
用法 | SymbolType() 返回期货的品种代码,例如Cu,Ru,SR,IF等
来自“http://www.hs633.com/kthelp/index.php?title=SymbolType_%E8%BF%94%E5%9B%9E%E6%9C%9F%E8%B4%A7%E7%9A%84%E5%93%81%E7%A7%8D%E4%BB%A3%E7%A0%81&oldid=1560”


TradeConneted 交易服务器连通

函数 | TradeConneted
别名 | 交易服务器连通
所属类别 | 系统函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 检查某经纪商交易服务是否连通
用法 | TradeConnected( BrokerID ) 例如： TradeConnected( ‘3030’ );
来自“http://www.hs633.com/kthelp/index.php?title=TradeConneted_%E4%BA%A4%E6%98%93%E6%9C%8D%E5%8A%A1%E5%99%A8%E8%BF%9E%E9%80%9A&oldid=1576”


Align

函数 | Align
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画图标、文字的对齐方式
用法 | 对于DRAWICON,0图标中对齐;1图标上缘;2图标中缘;3图中;4图上;5图下 对于DRAWTEXT,DRAWNUMBER,0中对齐;1左对齐;2右对齐;3图中;4图上;5图下。 对于DRAWYITEXT，3为竖排 例如: drawicon(cross(ma(c,5),ma(c,20)),H,3),align3;
来自“http://www.hs633.com/kthelp/index.php?title=Align&oldid=1421”


AreaColor

函数 | AreaColor
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 颜色填充
用法 | #Run_by_Bar Close,AreaColor;
来自“http://www.hs633.com/kthelp/index.php?title=AreaColor&oldid=1480”


AreaHatchCross

函数 | AreaHatchCross
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 正十字线填充
用法 | #Run_by_Bar Close,AreaHatchCross;
来自“http://www.hs633.com/kthelp/index.php?title=AreaHatchCross&oldid=1483”


AreaHatchDiag

函数 | AreaHatchDiag
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 交叉线填充
用法 | #Run_by_Bar Close,AreaHatchDiag;
来自“http://www.hs633.com/kthelp/index.php?title=AreaHatchDiag&oldid=1484”


AreaHatchDown

函数 | AreaHatchDown
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 下斜线填充
用法 | #Run_by_Bar Close,AreaHatchDown;
来自“http://www.hs633.com/kthelp/index.php?title=AreaHatchDown&oldid=1481”


AreaHatchHor

函数 | AreaHatchHor
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 水平线填充
用法 | #Run_by_Bar Close,AreaHatchHor;
来自“http://www.hs633.com/kthelp/index.php?title=AreaHatchHor&oldid=1485”


AreaHatchVer

函数 | AreaHatchVer
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 垂直线填充
用法 | #Run_by_Bar Close,AreaHatchVer;
来自“http://www.hs633.com/kthelp/index.php?title=AreaHatchVer&oldid=1486”


AreaHathUp

函数 | AreaHathUp
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 上斜线填充
用法 | #Run_by_Bar Close,AreaHatchUp;
来自“http://www.hs633.com/kthelp/index.php?title=AreaHathUp&oldid=1482”


AreaStack

函数 | AreaStack
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 把多个都用AreaStack的区域堆叠起来
用法 | #Run_by_Bar Close,AreaStack; Open,AreaStack;
来自“http://www.hs633.com/kthelp/index.php?title=AreaStack&oldid=1487”


AutoTitle

函数 | AutoTitle
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 当此变量初始化后一直都没被赋过值，则不作为输出，也不在题头上显示
用法 | 例如: vol,VolStick,LineThick15; 持仓:0,AutoTitle,OwnerScale; IF (Category()=C_FUTURES) THEN begin 持仓:=OPENINT; END
来自“http://www.hs633.com/kthelp/index.php?title=AutoTitle&oldid=1466”


BarPercent 显示百分比

函数 | BarPercent
别名 | 显示百分比
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 在bar上显示百分比
用法 | a1:50,BarPercent; b1:25,BarPercent; c1:,,BarPercent;
来自“http://www.hs633.com/kthelp/index.php?title=BarPercent_%E6%98%BE%E7%A4%BA%E7%99%BE%E5%88%86%E6%AF%94&oldid=1476”


BarStack 颜色堆叠数

函数 | BarStack
别名 | 颜色堆叠数
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 当有多个BarStack输出时，bar以不同的颜色堆叠在一起
用法 | a1:50,BarStack; b1:25,BarStack; c1:,,BarStack;
来自“http://www.hs633.com/kthelp/index.php?title=BarStack_%E9%A2%9C%E8%89%B2%E5%A0%86%E5%8F%A0%E6%95%B0&oldid=1475”


CircleDot 画小圆圈线

函数 | CircleDot
别名 | 画小圆圈线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画小圆圈线
用法 | 例如: CLOSE,CIRCLEDOT;
来自“http://www.hs633.com/kthelp/index.php?title=CircleDot_%E7%94%BB%E5%B0%8F%E5%9C%86%E5%9C%88%E7%BA%BF&oldid=1422”


Color

函数 | Color
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 改变指标线颜色
用法 | 例如: ma1:ma(close,5),coloryellow; ma1:ma(close,5),colorff0000;
来自“http://www.hs633.com/kthelp/index.php?title=Color&oldid=1423”


ColorBlack 黑色

函数 | ColorBlack
别名 | 黑色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为黑色
用法 | 例如: ma1:ma(close,5),COLORBLACK;
来自“http://www.hs633.com/kthelp/index.php?title=ColorBlack_%E9%BB%91%E8%89%B2&oldid=1426”


ColorBlue 蓝色

函数 | ColorBlue
别名 | 蓝色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为蓝色
用法 | 例如: ma1:ma(close,5),COLORBLUE;
来自“http://www.hs633.com/kthelp/index.php?title=ColorBlue_%E8%93%9D%E8%89%B2&oldid=1427”


ColorBrown 棕色

函数 | ColorBrown
别名 | 棕色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为棕色
用法 | 例如: ma1:ma(close,5),COLORBROWN;
来自“http://www.hs633.com/kthelp/index.php?title=ColorBrown_%E6%A3%95%E8%89%B2&oldid=1428”


ColorCyan 青色

函数 | ColorCyan
别名 | 青色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为青色
用法 | 例如: ma1:ma(close,5),COLORCYAN;
来自“http://www.hs633.com/kthelp/index.php?title=ColorCyan_%E9%9D%92%E8%89%B2&oldid=1430”


ColorGray 灰色

函数 | ColorGray
别名 | 灰色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为灰色
用法 | 例如: ma1:ma(close,5),COLORGRAY;
来自“http://www.hs633.com/kthelp/index.php?title=ColorGray_%E7%81%B0%E8%89%B2&oldid=1431”


ColorGreen 绿色

函数 | ColorGreen
别名 | 绿色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为绿色
用法 | 例如: ma1:ma(close,5),COLORGREEN;
来自“http://www.hs633.com/kthelp/index.php?title=ColorGreen_%E7%BB%BF%E8%89%B2&oldid=1432”


ColorLightBlue 淡蓝色

函数 | ColorLightBlue
别名 | 淡蓝色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为淡蓝色
用法 | 例如: ma1:ma(close,5),COLORLIGHTBLUE;
来自“http://www.hs633.com/kthelp/index.php?title=ColorLightBlue_%E6%B7%A1%E8%93%9D%E8%89%B2&oldid=1435”


ColorLightCyan 淡青色

函数 | ColorLightCyan
别名 | 淡青色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为淡青色
用法 | 例如: ma1:ma(close,5),COLORLIGHTCYAN;
来自“http://www.hs633.com/kthelp/index.php?title=ColorLightCyan_%E6%B7%A1%E9%9D%92%E8%89%B2&oldid=1437”


ColorLightGreen 淡绿色

函数 | ColorLightGreen
别名 | 淡绿色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为淡绿色
用法 | 例如: ma1:ma(close,5),COLORLIGHTGREEN;
来自“http://www.hs633.com/kthelp/index.php?title=ColorLightGreen_%E6%B7%A1%E7%BB%BF%E8%89%B2&oldid=1436”


ColorLightMagenta 淡洋红色

函数 | ColorLightMagenta
别名 | 淡洋红色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为淡洋红色
用法 | 例如: ma1:ma(close,5),COLORLIGHTMAGENTA;
来自“http://www.hs633.com/kthelp/index.php?title=ColorLightMagenta_%E6%B7%A1%E6%B4%8B%E7%BA%A2%E8%89%B2&oldid=1439”


ColorLightRed 淡红色

函数 | ColorLightRed
别名 | 淡红色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为淡红色
用法 | 例如: ma1:ma(close,5),COLORLIGHTRED;
来自“http://www.hs633.com/kthelp/index.php?title=ColorLightRed_%E6%B7%A1%E7%BA%A2%E8%89%B2&oldid=1438”


ColorMagenta 晶红色

函数 | ColorMagenta
别名 | 晶红色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为晶红色
用法 | 例如: ma1:ma(close,5),COLORMAGENTA;
来自“http://www.hs633.com/kthelp/index.php?title=ColorMagenta_%E6%99%B6%E7%BA%A2%E8%89%B2&oldid=1433”


ColorRed 红色

函数 | ColorRed
别名 | 红色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为红色
用法 | 例如: ma1:ma(close,5),COLORRED;
来自“http://www.hs633.com/kthelp/index.php?title=ColorRed_%E7%BA%A2%E8%89%B2&oldid=1434”


ColorStick 彩色棒状线

函数 | ColorStick
别名 | 彩色棒状线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 彩色棒状线
用法 | 以零轴为中心画彩色棒状线，零轴下为阴线颜色，零轴上为阳线颜色 例如: CLOSE-OPEN,COLORSTICK;
来自“http://www.hs633.com/kthelp/index.php?title=ColorStick_%E5%BD%A9%E8%89%B2%E6%A3%92%E7%8A%B6%E7%BA%BF&oldid=1440”


ColorWhite 白色

函数 | ColorWhite
别名 | 白色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为白色
用法 | 例如: ma1:ma(close,5),COLORWHIT;
来自“http://www.hs633.com/kthelp/index.php?title=ColorWhite_%E7%99%BD%E8%89%B2&oldid=1441”


ColorYellow 黄色

函数 | ColorYellow
别名 | 黄色
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 设为黄色
用法 | 例如: ma1:ma(close,5),COLORYELLOW;
来自“http://www.hs633.com/kthelp/index.php?title=ColorYellow_%E9%BB%84%E8%89%B2&oldid=1442”


CrossDot 叉状线,x状线

函数 | CrossDot
别名 | 叉状线,x状线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画叉状线或x状线
用法 | 例如: CLOSE,CROSSDOT;
来自“http://www.hs633.com/kthelp/index.php?title=CrossDot_%E5%8F%89%E7%8A%B6%E7%BA%BF,x%E7%8A%B6%E7%BA%BF&oldid=1457”


GetPlotColor 指标颜色

函数 | GetPlotColor
别名 | 指标颜色
所属类别 | 线型描述
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 指标颜色
用法 | 例如: GetPlotColor(plotNumber)
来自“http://www.hs633.com/kthelp/index.php?title=GetPlotColor_%E6%8C%87%E6%A0%87%E9%A2%9C%E8%89%B2&oldid=1490”


GetPlotWidth 指标线宽

函数 | GetPlotWidth
别名 | 指标线宽
所属类别 | 线型描述
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 指标线宽
用法 | 例如: GetPlotWidth( plotNumber );
来自“http://www.hs633.com/kthelp/index.php?title=GetPlotWidth_%E6%8C%87%E6%A0%87%E7%BA%BF%E5%AE%BD&oldid=1493”


InvalidPlot

函数 | InvalidPlot
别名 | 无
所属类别 | 线型描述
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 当前周期不绘制指定的输出(无效值不画出来)
用法 InvalidPlot(PlotN)

PlotN - 指定的输出号，取值范围1-99

例如：

  1. Run_By_Bar

Plot1(close);

if C>O then

InvalidPlot(1) ;

来自“http://www.hs633.com/kthelp/index.php?title=InvalidPlot&oldid=1478”


LineDash 长虚线

函数 | LineDash
别名 | 长虚线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画长虚状
用法 | 例如: MA(CLOSE,20),LINEDASH;
来自“http://www.hs633.com/kthelp/index.php?title=LineDash_%E9%95%BF%E8%99%9A%E7%BA%BF&oldid=1458”


LineDashDot 长短虚线

函数 | LineDashDot
别名 | 长短虚线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画长短虚线
用法 | 例如: MA(CLOSE,20),LINEDASHDOT;
来自“http://www.hs633.com/kthelp/index.php?title=LineDashDot_%E9%95%BF%E7%9F%AD%E8%99%9A%E7%BA%BF&oldid=1460”


LineDot 短虚线

函数 | LineDot
别名 | 短虚线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画短虚线
用法 | 例如: MA(CLOSE,20),LINEDOT;
来自“http://www.hs633.com/kthelp/index.php?title=LineDot_%E7%9F%AD%E8%99%9A%E7%BA%BF&oldid=1461”


LineSolid 长实线

函数 | LineSolid
别名 | 长实线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画长实状
用法 | 例如: MA(CLOSE,20),LINESOLID;
来自“http://www.hs633.com/kthelp/index.php?title=LineSolid_%E9%95%BF%E5%AE%9E%E7%BA%BF&oldid=1459”


LineStick 棒状指标线

函数 | LineStick
别名 | 棒状指标线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 同时画棒状线与指标线。
用法 | 例如: VOL,LINESTICK;
来自“http://www.hs633.com/kthelp/index.php?title=LineStick_%E6%A3%92%E7%8A%B6%E6%8C%87%E6%A0%87%E7%BA%BF&oldid=1462”


LineThick 指标线粗细

函数 | LineThick
别名 | 指标线粗细
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 改变指标线粗细
用法 | 例如: ma1:ma(close,5),linethick3; LINETHICK0 表示不画出指标线，不影响坐标，但可在顶部显示数值
来自“http://www.hs633.com/kthelp/index.php?title=LineThick_%E6%8C%87%E6%A0%87%E7%BA%BF%E7%B2%97%E7%BB%86&oldid=1463”


NoAxis

函数 | NoAxis
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 不影响坐标最高最低值
用法 | 例如: C,NOAXIS; 输出收盘价,但不影响坐标最高最低值,用于叠加到其它指标上
来自“http://www.hs633.com/kthelp/index.php?title=NoAxis&oldid=1464”


NoDrawInvalid

函数 | NoDrawInvalid
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 当添加了NoDrawInvalid描述时，公式中的invalid数据不画
用法 | c1:if(c>o,c,invalid),NoDrawInvalid;//只画阳线所在的点
来自“http://www.hs633.com/kthelp/index.php?title=NoDrawInvalid&oldid=1477”


NoPlot

函数 | NoPlot
别名 | 无
所属类别 | 线型描述
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 当前周期不绘制指定的输出(在有效值直接连线)
用法 NoPlot(PlotN)

PlotN - 指定的输出号，取值范围1-99

例如：

  1. Run_By_Bar

Plot1(close);

if C>O then

NoPlot(1) ;

来自“http://www.hs633.com/kthelp/index.php?title=NoPlot&oldid=1479”


NoTitle

函数 | NoTitle
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 只画指标线，不在标题栏显示数值
用法 | 例如: C,NoTitle; 只画收盘价指标线，不在标题栏显示收盘价数值
来自“http://www.hs633.com/kthelp/index.php?title=NoTitle&oldid=1465”


OwnerScale

函数 | OwnerScale
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 让指标用自己的坐标来显示
用法 | #mainchart close,ownerscale; open>close,ownerscale;
来自“http://www.hs633.com/kthelp/index.php?title=OwnerScale&oldid=1424”


PlotPb 画蜡烛线

函数 | PlotPb
别名 | 画蜡烛线
所属类别 | 线型描述
参数数量 | 8
运行模式 | 逐根/逐行
说明 | 指标线宽
用法 | 例如: fuckfuckfuck PlotPaintBar( BarHigh, BarLow, BarOpen, BarClose ,'PlotName',PlotColor ,0,LineWidth) BarHigh,BarLow,BarOpen,BarClose：高低开收 PlotName：给线起名字 0：保留参数，只需填0即可 PlotColor：颜色 LineWidth：线宽
来自“http://www.hs633.com/kthelp/index.php?title=PlotPb_%E7%94%BB%E8%9C%A1%E7%83%9B%E7%BA%BF&oldid=1495”


PointDot 点状线

函数 | PointDot
别名 | 点状线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画点状线
用法 | 例如: CLOSE,POINTDOT;
来自“http://www.hs633.com/kthelp/index.php?title=PointDot_%E7%82%B9%E7%8A%B6%E7%BA%BF&oldid=1467”


PreCisiono 显示小数位数

函数 | PreCisiono
别名 | 显示小数位数
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 指标图上指标数值显示x位小数,x取值范围0-7
用法 | 例如: MA1: ROUND(MA(C,10)),PRECISION0; 显示四舍五入的整数
来自“http://www.hs633.com/kthelp/index.php?title=PreCisiono_%E6%98%BE%E7%A4%BA%E5%B0%8F%E6%95%B0%E4%BD%8D%E6%95%B0&oldid=1468”


Pxdn 下偏移

函数 | Pxdn
别名 | 下偏移
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 文字或图形向下偏移x个像素
用法 | 例如: 用于DRAWICON, DRAWTEXT, DRAWNUMBER, DRAWYITEXT语句后.最多可偏移127个像素
来自“http://www.hs633.com/kthelp/index.php?title=Pxdn_%E4%B8%8B%E5%81%8F%E7%A7%BB&oldid=1469”


Pxup 上偏移

函数 | Pxup
别名 | 上偏移
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 文字或图形向上偏移x个像素
用法 | 用于DRAWICON, DRAWTEXT, DRAWNUMBER, DRAWYITEXT语句后.最多可偏移127个像素 例如: DRAWICON(C>O,H,0),PXUP20;
来自“http://www.hs633.com/kthelp/index.php?title=Pxup_%E4%B8%8A%E5%81%8F%E7%A7%BB&oldid=1470”


SetPlotColor 设指标颜色

函数 | SetPlotColor
别名 | 设指标颜色
所属类别 | 线型描述
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 设指标颜色
用法 | 例如: SetPlotColor( plotNumber, color ); 例子：SetPlotColor( 1, colorRed );
来自“http://www.hs633.com/kthelp/index.php?title=SetPlotColor_%E8%AE%BE%E6%8C%87%E6%A0%87%E9%A2%9C%E8%89%B2&oldid=1492”


SetPlotWidth 设指标线宽

函数 | SetPlotWidth
别名 | 设指标线宽
所属类别 | 线型描述
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 设指标线宽
用法 | 例如: SetPlotWidth( plotNumber, LineWidth); 例子：SetPlotWidth( 1, 10 );
来自“http://www.hs633.com/kthelp/index.php?title=SetPlotWidth_%E8%AE%BE%E6%8C%87%E6%A0%87%E7%BA%BF%E5%AE%BD&oldid=1494”


Shift 指标线偏移

函数 | Shift
别名 | 指标线偏移
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 指标线向后（向右）偏移x个周期
用法 | 例如: MA1: MA(C,10),SHIFT2; 将MA1指标线向后偏移2个周期.最多可偏移255个周期
来自“http://www.hs633.com/kthelp/index.php?title=Shift_%E6%8C%87%E6%A0%87%E7%BA%BF%E5%81%8F%E7%A7%BB&oldid=1471”


Stick 棒状线

函数 | Stick
别名 | 棒状线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画棒状线
用法 | 例如: VOL,STICK;
来自“http://www.hs633.com/kthelp/index.php?title=Stick_%E6%A3%92%E7%8A%B6%E7%BA%BF&oldid=1472”


TFilter

函数 | TFilter
别名 | 无
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 过滤交易信号
用法 | 用于交易系统公式ENTERLONG, EXITLONG, ENTERSHORT, EXITSHORT后, 以ENTER和EXIT为间隔，过滤连续的同种信号 例如: ENTERLONG:CROSS(LL,BIAS),TFILTER; EXITLONG:CROSS(BIAS,LH),TFILTER;
来自“http://www.hs633.com/kthelp/index.php?title=TFilter&oldid=1473”


VolStick 成交量柱状线

函数 | VolStick
别名 | 成交量柱状线
所属类别 | 线型描述
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 画成交量柱状线
用法 | 画成交量柱状线 例如: VOL,VOLSTICK;
来自“http://www.hs633.com/kthelp/index.php?title=VolStick_%E6%88%90%E4%BA%A4%E9%87%8F%E6%9F%B1%E7%8A%B6%E7%BA%BF&oldid=1474”


Beta 贝塔系数

函数 | Beta
别名 | 贝塔系数
所属类别 | 协方差函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求当前品种的贝塔系数。
用法 | BETA(N) 为当前品种N收益与大盘收益相比的贝塔系数， 该系数表明大盘每变动1%,则该品种将变动V% 例如:BETA(5) 表示5周期贝塔系数
来自“http://www.hs633.com/kthelp/index.php?title=Beta_%E8%B4%9D%E5%A1%94%E7%B3%BB%E6%95%B0&oldid=1344”


Beta2 相关放大系数

函数 | Beta2
别名 | 相关放大系数
所属类别 | 协方差函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 求2个序列间的相关放大系数。
用法 | BETA2(X1,X2,N) 为X1与X2的N周期的相关放大系数，表示Y变化1，则X将变化V 例如: BETA2(CLOSE,INDEXC,5)表示收盘价与大盘指数之间的5周期相关放大系数
来自“http://www.hs633.com/kthelp/index.php?title=Beta2_%E7%9B%B8%E5%85%B3%E6%94%BE%E5%A4%A7%E7%B3%BB%E6%95%B0&oldid=1345”


BetaDown 下跌贝塔系数

函数 | BetaDown
别名 | 下跌贝塔系数
所属类别 | 协方差函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求当前品种的下跌贝塔系数。
用法 | BETADOWN(N) 为当前品种N收益与大盘收益相比的下跌贝塔系数, 该系数表明大盘每下跌1%,则该品种将下跌V% 例如:BETADOWN(5) 表示5周期下跌贝塔系数
来自“http://www.hs633.com/kthelp/index.php?title=BetaDown_%E4%B8%8B%E8%B7%8C%E8%B4%9D%E5%A1%94%E7%B3%BB%E6%95%B0&oldid=1346”


BetaUp 上涨贝塔系数

函数 | BetaUp
别名 | 上涨贝塔系数
所属类别 | 协方差函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求当前品种的上涨贝塔系数
用法 | BETAUP(N) 为当前品种N收益与大盘收益相比的上涨贝塔系数， 该系数表明大盘每上涨1%,则该品种将上涨V% 例如: BETAUP(5) 表示5周期上涨贝塔系数
来自“http://www.hs633.com/kthelp/index.php?title=BetaUp_%E4%B8%8A%E6%B6%A8%E8%B4%9D%E5%A1%94%E7%B3%BB%E6%95%B0&oldid=1347”


CorrTpl 与模板相关系数

函数 | CorrTpl
别名 | 与模板相关系数
所属类别 | 协方差函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 与模板相关系数。
用法 | CORRTPL(TPLNAME,X,D,N) D为常数,表示0:开盘价,1:最高价,2:最低价,3:收盘价,4:成交量,5:成交额 N表示仅计算最后多少个有效数据，为0表示计算所有。 用于当前选股时N设为1可大大减小计算量,用于历史测试和训练模式应设为0避免有效数据过少而失真 例如: CORRTPL('一马平川',CLOSE,3,1) 表示求收盘价线与一马平川收盘价线的最后一组的相关系数
来自“http://www.hs633.com/kthelp/index.php?title=CorrTpl_%E4%B8%8E%E6%A8%A1%E6%9D%BF%E7%9B%B8%E5%85%B3%E7%B3%BB%E6%95%B0&oldid=1348”


Covar 协方差

函数 | Covar
别名 | 协方差
所属类别 | 协方差函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 求2个序列的协方差。
用法 | COVAR(X1,X2,N) 为X1与X2的N周期的协方差 例如: COVAR(CLOSE,INDEXC,8) 表示收盘价与大盘指数之间的8周期的协方差
来自“http://www.hs633.com/kthelp/index.php?title=Covar_%E5%8D%8F%E6%96%B9%E5%B7%AE&oldid=1349”


Relate CORR, 相关系数

函数 | Relate
别名 | CORR, 相关系数
所属类别 | 协方差函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 求2个序列间的相关系数。
用法 | CORR(X1,X2,N) 为X1与X2的N周期的相关系数 例如: CORR(CLOSE,INDEXC,5) 表示收盘价与大盘指数之间的5周期的相关系数
来自“http://www.hs633.com/kthelp/index.php?title=Relate_CORR,_%E7%9B%B8%E5%85%B3%E7%B3%BB%E6%95%B0&oldid=1350”


Text_Delete 删除文本

函数 | Text_Delete
别名 | 删除文本
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 删除文本
用法 | Text_Delete(ID) 删除标识号为ID的文本对象，成功返回0，文本对象无效返回-2 例如： Value1:=Text_Delete(2); 删除标识号为2的文本对象
来自“http://www.hs633.com/kthelp/index.php?title=Text_Delete_%E5%88%A0%E9%99%A4%E6%96%87%E6%9C%AC&oldid=2132”


Text_GetActive 当前文本

函数 | Text_GetActive
别名 | 当前文本
所属类别 | 新画线函数
参数数量 |
运行模式 | 逐根
说明 | 当前文本
用法 | Text_GetActive 返回当前选中的文本对象的标识号，返回-1表示无选中的文本对象 例如： Value1:=Text_GetActive; 当前选中的文本对象的标识号赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetActive_%E5%BD%93%E5%89%8D%E6%96%87%E6%9C%AC&oldid=2152”


Text_GetAttribute 文本属性

函数 | Text_GetAttribute
别名 | 文本属性
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 文本属性
用法 | Text_GetAttribute(ID,A) 返回标识号为ID的文本对象的指定属性，有此属性返回True(1)，无此属性或对象无效返回False(0)， A：属性类型取值范围: 0 - 边框 1 - 粗体 2 - 斜体 3 - 删除线 4 - 下划线 例如： GetAttribute(2,3); 返回标识号为2的文本对象中间是否一条有横线（删除线）
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetAttribute_%E6%96%87%E6%9C%AC%E5%B1%9E%E6%80%A7&oldid=2138”


Text GetBgColor 文本背景色

函数 | Text_GetBgColor
别名 | 文本背景色
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本背景色
用法 | Text_GetBGColor(ID) 返回标识号为ID的文本对象的RGB颜色值，对象无效返回-2
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetBgColor_%E6%96%87%E6%9C%AC%E8%83%8C%E6%99%AF%E8%89%B2&oldid=2145”


Text_GetBorder 文本边框

函数 | Text_GetBorder
别名 | 文本边框
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本边框
用法 | Text_GetBorder(ID) 返回标识号为ID的文本对象是否有边框，有边框返回True(1)，否则返回False(0)，对象无效返回False(0)
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetBorder_%E6%96%87%E6%9C%AC%E8%BE%B9%E6%A1%86&oldid=2147”


Text GetColor 文本颜色

函数 | Text_GetColor
别名 | 文本颜色
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本颜色
用法 | Text_GetColor(ID) 返回标识号为ID的文本对象的RGB颜色值，对象无效返回-2
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetColor_%E6%96%87%E6%9C%AC%E9%A2%9C%E8%89%B2&oldid=2143”


Text_GetDate 文本日期

函数 | Text_GetDate
别名 | 文本日期
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本日期
用法 | Text_GetDate(ID) 返回标识号为ID的文本对象所在的日期，格式为YYYMMDD，对象无效返回-2 例如： Value1:=Text_GetDate(2); 将标识号为2的文本对象所在的日期赋值给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetDate_%E6%96%87%E6%9C%AC%E6%97%A5%E6%9C%9F&oldid=2136”


Text_GetFirst 第一个文本

函数 | Text_GetFirst
别名 | 第一个文本
所属类别 | 新画线函数
参数数量 |
运行模式 | 逐根
说明 | 第一个文本
用法 | Text_GetFirst(Origin=1) 返回指定范围的最早绘制的第一个文本对象的标识号，对象无效返回-2 参数： Origin取值范围： 1 - 当前公式绘制的 2 - 其它公式或手工绘制的 3 - 所有的 4 - 当前公式或手工绘制的 5 - 其它公式绘制的 6 - 所有公式绘制的 7 - 手工绘制的 例如： Value1:=Text_GetFirst; 将当前公式最早绘制的文本对象的标识号赋给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetFirst_%E7%AC%AC%E4%B8%80%E4%B8%AA%E6%96%87%E6%9C%AC&oldid=2153”


Text_GetHStyle 文本水平对齐

函数 | Text_GetHStyle
别名 | 文本水平对齐
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本水平对齐
用法 | Text_GetHStyle(ID) 返回标识号为ID的文本对象与定位点的水平对齐方式，对象无效返回-2 返回值为： 0 - 左对齐 1 - 右对齐 2 - 中间对齐 例如： Value1:=Text_GetHStyle(2); 将标识号为2的文本对象的水平对齐方式赋值给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetHStyle_%E6%96%87%E6%9C%AC%E6%B0%B4%E5%B9%B3%E5%AF%B9%E9%BD%90&oldid=2141”


Text_GetNext 下一个文本

函数 | Text_GetNext
别名 | 下一个文本
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 下一个文本
用法 | Text_GetNext(ID,Origin=1) 返回指定范围的标识号为ID的文本对象的下一个绘制的文本对象的标识号，对象无效返回-2 参数： Origin取值范围： 1 - 当前公式绘制的 2 - 其它公式或手工绘制的 3 - 所有的 4 - 当前公式或手工绘制的 5 - 其它公式绘制的 6 - 所有公式绘制的 7 - 手工绘制的 例如： Value1:=Text_GetNext(2,1); 将当前公式绘制的标识号为2的文本对象的下一个文本对象的标识号赋给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetNext_%E4%B8%8B%E4%B8%80%E4%B8%AA%E6%96%87%E6%9C%AC&oldid=2154”


Text_GetSize 文本字体大小

函数 | Text_GetSize
别名 | 文本字体大小
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 文本字体大小
用法 | Text_GetSize(ID) 返回标识号为ID的文本对象的字体大小，对象无效返回-2
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetSize_%E6%96%87%E6%9C%AC%E5%AD%97%E4%BD%93%E5%A4%A7%E5%B0%8F&oldid=1545”


Text_GetString 文本字串

函数 | Text_GetString
别名 | 文本字串
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本字串
用法 | Text_GetString(ID) 返回标识号为ID的文本对象的字符串 例如： Text_GetString(2); 返回标识号为2的文本对象的字符串
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetString_%E6%96%87%E6%9C%AC%E5%AD%97%E4%B8%B2&oldid=2134”


Text_GetTime 文本时间

函数 | Text_GetTime
别名 | 文本时间
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本时间
用法 | Text_GetTime(ID) 返回标识号为ID的文本对象所在的时间，格式为HHMMSS，对象无效返回-2 例如： Value1:=Text_GetTime(2); 将标识号为2的文本对象所在的时间赋值给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetTime_%E6%96%87%E6%9C%AC%E6%97%B6%E9%97%B4&oldid=2135”


Text_GetValue 文本位置数值

函数 | Text_GetValue
别名 | 文本位置数值
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本位置数值
用法 | Text_GetValue(ID) 返回标识号为ID的文本对象所在垂直位置的数值，对象无效返回-2 例如： Value1:=Text_GetValue(2); 将标识号为2的文本对象所在垂直位置的数值赋值给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetValue_%E6%96%87%E6%9C%AC%E4%BD%8D%E7%BD%AE%E6%95%B0%E5%80%BC&oldid=2137”


Text_GetVStyle 文本水平对齐

函数 | Text_GetVStyle
别名 | 文本水平对齐
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本水平对齐
用法 | Text_GetVStyle(ID) 返回标识号为ID的文本对象与定位点的垂直对齐方式，对象无效返回-2 返回值为： 0 - 上对齐 1 - 下对齐 2 - 中间对齐 例如： Value1:=Text_GetVStyle(2); 将标识号为2的文本对象的垂直对齐方式赋值给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Text_GetVStyle_%E6%96%87%E6%9C%AC%E6%B0%B4%E5%B9%B3%E5%AF%B9%E9%BD%90&oldid=2142”


Text_New 新建文本

函数 | TEXT_NEW
别名 | 新建文本
所属类别 | 新画线函数
参数数量 | 4
运行模式 | 逐根
说明 | 新建文本
用法 | Text_New (BarDate, BarTime, PriceValue,Express,bool) 在指定位置创建文本对象并显示，定位点由BarDate、BarTime、PriceValue参数进行设定 返回所创建文本对象的唯一数字标识号，从0开始计数，用于将来的读取与设置。 参数： BarDate: 定位日期，格式为YYYMMDD BarTime: 定位时间，格式为HHMMSS PriceValue: 数值坐标位置 Express: 显示字符串、数值(bool为true时则该值是符号索引) 查看符号索引代码 bool: Express为数值和bool内容为true是表示创建数值对应的符号 例如： If C>C[1] And C[1]>C[2] Then ID1:=Text_New(Date,Time,H,'上涨'); //连续3个周期收盘价上涨，则在最高价处显示'上涨' ID1:=Text_New(Date,Time, H, '最高'); //在最高价处显示 ‘最高' ID1:=Text_New(Date,Time, H, H); //在最高价处显示 最高价格 ID1:=Text_New(Date,Time, H, 211, true);//显示符号最后一个参数设为true, 211代表符号索引，范围从0-680，可以在符号对话框看到各种符号的索引。 也可以通过调用 以下代码达到一样的符号效果 Text_SetFontName(ID1, 'symbols'); //将标识号为ID1的对象设为符号 Text_SetString(ID1, 211); // 将标识号为ID1的对象替换为符号索引 211
来自“http://www.hs633.com/kthelp/index.php?title=TEXT_NEW_%E6%96%B0%E5%BB%BA%E6%96%87%E6%9C%AC&oldid=2130”


Text_SetAttribute 设置文本属性

函数 | Text_SetAttribute
别名 | 设置文本属性
所属类别 | 新画线函数
参数数量 | 3
运行模式 | 逐根
说明 | 设置文本属性
用法 Text_SetAttribute(ID,A,L=True)

设置标识号为ID的文本对象的指定属性，L为True或1时设置该属性，L为False或0时取消该属性

A：属性类型取值范围:

0 - 边框

1 - 粗体

2 - 斜体

3 - 删除线

4 - 下划线

成功返回0，对象无效返回-2

例如：

Value1:=TL_SetAttribute(2,3,True);

使标识号为2的文本对象中间带一条横线（删除线）

来自“http://www.hs633.com/kthelp/index.php?title=Text_SetAttribute_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E5%B1%9E%E6%80%A7&oldid=2139”


Text_SetBgColor 设置文本背景色

函数 | Text_SetBgColor
别名 | 设置文本背景色
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置文本背景色
用法 | Text_SetBGColor(ID,BGColor) 设置标识号为ID的文本对象的背景色色，BGColor为RGB颜色值 成功返回0，对象无效返回-2 例如： Value1:=Text_SetBGColor(2,Blue); 设置标识号为2的文本对象背景色为蓝色
来自“http://www.hs633.com/kthelp/index.php?title=Text_SetBgColor_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E8%83%8C%E6%99%AF%E8%89%B2&oldid=2146”


Text_SetBorder 设置文本边框

函数 | Text_SetBorder
别名 | 设置文本边框
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置文本边框
用法 | Text_SetBorder(ID,L=True) 设置标识号为ID的文本对象是否有边框，L为True或1，加上边框；L为False或0，移去边框 成功返回0，对象无效返回-2 例如： Value1:=Text_SetBorder(2,True); 使标识号为2的文本对象显示边框 Value1:=Text_SetBorder(1,0); 使标识号为1的文本对象移去边框线
来自“http://www.hs633.com/kthelp/index.php?title=Text_SetBorder_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E8%BE%B9%E6%A1%86&oldid=2148”


Text_SetColor 设置文本颜色

函数 | Text_SetColor
别名 | 设置文本颜色
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置文本颜色
用法 | Text_SetColor(ID,TextColor) 设置标识号为ID的文本对象的颜色，TextColor为RGB颜色值 成功返回0，对象无效返回-2 例如： Value1:=Text_SetColor(2,ColorBlue); 设置标识号为2的文本对象为蓝色
来自“http://www.hs633.com/kthelp/index.php?title=Text_SetColor_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E9%A2%9C%E8%89%B2&oldid=2144”


Text_SetFontName 设置文本字体

函数 | Text_SetFontName
别名 | 设置文本字体
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置文本字体
用法 | Text_SetFontName(ID,'FontName') 设置标识号为ID的文本对象的字体，由'FontName'指定 成功返回0，对象无效返回-2 例如： Value1:=Text_SetFontName(2,'楷体'); 设置标识号为2的文本对象的字体为楷体 当字体设置为”Wingdings“时，可以有多种小图标，这样就可以用Text_***函数代替Arw_***类函数了
来自“http://www.hs633.com/kthelp/index.php?title=Text_SetFontName_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E5%AD%97%E4%BD%93&oldid=2151”


Text_SetLocation 设置文本位置

函数 | Text_SetLocation
别名 | 设置文本位置
所属类别 | 新画线函数
参数数量 | 5
运行模式 | 逐根
说明 | 设置文本位置
用法 | Text_SetLocation(ID, BarDate, BarTime, PriceValue) 将标识号为ID的文本对象移到指定位置并显示，成功返回0，对象无效返回-2 参数： BarDate: 定位日期，格式为YYYMMDD BarTime: 定位时间，格式为HHMMSS PriceValue: 数值坐标位置 例如： Value1=Text_SetLocation(2,Date,Time,High); 将标识号为2的文本对象移到当前周期最高价处
来自“http://www.hs633.com/kthelp/index.php?title=Text_SetLocation_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E4%BD%8D%E7%BD%AE&oldid=2133”


Text_SetSize 设置文本字体大小

函数 | Text_SetSize
别名 | 设置文本字体大小
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置文本字体大小
用法 | Text_SetSize(ID,FontSize) 设置标识号为ID的文本对象的字体大小，由FontSize指定 成功返回0，对象无效返回-2 例如： Value1:=Text_SetSize(2,18); 设置标识号为2的文本对象的字体大小为18
来自“http://www.hs633.com/kthelp/index.php?title=Text_SetSize_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E5%AD%97%E4%BD%93%E5%A4%A7%E5%B0%8F&oldid=2149”


Text_SetString 设置文本字串或符号

函数 | TEXT_SETSTRING
别名 | 设置文本字串或符号
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置文本字串或符号
用法 | Text_SetString(ID,Express) 设置标识号为ID的对象为字符串或者符号索引，成功返回0，对象无效返回-2 例如： Text_SetString(2,'N字高点'); 将标识号为2的对象替换为的字符串'N字高点' Text_SetFontName(2, 'symbols'); //将标识号为2的对象设为符号 Text_SetString(2, 211); // 将标识号为2的对象替换为符号索引 211 查看符号索引代码
来自“http://www.hs633.com/kthelp/index.php?title=TEXT_SETSTRING_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E5%AD%97%E4%B8%B2%E6%88%96%E7%AC%A6%E5%8F%B7&oldid=2131”


Text_SetStyle 设置文本对齐

函数 | Text_SetStyle
别名 | 设置文本对齐
所属类别 | 新画线函数
参数数量 | 3
运行模式 | 逐根
说明 | 设置文本对齐
用法 Text_SetStyle(ID, HP, VP)

设置标识号为ID的文本对象与定位点的水平和垂直的对齐方式

HP：水平对齐方式，取值范围

0 - 左对齐

1 - 右对齐

2 - 中间对齐

VP：垂直对齐方式，取值范围

0 - 上对齐

1 - 下对齐

2 - 中间对齐

成功返回0，对象无效返回-2

例如：

Value1:=TL_SetAttribute(2,2,2);

使标识号为2的文本对象的水平垂直都与定位点中间对齐，其中心位于定位点处

来自“http://www.hs633.com/kthelp/index.php?title=Text_SetStyle_%E8%AE%BE%E7%BD%AE%E6%96%87%E6%9C%AC%E5%AF%B9%E9%BD%90&oldid=2140”


Text-GetFontName 文本字体

Text_GetFontName 文本字体

函数 | Text-GetFontName
别名 | 文本字体
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 文本字体
用法 | Text_GetFontName(ID) 返回标识号为ID的文本对象的字体名称，返回类型为字符串
来自“http://www.hs633.com/kthelp/index.php?title=Text-GetFontName_%E6%96%87%E6%9C%AC%E5%AD%97%E4%BD%93&oldid=2150”


Tl_Delete 删除趋势线

函数 | Tl_Delete
别名 | 删除趋势线
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 删除趋势线
用法 | TL_Delete(TL_ID) 删除标识号为TL_ID的趋势线，成功返回0，趋势线无效返回-2 例如： Value1:=TL_Delete(3); 删除标识号为3的趋势线
来自“http://www.hs633.com/kthelp/index.php?title=Tl_Delete_%E5%88%A0%E9%99%A4%E8%B6%8B%E5%8A%BF%E7%BA%BF&oldid=2107”


Tl GetActive 选中趋势线

函数 | Tl_GetActive
别名 | 选中趋势线
所属类别 | 新画线函数
参数数量 |
运行模式 | 逐根
说明 | 选中趋势线
用法 | TL_GetActive 返回当前选中的趋势线的标识号，返回-1表示无选中的趋势线 例如： Value1:=TL_GetActive; 当前激活的趋势线的标识号赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetActive_%E9%80%89%E4%B8%AD%E8%B6%8B%E5%8A%BF%E7%BA%BF&oldid=2115”


Tl_GetAlert 趋势线预警

函数 | Tl_GetAlert
别名 | 趋势线预警
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 趋势线预警
用法 | TL_GetAlert(TL_ID) 返回标识号为TL_ID的趋势线的预警状态，趋势线无效返回-2 返回值： 0 - 不预警 1 - 周期内突破：最高价上穿或最低价下穿趋势线触发 2 - 收盘价突破：前一周期与本周期收盘价连线与趋势线发生交叉时触发 例如： Value1:=TL_GetAlert(3); 将标识号为3的趋势线的预警状态赋值给Value1变量
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetAlert_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E9%A2%84%E8%AD%A6&oldid=2118”


Tl_GetBeginDate 趋势线起点日期

函数 | Tl_GetBeginDate
别名 | 趋势线起点日期
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线起点日期
用法 | TL_GetBeginDate(TL_ID) 返回标识号为TL_ID的趋势线的起点日期，格式为YYYMMDD，趋势线无效返回-2 对于趋势线的两个点，时间较晚的点作为终点，对于相同时间的垂直线，数值较高的点作为终点 例如： Value1:=TL_GetBeginDate(3); 将标识号为3的趋势线的起点日期赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetBeginDate_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E8%B5%B7%E7%82%B9%E6%97%A5%E6%9C%9F&oldid=2110”


Tl_GetBeginTime 趋势线起点时间

函数 | Tl_GetBeginTime
别名 | 趋势线起点时间
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 趋势线起点时间
用法 | TL_GetBeginTime(TL_ID) 返回标识号为TL_ID的趋势线的起点时间，格式为HHMMSS，趋势线无效返回-2 对于趋势线的两个点，时间较晚的点作为终点，对于相同时间的垂直线，数值较高的点作为终点 例如： Value1:=TL_GetBeginTime(3); 将标识号为3的趋势线的起点时间赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetBeginTime_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E8%B5%B7%E7%82%B9%E6%97%B6%E9%97%B4&oldid=1504”


Tl_GetBeginVal 趋势线起点数值

函数 | Tl_GetBeginVal
别名 | 趋势线起点数值
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线起点数值
用法 | TL_GetBeginVal(TL_ID) 返回标识号为TL_ID的趋势线的起点数值，趋势线无效返回-2 对于趋势线的两个点，时间较晚的点作为终点，对于相同时间的垂直线，数值较高的点作为终点 例如： Value1:=TL_GetBeginVal(3); 将标识号为3的趋势线的起点数值赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetBeginVal_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E8%B5%B7%E7%82%B9%E6%95%B0%E5%80%BC&oldid=2111”


Tl_GetColor 趋势线颜色

函数 | Tl_GetColor
别名 | 趋势线颜色
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线颜色
用法 | TL_GetColor(TL_ID) 返回标识号为TL_ID的趋势线的RGB颜色值，趋势线无效返回-2
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetColor_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E9%A2%9C%E8%89%B2&oldid=2128”


Tl_GetEndDate 趋势线终点日期

函数 | Tl_GetEndDate
别名 | 趋势线终点日期
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线终点日期
用法 | TL_GetEndDate(TL_ID) 返回标识号为TL_ID的趋势线的终点日期，格式为YYYMMDD，趋势线无效返回-2 对于趋势线的两个点，时间较晚的点作为终点，对于相同时间的垂直线，数值较高的点作为终点 例如： Value1:=TL_GetEndDate(3); 将标识号为3的趋势线的终点日期赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetEndDate_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BB%88%E7%82%B9%E6%97%A5%E6%9C%9F&oldid=2112”


Tl_GetEndTime 趋势线终点时间

函数 | Tl_GetEndTime
别名 | 趋势线终点时间
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线终点时间
用法 | TL_GetEndTime(TL_ID) 返回标识号为TL_ID的趋势线的终点时间，格式为HHMMSS，趋势线无效返回-2 对于趋势线的两个点，时间较晚的点作为终点，对于相同时间的垂直线，数值较高的点作为终点 例如： Value1:=TL_GetEndTime(3); 将标识号为3的趋势线的终点时间赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetEndTime_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BB%88%E7%82%B9%E6%97%B6%E9%97%B4&oldid=2113”


Tl_GetEndVal 趋势线终点数值

函数 | Tl_GetEndVal
别名 | 趋势线终点数值
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 趋势线终点数值
用法 | TL_GetEndVal(TL_ID) 返回标识号为TL_ID的趋势线的终点数值，趋势线无效返回-2 对于趋势线的两个点，时间较晚的点作为终点，对于相同时间的垂直线，数值较高的点作为终点 例如： Value1:=TL_GetEndVal(3); 将标识号为3的趋势线的终点数值赋值给Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetEndVal_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BB%88%E7%82%B9%E6%95%B0%E5%80%BC&oldid=1508”


Tl_GetExtLeft 趋势线左延长

函数 | Tl_GetExtLeft
别名 | 趋势线左延长
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线左延长
用法 | TL_GetExtLeft(TL_ID) 返回标识号为TL_ID的趋势线是否向左延长，向左延长则返回True(1)，否则返回False(0)，趋势线无效返回False(0)
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetExtLeft_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E5%B7%A6%E5%BB%B6%E9%95%BF&oldid=2120”


Tl_GetExtRight 趋势线右延长

函数 | Tl_GetExtRight
别名 | 趋势线右延长
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线右延长
用法 | TL_GetExtLeft(TL_ID) 返回标识号为TL_ID的趋势线是否向右延长，向右延长则返回True(1)，否则返回False(0)，趋势线无效返回False(0)
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetExtRight_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E5%8F%B3%E5%BB%B6%E9%95%BF&oldid=2122”


Tl_GetFirst 第一条趋势线

函数 | Tl_GetFirst
别名 | 第一条趋势线
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 第一条趋势线
用法 | TL_GetFirst (Origin=1) 返回指定范围的最早绘制的第1条趋势线的标识号，趋势线无效返回-2 参数： Origin取值范围： 1 - 当前公式绘制的 2 - 其它公式或手工绘制的 3 - 所有的 4 - 当前公式或手工绘制的 5 - 其它公式绘制的 6 - 所有公式绘制的 7 - 手工绘制的 例如： Value1:=TL_GetFirst; 将当前公式最早绘制的趋势线的标识号赋给变量Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetFirst_%E7%AC%AC%E4%B8%80%E6%9D%A1%E8%B6%8B%E5%8A%BF%E7%BA%BF&oldid=2116”


Tl_GetNext 下一条趋势线

函数 | Tl_GetNext
别名 | 下一条趋势线
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 下一条趋势线
用法 | TL_GetNext (TL_ID,Origin=1) 返回指定范围的标识号为TL_ID的趋势线的下一个绘制的趋势线的标识号，趋势线无效返回-2 参数： Origin取值范围： 1 - 当前公式绘制的 2 - 其它公式或手工绘制的 3 - 所有的 4 - 当前公式或手工绘制的 5 - 其它公式绘制的 6 - 所有公式绘制的 7 - 手工绘制的 例如： Value1:=TL_GetNext(2,1); 将当前公式绘制的标识号为2的趋势线的下一个趋势线的标识号赋给变量Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetNext_%E4%B8%8B%E4%B8%80%E6%9D%A1%E8%B6%8B%E5%8A%BF%E7%BA%BF&oldid=2117”


Tl_GetSize 趋势线线宽

函数 | Tl_GetSize
别名 | 趋势线线宽
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线线宽
用法 | TL_GetSize(TL_ID) 返回标识号为TL_ID的趋势线的线宽，趋势线无效返回-2
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetSize_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BA%BF%E5%AE%BD&oldid=2124”


Tl_GetStyle 趋势线线型

函数 | Tl_GetStyle
别名 | 趋势线线型
所属类别 | 新画线函数
参数数量 | 1
运行模式 | 逐根
说明 | 趋势线线型
用法 | TL_GetStyle(TL_ID) 返回标识号为TL_ID的趋势线的线型，趋势线无效返回-2
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetStyle_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BA%BF%E5%9E%8B&oldid=2126”


Tl_GetValue 趋势线时点数值

函数 | Tl_GetValue
别名 | 趋势线时点数值
所属类别 | 新画线函数
参数数量 | 3
运行模式 | 逐根
说明 | 趋势线时点数值
用法 | TL_GetValue (TL_ID, Date, Time) 返回标识号为TL_ID的趋势线的指定日期为Date、时间为Time时的数值，趋势线无效返回-2 返回值位于趋势线两端点之间以及其左右延长线上。 例如： Value1:=TL_GetValue(3,1120813,1000); 将标识号为3的趋势线在2012年8月13日10:00时的数值赋给变量Value1
来自“http://www.hs633.com/kthelp/index.php?title=Tl_GetValue_%E8%B6%8B%E5%8A%BF%E7%BA%BF%E6%97%B6%E7%82%B9%E6%95%B0%E5%80%BC&oldid=2114”


Tl_New 新建趋势线

函数 | Tl_New
别名 | 新建趋势线
所属类别 | 新画线函数
参数数量 | 6
运行模式 | 逐根
说明 | 新建趋势线
用法 | TL_New (sDate, sTime, sPriceValue, eDate, eTime, ePriceValue) 参数： sDate: 起点日期，格式为YYYMMDD sTime: 起点时间，格式为HHMMSS sPriceValue: 起点数值 eDate: 终点日期 eTime: 终点时间 ePriceValue: 终点数值 返回所创建趋势线的唯一数字标识号，从0开始计数，用于将来的读取与设置。 例如： TL_ID1:=TL_New(1120813,90000,2310,1120818,140000,2380); 绘制1条趋势线，起点位于2012年8月13日9:00时的2310处，终点位于2012年8月18日14:00时的2380处 如果因日期非法或其他原因画线创建失败，则函数返回-2
来自“http://www.hs633.com/kthelp/index.php?title=Tl_New_%E6%96%B0%E5%BB%BA%E8%B6%8B%E5%8A%BF%E7%BA%BF&oldid=2106”


Tl_SetAlert 设置趋势线预警

函数 | Tl_SetAlert
别名 | 设置趋势线预警
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置趋势线预警
用法 | TL_SetAlert(TL_ID,AlertStatus) 设置标识号为TL_ID的趋势线的预警状态，成功返回0，趋势线无效返回-2 AlertStatus取值范围 0 - 不预警 1 - 周期内突破：最高价上穿或最低价下穿趋势线触发 2 - 收盘价突破：前一周期与本周期收盘价连线与趋势线发生交叉时触发 例如： Value1:=TL_SetAlert(3,2); 设置标识号为3的趋势线的预警状态为“收盘价突破”
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetAlert_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E9%A2%84%E8%AD%A6&oldid=2119”


Tl_SetBegin 设置趋势线起点

函数 | Tl_SetBegin
别名 | 设置趋势线起点
所属类别 | 新画线函数
参数数量 | 4
运行模式 | 逐根
说明 | 设置趋势线起点
用法 | TL_SetBegin(TL_ID, sDate, sTime, sPriceValue) 设置标识号为TL_ID的趋势线的起点，成功返回0，趋势线无效返回-2 对于趋势线的两个点，时间较早的点作为起点，对于相同时间的垂直线，数值较低的点作为起点 参数说明参见TL_New函数 例如： Value1:=TL_SetBegin(3,1120813,90000,2310); 将标识号为3的趋势线的起点移到2012年8月13日9:00时的2310处
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetBegin_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E8%B5%B7%E7%82%B9&oldid=2108”


Tl_SetColor 设置趋势线颜色

函数 | Tl_SetColor
别名 | 设置趋势线颜色
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置趋势线颜色
用法 | TL_SetColor(TL_ID,TL_Color) 设置标识号为TL_ID的趋势线的颜色，TL_Color为RGB颜色值 成功返回0，趋势线无效返回-2 例如： Value1:=TL_SetColor(2,Blue); 设置标识号为2的趋势线为蓝色
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetColor_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E9%A2%9C%E8%89%B2&oldid=2129”


Tl_SetEnd 设置趋势线终点

函数 | Tl_SetEnd
别名 | 设置趋势线终点
所属类别 | 新画线函数
参数数量 | 4
运行模式 | 逐根
说明 | 设置趋势线终点
用法 | TL_SetEnd(TL_ID, eDate, eTime, ePriceValue) 设置标识号为TL_ID的趋势线的终点，成功返回0，趋势线无效返回-2 对于趋势线的两个点，时间较晚的点作为终点，对于相同时间的垂直线，数值较高的点作为终点 参数说明参见TL_New函数 例如： Value1:=TL_SetEnd(3,1120818,140000,2380); 将标识号为3的趋势线的终点移到2012年8月18日14:00时的2380处
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetEnd_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BB%88%E7%82%B9&oldid=2109”


Tl_SetExtLeft 设置趋势线左延长

函数 | Tl_SetExtLeft
别名 | 设置趋势线左延长
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置趋势线左延长
用法 | TL_SetExtLeft(TL_ID,L=True) 设置标识号为TL_ID的趋势线是否向左延长，L为True或1，向左延长；L为False或0，移去左延长线 成功返回0，趋势线无效返回-2 例如： Value1:=TL_SetExtLeft(2,True); 使标识号为2的趋势线向左延长 Value1:=TL_SetExtLeft(1,False); 使标识号为1的趋势线取消左延长，移去左延长线
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetExtLeft_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E5%B7%A6%E5%BB%B6%E9%95%BF&oldid=2121”


Tl_SetExtRight 设置趋势线右延长

函数 | Tl_SetExtRight
别名 | 设置趋势线右延长
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置趋势线右延长
用法 | TL_SetExtLeft(TL_ID,L=True) 设置标识号为TL_ID的趋势线是否向右延长，L为True或1，向右延长；L为False或0，移去右延长线 成功返回0，趋势线无效返回-2 例如： Value1:=TL_SetExtLeft(2,True); 使标识号为2的趋势线向右延长 Value1:=TL_SetExtLeft(1,False); 使标识号为1的趋势线取消右延长，移去右延长线
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetExtRight_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E5%8F%B3%E5%BB%B6%E9%95%BF&oldid=2123”


Tl_SetSize 设置趋势线线宽

函数 | Tl_SetSize
别名 | 设置趋势线线宽
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置趋势线线宽
用法 | TL_SetSize(TL_ID,LineWidth=1) 设置标识号为TL_ID的趋势线的线宽,线宽LineWidth取值范围从0到6 成功返回0，趋势线无效返回-2 例如： Value1:=TL_SetSize(2,5); 设置标识号为2的趋势线宽为5
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetSize_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BA%BF%E5%AE%BD&oldid=2125”


Tl_SetStyle 设置趋势线线型

函数 | Tl_SetStyle
别名 | 设置趋势线线型
所属类别 | 新画线函数
参数数量 | 2
运行模式 | 逐根
说明 | 设置趋势线线型
用法 | TL_SetStyle(TL_ID,TL_Style) 设置标识号为TL_ID的趋势线的线型 成功返回0，趋势线无效返回-2 TL_Style: 1 Tool_Solid 实线 ____________________ 2 Tool_Dashed 虚线 - - - - - - - - - - 3 Tool_Dotted 点线 .................... 4 Tool_Dashed2 长短虚线 __ _ __ _ __ _ __ _ 5 Tool_Dashed3 长短短虚线 ___ _ _ ___ _ _ ___ 例如： Value1:=TL_SetStyle(3, 2); 设置标识号为3的趋势线为虚线 Value1:=TL_SetStyle(2, Tool_Dashed); 设置标识号为2的趋势线为虚线
来自“http://www.hs633.com/kthelp/index.php?title=Tl_SetStyle_%E8%AE%BE%E7%BD%AE%E8%B6%8B%E5%8A%BF%E7%BA%BF%E7%BA%BF%E5%9E%8B&oldid=2127”


ADVANCE 上涨家数

函数 | Advance
别名 | 上涨家数
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期市场上涨家数。(本函数仅对大盘指数有效)
用法 | ADVANCE

例子：

1,求历史上海，深圳2市上涨家数

上涨数:Invalid,NoDrawInvalid;
if (StkLabel=='000001' and MarketLabel=='SH')
  or (StkLabel=='399001' and MarketLabel=='SZ') then
  上涨数:ADVANCE;
{
 1,advance函数只对2个大盘指数才起作用
 2,为什么不能写
   上涨家数:ADVANCE;
 因为金语言支持中文编程，上涨家数其实和ADVANCE表达的意思一样
};
来自“http://www.hs633.com/kthelp/index.php?title=ADVANCE_%E4%B8%8A%E6%B6%A8%E5%AE%B6%E6%95%B0&oldid=838”


AMOUNT 成交额

函数 | Amount
别名 | 成交额
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期成交额。
用法 | AMOUNT
来自“http://www.hs633.com/kthelp/index.php?title=AMOUNT_%E6%88%90%E4%BA%A4%E9%A2%9D&oldid=855”


AMOUNTD N天前成交额

函数 | AmountD
别名 | N天前成交额
所属类别 | 行情函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得该周期N天前成交额。
用法 | AMOUNTD AmountD(3,'sz000659') 取得3天前的成交额，N为0当天，1昨天，依此类推
来自“http://www.hs633.com/kthelp/index.php?title=AMOUNTD_N%E5%A4%A9%E5%89%8D%E6%88%90%E4%BA%A4%E9%A2%9D&oldid=893”


ASKPRICE 委卖价

函数 | AskPrice
别名 | 委卖价
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得委卖1-委卖3价格。
用法 | ASKPRICE(N),N取1--3 (本函数仅个股在分笔成交分析周期有效)
来自“http://www.hs633.com/kthelp/index.php?title=ASKPRICE_%E5%A7%94%E5%8D%96%E4%BB%B7&oldid=863”


ASKVOL 委卖量

函数 | AskVol
别名 | 委卖量
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得委卖1-委卖3量。
用法 | ASKVOL(N),N取1--3 (本函数仅个股在分笔成交分析周期有效)
来自“http://www.hs633.com/kthelp/index.php?title=ASKVOL_%E5%A7%94%E5%8D%96%E9%87%8F&oldid=864”


BIDPRICE 委买价

函数 | BidPrice
别名 | 委买价
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得委买1-委买3价格。
用法 | BIDPRICE(N),N取1--3 (本函数仅个股在分笔成交分析周期有效)
来自“http://www.hs633.com/kthelp/index.php?title=BIDPRICE_%E5%A7%94%E4%B9%B0%E4%BB%B7&oldid=865”


BIDVOL 委买量

函数 | BidVol
别名 | 委买量
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得委买1-委买3量。
用法 | BIDVOL(N),N取1--3 (本函数仅个股在分笔成交分析周期有效)
来自“http://www.hs633.com/kthelp/index.php?title=BIDVOL_%E5%A7%94%E4%B9%B0%E9%87%8F&oldid=867”


BUYVOL 主动性买单

函数 | BuyVol
别名 | 主动性买单
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得主动性买单量。
用法 | BUYVOL,当本笔成交为主动性买盘时,其数值为该笔成交量, 否则为0 (本函数仅个股在分笔成交分析周期有效)
来自“http://www.hs633.com/kthelp/index.php?title=BUYVOL_%E4%B8%BB%E5%8A%A8%E6%80%A7%E4%B9%B0%E5%8D%95&oldid=868”


C 收盘价

函数 | c
别名 | 收盘价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期收盘价。
用法 | CLOSE
来自“http://www.hs633.com/kthelp/index.php?title=C_%E6%94%B6%E7%9B%98%E4%BB%B7&oldid=870”


CLOSE C, 收盘价

函数 | Close
别名 | C, 收盘价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期收盘价。
用法 | CLOSE
来自“http://www.hs633.com/kthelp/index.php?title=CLOSE_C,_%E6%94%B6%E7%9B%98%E4%BB%B7&oldid=869”


CLOSED N天前收盘价

函数 | CloseD
别名 | N天前收盘价
所属类别 | 行情函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得该周期N天前收盘价。
用法 | CLOSED CloseD(3,'sz000659') 取得3天前的收盘价，N为0当天，1昨天，依此类推
来自“http://www.hs633.com/kthelp/index.php?title=CLOSED_N%E5%A4%A9%E5%89%8D%E6%94%B6%E7%9B%98%E4%BB%B7&oldid=891”


DATA2 数据2

函数 | Data2
别名 | 数据2
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 引用另一个品种的行情数据。
用法 | DATA2.OPEN, DATA2.HIGH, DATA2.LOW, DATA2.CLOSE, DATA2.VOL, DATA2.AMOUNT 从DATA2到DATA10可引用其他9只品种的行情数据 表示另一只品种的开、高、低、收、量额; 例如: RELATE(C, DATA2.CLOSE, 10); 对于指标图表示计算与主图叠加的品种的收盘价10周期相关系数
来自“http://www.hs633.com/kthelp/index.php?title=DATA2_%E6%95%B0%E6%8D%AE2&oldid=871”


DECLINE 下跌家数

函数 | DecLine
别名 | 下跌家数
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期市场下跌家数。(本函数仅对大盘指数有效)
用法 | DECLINE
来自“http://www.hs633.com/kthelp/index.php?title=DECLINE_%E4%B8%8B%E8%B7%8C%E5%AE%B6%E6%95%B0&oldid=872”


DIVIDBARS 派息发生周期数

函数 | DividBars
别名 | 派息发生周期数
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 派息到现在的周期数。
用法 | DIVIDBARS(N), 取得之前第N次派息到当前的周期数 例如: DIVIDBARS(0)=0表示当天发生派息
来自“http://www.hs633.com/kthelp/index.php?title=DIVIDBARS_%E6%B4%BE%E6%81%AF%E5%8F%91%E7%94%9F%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=873”


DIVIDEND 派息

函数 | DividEnd
别名 | 派息
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 每股派息数量。
用法 | DIVIDEND(N),取得之前第N次每股派息数量 例如: DIVIDEND(0)表示最近一次派息的数量
来自“http://www.hs633.com/kthelp/index.php?title=DIVIDEND_%E6%B4%BE%E6%81%AF&oldid=874”


H 最高价

函数 | h
别名 | 最高价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期最高价。
用法 | HIGH
来自“http://www.hs633.com/kthelp/index.php?title=H_%E6%9C%80%E9%AB%98%E4%BB%B7&oldid=876”


HIGH H, 最高价

函数 | High
别名 | H, 最高价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期最高价。
用法 | HIGH
来自“http://www.hs633.com/kthelp/index.php?title=HIGH_H,_%E6%9C%80%E9%AB%98%E4%BB%B7&oldid=875”


HIGHD N天前最高价

函数 | HighD
别名 | N天前最高价
所属类别 | 行情函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得该周期N天前最高价。
用法 | HIGHD HighD(3,'sz000659') 取得3天前的最高价，N为0当天，1昨天，依此类推
来自“http://www.hs633.com/kthelp/index.php?title=HIGHD_N%E5%A4%A9%E5%89%8D%E6%9C%80%E9%AB%98%E4%BB%B7&oldid=889”


INDEXA 对应大盘成交额

函数 | IndexA
别名 | 对应大盘成交额
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应大盘指数成交额。
用法 | INDEXA,表示同期大盘的成交额
来自“http://www.hs633.com/kthelp/index.php?title=INDEXA_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E6%88%90%E4%BA%A4%E9%A2%9D&oldid=877”


INDEXADV 对应大盘上涨家数

函数 | IndexAdv
别名 | 对应大盘上涨家数
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应市场上涨家数。
用法 | INDEXADV,表示同期对应市场的上涨家数
来自“http://www.hs633.com/kthelp/index.php?title=INDEXADV_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E4%B8%8A%E6%B6%A8%E5%AE%B6%E6%95%B0&oldid=879”


INDEXC 对应大盘收盘价

函数 | IndexC
别名 | 对应大盘收盘价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应大盘指数收盘价。
用法 | INDEXC,表示同期大盘的收盘价
来自“http://www.hs633.com/kthelp/index.php?title=INDEXC_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E6%94%B6%E7%9B%98%E4%BB%B7&oldid=880”


INDEXDEC 对应大盘下跌家数

函数 | IndexDec
别名 | 对应大盘下跌家数
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应市场下跌家数。
用法 | INDEXDEC,表示同期对应市场的下跌家数
来自“http://www.hs633.com/kthelp/index.php?title=INDEXDEC_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E4%B8%8B%E8%B7%8C%E5%AE%B6%E6%95%B0&oldid=881”


INDEXH 对应大盘最高价

函数 | IndexH
别名 | 对应大盘最高价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应大盘指数最高价。
用法 | INDEXH,表示同期大盘的最高价
来自“http://www.hs633.com/kthelp/index.php?title=INDEXH_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E6%9C%80%E9%AB%98%E4%BB%B7&oldid=882”


INDEXL 对应大盘最低价

函数 | IndexL
别名 | 对应大盘最低价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应大盘指数最低价。
用法 | INDEXL,表示同期大盘的最低价
来自“http://www.hs633.com/kthelp/index.php?title=INDEXL_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E6%9C%80%E4%BD%8E%E4%BB%B7&oldid=883”


INDEXO 对应大盘开盘价

函数 | IndexO
别名 | 对应大盘开盘价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应大盘指数开盘价。
用法 | INDEXO,表示同期大盘的开盘价
来自“http://www.hs633.com/kthelp/index.php?title=INDEXO_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E5%BC%80%E7%9B%98%E4%BB%B7&oldid=884”


INDEXV 对应大盘成交量

函数 | IndexV
别名 | 对应大盘成交量
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 对应大盘指数成交量。
用法 | INDEXV,表示同期大盘的成交量
来自“http://www.hs633.com/kthelp/index.php?title=INDEXV_%E5%AF%B9%E5%BA%94%E5%A4%A7%E7%9B%98%E6%88%90%E4%BA%A4%E9%87%8F&oldid=885”


ISBUYORDER 是否主动性买单

函数 | IsBuyOrder
别名 | 是否主动性买单
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该成交是否为主动性买单。
用法 | ISBUYORDER 当本笔成交为主动性买盘时,返回1,否则为0 (本函数仅个股在分笔成交分析周期有效)
来自“http://www.hs633.com/kthelp/index.php?title=ISBUYORDER_%E6%98%AF%E5%90%A6%E4%B8%BB%E5%8A%A8%E6%80%A7%E4%B9%B0%E5%8D%95&oldid=886”


KONGPAN 空盘家数

函数 | KongPan
别名 | 空盘家数
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得对应市场空盘家数。
用法 | KONGPAN
来自“http://www.hs633.com/kthelp/index.php?title=KONGPAN_%E7%A9%BA%E7%9B%98%E5%AE%B6%E6%95%B0&oldid=887”


L 最低价

函数 | l
别名 | 最低价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期最低价。
用法 | LOW
来自“http://www.hs633.com/kthelp/index.php?title=L_%E6%9C%80%E4%BD%8E%E4%BB%B7&oldid=899”


LOW L, 最低价

函数 | Low
别名 | L, 最低价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期最低价。
用法 | LOW
来自“http://www.hs633.com/kthelp/index.php?title=LOW_L,_%E6%9C%80%E4%BD%8E%E4%BB%B7&oldid=898”


LOWD N天前最低价

函数 | LowD
别名 | N天前最低价
所属类别 | 行情函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得该周期N天前最低价。
用法 | LOWD LowD(3,'sz000659') 取得3天前的最低价，N为0当天，1昨天，依此类推
来自“http://www.hs633.com/kthelp/index.php?title=LOWD_N%E5%A4%A9%E5%89%8D%E6%9C%80%E4%BD%8E%E4%BB%B7&oldid=890”


O 开盘价

函数 | o
别名 | 开盘价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期开盘价。
用法 | OPEN
来自“http://www.hs633.com/kthelp/index.php?title=O_%E5%BC%80%E7%9B%98%E4%BB%B7&oldid=901”


OPEN O, 开盘价

函数 | Open
别名 | O, 开盘价
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期开盘价。
用法 | OPEN
来自“http://www.hs633.com/kthelp/index.php?title=OPEN_O,_%E5%BC%80%E7%9B%98%E4%BB%B7&oldid=900”


OPEND N天前开盘价

函数 | OpenD
别名 | N天前开盘价
所属类别 | 行情函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得该周期N天前开盘价。
用法 | OPEND OpenD(3,'sz000659') 取得3天前的开盘价，N为0当天，1昨天，依此类推
来自“http://www.hs633.com/kthelp/index.php?title=OPEND_N%E5%A4%A9%E5%89%8D%E5%BC%80%E7%9B%98%E4%BB%B7&oldid=888”


OPENINT 持仓量

函数 | OpenInt
别名 | 持仓量
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得期货品种该周期最后时刻持仓量。
用法 | OPENINT
来自“http://www.hs633.com/kthelp/index.php?title=OPENINT_%E6%8C%81%E4%BB%93%E9%87%8F&oldid=902”


OPENINTD N天前持仓量

函数 | OpenIntD
别名 | N天前持仓量
所属类别 | 行情函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得该周期N天前持仓量。
用法 | OPENINTD OpenIntD(3,'SQcu01') 取得3天前的持仓量，N为0当天，1昨天，依此类推
来自“http://www.hs633.com/kthelp/index.php?title=OPENINTD_N%E5%A4%A9%E5%89%8D%E6%8C%81%E4%BB%93%E9%87%8F&oldid=895”


PINGPAN 平盘家数

函数 | PingPan
别名 | 平盘家数
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得对应市场平盘家数。
用法 | PINGPAN
来自“http://www.hs633.com/kthelp/index.php?title=PINGPAN_%E5%B9%B3%E7%9B%98%E5%AE%B6%E6%95%B0&oldid=903”


QT 分笔数量

函数 | QT
别名 | 分笔数量
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期成交分笔。
用法 | QT
来自“http://www.hs633.com/kthelp/index.php?title=QT_%E5%88%86%E7%AC%94%E6%95%B0%E9%87%8F&oldid=904”


SELLVOL 无

函数 | SellVol
别名 | 无
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得主动性卖单量。
用法 | SELLVOL 当本笔成交为主动性卖盘时,其数值为该笔成交量,否则为0 (本函数仅个股在分笔成交分析周期有效)
来自“http://www.hs633.com/kthelp/index.php?title=SELLVOL_%E6%97%A0&oldid=905”


SPLIT 除权比例

函数 | Split
别名 | 除权比例
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 除权比例
用法 | SPLIT(N),取得之前第N次除权(送股或配股)的除权比例， 表示除权后股价将下跌该比例 例如: SPLIT(0)=0.5表示最近一次除权可能是10送10，股价下跌一半
来自“http://www.hs633.com/kthelp/index.php?title=SPLIT_%E9%99%A4%E6%9D%83%E6%AF%94%E4%BE%8B&oldid=906”


SPLITBARS 除权发生周期数

函数 | SplitBars
别名 | 除权发生周期数
所属类别 | 行情函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 除权到现在的周期数
用法 | SPLITBARS(N),取得之前第N次除权到当前的周期数 例如: SPLITBARS(0)=0表示当天发生除权
来自“http://www.hs633.com/kthelp/index.php?title=SPLITBARS_%E9%99%A4%E6%9D%83%E5%8F%91%E7%94%9F%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=907”


SPLITDATA 除权数据

函数 | SplitData
别名 | 除权数据
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 除权函数
用法 | SPLITDATA(N) 取得对应除权数据 N参数表示取那种分红数据 N=0 有除权时为1，否则为0 N=1 红股，得到当时每十股送几股 N=2 配股，得到当时每十股配几股 N=3 认购价，得到当时认购价格 N=4 红利，得到当时每十股派息几元 N=6 取得主连复权的价差 N=7 取得日间复权的价差
来自“http://www.hs633.com/kthelp/index.php?title=SPLITDATA_%E9%99%A4%E6%9D%83%E6%95%B0%E6%8D%AE&oldid=908”


V 成交量

函数 | v
别名 | 成交量
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期成交量。
用法 | v,VOL,volume
来自“http://www.hs633.com/kthelp/index.php?title=V_%E6%88%90%E4%BA%A4%E9%87%8F&oldid=910”


VOL 成交量

函数 | Vol
别名 | 成交量
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期成交量。单位为股。
用法 | v,VOL,volume
来自“http://www.hs633.com/kthelp/index.php?title=VOL_%E6%88%90%E4%BA%A4%E9%87%8F&oldid=909”


VOLDN 天前成交

函数 | VolD
别名 | N天前成交量
所属类别 | 行情函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得该周期N天前成交量。
用法 | VOLD VolD(3,'sz000659') 取得3天前的成交量，N为0当天，1昨天，依此类推
来自“http://www.hs633.com/kthelp/index.php?title=VOLDN_%E5%A4%A9%E5%89%8D%E6%88%90%E4%BA%A4&oldid=892”


VOLUME 成交量

函数 | Volume
别名 | 成交量
所属类别 | 行情函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得该周期成交量。
用法 | v,VOL,volume
来自“http://www.hs633.com/kthelp/index.php?title=VOLUME_%E6%88%90%E4%BA%A4%E9%87%8F&oldid=911”


Dzgx 地支关系

函数 | Dzgx
别名 | 地支关系
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得地支间的关系。
用法 | DZGX(DZ1, DZ2) DZ1, DZ2为地支代码的数组或常数，有效值范围为(0-11) 函数返回地支关系代码，有效值范围为(0-5)依次表示： 无关(0)、DZ1生DZ2(1)、DZ1克DZ2(2)、相冲(3)、相害(4)、DZ1刑DZ2(5)
来自“http://www.hs633.com/kthelp/index.php?title=Dzgx_%E5%9C%B0%E6%94%AF%E5%85%B3%E7%B3%BB&oldid=1352”


Dzxh 地支相合

函数 | Dzxh
别名 | 地支相合
所属类别 | 易理函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 取得地支间的相合关系。
用法 | DZXH(DZ1, DZ2,DZ3, DZ4) DZ1, DZ2, DZ3, DZ4为地支代码的数组或常数，有效值范围为(0-11) 若求六合，则DZ3为-1, DZ4除算申子辰化合成水局外为-1 函数返回合成的五行代码，有效值范围为(-1-4)，-1表示无相合关系
来自“http://www.hs633.com/kthelp/index.php?title=Dzxh_%E5%9C%B0%E6%94%AF%E7%9B%B8%E5%90%88&oldid=1353”


GanZhi 干支

函数 | GanZhi
别名 | 干支
所属类别 | 易理函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 取得时间的年月日时干支代码。
用法 | GANZHI(DATE, TIME, TYPE) TYPE为常数，取0--3，分别表示计算的是年、月、日、时的干支 DATE为数组或常数，有效值范围(年月日80010100-130123123); TIME为数组或常数，有效值范围(时分秒000000-235959) 函数返回有效值范围为(0-59)
来自“http://www.hs633.com/kthelp/index.php?title=GanZhi_%E5%B9%B2%E6%94%AF&oldid=1354”


KGua K线卦象

函数 | KGua
别名 | K线卦象
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得K线卦象代码。
用法 | KGUA(TYPE, N) TYPE表取爻次序，为0表示以第一个周期为初爻，当前周期为上爻，不为0则反之 N为所取的周期数，为0取3个周期，不为0表示取6个周期 函数返回K线卦象代码，若N为0，返回八卦(1-8)，否则返回六十四卦
来自“http://www.hs633.com/kthelp/index.php?title=KGua_K%E7%BA%BF%E5%8D%A6%E8%B1%A1&oldid=1355”


NumberSum 各位数字之和

函数 | NumberSum
别名 | 各位数字之和
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得各位数字之和。
用法 | NUMBERSUM(NUMBER,N) 返回各位数字之和，N为所取的小数位数. NUMBERSUM(CLOSE,2), 则收盘价为9.53时返回17; NUMBERSUM(19000000+DATE,0), 返回年+月+日之和
来自“http://www.hs633.com/kthelp/index.php?title=NumberSum_%E5%90%84%E4%BD%8D%E6%95%B0%E5%AD%97%E4%B9%8B%E5%92%8C&oldid=1356”


WuXing 五行

函数 | WuXing
别名 | 五行
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得天干、地支、八卦对应的五行。
用法 | WUXING(X, TYPE) TYPE为常数，取0--2，分别表示计算的是天干、地支、八卦对应的五行代码,X为对应的代码 函数返回有效值范围为(0-4)
来自“http://www.hs633.com/kthelp/index.php?title=WuXing_%E4%BA%94%E8%A1%8C&oldid=1357”


WxGx 五行关系

函数 | WxGx
别名 | 五行关系
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得五行相生相克的关系。
用法 | WXGX(X1, X2) X1、X2为对应的五行代码 函数返回有效值范围为(0-4),依次表示X1与X2相同、X1无关X2、X1生X2、X1克X2、其余情况
来自“http://www.hs633.com/kthelp/index.php?title=WxGx_%E4%BA%94%E8%A1%8C%E5%85%B3%E7%B3%BB&oldid=1358”


WxLd 五行力度

函数 | WxLd
别名 | 五行力度
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得不同时间的力度（旺相休囚死）对应的五行。
用法 | WXLD( JI, LD) LD为五行四季力度，有效值范围为(4-0)，依次表示旺(4)、相(3)、休(2)、囚(1)、死(0); JI为四季数，有效值范围为(0-4)，依次表示春、夏、秋、冬、四季土 函数返回五行代码(0-4),依次表示金0 水1 木2 火3 土4
来自“http://www.hs633.com/kthelp/index.php?title=WxLd_%E4%BA%94%E8%A1%8C%E5%8A%9B%E5%BA%A6&oldid=1359”


WxSs 五行盛衰

函数 | WxSs
别名 | 五行盛衰
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得地支间的关系。
用法 | WXSS(WX, SS) WX为五行代码的数组或常数，SS五行盛衰十二阶段，有效值范围为(0-11): 依次表示绝、胎、养、长生、沐浴、冠带、临官、帝旺、衰、病、死、墓 函数返回地支代码，0-11分别表示子、丑...亥
来自“http://www.hs633.com/kthelp/index.php?title=WxSs_%E4%BA%94%E8%A1%8C%E7%9B%9B%E8%A1%B0&oldid=1360”


ZqdmNum 品种代码数字

函数 | ZqdmNum
别名 | 品种代码数字
所属类别 | 易理函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得地支间的关系。
用法 | ZQDMNUM 返回品种代码数 如0001返回1，600001返回600001， 带字母的返回0
来自“http://www.hs633.com/kthelp/index.php?title=ZqdmNum_%E5%93%81%E7%A7%8D%E4%BB%A3%E7%A0%81%E6%95%B0%E5%AD%97&oldid=1361”


ZqdmSum 品种代码数之和

函数 | ZqdmSum
别名 | 品种代码数之和
所属类别 | 易理函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取得品种代码数之和。
用法 | ZQDMSUM 返回品种代码数之和 如0001返回1，600205返回13，指数返回3
来自“http://www.hs633.com/kthelp/index.php?title=ZqdmSum_%E5%93%81%E7%A7%8D%E4%BB%A3%E7%A0%81%E6%95%B0%E4%B9%8B%E5%92%8C&oldid=1362”


AdaptiveMovAvg 自适应移动平均

函数 | AdaptiveMovAvg
别名 | 自适应移动平均
所属类别 | 引用函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 自适应移动平均。
用法 AdaptiveMovAvg(X,ER,FL=2,SL=30)

返回指定参数的序列X的自适应移动平均

参数说明

X:需要计算移动平均的序列

ER:用于计算效率系数的周期数

FL:快速平均的周期数

SL:慢速平均的周期数

缺省值FL=2,SL=30为Kaufman在其《精明交易者》中所用的参数

例如：

AdaptiveMovAvg(Close, 10);

计算收盘价的10周期自适应移动平均值。

来自“http://www.hs633.com/kthelp/index.php?title=AdaptiveMovAvg_%E8%87%AA%E9%80%82%E5%BA%94%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87&oldid=1184”


AltFilter 交替信号过滤

函数 | AltFilter
别名 | 交替信号过滤
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 交替过滤连续出现的信号。
用法 | ALTFILTER(X1,X2):用X2交替过滤X1, 在X2信号间不会出现多于1个的连续信号 例如: ENTERLONG:ALTFILTER(BB,SS) 假设BB为原始买入信号(会出现连续买入),SS为卖出信号, 过滤后在SS信号之间最多只有1个买入信号
来自“http://www.hs633.com/kthelp/index.php?title=AltFilter_%E4%BA%A4%E6%9B%BF%E4%BF%A1%E5%8F%B7%E8%BF%87%E6%BB%A4&oldid=1162”


Atr 平均真实波幅

函数 | Atr
别名 | 平均真实波幅
所属类别 | 引用函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求平均真实波幅。
用法 | ATR(10) 表示求平均真实波幅
来自“http://www.hs633.com/kthelp/index.php?title=Atr_%E5%B9%B3%E5%9D%87%E7%9C%9F%E5%AE%9E%E6%B3%A2%E5%B9%85&oldid=1194”


Atrd 日线的平均真实波幅

函数 | Atrd
别名 | 日线的平均真实波幅
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | N天前的日线的计算周期为M的ATR值
用法 | ATRD(M,N=1) ATRD(M,N) N天前周期为M的ATR，N>=0,M>1 数据不存在时返回-1
来自“http://www.hs633.com/kthelp/index.php?title=Atrd_%E6%97%A5%E7%BA%BF%E7%9A%84%E5%B9%B3%E5%9D%87%E7%9C%9F%E5%AE%9E%E6%B3%A2%E5%B9%85&oldid=1195”


BackSet 向前赋值

函数 | BackSet
别名 | 向前赋值
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 将当前位置到若干周期前的数据设为1。
用法 | BACKSET(X,N),若X非0,则将当前位置到N周期前的数值设为1。 例如: BACKSET(CLOSE>OPEN,2) 若收阳则将该周期及前一周期数值设为1,否则为0
来自“http://www.hs633.com/kthelp/index.php?title=BackSet_%E5%90%91%E5%89%8D%E8%B5%8B%E5%80%BC&oldid=1163”


BarsCount 有效值周期数

函数 | BarsCount
别名 | 有效值周期数
所属类别 | 引用函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 求总的周期数。
用法 | BARSCOUNT(X)第一个有效数据到当前的天数 例如: BARSCOUNT(CLOSE) 对于日线数据取得上市以来总交易日数，对于分笔成交取得当日成交笔数
来自“http://www.hs633.com/kthelp/index.php?title=BarsCount_%E6%9C%89%E6%95%88%E5%80%BC%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1164”


BarsLast 上一次条件成立位置

函数 | BarsLast
别名 | 上一次条件成立位置
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 上一次条件成立到当前的周期数。
用法 | BARSLAST(X,N):前N次X不为0到现在的天数 例如: BARSLAST(CLOSE/REF(CLOSE,1)>=1.1,1) 表示上一个涨停板到当前的周期数 N必须大于1
来自“http://www.hs633.com/kthelp/index.php?title=BarsLast_%E4%B8%8A%E4%B8%80%E6%AC%A1%E6%9D%A1%E4%BB%B6%E6%88%90%E7%AB%8B%E4%BD%8D%E7%BD%AE&oldid=1165”


BarsLastCount 倒数连续满足条件的次数

函数 | BarsLastCount
别名 | 倒数连续满足条件的次数
所属类别 | 引用函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 统计从当前开始往回数，连续满足条件的次数，只要碰到不满足就终止。
用法 | BarsLastCount(X):倒数，X连续不为0的周期数 例如: BARSLASTCOUNT(CLOSE>OPEN) 表示统计连续收阳的周期数
来自“http://www.hs633.com/kthelp/index.php?title=BarsLastCount_%E5%80%92%E6%95%B0%E8%BF%9E%E7%BB%AD%E6%BB%A1%E8%B6%B3%E6%9D%A1%E4%BB%B6%E7%9A%84%E6%AC%A1%E6%95%B0&oldid=1197”


BarsSince 第一个条件成立位置

函数 | BarsSince
别名 | 第一个条件成立位置
所属类别 | 引用函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 第一个条件成立到当前的周期数。
用法 | BARSSINCE(X):第一次X不为0到现在的天数 例如: BARSSINCE(HIGH>20) 表示股价超过20元时到当前的周期数
来自“http://www.hs633.com/kthelp/index.php?title=BarsSince_%E7%AC%AC%E4%B8%80%E4%B8%AA%E6%9D%A1%E4%BB%B6%E6%88%90%E7%AB%8B%E4%BD%8D%E7%BD%AE&oldid=1166”


Count 统计总数

函数 | Count
别名 | 统计总数
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 统计满足条件的周期数。
用法 | COUNT(X,N),统计N周期中满足条件X的周期数, 若N=0则从第一个有效值开始。 例如: COUNT(CLOSE表示统计10周期内收阴的周期数
来自“http://www.hs633.com/kthelp/index.php?title=Count_%E7%BB%9F%E8%AE%A1%E6%80%BB%E6%95%B0&oldid=1167”


Dma 动态移动平均

函数 | Dma
别名 | 动态移动平均
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 |
用法 | DMA(X,A),求X的动态移动平均。 算法: 若Y=DMA(X,A) 则 Y=A*X+(1-A)*Y', 其中Y'表示上一周期Y值,A必须小于1。 例如: DMA(CLOSE,VOL/CAPITAL) 表示求以换手率作平滑因子的平均价
来自“http://www.hs633.com/kthelp/index.php?title=Dma_%E5%8A%A8%E6%80%81%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87&oldid=1168”


Ema 指数平滑移动平均

函数 | Ema
别名 | 指数平滑移动平均
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求指数平滑移动平均。
用法 | EMA(X,N),求X的N周期指数平滑移动平均。 算法: 若Y=EMA(X,N) 则Y=[2*X+(N-1)*Y']/(N+1), 其中Y'表示上一周期Y值。 例如: EMA(CLOSE,20) 表示求20日指数平滑均价
来自“http://www.hs633.com/kthelp/index.php?title=Ema_%E6%8C%87%E6%95%B0%E5%B9%B3%E6%BB%91%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87&oldid=1169”


ExpMema 指数平滑移动平均 EX

函数 | ExpMema
别名 | 指数平滑移动平均_EX
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求指数平滑移动平均。
用法 | EXPMEMA(X,M),求X的M周期指数平滑移动平均。 算法: 若Y=EXPMEMA(X,M) 则Y=[2*X+(M-1)*Y']/(M+1), 其中Y'表示上一周期Y值。 例如: EXPMEMA(CLOSE,20) 表示求20日指数平滑均价
来自“http://www.hs633.com/kthelp/index.php?title=ExpMema_%E6%8C%87%E6%95%B0%E5%B9%B3%E6%BB%91%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87_EX&oldid=1170”


Filter 信号过滤

函数 | Filter
别名 | 信号过滤
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 过滤连续出现的信号。
用法 | FILTER(X,N):X满足条件后，将其后N周期内的数据置为0 例如:FILTER(CLOSE>OPEN,3) 查找阳线，3天内再次出现的阳线不被记录在内
来自“http://www.hs633.com/kthelp/index.php?title=Filter_%E4%BF%A1%E5%8F%B7%E8%BF%87%E6%BB%A4&oldid=1171”


FilterX 反向信号过滤

函数 | FilterX
别名 | 反向信号过滤
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 反向过滤连续出现的信号。
用法 | FILTERX(X,N):X满足条件时，将其前N周期内的数据置为0 例如: FILTERX(CLOSE>OPEN,3) 查找阳线，前3天内出现过的阳线不被记录在内
来自“http://www.hs633.com/kthelp/index.php?title=FilterX_%E5%8F%8D%E5%90%91%E4%BF%A1%E5%8F%B7%E8%BF%87%E6%BB%A4&oldid=1172”


FindHigh 寻找最高价

函数 | FindHigh
别名 | 寻找最高价
所属类别 | 引用函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | N周期前的M周期内的第T个最大值
用法 | N周期前的M周期内的第T个最大值 用法: FindHigh(VAR,N,M,T):VAR在N日前的M天内第T个最高价
来自“http://www.hs633.com/kthelp/index.php?title=FindHigh_%E5%AF%BB%E6%89%BE%E6%9C%80%E9%AB%98%E4%BB%B7&oldid=1180”


FindHighBars 寻找最高价位置

函数 | FindHighBars
别名 | 寻找最高价位置
所属类别 | 引用函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | N周期前的M周期内的第T个最大值到当前周期的周期数
用法 | N周期前的M周期内的第T个最大值到当前周期的周期数 用法: FINDHIGHBARS(VAR,N,M,T):VAR在N日前的M天内第T个最高价到当前周期的周期数
来自“http://www.hs633.com/kthelp/index.php?title=FindHighBars_%E5%AF%BB%E6%89%BE%E6%9C%80%E9%AB%98%E4%BB%B7%E4%BD%8D%E7%BD%AE&oldid=1181”


FindLow 寻找最低价

函数 | FindLow
别名 | 寻找最低价
所属类别 | 引用函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | N周期前的M周期内的第T个最小值
用法 | N周期前的M周期内的第T个最小值 用法: FindLow(VAR,N,M,T):VAR在N日前的M天内第T个最低价
来自“http://www.hs633.com/kthelp/index.php?title=FindLow_%E5%AF%BB%E6%89%BE%E6%9C%80%E4%BD%8E%E4%BB%B7&oldid=1178”


FindLowBars 寻找最低价位置

函数 | FindLowBars
别名 | 寻找最低价位置
所属类别 | 引用函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | N周期前的M周期内的第T个最小值到当前周期的周期数
用法 | N周期前的M周期内的第T个最小值到当前周期的周期数 用法: FINDLOWBARS(VAR,N,M,T):VAR在N日前的M天内第T个最低价到当前周期的周期数.
来自“http://www.hs633.com/kthelp/index.php?title=FindLowBars_%E5%AF%BB%E6%89%BE%E6%9C%80%E4%BD%8E%E4%BB%B7%E4%BD%8D%E7%BD%AE&oldid=1179”


Hhv 最高值

函数 | Hhv
别名 | 最高值
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求最高值。
用法 | HHV(HIGH,30) 表示求30日最高价
来自“http://www.hs633.com/kthelp/index.php?title=Hhv_%E6%9C%80%E9%AB%98%E5%80%BC&oldid=1173”


HhvBars 上一高点位置

函数 | HhvBars
别名 | 上一高点位置
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求上一高点到当前的周期数。
用法 | HHVBARS(X,N):求N周期内X最高值到当前周期数， N=0表示从第一个有效值开始统计 例如: HHVBARS(HIGH,0) 求得历史新高到到当前的周期数
来自“http://www.hs633.com/kthelp/index.php?title=HhvBars_%E4%B8%8A%E4%B8%80%E9%AB%98%E7%82%B9%E4%BD%8D%E7%BD%AE&oldid=1174”


Hod 高值名次

函数 | Hod
别名 | 高值名次
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求高值名次。
用法 | HOD(X,N):求当前X数据是N周期内的第几个高值, N=0则从第一个有效值开始 例如: HOD(HIGH,20) 返回是20日的第几个高价
来自“http://www.hs633.com/kthelp/index.php?title=Hod_%E9%AB%98%E5%80%BC%E5%90%8D%E6%AC%A1&oldid=1175”


Llv 最低值

函数 | Llv
别名 | 最低值
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求最低值。
用法 | LLV(X,N),求N周期内X的最低值,N=0则从第一个有效值开始。 例如: LLV(LOW,0) 表示求历史最低价
来自“http://www.hs633.com/kthelp/index.php?title=Llv_%E6%9C%80%E4%BD%8E%E5%80%BC&oldid=1176”


LlvBars 上一低点位置

函数 | LlvBars
别名 | 上一低点位置
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求上一低点到当前的周期数。
用法 | LLVBARS(X,N):求N周期内X最低值到当前周期数， N=0表示从第一个有效值开始统计 例如: LLVBARS(HIGH,10) 求得10日最低点到当前的周期数
来自“http://www.hs633.com/kthelp/index.php?title=LlvBars_%E4%B8%8A%E4%B8%80%E4%BD%8E%E7%82%B9%E4%BD%8D%E7%BD%AE&oldid=1177”


Lod 低值名次

函数 | Lod
别名 | 低值名次
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求低值名次。
用法 | LOD(X,N):求当前X数据是N周期内的第几个低值, N=0则从第一个有效值开始 例如: LOD(LOW,20) 返回是20日的第几个低价
来自“http://www.hs633.com/kthelp/index.php?title=Lod_%E4%BD%8E%E5%80%BC%E5%90%8D%E6%AC%A1&oldid=1182”


Ma 简单移动平均

函数 | Ma
别名 | 简单移动平均
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求简单移动平均。
用法 | MA(X,N),求X的N周期简单移动平均值。 算法： (X1+X2+X3+...+Xn)/N 例如: MA(CLOSE,20) 表示求20日均价
来自“http://www.hs633.com/kthelp/index.php?title=Ma_%E7%AE%80%E5%8D%95%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87&oldid=1183”


MD 动向平均

函数 | MD
别名 | 动向平均
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求动向平均。
用法 | MD(X,N),求X的动向平均，N为计算周期。 例如: MD(CLOSE,10) 表示求10周期动向平均
来自“http://www.hs633.com/kthelp/index.php?title=MD_%E5%8A%A8%E5%90%91%E5%B9%B3%E5%9D%87&oldid=1185”


Ref 向前引用

函数 | Ref
别名 | 向前引用
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 引用若干周期前的数据。
用法 | REF(X,A),引用A周期前的X值。 例如: REF(CLOSE,1) 表示上一周期的收盘价，在日线上就是昨收
来自“http://www.hs633.com/kthelp/index.php?title=Ref_%E5%90%91%E5%89%8D%E5%BC%95%E7%94%A8&oldid=1186”


RefX 向后引用

函数 | RefX
别名 | 向后引用
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 引用若干周期后的数据。
用法 | REFX(X,A),引用A周期后的X值。 例如: REFX(CLOSE,1) 表示后一周期的收盘价，在日线上就是明收
来自“http://www.hs633.com/kthelp/index.php?title=RefX_%E5%90%91%E5%90%8E%E5%BC%95%E7%94%A8&oldid=1187”


SetVal 周期设值

函数 | SetVal
别名 | 周期设值
所属类别 | 引用函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 根据条件对前后N个周期设值。
用法 | SETVAL(X,Q,N,V):X满足条件时,N=0将当前周期设为V值, N>0将后面N个周期设为V值, N<0将前面N个周期设为V值(不含当前周期),未设部分取Q值 例如: A:SETVAL(C>O,C,5,C-O)
来自“http://www.hs633.com/kthelp/index.php?title=SetVal_%E5%91%A8%E6%9C%9F%E8%AE%BE%E5%80%BC&oldid=1188”


Sma 移动平均

函数 | Sma
别名 | 移动平均
所属类别 | 引用函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 求移动平均。
用法 | SMA(X,N,M),求X的N周期移动平均，M为权重。 算法: 若Y=SMA(X,N,M) 则 Y=(M*X+(N-M)*Y')/N, 其中Y'表示上一周期Y值,N必须大于M。 例如: SMA(CLOSE,20,1) 表示求20日移动平均价
来自“http://www.hs633.com/kthelp/index.php?title=Sma_%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87&oldid=1189”


Sum 求和

函数 | Sum
别名 | 求和
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求总和。
用法 | SUM(X,N),统计N周期中X的总和,N=0则从第一个有效值开始。 例如: SUM(VOL,0) 表示统计从第一根K线以来的成交量总和
来自“http://www.hs633.com/kthelp/index.php?title=Sum_%E6%B1%82%E5%92%8C&oldid=1190”


SumBars 累加到指定值周期数

函数 | SumBars
别名 | 累加到指定值周期数
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 向前累加到指定值到现在的周期数。
用法 | SUMBARS(X,A):将X向前累加直到大于等于A,返回这个区间的周期数 例如: SUMBARS(VOL/100,CAPITAL) 求完全换手到现在的周期数
来自“http://www.hs633.com/kthelp/index.php?title=SumBars_%E7%B4%AF%E5%8A%A0%E5%88%B0%E6%8C%87%E5%AE%9A%E5%80%BC%E5%91%A8%E6%9C%9F%E6%95%B0&oldid=1191”


Tma 递归移动平均

函数 | Tma
别名 | 递归移动平均
所属类别 | 引用函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 求递归移动平均。
用法 | TMA(X,N,M),求X的递归移动平均，N、M为权重。 算法: 若Y=TMA(X,N,M) 则 Y=(N*Y'+M*X), 其中Y'表示上一周期Y值。初值为M*X 例如: TMA(CLOSE,0.9,0.1) 表示求X的递归移动平均
来自“http://www.hs633.com/kthelp/index.php?title=Tma_%E9%80%92%E5%BD%92%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87&oldid=1192”


Tr 真实波幅

函数 | Tr
别名 | 真实波幅
所属类别 | 引用函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 求真实波幅。
用法 | ATR1:=MA(TR,10) 表示求真实波幅的10周期均值
来自“http://www.hs633.com/kthelp/index.php?title=Tr_%E7%9C%9F%E5%AE%9E%E6%B3%A2%E5%B9%85&oldid=1193”


ValueLast 向前引用非0的数值

函数 | ValueLast
别名 | 向前引用非0的数值
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 引用若干周期前不为0的数值。
用法 | ValueLast( X, N) 例如： ValueLast(CLOSE,1); 表示取得收盘价上次不为0的数值
来自“http://www.hs633.com/kthelp/index.php?title=ValueLast_%E5%90%91%E5%89%8D%E5%BC%95%E7%94%A8%E9%9D%9E0%E7%9A%84%E6%95%B0%E5%80%BC&oldid=1199”


ValueWhen 条件跟随

函数 | ValueWhen
别名 | 条件跟随
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 当条件COND满足时，取当时的DATA的值，否则取得VALUEWHEN的前一个值。
用法 | ValueWhen( cond, data) 例如： VALUEWHEN(HIGH>REF(HIGH,5),HIGH); 表示当前最高价大于前五个周期最高价的最大值时返回当前最高价
来自“http://www.hs633.com/kthelp/index.php?title=ValueWhen_%E6%9D%A1%E4%BB%B6%E8%B7%9F%E9%9A%8F&oldid=1198”


Wma 加权移动平均

函数 | Wma
别名 | 加权移动平均
所属类别 | 引用函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 求加权移动平均。
用法 | WMA(X,A),求X的加权移动平均。 算法: 若Y=WMA(X,A) 则 Y=(N*X0+(N-1)*X1+(N-2)*X2)+...+1*XN)/(N+(N-1)+(N-2)+...+1)X0表示本周期值，X1表示上一周期值... 例如: WMA(CLOSE,20) 表示求20日加权均价
来自“http://www.hs633.com/kthelp/index.php?title=Wma_%E5%8A%A0%E6%9D%83%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87&oldid=1196”


AddMenu 增加菜单

函数 | AddMenu
别名 | 增加菜单
所属类别 | 应用程序接口
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 增加菜单
用法 | AddMenu (parentMenuName, MenuName, viewType, Function) 参数： parentMenuName: 父菜单名字,如果为空串,则增加顶层菜单 MenuName: 菜单名字 period：可选,指定周期 vewType: 1为报价窗口,2为技术分析窗口 Function: 响应函数，必须在前面已经定义 例如： 增加一个 资讯 顶层菜单 function OnOpenChartView begin OpenChartView('SH600018', 'boll', 0, false); end AddMenu(, '资讯(&I)', 0, OnOpenChartView); 在 资讯 下 增加一个 打开公式 菜单 AddMenu('资讯(&I)', '打开公式', 0, OnOpenChartView);
来自“http://www.hs633.com/kthelp/index.php?title=AddMenu_%E5%A2%9E%E5%8A%A0%E8%8F%9C%E5%8D%95&oldid=1995”


OpenChartView 打开技术分析窗口

函数 | OpenChartView
别名 | 打开技术分析窗口
所属类别 | 应用程序接口
参数数量 | 6
运行模式 | 逐根/逐行
说明 | 打开技术分析窗口
用法 | 目前可用在扩展公式,也可以在预警中条件符合是打开窗口自动交易 OpenChartView (longCode, fmlNameOrPath, period, replaceFml, startTrade, newWindow) 参数： longCode: 必需参数, 比如 SH600000 fmlNameOrPath: 可选, 指定公式名字或者相对FML的路径 period：可选,指定周期 replaceFml: 可选, 是否替换图上现有公式，默认true startTrade: 可选，是否开始交易 默认false newWindow: 可选, 是否打开新窗口,默认false 例如： OpenChartView ('SH600000', 'ma'); 打开浦发银行分析窗口并运行ma
来自“http://www.hs633.com/kthelp/index.php?title=OpenChartView_%E6%89%93%E5%BC%80%E6%8A%80%E6%9C%AF%E5%88%86%E6%9E%90%E7%AA%97%E5%8F%A3&oldid=1994”


Cost 成本分布

函数 | Cost
别名 | 成本分布
所属类别 | 指标函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 成本分布情况。
用法 | COST(20) 表示20%获利盘的价格是多少 即有20%的持仓量在该价格以下,其余80%在该价格以上,为套牢盘 该函数仅对日线分析周期比较有效
来自“http://www.hs633.com/kthelp/index.php?title=Cost_%E6%88%90%E6%9C%AC%E5%88%86%E5%B8%83&oldid=1267”


DiverGence 背离

函数 | DiverGence
别名 | 背离
所属类别 | 指标函数
参数数量 | 5
运行模式 | 逐根/逐行
说明 | 背离
用法 Divergence(X1,X2,S,L,HL)

返回序列X1与X2在指定周期内是否发生背离

参数说明：

X1,X2: 判断背离所需的两个序列

S: 设置转折点两边需要的周期数，取值应小于L；

L: 计算范围周期数。

HL: 1表示计算波峰点，X1高点比高点高，但X2高点比高点低，熊背离，或称顶背离

-1表示计算波谷点，X1低点比低点高，但X2低点比低点低，牛背离，或称底背离；

Divergence(C, RSI1, 3, 20, -1)

返回1则表示RSI指标发生牛背离，价格波谷创新低，但RSI指标波谷走高

Divergence(C, RSI1, 3, 20, 1)

返回1则表示RSI指标发生熊背离，价格波峰创新高，但RSI指标波峰走低

来自“http://www.hs633.com/kthelp/index.php?title=DiverGence_%E8%83%8C%E7%A6%BB&oldid=1291”


FlatZig 归一化之字转向

函数 | FlatZig
别名 | 归一化之字转向
所属类别 | 指标函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 归一化之字转向。
用法 | FLATZIG(X,N),当序列或K线变化量超过N%时转向 X为序列或常数,为常数时表示0:开盘价,1:最高价,2:最低价,3:收盘价,4: 高点用最高价、低点用最低价 与ZIG函数不同的是本函数返回值在0-1之间。 例如: FLATZIG(3,10)表示收盘价的10%的FLATZIG转向 FLATZIG(MA(C,20),10)表示均线的10%的FLATZIG转向
来自“http://www.hs633.com/kthelp/index.php?title=FlatZig_%E5%BD%92%E4%B8%80%E5%8C%96%E4%B9%8B%E5%AD%97%E8%BD%AC%E5%90%91&oldid=1268”


FlatZiga 归一化绝对变化量之字转向

函数 | FlatZiga
别名 | 归一化绝对变化量之字转向
所属类别 | 指标函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 归一化之字转向(绝对变化量)。
用法 | FLATZIGA(X,N),当序列X变化量超过N时转向 与ZIGA函数不同的是本函数返回值在0-1之间。 例如: FLATZIGA(RSI1,10)
来自“http://www.hs633.com/kthelp/index.php?title=FlatZiga_%E5%BD%92%E4%B8%80%E5%8C%96%E7%BB%9D%E5%AF%B9%E5%8F%98%E5%8C%96%E9%87%8F%E4%B9%8B%E5%AD%97%E8%BD%AC%E5%90%91&oldid=1269”


LWinner 近期获利盘比例

函数 | LWinner
别名 | 近期获利盘比例
所属类别 | 指标函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 近期获利盘比例。
用法 | LWINNER(20,CLOSE) 表示最近20天的那部分成本以当前收市价卖出的获利盘比例， 例如返回0.2表示20%获利盘 该函数仅对日线分析周期有效
来自“http://www.hs633.com/kthelp/index.php?title=LWinner_%E8%BF%91%E6%9C%9F%E8%8E%B7%E5%88%A9%E7%9B%98%E6%AF%94%E4%BE%8B&oldid=1271”


Peak 前M个波峰值

函数 | Peak
别名 | 前M个波峰值
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIG转向波峰值。
用法 | PEAK(X,N,M)表示之字转向ZIG(X,N)的前M个波峰的数值,M必须大于等于1 例如: PEAK(1,5,1)表示5%最高价ZIG转向的上一个波峰的数值 PEAK(MA(C,20),10,1)表示均线的10%的ZIG转向的上一个波峰的数值
来自“http://www.hs633.com/kthelp/index.php?title=Peak_%E5%89%8DM%E4%B8%AA%E6%B3%A2%E5%B3%B0%E5%80%BC&oldid=1270”


Peaka ZIGA前M个波峰值

函数 | Peaka
别名 | ZIGA前M个波峰值
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIGA转向波峰值(绝对变化量)。
用法 | PEAKA(X,N,M) 表示之字转向ZIGA(X,N)的前M个波峰的数值,M必须大于等于1 例如: PEAKA(RSI1,10,1)
来自“http://www.hs633.com/kthelp/index.php?title=Peaka_ZIGA%E5%89%8DM%E4%B8%AA%E6%B3%A2%E5%B3%B0%E5%80%BC&oldid=1272”


PeakBars 前M个波峰位置

函数 | PeakBars
别名 | 前M个波峰位置
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIG转向波峰到当前周期数。
用法 | PEAKBARS(X,N,M) 表示之字转向ZIG(X,N)的前M个波峰到当前的周期数,M必须大于等于1 例如: PEAKBARS(0,8,1)表示%8开盘价ZIG转向的上一个波峰到当前的周期数 PEAKBARS(MA(C,20),8,1)表示均线的8%的ZIG转向的上一个波峰到当前的周期数
来自“http://www.hs633.com/kthelp/index.php?title=PeakBars_%E5%89%8DM%E4%B8%AA%E6%B3%A2%E5%B3%B0%E4%BD%8D%E7%BD%AE&oldid=1273”


PeakBarSa ZIGA前M个波峰位置

函数 | PeakBarSa
别名 | ZIGA前M个波峰位置
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIGA转向波峰到当前周期数(绝对变化量)。
用法 | PEAKBARSA(X,N,M) 表示之字转向ZIGA(X,N)的前M个波峰到当前的周期数,M必须大于等于1 例如: PEAKBARSA(RSI1,10,1)
来自“http://www.hs633.com/kthelp/index.php?title=PeakBarSa_ZIGA%E5%89%8DM%E4%B8%AA%E6%B3%A2%E5%B3%B0%E4%BD%8D%E7%BD%AE&oldid=1274”


PPart 远期成本比例

函数 | PPart
别名 | 远期成本比例
所属类别 | 指标函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 远期成本比例。
用法 | PPART(N) 表示N周期前的成本占总成本的比例,如返回0.2表示20% 例如: PPART(5) 5天前的成本占总成本的比例 该函数仅对日线分析周期比较有效
来自“http://www.hs633.com/kthelp/index.php?title=PPart_%E8%BF%9C%E6%9C%9F%E6%88%90%E6%9C%AC%E6%AF%94%E4%BE%8B&oldid=1275”


PWinner 远期获利盘比例

函数 | PWinner
别名 | 远期获利盘比例
所属类别 | 指标函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 远期获利盘比例。
用法 | PWINNER(10,CLOSE) 表示10天前的那部分成本以当前收市价卖出的获利盘比例 例如返回0.2表示20%获利盘 该函数仅对日线分析周期比较有效
来自“http://www.hs633.com/kthelp/index.php?title=PWinner_%E8%BF%9C%E6%9C%9F%E8%8E%B7%E5%88%A9%E7%9B%98%E6%AF%94%E4%BE%8B&oldid=1276”


Sar 抛物转向

函数 | Sar
别名 | 抛物转向
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 抛物转向。
用法 | SAR(N,S,M),N为计算周期,S为步长,M为极值 例如： SAR(5,2,10) 表示计算5日抛物转向，步长为2%，极限值为10%
来自“http://www.hs633.com/kthelp/index.php?title=Sar_%E6%8A%9B%E7%89%A9%E8%BD%AC%E5%90%91&oldid=1277”


SarTurn 抛物转向点

函数 | SarTurn
别名 | 抛物转向点
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 抛物转向点。
用法 | SARTURN(N,S,M) N为计算周期,S为步长,M为极值, 若发生向上转向则返回1，若发生向下转向则返回-1，否则为0 其用法与SAR函数相同
来自“http://www.hs633.com/kthelp/index.php?title=SarTurn_%E6%8A%9B%E7%89%A9%E8%BD%AC%E5%90%91%E7%82%B9&oldid=1278”


SwingHigh 波峰点

函数 | SwingHigh
别名 | 波峰点
所属类别 | 指标函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 波峰点
用法 | SwingHigh(N,X,S,L) 返回指定周期内波峰点（转折高点、分形高点）的数值 参数说明： N:设置波峰点序号，1表示最近的波峰点，2表示最近第二个... X:用于求波峰点的序列; S:设置波峰点两边需要的周期数，取值应小于L； L:计算范围周期数。 例如： SwingHigh(1,High,2,10) 计算最近的10个周期内的两边至少都有2个相对低点的波峰点的值
来自“http://www.hs633.com/kthelp/index.php?title=SwingHigh_%E6%B3%A2%E5%B3%B0%E7%82%B9&oldid=1287”


SwingHighBar 波峰点位置

函数 | SwingHighBar
别名 | 波峰点位置
所属类别 | 指标函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 波峰点位置
用法 | SwingHighBar(N,X,S,L) 返回波峰点（转折高点、分形高点）距当前周期数 参数说明： N:设置波峰点序号，1表示最近的波峰点，2表示最近第二个... X:用于求波峰点的序列; S:设置波峰点两边需要的周期数，取值应小于L； L:计算范围周期数。
来自“http://www.hs633.com/kthelp/index.php?title=SwingHighBar_%E6%B3%A2%E5%B3%B0%E7%82%B9%E4%BD%8D%E7%BD%AE&oldid=1288”


SwingLow 波谷点

函数 | SwingLow
别名 | 波谷点
所属类别 | 指标函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 波谷点。
用法 | SwingLow(N,X,S,L) 返回波谷点（转折低点、分形低点）数值 参数说明： N:设置波谷点序号，1表示最近的波谷点，2表示最近第二个... X:用于求波谷点的序列; S:设置波谷点两边需要的周期数，取值应小于L； L:计算范围周期数。
来自“http://www.hs633.com/kthelp/index.php?title=SwingLow_%E6%B3%A2%E8%B0%B7%E7%82%B9&oldid=1289”


SwingLowBar 波谷点位置

函数 | SwingLowBar
别名 | 波谷点位置
所属类别 | 指标函数
参数数量 | 4
运行模式 | 逐根/逐行
说明 | 波谷点位置
用法 | SwingLowBar(N,X,S,L) 返回波谷点（转折低点、分形低点）距当前周期数 参数说明： N:设置波峰点序号，1表示最近的波峰点，2表示最近第二个... X:用于求波峰点的序列; S:设置波峰点两边需要的周期数，取值应小于L； L:计算范围周期数。
来自“http://www.hs633.com/kthelp/index.php?title=SwingLowBar_%E6%B3%A2%E8%B0%B7%E7%82%B9%E4%BD%8D%E7%BD%AE&oldid=1290”


Trough 前M个波谷值

函数 | Trough
别名 | 前M个波谷值
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIG转向波谷值。
用法 | TROUGH(X,N,M) 表示之字转向ZIG(X,N)的前M个波谷的数值,M必须大于等于1 例如: TROUGH(2,8,3)表示%8最低价ZIG转向的前3个波谷的数值 TROUGH(MA(C,20),5,2)表示均线的5%的ZIG转向的前2个波谷的数值
来自“http://www.hs633.com/kthelp/index.php?title=Trough_%E5%89%8DM%E4%B8%AA%E6%B3%A2%E8%B0%B7%E5%80%BC&oldid=1279”


TroughA ZIGA前M个波谷值

函数 | TroughA
别名 | ZIGA前M个波谷值
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIGA转向波谷值(绝对变化量)。
用法 | TROUGHA(X,N,M) 表示之字转向ZIGA(X,N)的前M个波谷的数值,M必须大于等于1 例如: TROUGHA(RSI1,10,2)
来自“http://www.hs633.com/kthelp/index.php?title=TroughA_ZIGA%E5%89%8DM%E4%B8%AA%E6%B3%A2%E8%B0%B7%E5%80%BC&oldid=1280”


TroughBars 前M个波谷位置

函数 | TroughBars
别名 | 前M个波谷位置
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIG转向波谷到当前周期数。
用法 | TROUGHBARS(X,N,M) 表示之字转向ZIG(X,N)的前M个波谷到当前的周期数,M必须大于等于1 例如: TROUGHBARS(2,8,3) 表示%8最低价ZIG转向的前3个波谷到当前的周期数 TROUGHBARS(MA(C,20),5,2) 表示均线的5%的ZIG转向的前2个波谷到当前的周期数
来自“http://www.hs633.com/kthelp/index.php?title=TroughBars_%E5%89%8DM%E4%B8%AA%E6%B3%A2%E8%B0%B7%E4%BD%8D%E7%BD%AE&oldid=1281”


TroughBarsA ZIGA前M个波谷位置

函数 | TroughBarsA
别名 | ZIGA前M个波谷位置
所属类别 | 指标函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 前M个ZIGA转向波谷到当前周期数(绝对变化量)。
用法 | TROUGHBARSA(X,N,M) 表示之字转向ZIGA(X,N)的前M个波谷到当前的周期数,M必须大于等于1 例如: TROUGHBARSA(RSI1,10,2)
来自“http://www.hs633.com/kthelp/index.php?title=TroughBarsA_ZIGA%E5%89%8DM%E4%B8%AA%E6%B3%A2%E8%B0%B7%E4%BD%8D%E7%BD%AE&oldid=1282”


Winner 获利盘比例

函数 | Winner
别名 | 获利盘比例
所属类别 | 指标函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 获利盘比例。
用法 | WINNER(CLOSE) 表示以当前收市价卖出的获利盘比例,如返回0.2表示20%获利盘； 例如: WINNER(10) 表示10元价格的获利盘比例 该函数仅对比较日线分析周期有效
来自“http://www.hs633.com/kthelp/index.php?title=Winner_%E8%8E%B7%E5%88%A9%E7%9B%98%E6%AF%94%E4%BE%8B&oldid=1283”


Zig 之字转向

函数 | Zig
别名 | 之字转向
所属类别 | 指标函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 之字转向。
用法 | ZIG(X,N),当序列或K线变化量超过N%时转向 X为序列或常数,为常数时表示0:开盘价,1:最高价,2:最低价,3:收盘价,4 高点用最高价、低点用最低价例如: ZIG(3,10)表示收盘价的10%的ZIG转向 ZIG(MA(C,20),10)表示均线的10%的ZIG转向
来自“http://www.hs633.com/kthelp/index.php?title=Zig_%E4%B9%8B%E5%AD%97%E8%BD%AC%E5%90%91&oldid=1284”


Ziga 绝对之字转向

函数 | Ziga
别名 | 绝对之字转向
所属类别 | 指标函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 绝对变化量之字转向。
用法 | ZIGA(X,N),当序列X变化量超过N时转向 例如: ZIGA(RSI1,10)
来自“http://www.hs633.com/kthelp/index.php?title=Ziga_%E7%BB%9D%E5%AF%B9%E4%B9%8B%E5%AD%97%E8%BD%AC%E5%90%91&oldid=1285”


Opt_AnnualReturnRate

函数 | Opt_AnnualReturnRate
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 年化收益率
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_AnnualReturnRate&oldid=1853”


Opt_AvgLoss

函数 | Opt_AvgLoss
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 平均亏损
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_AvgLoss&oldid=1877”


Opt_AvgLossPeriod

函数 | Opt_AvgLossPeriod
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 平均亏损周期
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_AvgLossPeriod&oldid=1879”


Opt_AvgPayoff

函数 | Opt_AvgPayoff
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 平均盈亏
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_AvgPayoff&oldid=1865”


Opt_AvgWin

函数 | Opt_AvgWin
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 平均盈利
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_AvgWin&oldid=1876”


Opt_AvgWinPeriod

函数 | Opt_AvgWinPeriod
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 平均盈利周期
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_AvgWinPeriod&oldid=1878”


Opt_Balance

函数 | Opt_Balance
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 资金余额
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_Balance&oldid=1849”


Opt_GrossLoss

函数 | Opt_GrossLoss
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 总亏损
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_GrossLoss&oldid=1869”


Opt_GrossProfit

函数 | Opt_GrossProfit
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 总盈利
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_GrossProfit&oldid=1868”


Opt_LossRate

函数 | Opt_LossRate
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 败率
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_LossRate&oldid=1863”


Opt_LossTrades

函数 | Opt_LossTrades
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 亏损次数
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_LossTrades&oldid=1871”


Opt_MaxConsecLoss

函数 | Opt_MaxConsecLoss
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大连续亏损次数
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_MaxConsecLoss&oldid=1873”


Opt_MaxConsecWin

函数 | Opt_MaxConsecWin
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大连续盈利次数
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_MaxConsecWin&oldid=1872”


Opt_MaxDrawdown

函数 | Opt_MaxDrawdown
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大回撤
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_MaxDrawdown&oldid=1855”


Opt_MaxDrawdownPct

函数 | Opt_MaxDrawdownPct
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大回撤幅度
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_MaxDrawdownPct&oldid=1854”


Opt_MaxLoss

函数 | Opt_MaxLoss
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大单次亏损
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_MaxLoss&oldid=1875”


Opt_MaxWin

函数 | Opt_MaxWin
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 最大单次盈利
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_MaxWin&oldid=1874”


Opt_NetProfit

函数 | Opt_NetProfit
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 净利润
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_NetProfit&oldid=1848”


Opt_PayOffRate

函数 | Opt_PayOffRate
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 盈亏比
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_PayOffRate&oldid=1864”


Opt_ProfitFactor

函数 | Opt_ProfitFactor
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 盈利因子
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_ProfitFactor&oldid=1852”


Opt_ProfitRiskRatio

函数 | Opt_ProfitRiskRatio
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 收益风险比
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_ProfitRiskRatio&oldid=1851”


Opt_SharpIndex

函数 | Opt_SharpIndex
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 夏普指数
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_SharpIndex&oldid=1867”


Opt_TotalTrades

函数 | Opt_TotalTrades
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 交易次数
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_TotalTrades&oldid=1866”


Opt_WinRate

函数 | Opt_WinRate
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 胜率
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_WinRate&oldid=1862”


Opt_WinTrades

函数 | Opt_WinTrades
别名 | 无
所属类别 | 宏
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 盈利次数
用法 |
来自“http://www.hs633.com/kthelp/index.php?title=Opt_WinTrades&oldid=1870”


AddToBlock 添加品种到板块

函数 | AddToBlock
别名 | 添加品种到板块
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 添加指定的品种到板块
用法 | ADDTOBLOCK(STK,BLK) 将品种代码STK参数表示的证券添加到BLK板块,添加成功输出1否则为0 例如: ADDTOBLOCK(STKLABEL,'上海A股') ADDTOBLOCK('SH600000','金融板块')
来自“http://www.hs633.com/kthelp/index.php?title=AddToBlock_%E6%B7%BB%E5%8A%A0%E5%93%81%E7%A7%8D%E5%88%B0%E6%9D%BF%E5%9D%97&oldid=1340”


BlkName 所属板块

函数 | BlkName
别名 | 所属板块
所属类别 | 字符串函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取品种所属分类板块名称
用法 | EXPLAIN(1,STKNAME+STKLABEL+'\n所属板块:'+BLKNAME)
来自“http://www.hs633.com/kthelp/index.php?title=BlkName_%E6%89%80%E5%B1%9E%E6%9D%BF%E5%9D%97&oldid=1310”


DeleteFromBlock 从板块中删除品种

函数 | DeleteFromBlock
别名 | 从板块中删除品种
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 从板块中删除指定的品种
用法 | DELETEFROMBLOCK(STK,BLK) 从BKL板块中将品种代码STK参数表示的证券删除,删除成功输出1否则为0 例如: DELETEFROMBLOCK(STKLABEL,'上海A股') DELETEFROMBLOCK('SH600000','金融板块')
来自“http://www.hs633.com/kthelp/index.php?title=DeleteFromBlock_%E4%BB%8E%E6%9D%BF%E5%9D%97%E4%B8%AD%E5%88%A0%E9%99%A4%E5%93%81%E7%A7%8D&oldid=1341”


InBlock 是否板块成员

函数 | InBlock
别名 | 是否板块成员
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 当前品种是否属于板块
用法 | INBLOCK(BLKNAME) 属于输出1否则为0 例如: INBLOCK('上海A股');INBLOCK('金融板块')
来自“http://www.hs633.com/kthelp/index.php?title=InBlock_%E6%98%AF%E5%90%A6%E6%9D%BF%E5%9D%97%E6%88%90%E5%91%98&oldid=1311”


LowerStr 小写字符串

函数 | LowerStr
别名 | 小写字符串
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 将字符串转换为小写
用法 | LOWERSTR(STR) 例如: VAR1:=LOWERSTR(MARKETLABEL, 'sh', 2)=0 输出1表示该股为上海证券
来自“http://www.hs633.com/kthelp/index.php?title=LowerStr_%E5%B0%8F%E5%86%99%E5%AD%97%E7%AC%A6%E4%B8%B2&oldid=1312”


LTrim 除去开始空格

函数 | LTrim
别名 | 除去开始空格
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 除去字符串开始空格
用法 | LTRIM(STR) 例如: LTRIM(' SH') 返回SH
来自“http://www.hs633.com/kthelp/index.php?title=LTrim_%E9%99%A4%E5%8E%BB%E5%BC%80%E5%A7%8B%E7%A9%BA%E6%A0%BC&oldid=1313”


MainContract 主力合约

函数 | MainContract
别名 | 主力合约
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 主连当时所对应的合约代码
用法 | MainContract(date)
来自“http://www.hs633.com/kthelp/index.php?title=MainContract_%E4%B8%BB%E5%8A%9B%E5%90%88%E7%BA%A6&oldid=1339”


MarketLabel STKMARKET, 市场代码

函数 | MarketLabel
别名 | STKMARKET, 市场代码
所属类别 | 字符串函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取品种所在市场代码字符串
用法 | MARKETLABEL 例如: VAR1:=STRCMP(MARKETLABEL, 'SH')=0 输出1表示该品种为上交所证券
来自“http://www.hs633.com/kthelp/index.php?title=MarketLabel_STKMARKET,_%E5%B8%82%E5%9C%BA%E4%BB%A3%E7%A0%81&oldid=1316”


MarketName 市场名称

函数 | MarketName
别名 | 市场名称
所属类别 | 字符串函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取品种所在市场名称
用法 | MARKETNAME 例如: EXPLAIN(1,MARKETNAME)
来自“http://www.hs633.com/kthelp/index.php?title=MarketName_%E5%B8%82%E5%9C%BA%E5%90%8D%E7%A7%B0&oldid=1317”


NumToStr 数字转化为字符串

函数 | NumToStr
别名 | 数字转化为字符串
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 将数字转化为字符串
用法 | NUMTOSTR(N,M) 将N转化为字符串返回，精确到小数点后M位 例如: EXPLAIN(1, NUMTOSTR(0.12345, 2)) 输出0.12
来自“http://www.hs633.com/kthelp/index.php?title=NumToStr_%E6%95%B0%E5%AD%97%E8%BD%AC%E5%8C%96%E4%B8%BA%E5%AD%97%E7%AC%A6%E4%B8%B2&oldid=1318”


RTrim 除去尾部空格

函数 | RTrim
别名 | 除去尾部空格
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 除去字符串尾部空格
用法 | RTRIM(STR) 例如: RTRIM('SH ') 返回SH
来自“http://www.hs633.com/kthelp/index.php?title=RTrim_%E9%99%A4%E5%8E%BB%E5%B0%BE%E9%83%A8%E7%A9%BA%E6%A0%BC&oldid=1319”


SelfString 自定义字符串数据

函数 | SelfString
别名 | 自定义字符串数据
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取得自定义字符串数据
用法 | SELFSTRING(S) 取得名为S的自定义字符串数据 例如: EXPLAIN(1, SELFSTRING('所属板块')) 输出命名为[所属板块]的自定义字符串数据 注:在[自定义数据管理]中定义单值字符串数据并编辑或从外部提取、导入
来自“http://www.hs633.com/kthelp/index.php?title=SelfString_%E8%87%AA%E5%AE%9A%E4%B9%89%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%95%B0%E6%8D%AE&oldid=1320”


StkCount 板块含品种数量

函数 | StkCount
别名 | 板块含品种数量
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 板块所包含品种数量
用法 | STKCOUNT(BLKNAME) 属于输出1否则为0 例如: STKCOUNT('上海A股');STKCOUNT('金融板块')
来自“http://www.hs633.com/kthelp/index.php?title=StkCount_%E6%9D%BF%E5%9D%97%E5%90%AB%E5%93%81%E7%A7%8D%E6%95%B0%E9%87%8F&oldid=1321”


StkFromBlk 取板块成员代码

函数 | StkFromBlk
别名 | 取板块成员代码
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得板块成员的品种代码
用法 | STKFROMBLK(BLK,N) 返回BLK板块中的第N个成员的品种代码 例如: explain(1,STKFROMBLK('上海A股', 1)); 在[解]中显示[上海A股]板块中的第1个成员的品种代码
来自“http://www.hs633.com/kthelp/index.php?title=StkFromBlk_%E5%8F%96%E6%9D%BF%E5%9D%97%E6%88%90%E5%91%98%E4%BB%A3%E7%A0%81&oldid=1322”


StkInBlock 品种是否板块成员

函数 | StkInBlock
别名 | 品种是否板块成员
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 指定的品种是否属于板块
用法 | STKINBLOCK(STK,BLK) 品种代码STK参数表示的证券是否属于BLK板块,属于输出1否则为0 例如: STKINBLOCK(STKLABEL,'上海A股') STKINBLOCK('SH600000','金融板块')
来自“http://www.hs633.com/kthelp/index.php?title=StkInBlock_%E5%93%81%E7%A7%8D%E6%98%AF%E5%90%A6%E6%9D%BF%E5%9D%97%E6%88%90%E5%91%98&oldid=1323”


StkLabel 品种代码

函数 | StkLabet
别名 | 品种代码
所属类别 | 字符串函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取品种代码字符串
用法 | STKLABEL
来自“http://www.hs633.com/kthelp/index.php?title=StkLabel_%E5%93%81%E7%A7%8D%E4%BB%A3%E7%A0%81&oldid=1324”


StkLabelN 指定品种代码

函数 | StkLabelN
别名 | 指定品种代码
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取指定品种名称的代码字符串
用法 | STKLABELN(S),S为品种名称 例如： STKLABELN('浦发银行')返回600000
来自“http://www.hs633.com/kthelp/index.php?title=StkLabelN_%E6%8C%87%E5%AE%9A%E5%93%81%E7%A7%8D%E4%BB%A3%E7%A0%81&oldid=1325”


StkMarket MARKETLABEL, 市场代码

函数 | StkMarket
别名 | MARKETLABEL, 市场代码
所属类别 | 字符串函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取品种所在市场代码字符串
用法 | STKMARKET 例如: VAR1:=STRCMP(STKMARKET, 'SH')=0 输出1表示该品种为上交所证券
来自“http://www.hs633.com/kthelp/index.php?title=StkMarket_MARKETLABEL,_%E5%B8%82%E5%9C%BA%E4%BB%A3%E7%A0%81&oldid=1315”


StkName 品种名称

函数 | StkName
别名 | 品种名称
所属类别 | 字符串函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 取品种名称字符串
用法 | STKNAME
来自“http://www.hs633.com/kthelp/index.php?title=StkName_%E5%93%81%E7%A7%8D%E5%90%8D%E7%A7%B0&oldid=1326”


StkNameEx 指定品种名称

函数 | StkNameEx
别名 | 指定品种名称
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取指定品种代码的名称字符串
用法 | STKNAMEEX(S),S为品种代码 例如： STKNAMEEX('600000')或STKNAMEEX('SH600000') 返回浦发银行
来自“http://www.hs633.com/kthelp/index.php?title=StkNameEx_%E6%8C%87%E5%AE%9A%E5%93%81%E7%A7%8D%E5%90%8D%E7%A7%B0&oldid=1327”


StrCmp 字符串比较

函数 | StrCmp
别名 | 字符串比较
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 比较字符串
用法 | STRCMP(STR1, STR2) STR1>STR2输出1;STR1=STR2输出0;STR1例如: VAR1:=STRCMP(STKLABEL, '000001') 为0表示品种代码为000001
来自“http://www.hs633.com/kthelp/index.php?title=StrCmp_%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%AF%94%E8%BE%83&oldid=1328”


StrFind 查找字符串

函数 | StrFind
别名 | 查找字符串
所属类别 | 字符串函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 在字符串中查找另一个字符串
用法 | STRFIND(STR,S,N) 从字符串STR的第N个字符开始查找字符串S1, 返回找到的位置，若没有找到就返回0 例如: STRFIND('ABCDEF',UPPERSTR('cde'),1)返回3
来自“http://www.hs633.com/kthelp/index.php?title=StrFind_%E6%9F%A5%E6%89%BE%E5%AD%97%E7%AC%A6%E4%B8%B2&oldid=1330”


StrIcmp 字符串比较(不区分大小写)

函数 | StrIcmp
别名 | 字符串比较(不区分大小写)
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 比较字符串(不区分大小写)
用法 | STRICMP(STR1, STR2) STR1>STR2输出1;STR1=STR2输出0;STR1例如: VAR1:=STRICMP(USERNAME, 'FOX') 为0表示用户注册名为FOX或fox,Fox,FOx,FoX,fOX,fOx,foX
来自“http://www.hs633.com/kthelp/index.php?title=StrIcmp_%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%AF%94%E8%BE%83(%E4%B8%8D%E5%8C%BA%E5%88%86%E5%A4%A7%E5%B0%8F%E5%86%99)&oldid=1329”


StrLeft 字符串的左部

函数 | StrLeft
别名 | 字符串的左部
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得字符串的左边部分
用法 | STRLEFT(STR,N),返回字符串STR的左边N个字符 例如: EXPLAIN(1, STRLEFT(STKLABEL, 3)) 输出品种代码前3位
来自“http://www.hs633.com/kthelp/index.php?title=StrLeft_%E5%AD%97%E7%AC%A6%E4%B8%B2%E7%9A%84%E5%B7%A6%E9%83%A8&oldid=1331”


StrLen 字符串长度

函数 | StrLen
别名 | 字符串长度
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 取字符串长度
用法 | STRLEN(STR) 例如: check:=STRLEN(USERNAME)>0 为0表示用户注册名为空
来自“http://www.hs633.com/kthelp/index.php?title=StrLen_%E5%AD%97%E7%AC%A6%E4%B8%B2%E9%95%BF%E5%BA%A6&oldid=1332”


StrMid 字符串的中部

函数 | StrMid
别名 | 字符串的中部
所属类别 | 字符串函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 取得字符串的中间部分
用法 | STRMID(STR,N,M) 返回字符串STR的第N个字符开始的长度为M个字符的字符串,M为0则取到末尾 例如: EXPLAIN(1, STRMID('ABCDEF',3,3)) 输出CDE
来自“http://www.hs633.com/kthelp/index.php?title=StrMid_%E5%AD%97%E7%AC%A6%E4%B8%B2%E7%9A%84%E4%B8%AD%E9%83%A8&oldid=1333”


StrNcmp 部分字符串比较

函数 | StrNcmp
别名 | 部分字符串比较
所属类别 | 字符串函数
参数数量 | 3
运行模式 | 逐根/逐行
说明 | 指定长度比较字符串
用法 | STRNCMP(STR1, STR2, LEN) 例如: VAR1:=STRNCMP(STKNAME, 'ST', 2)=0 输出1表示该股为ST股
来自“http://www.hs633.com/kthelp/index.php?title=StrNcmp_%E9%83%A8%E5%88%86%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%AF%94%E8%BE%83&oldid=1334”


StrReplace 字符串替换

函数 | StrReplace
别名 | 字符串替换
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 替换字符串中的子字符串,返回替换后的字符串
用法 | StrReplace(str,oldValue,newValue) 为X1与X2的N周期的相关系数 例如:StrReplace('abcdefg', 'ef' , 'Hello') 返回 'abcdHellog'
来自“http://www.hs633.com/kthelp/index.php?title=StrReplace_%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%9B%BF%E6%8D%A2&oldid=1342”


StrRight 字符串的右部

函数 | StrRight
别名 | 字符串的右部
所属类别 | 字符串函数
参数数量 | 2
运行模式 | 逐根/逐行
说明 | 取得字符串的右边部分
用法 | STRRIGHT(STR,N) 返回字符串STR的右边N个字符 例如: EXPLAIN(1, STRRIGHT(STKLABEL, 3)) 输出品种代码后3位
来自“http://www.hs633.com/kthelp/index.php?title=StrRight_%E5%AD%97%E7%AC%A6%E4%B8%B2%E7%9A%84%E5%8F%B3%E9%83%A8&oldid=1335”


StrToNum 字符串转化为数字

函数 | StrToNum
别名 | 字符串转化为数字
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 将字符串转化为数字
用法 | STRTONUM(STR),将STR转化为数字 例如: STRTONUM('1.2345') 返回数值1.2345
来自“http://www.hs633.com/kthelp/index.php?title=StrToNum_%E5%AD%97%E7%AC%A6%E4%B8%B2%E8%BD%AC%E5%8C%96%E4%B8%BA%E6%95%B0%E5%AD%97&oldid=1336”


TplDataCount K线模板数据数量

函数 | TplDataCount
别名 | K线模板数据数量
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | K线模板数据数量
用法 | TPLDATACOUNT(TPLNAME) 例如: TPLDATACOUNT('一马平川');“一马平川”K线模板数据数量
来自“http://www.hs633.com/kthelp/index.php?title=TplDataCount_K%E7%BA%BF%E6%A8%A1%E6%9D%BF%E6%95%B0%E6%8D%AE%E6%95%B0%E9%87%8F&oldid=1337”


Trim 除去头尾空格

函数 | Trim
别名 | 除去头尾空格
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 除去字符串头尾空格
用法 | TRIM(STR) 例如: TRIM(' SH ') 返回SH
来自“http://www.hs633.com/kthelp/index.php?title=Trim_%E9%99%A4%E5%8E%BB%E5%A4%B4%E5%B0%BE%E7%A9%BA%E6%A0%BC&oldid=1314”


UpperStr 大写字符串

函数 | UpperStr
别名 | 大写字符串
所属类别 | 字符串函数
参数数量 | 1
运行模式 | 逐根/逐行
说明 | 将字符串转换为大写
用法 | UPPERSTR(STR) 例如: EXPLAIN(1, UPPERSTR('sh')) 输出SH
来自“http://www.hs633.com/kthelp/index.php?title=UpperStr_%E5%A4%A7%E5%86%99%E5%AD%97%E7%AC%A6%E4%B8%B2&oldid=1338”


Portfolio_CurrentCapital 组合可用资金

函数 | Portfolio_CurrentCapital
别名 | 组合可用资金
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 按当前周期开盘价计算的可用资金
用法 | Portfolio_CurrentCapital
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_CurrentCapital_%E7%BB%84%E5%90%88%E5%8F%AF%E7%94%A8%E8%B5%84%E9%87%91&oldid=1978”


Portfolio_CurrentEntries 组合开仓次数

函数 | Portfolio_CurrentEntries
别名 | 组合开仓次数
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合的当前开仓次数
用法 | Portfolio_CurrentEntries
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_CurrentEntries_%E7%BB%84%E5%90%88%E5%BC%80%E4%BB%93%E6%AC%A1%E6%95%B0&oldid=1982”


Portfolio_CurrentEquity 组合动态权益

函数 | Portfolio_CurrentEquity
别名 | 组合动态权益
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合的动态权益
用法 | Portfolio_CurrentEquity
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_CurrentEquity_%E7%BB%84%E5%90%88%E5%8A%A8%E6%80%81%E6%9D%83%E7%9B%8A&oldid=1980”


Portfolio_GrossLoss 组合总亏损

函数 | Portfolio_GrossLoss
别名 | 组合总亏损
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回组合累计的总亏损，该值为负数
用法 | Portfolio_GrossLoss
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_GrossLoss_%E7%BB%84%E5%90%88%E6%80%BB%E4%BA%8F%E6%8D%9F&oldid=1983”


Portfolio_GrossProfit 组合总盈利

函数 | Portfolio_GrossProfit
别名 | 组合总盈利
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合总盈利
用法 | Portfolio_GrossProfit
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_GrossProfit_%E7%BB%84%E5%90%88%E6%80%BB%E7%9B%88%E5%88%A9&oldid=1984”


Portfolio_InitCapital 组合初始资金

函数 | Portfolio_InitCapital
别名 | 组合初始资金
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 获得投资组合的初始资金。
用法 | Portfolio_InitCapital
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_InitCapital_%E7%BB%84%E5%90%88%E5%88%9D%E5%A7%8B%E8%B5%84%E9%87%91&oldid=1977”


Portfolio_InvestedCapital 组合占用资金

函数 | Portfolio_InvestedCapital
别名 | 组合占用资金
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 期货为被占用的保证金，股票为投入资金额
用法 | Portfolio_InvestedCapital
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_InvestedCapital_%E7%BB%84%E5%90%88%E5%8D%A0%E7%94%A8%E8%B5%84%E9%87%91&oldid=1981”


Portfolio_MaxDrawdownRatio 组合最大资产回撤比例

函数 | Portfolio_MaxDrawdownRatio
别名 | 组合最大资产回撤比例
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回组合最大资产回撤比例，该值为0或负数
用法 | Portfolio_MaxDrawdownRatio
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_MaxDrawdownRatio_%E7%BB%84%E5%90%88%E6%9C%80%E5%A4%A7%E8%B5%84%E4%BA%A7%E5%9B%9E%E6%92%A4%E6%AF%94%E4%BE%8B&oldid=1991”


Portfolio_MaxIdDrawdown 组合最大资产回撤

函数 | Portfolio_MaxIdDrawdown
别名 | 组合最大资产回撤
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回组合最大资产回撤，该值为0或负数
用法 | Portfolio_MaxIdDrawdown
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_MaxIdDrawdown_%E7%BB%84%E5%90%88%E6%9C%80%E5%A4%A7%E8%B5%84%E4%BA%A7%E5%9B%9E%E6%92%A4&oldid=1990”


Portfolio_NetProfit 组合净利润

函数 | Portfolio_NetProfit
别名 | 组合净利润
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回累计的净利润
用法 | Portfolio_NetProfit
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_NetProfit_%E7%BB%84%E5%90%88%E5%87%80%E5%88%A9%E6%B6%A6&oldid=1985”


Portfolio_NumLossTrades 组合盈利交易次数

函数 | Portfolio_NumLossTrades
别名 | 组合盈利交易次数
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合盈利交易次数
用法 | Portfolio_NumLossTrades
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_NumLossTrades_%E7%BB%84%E5%90%88%E7%9B%88%E5%88%A9%E4%BA%A4%E6%98%93%E6%AC%A1%E6%95%B0&oldid=1988”


Portfolio_NumWinTrades 组合盈利交易次数

函数 | Portfolio_NumWinTrades
别名 | 组合盈利交易次数
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 返回盈利交易的总次数
用法 | Portfolio_NumWinTrades
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_NumWinTrades_%E7%BB%84%E5%90%88%E7%9B%88%E5%88%A9%E4%BA%A4%E6%98%93%E6%AC%A1%E6%95%B0&oldid=1987”


Portfolio_OpenPositionProfit 组合浮动盈亏

函数 | Portfolio_OpenPositionProfit
别名 | 组合的浮动盈亏
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合的浮动盈亏
用法 | Portfolio_OpenPositionProfit
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_OpenPositionProfit_%E7%BB%84%E5%90%88%E6%B5%AE%E5%8A%A8%E7%9B%88%E4%BA%8F&oldid=1979”


Portfolio_PercentProfit 组合胜率

函数 | Portfolio_PercentProfit
别名 | 组合胜率
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合胜率
用法 | Portfolio_PercentProfit
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_PercentProfit_%E7%BB%84%E5%90%88%E8%83%9C%E7%8E%87&oldid=1989”


Portfolio_StratEgyDrawdown 组合当前资产回撤

函数 | Portfolio_StratEgyDrawdown
别名 | 组合当前资产回撤
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合当前资产回撤
用法 | Portfolio_StratEgyDrawdown
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_StratEgyDrawdown_%E7%BB%84%E5%90%88%E5%BD%93%E5%89%8D%E8%B5%84%E4%BA%A7%E5%9B%9E%E6%92%A4&oldid=1992”


Portfolio_TotalTrades 组合交易次数

函数 | Portfolio_TotalTrades
别名 | 组合交易次数
所属类别 | 组合测评函数
参数数量 | 0
运行模式 | 逐根/逐行
说明 | 组合交易次数
用法 | Portfolio_TotalTrades
来自“http://www.hs633.com/kthelp/index.php?title=Portfolio_TotalTrades_%E7%BB%84%E5%90%88%E4%BA%A4%E6%98%93%E6%AC%A1%E6%95%B0&oldid=1986”


移动平均线MA

主图指标

绘制收盘价的P1日、P2日、P3日、P4日、P5日、P6日、P7日、P8日移动平均线

P1、P2、P3、P4一般取5日、10日、20日、60日

N选择主图显示多少条均线（最多同时显示8条）

用法：

葛氏八法则

1.短期均线向上穿越长期均线，多头买入信号

2.短期均线向下跌破长期均线，多头卖出信号

M1:MA(CLOSE,P1);
M2:MA(CLOSE,P2)*if(n<2,INVALID,1);
M3:MA(CLOSE,P3)*if(n<3,INVALID,1);
M4:MA(CLOSE,P4)*if(n<4,INVALID,1);
M5:MA(CLOSE,P5)*if(n<5,INVALID,1);
M6:MA(CLOSE,P6)*if(n<6,INVALID,1);
M7:MA(CLOSE,P7)*if(n<7,INVALID,1);
M8:MA(CLOSE,P8)*if(n<8,INVALID,1);

Moving Average，简称MA，原本的意思是移动平均，由于我们将其制作成线形，

所以一般称之为移动平均线，简称均线。它是将某一段时间的收盘价除以该周期。

比如日线MA5指5天内的收盘价除以5 。

详见 [[1]]

来自“http://www.hs633.com/kthelp/index.php?title=%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87%E7%BA%BFMA&oldid=586”


布林通道BOLL

BOLL带绘制支撑线(LOWER)、阻力线(UPER)、中线(MID)。

MID：收盘价的N1日移动平均

UPER：中线加偏移值

LOWER：中线减偏移值

参数：

M　设定统计天数 ，一般为26

N　设定BOLL带宽度，一般为2

用法：

1.股价上升穿越布林线上限时，回档机率大。

2.股价下跌穿越布林线下限时，反弹机率大。

3.布林线震动波带变窄时，表示变盘在即。

公式代码:

Input:
  M(26,5,300,1),
  N(2,1, 10, 1);
 MID :  MA(CLOSE,M);
 UPPER: MID + N*STD(CLOSE,M);
 LOWER: MID - N*STD(CLOSE,M);
来自“http://www.hs633.com/kthelp/index.php?title=%E5%B8%83%E6%9E%97%E9%80%9A%E9%81%93BOLL&oldid=858”


指数平滑异同移动平均线MACD

算法：

DIFF线　收盘价短期、长期指数平滑移动平均线间的差

DEA线　 DIFF线的M日指数平滑移动平均线

MACD线　DIFF线与DEA线的差，彩色柱状线

参数：S(短期)、P(长期)、M 天数，一般为12、26、9

用法：

1.DIF向上交叉MACD，买进；DIF向下交叉MACD，卖出。

2.DIF连续两次向下交叉MACD，将造成较大的跌幅。

3.DIF连续两次向上交叉MACD，将造成较大的涨幅。

4.DIF与股价形成背离时产生的信号，可信度较高。

Input:
  P(26,20,100,1),
  S(12,5,40,1),
  M(9,2,60,1);
DIFF : EMA(CLOSE,S) - EMA(CLOSE,P);
DEA  : EMA(DIFF,M);
MACD : 2*(DIFF-DEA), COLORSTICK;
来自“http://www.hs633.com/kthelp/index.php?title=%E6%8C%87%E6%95%B0%E5%B9%B3%E6%BB%91%E5%BC%82%E5%90%8C%E7%A7%BB%E5%8A%A8%E5%B9%B3%E5%9D%87%E7%BA%BFMACD&oldid=859”


相对强弱指标RSI

算法：

相对强弱值＝N日内收盘价上涨幅度总和／下跌幅度总和

RSI线：100-100/(1+相对强弱值)

参数：N1、N2、N3　统计天数，一般取6、12、24

用法：

1．RSI>20为超买；RSI<20为超卖。

2.RSI以50为中界线，大于50视为多头行情，小于50为空头行情。

3.RSI在80以上形成M头或头肩顶形态时，视为向下反转信号。

4.RSI在20以下形成W底或头肩底形态时，视为向上反转信号。

5.RSI向上突破其高点连线时，买进；RSI跌破其低点连线时，卖出。

Input:
  N1(6,2,100,1),
  N2(12,2,100,1),
  N3(24,2,100,1);

LC := REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI2:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
RSI3:SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;
来自“http://www.hs633.com/kthelp/index.php?title=%E7%9B%B8%E5%AF%B9%E5%BC%BA%E5%BC%B1%E6%8C%87%E6%A0%87RSI&oldid=862”


随机指标KDJ

1. 指标>80 时，回档机率大；指标<20 时，反弹机率大。

2. K在20左右向上交叉D时，视为买 进信号。

3. K在80左右向下交叉D时，视为卖出信号。

4. J>100 时，股价易反转下跌；J<0 时，股价易反转上涨。

5. KDJ 波动于50左右的任何信号，其作用不大。

Input:
  N(9,1,100,1),
  P1(3,2,40,1),
  P2(3,2,40);

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,P1,1);
D:SMA(K,P2,1);
J:3*K-2*D;
来自“http://www.hs633.com/kthelp/index.php?title=%E9%9A%8F%E6%9C%BA%E6%8C%87%E6%A0%87KDJ&oldid=861”


交易指令基础

智能交易攻略（1）-交易指令基础

作者：仁心慧能

博庭公司推出的量化软件继承了飞狐交易师优秀的技术分析功能，并且增加了许多新特性，

尤其是在公式系统和程序化交易方面，祝愿再创辉煌！

软件用于编写公式的语言称为金语言(KingLanguage,KL)，它有许多增强的特性，我们将逐步讲解。

软件在公式树中增设了一项新的智能交易公式类型，它与旧的交易系统公式相似而又不同。

旧交易系统的范式是：交易信号: 条件表达式

新智能交易的范式是：If 条件表达式Then 交易指令

与交易系统的四种信号对应，新智能交易也有四种基本指令，如下所示：

交易类别：老交易系统信号 –> 新智能交易指令

开多、多头开仓、买入开仓、买入：ENTERLONG–> Buy

平多、多头平仓、卖出平仓、卖出：EXITLONG–> Sell

开空、空头开仓、卖出开仓、空头卖出：ENTERSHORT–> SellShort

平空、空头平仓、买入平仓、空头回补：EXITSHORT–> BuyTocover

旧交易系统只能定义交易信号，但无法在公式中进行仓位控制等复杂操作。

新智能交易公式可以通过交易指令的参数以及许多交易相关函数进行各式各样的精细控制。

最好的学习方法是多实践。让我们开始创建公式，在公式树【智能交易】下【新建文件夹】，

命名为“攻略”，然后在其下【新建公式】，输入名称“例1_1”，确定后，出现公式编辑器，输入以下源代码：

   //-------智能交易公式--------------
   //例1_1 均线交叉延时过滤买卖策略
   {策略：
   1.收盘价金叉30周期均线，且在其上延时几个周期后买入
   2.收盘价死叉30周期均线，且在其下延时几个周期后卖出
   3.外部参数切换多种类型均线
   }
   input:
     均线周期数(30,5,200,5), //缺省值,最小值,最大值,步长
     延时周期数(0,0,6,1), 均线类型(1,1,5,1);
   switch 均线类型 begin
     case 1: MA1 := MA(C,均线周期数);
     case 2: MA1 := MA((H+L+C)/3,均线周期数);
     case 3: MA1 := EMA(C,均线周期数);
     case 4: MA1 := WMA(C,均线周期数);
     case 5: MA1 := SMA(C,均线周期数,1);
   end
   Plot(MA1,'均线'); //显示均线
   bEnterLong := BarsLast(Cross(C, MA1))=延时周期数 And C>MA1;
   bExitLong := BarsLast(Cross(MA1,C))=延时周期数 And C<MA1;
   if bEnterLong then Buy;
   if bExitLong then Sell;
   {
   注解:
   1.用 input 语句声明公式参数，好处是便于修改、复制。
     其中的最小值、最大值、步长用于今后的参数优化。
   2.均线类型在外部参数设置，可用于参数优化
     公式中用 switch case语句选用均线类型
   3.Plot函数输出指标线到主图
   4.交易条件先赋给 bEnterLong 等中间变量，便于今后修改、替换，
     但语句多了影响运行效率，若执行速度很重要，就直接把条件表达式写在If后。
   5.Buy类交易函数其实有很多参数，但从后到前可以取缺省值不用写出}

编写好公式后，点击工具栏第1个按钮进行编译，如果无误，编译信息窗会提示编译通过，这就可以应用公式了。

此时可以看到“攻略”文件夹下多了个“例1_1”公式，双击它或拖放到主图上，这时出现【策略设置】，

有【属性】【自动交易】【公式参数】三个页面，先初略看看，不管细节，点确定后：

可以看到，收盘价上穿均线后的次周期开盘价出现紫色的三角箭头指示买入价位，

收盘价下穿均线后的次周期开盘价出现反向的三角箭头指示卖出价位，这两个箭头间紫色连线表示这笔交易盈利，

蓝色则表示亏损。把鼠标移到三角箭头，出现浮动信息窗，可以看到交易详情，包括数量、价格、开平仓配对等信息。

在主图左上角公式名称处，右键菜单【查看测评报告】，选择【交易明细】页面，可以看到交易详情：

在主图左上角公式名称处，右键菜单【策略设置】，点选【公式参数】页面，修改这3个参数的值，

点确定后看看均线和交易信号发生了什么变化？

本软件的智能交易公式可输出指标线以及画线、文字等对象，便于核对交易信号与指标线的关系、提示报警等，

甚至可直接代替技术指标等其它类型的公式。与飞狐公式逐行执行不同，它的运行模式是逐根计算的，才能实现复杂的仓位控制。

我们看到期指主连的K线图下边有复权标记，这是因为股指期货存在换月价差，为了走势的连续性和指标、测评的正确性，

需要做复权处理，把鼠标移到复权标记处可看到换月价差信息。

Buy、Sell表示操作股票时的买入、卖出，如果我要操作期货呢？既做多也做空，我们试试下面的公式：

   //-------智能交易公式--------------
   //例1_2  自适应均线转向多空策略
   {策略：
   1.自适应均线上拐一定幅度后，平空反手开多
   2.自适应均线下拐一定幅度后，平多反手开空
   }
   input:
     N(10), Pct(0.05);
   AMA1: AdaptiveMovAvg(C, N, 2, 30);
   bEnterLong := (AMA1[0]/AMA1[1])>(100+Pct)/100;
   bEnterShort := (AMA1[0]/AMA1[1])<(100-Pct)/100;
   if bEnterLong then Buy;
   if bEnterShort then SellShort;
   {
   注解：
   1.AdaptiveMovAvg为自适应移动平均线，其参数FL=2,SL=30为Kaufman在其《精明交易者》中所用的数值
   2.序列下标表示K线位置，AMA1[0]表示取当前周期的值，AMA1[1]表示取前一个周期的值
   3.当AMA1上升且大于前值百分之Pct时买多，反之卖空
   }

有图有真相：

如图所示，多了蓝色箭头表示空头交易，我们发现，多头平仓交易与空头开仓交易同时执行，查看交易明细证实了这一点。

这是因为：

1、 单一策略只能持多仓、持空仓、无持仓三种状态，不允许多空双向同时持仓。

2、 某交易指令开仓时，如果已有反向持仓，先自动平掉旧仓再反手开新仓。

本例在市场中始终持仓，空头开仓时会自动先平掉原有的多头持仓，反之亦然。多空交易交错发生，不需要写平仓指令。

这种机制使得编写公式特别简洁，如果允许同时持有多头和空头仓，公式的逻辑和函数、语句将变得很复杂，难以掌握。

虽然单一策略不能同时有多头和空头的持仓，但不同策略可以持有不同方向的仓位，例如策略A持有多头，策略B持有空头，

它们互不干扰，而且，不同的策略可以编写在同一个公式文件中，如何实现？敬请持续关注本攻略！

以上例子属于趋势交易策略，我们再试试用布林通道实现振荡交易策略。

   //-------智能交易公式--------------
   //例1_3  布林通道振荡策略
   {策略：
   1.最低价低于下轨后开多，最高价高于中线后平多
   2.最高价高于上轨后开空，最低价低于中线后平空
   3.可连续同向开仓3次
   }
   input:
     M(20,5,200,5), N(2), S(3);
   //计算布林通道
   Mid : MA(C,M);
   Upper: Mid + N*STD(C,M);
   Lower: Mid - N*STD(C,M);

   AllowSameEntries(S);
   bEnterLong := L < Lower;  //多头开仓条件
   bExitLong := H > Mid;     //多头平仓条件
   bEnterShort := H > Upper; //空头开仓条件
   bExitShort := L < Mid;    //空头平仓条件
   if bEnterLong then Buy;
   if bExitLong then Sell;
   if bEnterShort then SellShort;
   if bExitShort then BuyToCover;
   {
   注解:
   1.AllowSameEntries函数设置允许连续同向开仓最大次数
     默认不能连续开同向仓}

有图有真相：

如图所示，可以用AllowSameEntries函数控制同方向连续开仓的最大次数，如果没有用到这个函数，

或者把S参数设置为1，则在已有持仓情况下，不再连续开同方向的仓，大家可以试试。默认不能连续开同向仓，

也是为了使大多数策略的公式编写简单，逻辑清晰。

从以上的例子，我们知道，不带任何参数的交易指令是在信号发生的下一周期开盘时进行交易的，

因为本周期收盘时才能确定信号最终不变的状态，但那一瞬间却是下不到单的。

在公式编辑器中把鼠标移到Buy函数名处，出现浮动信息窗，看到函数说明，我们发现其实它有很多参数，

如何应用这些参数？如何使用其它的下单方式、控制下单时机、价位和数量吗？如果想在收盘时下单怎么办呢？

另外，默认的交易数量是如何定的呢？回想起【策略设置】中有“委托数量”的设置，是在那里设置的吗？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E4%BA%A4%E6%98%93%E6%8C%87%E4%BB%A4%E5%9F%BA%E7%A1%80&oldid=1716”


交易指令进阶

智能交易攻略（2）-交易指令进阶

作者：仁心慧能

以多头开平仓函数为例：

Buy('Symbol'=,Size=DEFAULT,Price=0,Slippage=0,OT=OT_MARKET,OB=OB_NEXTBAR,EntryName=)

Sell('Symbol'=,Size=DEFAULT,Price=0,Slippage=-1,OT=OT_MARKET,OB=OB_NEXTBAR,ExitName=)<from 'EntryName'>

括号里面表示函数的参数，之所以见到有赋值，表示如果不写这个参数，其默认值为等号后面的值，实际应用时填入需要指定的值，而不是写赋值语句。

例如：

Buy; 等价于 Buy(, DEFAULT, 0, 0,OT_Market, OB_NextBar, );

Buy(,2); 等价于 Buy(, 2, 0, 0,OT_Market, OB_NextBar, );

Buy(,2, 0,1); 等价于 Buy(, 2, 0, 1,OT_Market, OB_NextBar, );

Buy(,2, 1000,0,OT_LIMIT); 等价于 Buy(, 2, 1000, 0,OT_LIMIT, OB_NextBar, );

也就是说，如果你不写从后到前的参数，系统会自动替你填进那些参数，怎么填呢？

就是格式中等号后面的那些值。

平仓函数后有尖括号括起来的<from 'EntryName'>，表示这是可选的，需要用到时才写。

这类函数可以设置交易商品、委托类型、时机、数量、价格、滑移价差，还可以指定一个开仓名EntryName，

用于标识不同的交易信号所开的仓，以及今后的单独控制；平仓函数则可指定一个平仓名ExitName，

并且用from 表示平其中某种信号开的仓。

函数的参量后若有等号，表示等号后的值是默认值，这样的参数按照从后到前的顺序，可以省略不写。

省略所有参数的交易指令，其委托数量是取用【策略设置】中的数值，可以为固定数量，也可以由资金自动计算下单量。

缺省的交易时机和类型是次周期(OB_NEXTBAR)市价单(OT_MARKET)，市价单是要求立即成交的委托单，

次周期市价单在历史测评时以下一周期的开盘价作为委托成交价，在实际交易中以周期开始时的市价下单，

委托价格一般在买入时为卖一价，卖出时为买一价，有时再加减允许的滑移价差，以保证立即成交。

更详细的参数说明可参看公式编辑器里的函数说明，我们还是多做些实验吧。

   //-------智能交易公式--------------
   //例2_1 一目均衡多空策略
   {策略：
   1.转换线金叉基准线，本周期收盘时平空反手做多
   2.转换线死叉基准线，本周期收盘时平多反手做空
   3.多头自开仓20周期后平仓
   }
   input:
     SN(26), FN(9);
   基准线: (HHV(H,SN)+LLV(L,SN))/2;
   转换线: (HHV(H,FN)+LLV(L,FN))/2;
   bEnterLong := CrossOver(转换线, 基准线);
   bEnterShort := CrossUnder(转换线, 基准线);
   if bEnterLong then Buy(, DEFAULT, 0, 0, OT_CLOSE, OB_THISBAR);
   if bEnterShort then SellShort (, DEFAULT, 0, 0, OT_CLOSE, OB_THISBAR);
   if BarsSinceEntry(0) >= 20 then Sell;
   if BarsSinceEntry(0) >= 20 then BuyToCover;
   {
   注解:
   1.CrossOver函数等同于Cross函数
   2.开仓DEFAULT指定的下单量为[策略设置]中的委托数量
     平仓函数里的DEFAULT表示全部平仓
   3.OT_CLOSE 与 OB_THISBAR 配合指定本周期收盘时交易，历史回测时以本周期收盘价作为成交价格，
      实盘自动交易时，对于分钟线周期，其实是在本周期结束，下一周期开始时下市价单的，
      对于日线周期，或者对于分钟线当天收盘的最后一个周期，
      则下单时机在[策略设置]-[自动交易]中的“日收盘交易在(n)秒前下单”指定。
   }

有图有真相：

对于例1_3的布林通道振荡策略，若想在价格达到上下轨或均线时下单，公式如下：

   //-------智能交易公式--------------
   //例2_2  布林通道振荡策略之二
   {策略：
   1.价格跌至下轨时开多，价格升至中线时平多
   2.价格升至上轨时开空，价格跌至中线时平空
   }
   input:
     M(20,5,200,5), N(2), S(3);
   Mid :  MA(C,M);
   Upper: Mid + N*STD(C,M),Shift1;
   Lower: Mid - N*STD(C,M),Shift1;
   Buy(, 1, Lower, 0, OT_LIMIT);
   Sell(, 1, Mid, 0, OT_LIMIT);
   SellShort(, 1, Upper, 0, OT_LIMIT,OB_NEXTBAR);
   BuyToCover(, 1, Mid, 0, OT_LIMIT,OB_NEXTBAR);
   {
   注解：
   1.Shift1 使指标线向右偏移1个周期，使得它显示时与NEXTBAR的交易时机对上。
   }

有图有真相：

如图所示，当价格跌到前周期的下轨值时买入，然后价格达到前周期的均线值时卖出，

因本周期未结束时，指标值是不定的，所以我们用上一周期的指标值，那么，交易指令的OB参数还是OB_NEXTBAR，

可省略，表示在下一周期用本周期的指标值下单，下单类型为OT_LIMIT限价单，限定价格Price参数为布林线下轨Lower等指标值。

这个策略在行情盘整时看起来不错，但在趋势行情时会亏损，那么，我们再来个反向操作策略，并且把布林通道改为肯特纳(Keltner)通道，

公式如下：

   //-------智能交易公式--------------
   //例2_3  肯特纳(Keltner)通道趋势策略
   {策略：
   1.价格升破上轨时开多，价格跌至中线时平多
   2.价格跌破下轨时开空，价格升至中线时平空
   }
   input:
     M(20,5,200,5), N(2);
   Mid :  EMA(C,M);
   Upper: Mid + N*ATR(10),Shift1;
   Lower: Mid - N*ATR(10),Shift1;
   Comment('突破买入价: ', Upper[1]:8:2), ColorRed;
   Comment('突破卖空价: ', Lower[1]:8:2), ColorBlue;
   Buy(, 2, Upper+MinDiff, -1, OT_STOP);
   Sell(, DEFAULT, Mid, -1, OT_STOP);
   SellShort(, 2, Lower-MinDiff, -1, OT_STOP);
   BuyToCover(, DEFAULT, Mid, -1, OT_STOP);
   {
   注解：
   1.ATR(10)为10周期平均真实波幅，均线加减ATR倍数即形成肯特纳(Keltner)通道
   2.Comment('突破买入价: ', Upper[1]:8:2)在主图左上角显示提示信息，
     此处指定输出的数字串为8个字符长度，带2位小数;可以指定颜色
   3.平仓函数委托数量为DEFAULT表示全部平仓
   }

运行结果如下图：

如图所示，这次的开平仓正好和前例是反着的，因为下单类型为OT_STOP停损单，它与限价单正好是相反的，

当我们要买入时，限价单是埋在当前市价的下方，等待价格下跌到限价时成交，而停损单是在当前市价的上方，

等待价格向上突破时成交。卖出时方向相反。对于停损单这个术语，卖出停损容易明白，对于买入开仓，

可以这样理解，因为我是要买入的，价格在不断往上行，少赚也是一种亏损，所以在价格升到一定位置时买入“停损”。

需要注意的是，停损价之后的Slippage参数都被设为-1，这表示只要价格突破停损价就交易，例如次日跳空高开，

不管多高都要买入。如果要限制交易价格，太高了就不买入，那就设置Slippage参数为允许的范围，这种单叫做停损限价单，

请自行修改测试。

这次我们在公式的交易指令函数中指定委托数量为2，可以把鼠标移到交易箭头处或查看测评报告中的交易明细。

以上的趋势和振荡策略实例在贴图中都用于日线周期，自动交易常用于日内交易，这类公式有些什么特殊的编制技巧呢？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E4%BA%A4%E6%98%93%E6%8C%87%E4%BB%A4%E8%BF%9B%E9%98%B6&oldid=1717”


日内交易之开盘区间突破

智能交易攻略（3）-日内交易之开盘区间突破

作者：仁心慧能

日内交易常用的一类策略是开盘区间突破，它与前例的通道突破策略相似，其基本公式是：

   //-------智能交易公式--------------
   //例3_1 开盘区间突破策略
   //用于分钟线周期
   {策略：
   1.当日开盘价加减指定价差形成区间
   2.突破区间高点做多，跌破区间低点做空
   3.当天仅做多1次，做空1次
   4.日内交易，收盘前清仓
   }
   input:
     Rng(10),        //区间范围
     EndTime(1400);  //下午14:00以后不开仓
   RngH: OpenD(0) + Rng;
   RngL: OpenD(0) - Rng;
   if Time < EndTime*100 then begin
     if EntriesToday(Date,MP_LONG)<1 then
       Buy(, 2, RngH, -1, OT_STOP);
     if ExitsToday(Date,MP_SHORT)<1 then
       SellShort(, 2, RngL, -1, OT_STOP);
   end;
   SetExitOnClose;
   {
   注解：
   1.OpenD(0)返回当日开盘价，这套函数在日内交易时方便常用；
   2.EntriesToday(Date,MP_LONG)取得当天多头开仓次数，MP_LONG 是值为1的宏；
   3.ExitsToday (Date,MP_SHORT)取得当天空头平仓次数，MP_SHORT 是值为-1的宏；
   4.SetExitOnClose用于在收市时清仓，历史测评时以收盘价作为平仓价，自动交易时在收市前若干秒平仓，
   可在【策略设置】中设置，默认在收市前60秒清仓。
   }

如图所示，该策略以当日开盘价加减由Rng参数指定的范围，形成一个区间，当价格突破区间时进场交易，收盘时清仓不过夜。

上例的区间范围Rng是个常数，不能适应市场变动，所以Rng通常用各种算法得到，例如，

著名的Dual Thrust系统曾长期在交易系统排行榜名列三甲，其原始公式应用于日线周期，不太能如实反映日内波动，

我们把它改造为应用于分钟周期的策略：

   //-------智能交易公式--------------
   //例3_2 Dual Thrust日内策略
   //用于1分钟-15分钟周期
   {策略：
   1.根据前几日的波动范围动态调整开盘区间
   2.突破区间高点做多，跌破区间低点做空
   3.可选是否持仓过夜
   }
   input:
     K1(0.5),K2(0.5),Mday(1),Nday(1),
     ExitOnClose(1);
   variable:
     BarsPerDay(48), BuyRange(1000), SellRange(1000);
   if BarPos = 1 then begin  //只需计算1次
     switch DataPeriod begin   //沪深300股指期货日周期数
       case 1: BarsPerDay:=270; //1分钟周期数/每日
       case 2: BarsPerDay:=54;  //5分钟周期数/每日
       case 3: BarsPerDay:=18;  //15分钟周期数/每日
     end
   end
   Bars:= Mday*BarsPerDay;
   MHH := HHV(H,Bars)[1];
   MHC := HHV(C,Bars)[1];
   MLL := LLV(L,Bars)[1];
   MLC := LLV(C,Bars)[1];
   Bars:= Nday*BarsPerDay;
   NHH := HHV(H,Bars)[1];
   NHC := HHV(C,Bars)[1];
   NLL := LLV(L,Bars)[1];
   NLC := LLV(C,Bars)[1];

   if Date <> Date[1] then begin  //新交易日开始，计算区间范围
     BuyRange := Max(MHH - MLC, MHC - MLL);
     SellRange := Max(NHH - NLC, NHC - NLL);
   end
   RngH: OpenD(0) + K1*BuyRange;
   RngL: OpenD(0) - K2*SellRange;

   if SessionLastBar = 0 then begin
     Buy(, DEFAULT, RngH, -1, OT_STOP,OB_NEXTBAR);
     SellShort(, DEFAULT, RngL, -1, OT_STOP,OB_NEXTBAR);
   end
   if ExitOnClose then SetExitOnClose;
   {
   注解：
   1.用不同的参数分别设置买卖区间的幅度
   2.BarsPerDay为1天的K线数量，只需在第1根K线时计算1次
     用switch语句根据周期类型赋值，公式中是股指期货的每日周期数量
   3.HHV(H,Bars)[1]表示取用前一周期的指标值
     可以把之前的:=改为:进行调试
   4.SessionLastBar函数用于判断是否是当日最后一个周期
   5.外部参数ExitOnClose控制是否做日内交易或持仓过夜
   }

如图所示：

可见，在同一时间段，本例的区间与上例相比较是动态变化的，各位可以修改公式参数看看运行结果。

在实际交易中，分批开平仓是常用的技巧，如何实现呢？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E6%97%A5%E5%86%85%E4%BA%A4%E6%98%93%E4%B9%8B%E5%BC%80%E7%9B%98%E5%8C%BA%E9%97%B4%E7%AA%81%E7%A0%B4&oldid=1766”


分批开平仓

智能交易攻略（4）-分批开平仓

作者：仁心慧能

分批开平仓不仅要求可以根据不同的信号连续进场，然后对分次开出的仓位分别控制，

另外，用不同的止盈目标位分批出场也是常用的技巧，我们来看一个实例，公式如下：

   //-------智能交易公式--------------
   //例4_1 区间突破分批策略
   {策略：
   1.允许连续买入2次
   2.突破20周期高点买入1次，该仓位命名为'Buy1'
   3.突破50周期高点买入1次，该仓位命名为'Buy2'
   4.跌破10周期低点卖出'Buy1'的仓位
   5.跌破25周期低点卖出'Buy2'的仓位
   }
   Buy1: HHV(H,20),Shift1;
   Buy2: HHV(H,50),Shift1;
   Sell1: LLV(L,10),Shift1;
   Sell2: LLV(L,25),Shift1;
   AllowSameEntries(2);
   //if EntryName <> 'Buy1' then
     Buy(,1,Buy1+MinDiff,-1,OT_STOP,OB_NEXTBAR,'Buy1');
   //if EntryName <> 'Buy2' then
     Buy(,1,Buy2+MinDiff,-1,OT_STOP,OB_NEXTBAR,'Buy2');
   Sell(,1,Sell1,-1,OT_STOP,OB_NEXTBAR,'Sell1') from 'Buy1';
   Sell(,1,Sell2,-1,OT_STOP,OB_NEXTBAR,'Sell2') from 'Buy2';
   {
   注解：
   1.MinDiff 为价格最小变动单位。
   2.用EntryName函数识别已有哪个信号的仓位。
     但因为即使允许连续同向开仓，也不允许连续开相同开仓名的仓，
     所以，EntryName判断已有哪种信号持仓的语句可以不用。
   3.平仓指令函数后用from指定平掉哪个信号的仓位。
   }

有图有真相：

右键菜单【查看测评报告】的交易明细：

可见，Sell1与Buy1、Sell2与Buy2分别一一配对，这样我们就可分别控制不同的仓位。

再看一个早盘区间突破分批平仓日内交易策略，公式如下：

   //-------智能交易公式--------------
   //例4_2 早盘区间突破分批平仓策略
   //用于5分钟周期
   {策略:
   1.根据上午10点前的价格波动范围画出最高价水平线
   2.下午14点前，价格突破区间高点买入2口
   3.跌破买入价以下20点清仓止损
   4.涨至买入价以上30点止盈其中1口
   5.当天若有亏损交易，不再开新仓
   6.日内交易，收市前清仓
   }
   input:
     早盘终点时间(1000), //10:00
     开仓结束时间(1400); //14:00
   variable:
     ID(-1);  //趋势线标识号，赋初值-1
   if Date <> Date[1] then begin  //新交易日开始
     RngH := High;
     ID := TL_new(Date,Time,RngH,Date,Time,RngH);  //新建画线
   end

   if Time < 早盘终点时间*100 then begin //上午10:00前的最高价作为区间高点
     RngH := Max(High, RngH);
   end

   //随时间调整区间高点水平线
   TL_SetBegin(ID, TL_GetBeginDate(ID), TL_GetBeginTime(ID), RngH);
   TL_SetEnd(ID, Date, Time, RngH);

   bTradeTime := Time >= 0955*100 And Time < 开仓结束时间*100; //交易时间
   if bTradeTime And DailyLosers(Date,0)<1 then //
     Buy(, 2, RngH, -1, OT_STOP, OB_NEXTBAR, '买入');
   if MarketPosition = 1 then  begin  //若持多头仓
     Sell(, DEFAULT, EntryPrice - 20, -1, OT_STOP, OB_NEXTBAR, '止损');
     if CurrentContracts = 2 then
       Sell(, 1, EntryPrice + 30, 0, OT_LIMIT, OB_NEXTBAR, '止盈');
   end
   SetExitOnClose; //收市前清仓
   {
   注解:
   1.画线函数TL_New、TL_SetBegin、TL_SetEnd用于画出区间通道
   2.5分钟周期，9:55 的下一个周期开始交易
     本软件以K线开始时间作为K线的时间
   3.DailyLosers(Date,0)取得当日亏损交易次数
   4.EntryPrice为开仓价，对多头开仓而言就是买入价
   5.CurrentContracts取得当前持仓数量
   }

有图有真相：

右键菜单【查看测评报告】的交易明细：

可见，开仓2口的单被拆成2笔，1笔止盈，1笔日内交易平仓。

从这个公式，我们可以看出它逐根计算的机制：在每天开盘的那根K线创建1条新的趋势线，

然后随着下1根K线的不断增加，调整趋势线的起点和终点。

以上介绍了仓位控制的方法，还有哪些风险控制的技巧呢？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E5%88%86%E6%89%B9%E5%BC%80%E5%B9%B3%E4%BB%93&oldid=1770”


指标背离交易及风险控制策略

智能交易攻略（5）-指标背离交易及风险控制策略

作者：仁心慧能

缠论等交易理论重视指标背离时的交易信号，请看如何实现：

   //-------智能交易公式--------------
   //例5_1 指标背离买入风险控制策略
   {策略:
   1、RSI指标上穿25且与价格形成底背离时买入，不采用指标平仓，而是
   2、综合运用止盈、止损、保本平仓、跟踪止损、盘整平仓等风险控制技术
   }
   input:
     波谷强度(3),//用于找波谷并判断背离
     止损价差(35),
     止赢价差(100),
     保本启动价差(20),
     跟踪启动价差(30),
     跟踪回撤价差(20),
     跟踪回撤幅度(20),
     盘整最大价差(5),
     盘整周期数(5),
     使用价差(1), //开关控制使用价差或金额参数
     止损金额(10000),
     止赢金额(30000),
     保本启动金额(6000),
     跟踪启动金额(9000),
     跟踪回撤金额(6000);
     //计算RSI指标
   RSI1 : SMA(Max(C-C[1],0),8,1)/SMA(Abs(C-C[1]),8,1)*100, OwnerScale;
   底背离: Divergence(C,RSI1,波谷强度,30,-1), LineThick0;

   //若指标与价格走势发生牛背离，则在指标上穿25时买入
   if 底背离 and CrossOver(RSI1,25) then Buy;

   if 使用价差 = 1 then begin
     SetStopContract;  //以下风控金额基于单口计算
     if 止损价差 > 0 then
       SetStopLoss(止损价差*BigPointValue);
     if 止赢价差 > 0 then
       SetProfitTarget(止赢价差*BigPointValue);
     if 保本启动价差 > 0 then
       SetBreakEven(保本启动价差*BigPointValue);
     if 跟踪启动价差 > 0 And 跟踪回撤价差 > 0 then
       SetDollarTrailing(跟踪回撤价差*BigPointValue,跟踪启动价差*BigPointValue);
     if 跟踪启动价差 > 0 And 跟踪回撤幅度 > 0 then
       SetPercentTrailing(跟踪启动价差*BigPointValue,跟踪回撤幅度);
     if 盘整最大价差 > 0 And 盘整周期数 > 0 then
       SetInactive(盘整最大价差*BigPointValue,盘整周期数);
   end
   else begin
     SetStopPosition;  //整个仓位的止损止盈金额
     if 止损金额 > 0 then
       SetStopLoss(止损金额);
     if 止赢金额 > 0 then
       SetProfitTarget(止赢金额);
     if 保本启动金额 > 0 then
       SetBreakEven(保本启动金额);
     if 跟踪启动金额 > 0 And 跟踪回撤金额 > 0 then
       SetDollarTrailing(跟踪回撤金额,跟踪启动金额);
     if 跟踪启动金额 > 0 And 跟踪回撤幅度 > 0 then
       SetPercentTrailing(跟踪启动金额,跟踪回撤幅度);
   end
   {
   注解：
   1.OwnerScale修饰符可以使RSI指标叠加在主图上
   2.LineThick0修饰符用于查看底背离状态而不画出指标线
   3.Divergence函数可用于判断指标与价格走势的背离，
     波谷点是前后各N个周期的相对低点，这个N即为波谷强度
     最后一个参数为1表示判断顶背离（熊背离），为-1表示判断底背离（牛背离）
   }

有图有真相：

可以看到，在买入前，RSI指标与价格走势发生了背离，当RSI上穿25时，发出买入指令，之后止盈平仓。

之前介绍的都是指标交易策略，能否实现形态交易呢？比如趋势线交易？

SetStopLoss之类的函数实现了经典的风险控制技巧，它们在满足条件时都是全部清仓的。

我们怎样通过Sell/BuyToCover平仓函数和一些交易状态函数实现更灵活的控制？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E6%8C%87%E6%A0%87%E8%83%8C%E7%A6%BB%E4%BA%A4%E6%98%93%E5%8F%8A%E9%A3%8E%E9%99%A9%E6%8E%A7%E5%88%B6%E7%AD%96%E7%95%A5&oldid=2207”


自动趋势线交易策略

智能交易攻略（6）-自动趋势线交易策略

作者：仁心慧能

之前介绍过画水平线，还可以通过波峰、波谷点函数自动画出趋势线并据此交易，让我们看看这个公式：

   //-------智能交易公式--------------
   //例6_1 自动趋势线交易加分级锁定盈利策略
   //用于5分钟周期
   {策略:
   1.在当天5分钟周期走势上自动画出下降趋势线
   2.突破下降趋势线买入
   3.当最大浮盈达到10点后，把盈利锁定在买入价之上1点
   4.当最大浮盈达到20点后，把盈利锁定在买入价之上8点
   5.当最大浮盈达到30点后，把盈利锁定在买入价之上10点
   6.买入价之上50点为止盈位，买入价之下10点为止损位
   }
   input: 波峰强度(3);
   const: 点数量(5);
   array: 波峰点日期[点数量](0),波峰点时间[点数量](0),波峰点数值[点数量](0);
   variable: 下降线ID(-1), 起点下标(0);

   if Date <> Date[1] then begin //每个交易日内重新找趋势线
   //  print('=============', Date, '=============');
     下降线ID := -1;
     for pos=0 to 点数量 do begin   //清空数组
       波峰点日期[pos]:=0; 波峰点时间[pos]:=0; 波峰点数值[pos]:=0;
     end
   end

   位置 : SwingHighBar(1,High,波峰强度,波峰强度+1),linethick0;

   if 位置 = 波峰强度 then begin  //出现新的波峰点
   //该波峰点是当天的且没被记录过
   if Date[位置] = Date And Time[位置] <> 波峰点时间[0] then begin
   //  print('时间:', Time/100, '  波峰强度: ', 波峰强度);

     for pos = 点数量-1 DownTo 0 do begin
       波峰点日期[pos+1] := 波峰点日期[pos];
       波峰点时间[pos+1] := 波峰点时间[pos];
       波峰点数值[pos+1] := 波峰点数值[pos];
     end
     //将新波峰点存入数组下标0的位置
     波峰点日期[0] := Date[波峰强度];
     波峰点时间[0] := Time[波峰强度];
     波峰点数值[0] := High[波峰强度];
   //  print('时间:', 波峰点时间[0]/100,'  数值:', 波峰点数值[0]);

     if MarketPosition < 1 then begin //如果未持多仓，更新趋势线
       //找趋势线起点，起点应比最近的新波峰点高，才能形成下降趋势线
       for pos = 1 to 点数量 do begin
         if 波峰点数值[pos] > 波峰点数值[0] then  begin//有更高的
           起点下标 := pos;
           pos := 点数量+1;   //For语句中再加1，然后跳出循环
      end
       end
       if pos <> 点数量+1  then begin   //表示找到有更高的波峰点
   //      print('TL_SetBegin:', 波峰点时间[起点下标]/100,'  数值:', 波峰点数值[起点下标]);
   //      print('TL_SetEnd  :', 波峰点时间[0]/100,'  数值:', 波峰点数值[0]);
   //   if 下降线ID = -1 then
           下降线ID := TL_New(Date,Time,High,Date,Time,High);
         TL_SetBegin(下降线ID, 波峰点日期[起点下标],波峰点时间[起点下标],波峰点数值[起点下标]);
         TL_SetEnd(下降线ID, 波峰点日期[0],波峰点时间[0],波峰点数值[0]);
       end
     end
   end
   end
   else begin
     TL_SetEnd(下降线ID,Date,Time,TL_GetValue(下降线ID,Date,Time));
   end
   TLValue:=TL_GetValue(下降线ID,Date,Time);
   bEnterLong := CrossOver(C, TLValue);
   if Time < 143000 And 下降线ID > -1 And bEnterLong then Buy;

   if MarketPosition>0 then begin  //持有多头仓位
     Sell(, DEFAULT, EntryPrice+50, 0, OT_LIMIT, OB_NEXTBAR, '止盈');
     Sell(, DEFAULT, EntryPrice-10, -1, OT_STOP, OB_NEXTBAR, '止损');
     if MaxContractProfit>10*BigPointValue then
       Sell(, DEFAULT, EntryPrice+1, -1, OT_STOP, OB_NEXTBAR, '锁盈1');
     if MaxContractProfit>20*BigPointValue then
       Sell(, DEFAULT, EntryPrice+8, -1, OT_STOP, OB_NEXTBAR, '锁盈2');
     if MaxContractProfit>30*BigPointValue then
       Sell(, DEFAULT, EntryPrice+10, -1, OT_STOP, OB_NEXTBAR, '锁盈3');
   end
   SetExitOnClose;
   {
   注解：
   1.const:点数量(5) 声明'点数量'为常量并赋值为5
   2.array: 波峰点日期[点数量](0) 声明'波峰点日期'为一维数组并赋初值为0
   3.找出最近5个波峰点，波峰点的H大于前后各N个周期的H，这个N即为波峰强度
   4.新出现一个波峰点后，就向前找到一个比它更高的波峰点作为起点，连接这两个点形成下降趋势线
   5.周期收盘价上叉下降趋势线时买入
   6.MarketPosition函数返回当前持仓方向
   7.MaxContractProfit为以单口计算的最大浮动盈利，BigPointValue为1整数点的单口价值。
   8.print函数输出到[公式日志]，可用于调试公式
   }

有图有真相：

可以看到，9月5日做了2笔趋势线交易，第1笔“锁盈1”平仓，第2笔日内交易平仓。

这个公式比较复杂，本ID在编写时用print函数在一些重要位置输出（到【公式日志】，

可在【量化交易】主菜单下打开）、观察数据进行调试，调试通过后再把print语句注释掉。

各位可以试着把本公式中的print语句前的注释去掉，运行公式，看看【公式日志】，

有助于理解公式逐根执行的逻辑，提升调试技巧。

公式逐根执行及其与逐行执行的不同解释如下：

逐行执行：对整个K线序列逐行地执行语句

逐根执行：对K线序列逐根地执行整个公式

假设当前有100根K线，公式有2行计算指标值1和指标值2的语句

MA1:MA(C,5);

MA2:MA(C,10);

逐行执行：

1.执行第1行语句，计算这100根K线的MA1

2.执行第2行语句，计算这100根K线的MA2

逐根执行：

1.对第1根K线，执行整个公式，计算第1根K线的MA1和MA2

2.对第2根K线，执行整个公式，计算第2根K线的MA1和MA2

...

100.对第100根K线，执行整个公式，计算第100根K线的MA1和MA2

继续，当有新行情生成第101根K线时

逐行执行：

3.执行第1行语句，计算全部101根K线的MA1

4.执行第2行语句，计算全部101根K线的MA2

逐根执行：

101.对第101根K线，执行整个公式，计算第101根K线的MA1和MA2

智能交易公式默认为逐根执行，为了能够对交易进行各种控制

技术指标类公式默认为逐行执行，为了兼容国内的主流公式

逐根执行是更灵活的执行方式，它能实现逐行执行做不到的功能

对技术指标类公式，可以用编译开关#RunMode设置执行模式

#RunMode RUN_BY_BAR  //逐根执行

#RunMode RUN_BY_SERIES  //逐行执行

只要控制好风险，加上人工干预，网格交易也是一种不错的方法，特别是在外汇市场，如何实现呢？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E8%87%AA%E5%8A%A8%E8%B6%8B%E5%8A%BF%E7%BA%BF%E4%BA%A4%E6%98%93%E7%AD%96%E7%95%A5&oldid=2208”


网格交易和鞅加仓策略

智能交易攻略（7）-网格交易和鞅加仓策略

作者：仁心慧能

网格交易法在振荡行情中用得较多，设想一个最简单的网格交易策略，公式如下：

   //-------智能交易公式--------------
   //例7_1 简单网格交易策略
   //用于分钟周期
   {策略:
   1.日内交易，预计行情震荡偏多
   2.起始价位下从第1笔开仓起每隔若干价差（网格间距）分批布多单
   3.每笔买入以网格间距止盈
   4.日内交易，收市前清仓
   }
   input:
     起始价位(2250), 网格总数(10), 网格间距(3);
   variable:
     BuyName(), SellName();
   AllowSameEntries(网格总数); //允许连续买入次数
   if MarketPosition = 0 and Not(SessionLastBar) then begin
       Buy(, 1, 起始价位-网格间距,0,OT_LIMIT,OB_NEXTBAR, '买1');
   end
   else if MarketPosition = 1 then begin
     if Not(SessionLastBar) then begin
       for n=CurrentEntries to 网格总数-1 do begin
         BuyName := '买'+NumToStr(n+1,0);
         Buy(, 1, EntryPrice-n*网格间距,0,OT_LIMIT,OB_NEXTBAR, BuyName);
       end
     end  for n=CurrentEntries downto 1 do begin
       BuyName := '买'+NumToStr(n,0);
       SellName := '卖'+NumToStr(n,0);
       Sell (, 1, EntryPrice-(n-2)*网格间距,0,OT_LIMIT,OB_NEXTBAR, SellName) from BuyName;
     end
   end
   SetExitOnClose;
   {
   注解：
   1.variable: BuyName()将BuyName声明为字符串变量
   2.若持仓中已有同名仓位，不会连续开仓
   3.CurrentEntries为当前持仓的开仓次数
   4.盈利目标位与网格间距相同
   }

如图所示：

可见，在振荡行情下，这样的策略可以频繁地小赚。

网格交易还可配合鞅（Martingale）加仓策略，初次买入后，若价格下跌，则分批加仓买入，

当价格稍有反弹，整个仓位即可盈利出场。公式如下：

   //-------智能交易公式--------------
   //例7_2 网格交易鞅加仓策略
   //用于分钟周期
   {策略:
   1.找个有利位置买入开仓，例如CCI指标小于-200；
   2.若价格相对上次开仓价格下跌了某个价差，根据加仓系数进行马丁格尔加仓；
   3.整个仓位按指定金额止盈；
   4.对整个仓位按指定金额止损，控制风险。
   }
   input:
     网格总数(10), 网格间距(6),
     初次单量(10), 加仓系数(1.2),
     盈利点数(6), 止损金额(20000);
   variable:
     BuyName();
   AllowSameEntries(网格总数); //允许连续买入次数

   //计算CCI指标
   TYP := (H + L + C)/3;
   CCI1:= (TYP-MA(TYP,14))/(0.015*AveDev(TYP,14));

   BuyName := '买1';
   if CCI1 < -200 and MarketPosition = 0 then
     Buy(, 初次单量,0,0,OT_Market,OB_NEXTBAR, BuyName);

   if MarketPosition = 1 then begin
     for n=2 to 网格总数 do begin
       BuyName := '买'+NumToStr(n,0);
       Buy(, Round(初次单量*Pow(1.2,n-1)), LASTENTRYPRICE-网格间距*(n-1),0,OT_LIMIT,OB_NEXTBAR, BuyName);
     end
   end
   SetStopPosition;
   SetProfitTarget(盈利点数*BigPointValue*初次单量);
   SetStopLoss (止损金额);
   {
   注解：
   1.SetStopPosition设定止盈止损金额以整个仓位计算，可以省略
   }

如图所示：

右键【查看测评报告】，其盈亏曲线如下：

以上2个例子的网格交易是越跌越买的，也可反向操作，越涨越买，再配合仓位控制、多空双向交易，有很多玩法，请各位试试。

之前的交易策略都是基于K线的，能实现点数图（OX图）的交易策略吗？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E7%BD%91%E6%A0%BC%E4%BA%A4%E6%98%93%E5%92%8C%E9%9E%85%E5%8A%A0%E4%BB%93%E7%AD%96%E7%95%A5&oldid=2209”


点数图突破交易策略

智能交易攻略（8）-点数图突破交易策略

作者：仁心慧能

   //-------智能交易公式--------------
   //例8_1 点数图突破交易策略
   {策略：
   1.价格升破点数图最近几列的最高点时平空开多
   2.价格跌破点数图最近几列的最低点时平多开空
   ***点数图的算法和画法请问度娘***
   }
   input:
     格值(30),转向格(5),突破列数(3),偏移量(1);
   const: 最大列数(10); //突破列数应小于此数
   array: 极点值[最大列数](0); //上涨列为最高格值，下跌列为最低格值
   variable: 转向价(0),涨跌方向(0),
     突破买价(99999),突破卖价(0);//初始化

   if BarPos <= 1 then begin
     转向价 := Round(Close);
     涨跌方向 := 0;  //初始化为无方向
     突破买价 := High + 偏移量;
     突破卖价 := Low - 偏移量;
   end

   else begin
     if 涨跌方向 = 0 then begin   //尚未确定方向
       if High >= 转向价 + 格值 * 转向格 then begin
         极点值[0] := 转向价 + 格值 * 转向格;
         涨跌方向 := 1;  //上涨
       end
       else if Low <= 转向价 - 格值 * 转向格 then begin
         极点值[0] := 转向价 - 格值 * 转向格;
         涨跌方向 := -1;  //下跌
       end;
     end

     else if 涨跌方向 = 1 then begin  //当前列为上涨
       if High >= 极点值[0] + 格值 then begin //增加向上的X格子
         while High >= 极点值[0] + 格值 do begin
           极点值[0] := 极点值[0] + 格值;
           转向价 := 极点值[0] - 格值 * 转向格;  //抬高转向价
         end;
       end
       else if Low <= 转向价 then begin  //上涨转为下跌
         for n = 0 to 最大列数-1 do begin  //数组移位
           极点值[最大列数-n] := 极点值[最大列数-n-1];
         end;
      //以下使点数图新增下跌列
         极点值[0] := 转向价;
         涨跌方向 := -1;  //转为下跌
         转向价 := 极点值[0] + 格值 * 转向格;
         while Low <= 极点值[0] - 格值 do begin
           极点值[0] := 极点值[0] - 格值;
           转向价 := 极点值[0] + 格值 * 转向格;
         end;
       end;
     end  //当前列为上涨

     else begin //当前列为下跌
       if Low <= 极点值[0] - 格值 then begin //增加向下的O格子
         while Low <= 极点值[0] - 格值 do begin
           极点值[0] := 极点值[0] - 格值;
           转向价 := 极点值[0] + 格值 * 转向格;
         end;
       end
       else if High >= 转向价 then begin  //下跌转为上涨
         for n = 0 to 最大列数-1 do begin
           极点值[最大列数-n] := 极点值[最大列数-n-1];
         end;
         极点值[0] := 转向价;
         涨跌方向 := 1;
         转向价 := 极点值[0] - 格值 * 转向格;
         while High >= 极点值[0] + 格值 do begin
           极点值[0] := 极点值[0] + 格值;
           转向价 := 极点值[0] - 格值 * 转向格;
         end;
       end;
     end; //当前列为下跌   //根据最近若干列的极点值计算突破价位
     value1:= 0;
     value2:= 99999;
     for n = 1 to 突破列数 do begin
       if 极点值[n] > value1 then value1 := 极点值[n];
       if 极点值[n] < value2 then value2 := 极点值[n];
     end;
     突破买价 := value1 + 偏移量;
     突破卖价 := value2 - 偏移量;
   end;

   Buy(, DEFAULT, 突破买价, -1, OT_STOP);
   SellShort(, DEFAULT, 突破卖价, -1, OT_STOP);

   买线: 突破买价, Precision0;
   卖线: 突破卖价, Precision0;
   盈利因子: -GrossProfit/GrossLoss, Precision2, LineThick0;
   盈亏比: -(GrossProfit/NumWinTrades)/(GrossLoss/NumLosTrades), Precision2, LineThick0;
   胜率%: PercentProfit, Precision2, LineThick0;
   净利: NetProfit, Precision2,LineThick0;
   当前连亏次数: NumConsecLosers, Precision0, LineThick0;
   {注解：
   1.用variable定义变量可增加可读性，在本例其实可以省略
   2.Precision指定输出数值的小数位数
   3.盈亏比=平均盈利/平均亏损，GrossLoss返回值为负数
   }

如图所示：

点数图算法的代码比较复杂，如果每个涉及到点数图的公式都包含那么多代码会比较难看，

我们是否可以把它做成公共代码供其它公式调用呢？用传统的调用指标公式的方法不太好使，

而且一次调用只能返回一个结果，本例的点数图就需要返回“突破买价”和“突破卖价”两个结果，

用户能否自编函数，并且让这个函数能同时返回多个结果呢？

敬请关注本攻略！

来自“http://www.hs633.com/kthelp/index.php?title=%E7%82%B9%E6%95%B0%E5%9B%BE%E7%AA%81%E7%A0%B4%E4%BA%A4%E6%98%93%E7%AD%96%E7%95%A5&oldid=2211”


均线与趋势线交叉加仓位管理

智能交易攻略（9）-均线与趋势线交叉加仓位管理

作者：仁心慧能

本节讲解如何应用公共（自编）函数，如何在公式中调用手工绘制的趋势线产生交易信号，

如何根据前次交易结果调整下单量，如何应用新的文本绘制函数，请跟随本ID一探究竟。

首先在公式树的【公共函数】下创建名为“显示绩效”的公式：

   input:
     NumericSeries MA1,   //序列参数
     Numeric 下单量,      //数值参数
     NumericRef 盈利因子, //数值型引用参量，装载计算结果
     NumericRef 盈亏比;
   均线: MA1,Precision0;
   单量: 下单量,Precision0, LineThick0;
   胜率%: PercentProfit, Precision0, LineThick0;

   盈利因子:= -GrossProfit/GrossLoss;  //总盈利/总亏损
   盈亏比:= -(GrossProfit/NumWinTrades)/(GrossLoss/NumLosTrades);
   return (InitialCapital+NetProfit);  //函数返回

编译通过后，再创建以下智能交易公式：

   //-------智能交易公式--------------
   //例9_1 均线与趋势线交叉加仓位管理策略
   {策略：
   1.均线与手工画的趋势线交叉作为交易信号
   2.上次交易为'止盈'平仓或首次开仓，下单量为初始单量
   3.上次交易为非'止盈'平仓的，下单量按加仓步长渐次增加
   4.下单量增大到超过最大单量则回复为初始单量
   }
   input:
     TL标识号(99), //手工绘制趋势线的标识号，【设置画线】标题栏可见
     止盈价差(600),
     止损价差(200),
     初始单量(1),
     加仓步长(1),    //下单量渐次增加步长
     最大单量(10),
     转折强度(15);    //波峰波谷前后N周期最高最低
   variable: 下单量(1),等量次数(1);

   MA1 := MA(C,2);
   TLV := TL_GetValue(TL标识号, Date, Time);  //趋势线数值序列
   bEnterLong := CrossOver(MA1,TLV);  //均线上叉趋势线平空开多
   bEnterShort:= CrossUnder(MA1,TLV); //均线下叉趋势线平多开空

   if bEnterLong or bEnterShort then begin
     //上次平仓标识为'止盈'或没有交易过
     if ExitName(1) = '止盈' OR ExitName(1) =  then
       下单量 = 初始单量;
     else begin //渐次增加下单量
       if 下单量=初始单量 or 等量次数 = 2 then begin
         下单量 = 下单量 + 加仓步长;
          等量次数 = 1;
       end else
         等量次数 = 等量次数 +1;
       if (下单量 > 最大单量) then 下单量 = 初始单量;
     end
   end

   if bEnterLong then begin
     Buy(,下单量);
     ID1:=Text_New(Date,Time, L, 314, true); //绘制314号图标-右上箭头
     Text_SetColor(ID1,ColorMagenta);
   end
   if bEnterShort then begin
     SellShort(,下单量);
     ID1:=Text_New(Date,Time, H, 316, true); //绘制316号图标-右下箭头
     Text_SetColor(ID1,ColorCyan);
     Text_SetStyle(ID1, 0, 1);  //设置下对齐
   end

   if MarketPosition = 1 then begin //多头持仓
     Sell(,DEFAULT,EntryPrice+止盈价差,0,OT_LIMIT,OB_NEXTBAR,'止盈');
     Sell(,DEFAULT,EntryPrice-止损价差,0,OT_STOP,OB_NEXTBAR,'止损');
   end
   if MarketPosition = -1 then begin //空头持仓
     BuyToCover(,DEFAULT,EntryPrice-止盈价差,0,OT_LIMIT,OB_NEXTBAR,'止盈');
     BuyToCover(,DEFAULT,EntryPrice+止损价差,0,OT_STOP,OB_NEXTBAR,'止损');
   end

   //显示波峰点
   pos := SwingHighBar(1,High,转折强度,转折强度+1);//波峰位置
   SWV := SwingHigh(1,High,转折强度,转折强度+1);   //波峰数值
   if pos = 转折强度 then begin
     ID1 :=Text_New(Date[pos],Time[pos], SWV, SWV);
     Text_SetColor(ID1,ColorMagenta);
     Text_SetStyle(ID1, 2, 1);      //设置水平中对齐、垂直下对齐
   end
   //显示波谷点
   pos := SwingLowBar(1,Low,转折强度,转折强度+1); //波谷位置
   SWV := SwingLow(1,Low,转折强度,转折强度+1);    //波谷数值
   if pos = 转折强度 then begin
     ID1 :=Text_New(Date[pos],Time[pos], SWV, SWV);
     Text_SetColor(ID1,ColorBlue);
     Text_SetStyle(ID1, 2, 0);  //设置水平中对齐、垂直上对齐
   end

   //调用“显示绩效”公共函数显示绩效，并计算返回余额、盈利因子、盈亏比
   variable:       //公式中可以有多组input、variable声明
     PF(0),PR(0);  //引用型变量，装回计算结果
   余额:显示绩效(MA1,下单量,PF,PR),Precision0,OwnerScale;
   盈亏比:PR, Precision1, LineThick0;
   盈利因子:PF, Precision1, LineThick0;
   {
   注解：
   1.ExitName(1)取得上一回持仓的最后一次平仓的标识名
   2.Text_*系列函数请参见【字典】中【新画线函数】类里的说明
   3.“显示绩效”为用户自编的公共函数
   }

如下图所示，在主图上手工绘制一条直线（图中粗紫色线），选中它，右键菜单【设置画线】，

标题栏上#后面的数字即为该画线的标识号，把公式的外部参数“TL标识号”的数值99改为这个数字，

然后把公式拖放到图上，即可让公式跑出交易结果。

右键菜单【查看测评报告】-【交易明细】，因公式中等单量次数上限为2，

所以下单量从1->2->2->3->，遇到止盈，再从1->2...，如图所示：

新的文本绘制函数Text_New 不仅可以在图上标出文本、数字，还能绘制680种图标，

图标与数字标号对照表请见下图：

上节的点数图算法可以改写成公共函数，这样，其它公式就可以直接调用而不用写繁杂的语句，

可以把“转向价”作为函数的return输出，用引用型参数NumericRef定义“突破买价”、“突破卖价”，

这样可以同时输出这三个计算结果，请各位自行试验。

我们已经介绍了一些经典的策略和交易技巧及其公式实现，在研发交易策略时，

如何评估策略的好坏、评估能否用于真实交易呢？

且听下回分解！

来自“http://www.hs633.com/kthelp/index.php?title=%E5%9D%87%E7%BA%BF%E4%B8%8E%E8%B6%8B%E5%8A%BF%E7%BA%BF%E4%BA%A4%E5%8F%89%E5%8A%A0%E4%BB%93%E4%BD%8D%E7%AE%A1%E7%90%86&oldid=2212”


向前引用 示范模型

 //-------智能交易公式--------------
 //该模型仅仅用来示范如何根据指标编写简单的模型
 //用户需要根据自己交易经验，进行修改后再实际应用!!!

 //AA=当前周期的开盘价 -[ （一个周期前的最高价减最低价的差+两个周期前的最高价减最低价的差+三个周期
 //前的最高价减最低价的差+四个周期前的最高价减最低价的差）/4]*1.8
 AA:O-(((H[1]-O[1])+(H[2]-O[2])+(H[3]-O[3])+(H[4]-O[4]))/4)*1.8;

 //连续四个周期的收盘价小于前一周期的收盘价并且当前周期的收盘价大于AA
 bEnterLong :=c[1]<c[2] and c[2]<c[3] and c[3]<c[4] and c>AA;
 //bExitLong :=0;
 //连续四个周期的收盘价大于前一周期的收盘价并且当前周期的收盘价小于等于AA
 bEnterShort :=c[1]>c[2] and c[2]>c[3] and c[3]>c[4] and c<=AA;
 //bExitShort :=0;

 //发出买平并且买开（反手）交易指令
 if bEnterLong then buy;
 //发出卖平并且卖开（反手）交易指令
 if bEnterShort then SellShort;
来自“http://www.hs633.com/kthelp/index.php?title=%E5%90%91%E5%89%8D%E5%BC%95%E7%94%A8_%E7%A4%BA%E8%8C%83%E6%A8%A1%E5%9E%8B&oldid=2204”


瀑布线 示例模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   input:P1(4,1,10,1),
     P2(6,1,10,1),
     P3(8,1,10,1),
     P4(11,1,30,1),
     P5(15,1,30,1),
     P6(19,1,30,1);

   //(收盘价的P1日指数移动平均+收盘价的2*P1日简单移动平均+收盘价的4*P1日简单移动平均)/3
   PB1:(ema(C,P1)+ma(C,2*P1)+ma(C,4*P1))/3;
   //(收盘价的P2日指数移动平均+收盘价的2*P2日简单移动平均+收盘价的4*P2日简单移动平均)/3
   PB2:(ema(C,P2)+ma(C,2*P2)+ma(C,4*P2))/3;
   PB3:(ema(C,P3)+ma(C,2*P3)+ma(C,4*P3))/3;
   PB4:(ema(C,P4)+ma(C,2*P4)+ma(C,4*P4))/3;
   PB5:(ema(C,P5)+ma(C,2*P5)+ma(C,4*P5))/3;
   PB6:(ema(C,P6)+ma(C,2*P6)+ma(C,4*P6))/3,COLORCYAN;//定义6条瀑布线

   //第一条瀑布线上穿第六条
   bEnterLong :=CROSS(PB1,PB6);
   //第六条瀑布线上穿第一条
   bEnterShort :=CROSS(PB6,PB1);

   if bEnterLong then buy;//短线瀑布线金叉长线瀑布，做多。
   if bEnterShort then SellShort;//短线瀑布线死叉长线瀑布，做空。
来自“http://www.hs633.com/kthelp/index.php?title=%E7%80%91%E5%B8%83%E7%BA%BF_%E7%A4%BA%E4%BE%8B%E6%A8%A1%E5%9E%8B&oldid=2210”


DMA-QL钱龙趋向 示例模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   input:n(14,2,100),
     m(6),
     n0(20),
     m0(20);

   //收盘价与最低价做差，最高价与前一周期收盘价做差，最低价与前一周期收盘价作差，在上述三个数据中取绝对值最大者，对该最大值做移动平均。
   TR1 := SMA(MAX(MAX(H-L,ABS(H-C[1])),ABS(L-C[1])),N,1);
   HD := H-H[1];//最高价与前一根K线最高价作差定义为HD
   LD := L[1]-L;//前一根K线最低价减去当前最低价
   DMP:= SMA(IIF(HD>0 and HD>LD,HD,0),N,1);//如果HD大于0并且HD>LD取HD否则取0，对该值做移动平均。
   DMM:= SMA(IIF(LD>0 and LD>HD,LD,0),N,1);//如果LD大于0并且LD>HD取LD否则取0，对该值做移动平均。
   PDI: DMP*100/TR1;
   MDI: DMM*100/TR1;
   //取(MDI与PDIN做差的绝对值)及(MDI及PDI的和)，差与和之间作比值并放大100倍，对该值做移动平均。
   ADX1: SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1);
   ADXR:(ADX1+ADX1[M])/2;//ADX与前M个周期的ADX之和的一半定义为ADXR

   //PDI上穿MDI
   bEnterLong :=CROSS(PDI,MDI);
   //N0周期内ADX1的最高值*(1-0.01*M0)上穿ADX1
   bEnterShort :=CROSS(HHV(ADX1,N0)*(1-0.01*M0),ADX1);

   if bEnterLong then buy;//PDI上穿MDI，做多。
   if bEnterShort then SellShort;//ADX回落超过前N0周期内的M0%，做空。
来自“http://www.hs633.com/kthelp/index.php?title=DMA-QL%E9%92%B1%E9%BE%99%E8%B6%8B%E5%90%91_%E7%A4%BA%E4%BE%8B%E6%A8%A1%E5%9E%8B&oldid=2213”


当根K线开仓模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   #Run_Every_Tick
   Input:x(9.3);

   //时间为9:30(93000)且最新价大于当天开盘价
   bEnterLong :=Time=(x*10000) and C>OpenD(0);
   //时间为9:30(93000)且最新价小于当天开盘价
   bEnterShort :=Time=(x*10000) and C<OpenD(0);

   //多头开仓条件满足，在当前k线下单
   if bEnterLong then Buy(, DEFAULT, 0, 0, OT_Market, OB_ThisBar,  );
   //空头开仓条件满足，在当前k线下单
   if bEnterShort then SellShort(, DEFAULT, 0, 0, OT_Market, OB_ThisBar,  );

   SetExitOnClose;//收盘平仓
来自“http://www.hs633.com/kthelp/index.php?title=%E5%BD%93%E6%A0%B9K%E7%BA%BF%E5%BC%80%E4%BB%93%E6%A8%A1%E5%9E%8B&oldid=2215”


日线四价引用示例模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   aa:=HighD(1);//引用昨天的最高价
   bb:=LowD(1);//引用昨天的最低价
   cc:=OpenD(1);//引用昨天的开盘价
   dd:=CloseD(1);//引用昨天的收盘价
   movAvgVal : (aa + bb + cc + dd)/4;

   //收盘价上穿movAvgVal
   bEnterLong :=CrossOver(c , movAvgVal); {多头开仓}
   //收盘价下穿movAvgVal
   bEnterShort :=CrossUnder(c , movAvgVal);{空头开仓}

   //多头开仓条件成立，开多仓，如果有空头仓位，会先平空仓，再开多仓
   if bEnterLong then Buy;

   //空头开仓条件成立，开空仓，如果有多头仓位，会先平多仓，再开空仓
   if bEnterShort then SellShort;

   {使内建平仓出场函数的参数基于单口持仓
   内建出场函数包括：SetStopLoss，SetProfitTarget，SetBreakEven，SetDollarTrailing，SetPercentTrailing }
   SetStopContract;

   {单口持仓的浮盈金额达到 20天平均真实波幅/2*BigPointValue 元后，启动跟踪止损，
   若从最大浮盈回撤了100元，则全部平仓出场 }
   SetDollarTrailing(100,ATRD(20)/2*BigPointValue);
   {单口持仓亏损金额达到 20天平均真实波幅/2*BigPointValue元（与开仓价差ATRD(20)/2个点）时平仓出场 }
   SetStopLoss(ATRD(20)/2*BigPointValue);
来自“http://www.hs633.com/kthelp/index.php?title=%E6%97%A5%E7%BA%BF%E5%9B%9B%E4%BB%B7%E5%BC%95%E7%94%A8%E7%A4%BA%E4%BE%8B%E6%A8%A1%E5%9E%8B&oldid=2217”


异同离差乖离率 示例模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   //参数设置
   Input:
     N(5,1,100),
     m(16,1,100),
     t(76,1,100); //缺省值,最小值,最大值,步长

   BIAS:=(C-MA(C,N))/MA(C,N);//(收盘价-N周期均值)/N周期均值
   DIF:=(BIAS-BIAS[M]);//当根K的BIAS与前M个周期的BIAS做差
   DBCD:SMA(DIF,T,1),OwnerScale;//DIF的移动平均值。
   MM:MA(DBCD,5),OwnerScale;//DBCD的5周期简单均值。

   //DBCD金叉MM
   bEnterLong :=CROSS(DBCD,MM); {多头开仓}
   //DBCD死叉MM
   bEnterShort :=CROSS(MM,DBCD);{空头开仓}

   if bEnterLong then buy;
   if bEnterShort then SellShort;

   利润:NetProfit,OwnerScale;//以自己的指标来显示利润
来自“http://www.hs633.com/kthelp/index.php?title=%E5%BC%82%E5%90%8C%E7%A6%BB%E5%B7%AE%E4%B9%96%E7%A6%BB%E7%8E%87_%E7%A4%BA%E4%BE%8B%E6%A8%A1%E5%9E%8B&oldid=2218”


价差型模型示例

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   MA5:MA(C,5);//5个周期收盘价的简单移动平均
   MA10:MA(C,10);//10个周期收盘价的简单移动平均

   //5周期均线上穿10周期均线或者收盘价与5周期均线的差值大于8
   bEnterLong :=CROSS(MA5,MA10) or (MA5-C)>8; {多头买入}
   //5周期均线与收盘价的差值大于6
   bExitLong :=(MA5-C)>6; {多头卖出}

   //10周期均线上穿5周期均线或者收盘价与5周期均线的差值大于8
   bEnterShort :=CROSS(MA10,MA5) or (C-MA5)>8;
   //收盘价与5周期均线的差值大于6
   bExitShort :=(C-MA5)>6;

   if bEnterLong then buy;//满足开多条件，开多仓
   if bExitLong then sell;//满足平多条件，平多仓
   if bEnterShort then SellShort;//满足开空条件，开空仓
   if bExitShort then BuyToCover;//满足平空条件，平空仓
来自“http://www.hs633.com/kthelp/index.php?title=%E4%BB%B7%E5%B7%AE%E5%9E%8B%E6%A8%A1%E5%9E%8B%E7%A4%BA%E4%BE%8B&oldid=2226”


慢速KD 示例模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   //参数设置
   Input:
     N(1,1,100),
     m1(6,2,50),
     m2(6,2,50),
     m3(5,1,50); //缺省值,最小值,最大值,步长

   //(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
   RSV:= (C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;
   FASTK:=SMA(RSV,M1,1);
   K:SMA(FASTK,M2,1);
   D:SMA(K,M3,1);

   //K金叉D
   bEnterLong :=CROSS(K,D);
   //D金叉K
   bEnterShort :=CROSS(D,K);

   if bEnterLong then buy;//满足开多条件，开多仓
   if bEnterShort then SellShort;//满足开空条件，开空仓
来自“http://www.hs633.com/kthelp/index.php?title=%E6%85%A2%E9%80%9FKD_%E7%A4%BA%E4%BE%8B%E6%A8%A1%E5%9E%8B&oldid=2227”


交叉型 示例模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   MA5:MA(C,5);  //5个周期收盘价的简单移动平均
   MA10:MA(C,10);//10个周期收盘价的简单移动平均
   MA20:MA(C,20);//20个周期收盘价的简单移动平均

   //MA10上穿MA20
   bEnterLong :=CROSS(MA10,MA20); {多头买入}
   //MA10上穿MA5
   bExitLong :=CROSS(MA5,MA10); {多头卖出}

   //MA20上穿MA10
   bEnterShort :=CROSS(MA20,MA10);
   //MA5上穿MA10
   bExitShort :=CROSS(MA10,MA5);

   if bEnterLong then buy;//满足开多条件，开多仓
   if bExitLong then sell;//满足平多条件，平多仓
   if bEnterShort then SellShort;//满足开空条件，开空仓
   if bExitShort then BuyToCover;//满足平空条件，平空仓
来自“http://www.hs633.com/kthelp/index.php?title=%E4%BA%A4%E5%8F%89%E5%9E%8B_%E7%A4%BA%E4%BE%8B%E6%A8%A1%E5%9E%8B&oldid=2228”


MIKE 示范模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   input:n(12,1,200);

   TYP:=(H+L+C)/3;//当根K线的最高值最低值收盘价的简单均值定义为TYP。
   LL:=LLV(L,N);//N个周期的最低值
   HH:=HHV(H,N);//N个周期的最高值

   SR:2*HH-LL;     //strong  resistance
   MR:TYP+(HH-LL); //medium 阻力
   WR:TYP+(TYP-LL);//weak 阻力
   WS:TYP-(HH-TYP);//weak Support
   MS:TYP-(HH-LL); //medium 支撑
   SS:2*LL-HH;     //strong 支撑

   //WR,MR,SR同时下拐
   bEnterLong :=WR<WR[1] and WR[1]>WR[2]  and  MR<MR[1] and MR[1]>MR[2]  and SR<SR[1] and SR[1]>SR[2];
   //WS,MS,SS同时上拐
   bEnterShort :=WS>WS[1] and WS[1]<WS[2]  and  MS>MS[1] and MS[1]<MS[2]  and SS>SS[1] and SS[1]<SS[2];

   if bEnterLong then buy;//满足开多条件，开多仓
   if bEnterShort then SellShort;//满足开空条件，开空仓
来自“http://www.hs633.com/kthelp/index.php?title=MIKE_%E7%A4%BA%E8%8C%83%E6%A8%A1%E5%9E%8B&oldid=2230”


时间函数 示例模型

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   MA5:MA(C,5);//定义5周期的简单移动平均线
   MA10:MA(C,10);//定义10周期的简单移动平均线

   {9点05分之后14点55分之前的时间段内出现5周期线金叉10周期线}
   bEnterLong :=TIME>=090500 and TIME<145500 and CROSS(MA5,MA10);
   //时间到14点55分
   bExitLong :=TIME>=145500;

   //9点05分之后14点55分之前的时间段内出现5周期线死叉10周期线
   bEnterShort :=TIME>=090500 and TIME<145500 and CROSS(MA10,MA5);
   //时间到14点55分
   bExitShort :=TIME>=145500;

   if bEnterLong then buy;//满足开多条件，开多仓
   if bExitLong then sell;//满足平多条件，平多仓
   if bEnterShort then SellShort;//满足开空条件，开空仓
   if bExitShort then BuyToCover;//满足平空条件，平空仓
来自“http://www.hs633.com/kthelp/index.php?title=%E6%97%B6%E9%97%B4%E5%87%BD%E6%95%B0_%E7%A4%BA%E4%BE%8B%E6%A8%A1%E5%9E%8B&oldid=2225”


多条件模型示例

   //-------智能交易公式--------------
   //该模型仅仅用来示范如何根据指标编写简单的模型
   //用户需要根据自己交易经验，进行修改后再实际应用!!!

   RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
   K:=SMA(RSV,3,1);
   D:=SMA(K,3,1);
   J:=3*K-2*D;
   //以上为KDJ公式

   MA5:MA(C,5);
   MA10:MA(C,10);
   //以上为定义5个周期收盘价的简单移动平均和10个周期收盘价的简单移动平均

   //5周期均线上穿10周期均线并且前一个周期的J值（KDJ）少于70或者KD金叉时并且J值小于30
   bEnterLong :=(CROSS(MA5,MA10) and J[1]<70) or(CROSS(K,D) and J<30); {多头买入}
   //KD出现金叉并且前一个周期J值小于30
   bExitLong :=CROSS(K,D) and J[1]<30; {多头卖出}

   //5周期均线下叉10周期均线并且前一个周期的J值（KDJ）大于30或者KD死叉时并且J值大于70
   bEnterShort :=(CROSS(MA10,MA5) and J[1]>30) or(CROSS(D,K) and J>70);
   //KD出现死叉并且前一个周期J值大于70
   bExitShort :=CROSS(D,K) and J[1]>70;

   if bEnterLong then buy;//满足开多条件，开多仓
   if bExitLong then sell;//满足平多条件，平多仓
   if bEnterShort then SellShort;//满足开空条件，开空仓
   if bExitShort then BuyToCover;//满足平空条件，平空仓
来自“http://www.hs633.com/kthelp/index.php?title=%E5%A4%9A%E6%9D%A1%E4%BB%B6%E6%A8%A1%E5%9E%8B%E7%A4%BA%E4%BE%8B&oldid=2229”


文件:Fml dll run dll.png

  • 文件
  • 文件历史
  • 文件用途
文件:Fml dll run dll.png
没有更高的分辨率。
Fml_dll_run_dll.png? （708 × 364像素，文件大小：30 KB，MIME类型：image/png）

文件历史

查看某一时刻的文件，请单击相应的日期/时间。

 | 日期/时间 | 缩略图 | 大小 | 用户 | 注解
当前 | 2013年4月11日 (四) 12:51 | 2013年4月11日 (四) 12:51的版本的缩略图 | 708 × 364 (30 KB) | John (讨论 | 贡献) |

  • 用外部应用程序编辑本文件 （更多信息请见安装说明）

文件用途

以下的1个页面链接到本文件：

  • 飞狐 DLL调用
来自“http://www.hs633.com/kthelp/index.php?title=%E6%96%87%E4%BB%B6:Fml_dll_run_dll.png&oldid=67”


数据引用与指标引用

数据引用

数据引用与数据对齐 前1根和前1天 分支里面的数据回溯

指标引用

来自“http://www.hs633.com/kthelp/index.php?title=%E6%95%B0%E6%8D%AE%E5%BC%95%E7%94%A8%E4%B8%8E%E6%8C%87%E6%A0%87%E5%BC%95%E7%94%A8&oldid=1105”