系统简介

金魔方软件是一款证券量化投资软件。

在金魔方上，您把您的投资思想和理念表述成计算机能懂的语言，也就是“策略”；利用历史数据验证、确认策略能够在将来赚钱；让策略在计算机上自动运行。最后，您能任意组合不同策略，让们互相配合抵消风险，长期稳健盈利。

主要功能模块

u 行情数据接收和展示、技术分析。

u 策略编写。

u 策略评测。

u 自动交易。

功能亮点

投资思想尽情表达

只要有想法，就能说出来。

金魔方语言平台淋漓尽致的表达能力,帮助你把各种投资思想变成“文字”。

数据访问能力强大。金魔方平台能自由地以需要的方式访问股票价量数据。既能访问K线图上的数据，也能访问不在K线图上的，其他品种的、其他周期的价量数据。

兼容。您能够使用基于国内主流公式语言（大智慧、通达信、飞狐交易师）发展而来的金魔方语言计算各种信号。

控制资金、管理仓位。金魔方平台能自由地访问股票帐户，得到资金、持仓数据，再辅以丰富完备的帐户统计函数，轻松实现仓位控制动作。

控制进入和退出。通过平台提供的止损止盈市价追价等指令，自如的控制入场和出场动作。

易拓展。如果平台丰富的函数仍不能完全满足需要，可以通过撰写DLL的方式拓展系统功能。

无限接近真实的策略评价

金魔方评测平台最大程度模拟真实交易的情形，帮助你对它们进行试炼，直观地、值得信赖地挑选出在真实市场能够稳健获利的策略。

最高精细到分笔级别的行情，真实地模拟行情的生长。

忠实地反映整个交易过程。包括期间仓位和资金的变化。

多角度全方位显微镜般细致入微的评测指标全面检视策略表现。

立体多维方式呈现参数变化带来的绩效表化。帮助你找到即使将来市道发生变化，也能很好适应的表现均衡的策略。

推进分析。用其中一段数据优化出来的参数，放到另一段乃至另外几段数据上进行评测。如果它们都表现优秀，那么将来的真实交易，将会只是另一个“新的段”，有很大的机会象之前几段一样表现优秀。

用本地的，按照你的意愿设置了模拟佣金、保证金比例等等交易参数的，逼近真实的模拟交易所，进行实时的模拟交易。

克服人性弱点、突破生理极限----自动交易。

金魔方交易平台目前支持国内期货CTP交易通道。并将陆续与合作伙伴开通股票交易通道。

平台的设计目标：

u 交易结果是确定的。

u 交易表现是稳定的。

u 交易过程是快速的。

u 交易过程的监控是直观的。

化腐朽为神奇----多策略组合

不同策略作用在同一只股票上，却不互相干扰对方仓位----A策略绝对不会卖掉B策略的仓位，这就是多策略。当A策略大幅回撤时，B策略的盈利保证了整个账户不会过度回撤。尽管B策略平时表现平庸，可是当风险来临时，B策略的补救给予组合以坚持下去信心。这就是化腐朽为神奇的含义。

在投资战场，生存是第一追求。爆仓的话，一切都是空谈。金魔方平台的多策略支持给予你长期生存、稳健获利的可能。

由于多策略发掘了“垃圾策略”的价值，站在策略生产者的立场，现在有更多机会发现自己“天生我才必有用”；站在策略购买者的立场，可选策略的空间前所未有的拓宽了，通过组合，有可能调配出自己独一无二的策略。

站在巨人的肩上-----丰富的素材和资源

市面上成千上万的大智慧、通达信、飞狐公式，囊括大量已有的策略思想。金魔方语言可以99%地兼容他们的语法。从这些现成公式出发编写策略，事半功倍。


系统配置要求

系统能在较低档配置的微机上运行，为个人版用户提供方便。

最低配置参考

硬件配置：建议采用奔腾Ⅲ/赛扬/500以上cpu，内存1GB，1024*768以上分辨率，64KB色显示模式，1GB硬盘空间（视乎所安装的历史数据大小而有所不同）

软件配置：操作系统，中文版windows 2000/xp/2003/vista/7版本

建议配置参考

硬件配置：奔腾Ⅳ/赛扬D以上，内存2GB，1280*1024以上分辨率，64KB色显示模式，高于10GB硬盘空间

软件配置：操作系统，中文版windows xp/2003/vista/win7/win8版本


常用术语

鼠标

    ◇ 单击左键（简称单击）：在对象上按动鼠标左键，通常使用单击来启动一个具体功能或打开菜单。
    ◇ 单击并拖动（简称拖放）：指向一个对象并单击，然后压住鼠标按键拖动它，就会把对象拖到一个新的位置。例如可以拖动“公式树”上的公式拖放到技术图形分析窗中的显示区域，或者可以把证券列表中的若干证券拖放到“证券树”上的某个板块中。
    ◇ 单击右键（简称右击）：当用右键单击一个窗口、列表、树、曲线等等对象时，会显示关于该对象的快捷菜单，其中包含有关该对象的常用命令。
    ◇ 双击左键（简称双击）：在鼠标所指的目标对象上快速地连续按动鼠标左键，通常用来启动一个程序或打开一个窗口。

键盘

    PageUp 上一页
    PageDown 下一页
    ↑ 光标向上移动一格
    ↓ 光标向下移动一格
    ← 光标向前移动一格
    → 光标向后移动一格
    Ctrl+← 光标快速向前移动
    Ctrl+→ 光标快速向后移动
    Esc 关闭当前窗口，退出当前功能（除行情显示表和系统主窗口外）
    Tab 切换类别
    Enter 确认键，如在行情显示窗口中快速进入光标所指股票的图形分析。


安装系统

打开计算机进入Windows操作系统，执行安装程序EXE。按照安装程序的提示，一步一步地操作即可成功地安装“『 金魔方 』”软件。 系统安装成功后，会在Windows中建立一个程序文件夹，并且自动地在计算机桌面上生成两个标有“『 金魔方 』”字样的快捷图标，分别是主程序、公式编辑器 。

进入系统

以下两种方式均可：

    1、鼠标双击击计算机桌面上的“『 金魔方 』”字样的快捷图标；

    2、通过选择Windows菜单“开始 → 程序 → 『 金魔方 』”，单击“『 金魔方 』”项；

软件的登陆与数据接收

1、登录行情服务器

当您需要查看证券的最新行情时，必须通过软件驱动程序连接行情服务器，才能获得。具体操作如下：

点击【系统】－【连接行情】，或者双击系统托盘上面的金魔方驱动程序图标，弹出金魔方驱动程序对话框（软件启动时也会自动弹出这个对话框），填写用户名和密码，然后点击“登录”按钮。

实用技巧：

如果您希望打开软件就自动登录，可将驱动程序对话框中的“保存用户名”、“保存密码”、“自动登录”选项都勾选即可。

“自动隐藏”的作用是登录成功之后就将驱动窗口自动隐藏。

“开启语音提示”功能（本功能仅适用于期货）

选择“行情断开”、“行情重连”后，系统会在出现以上情况下，进行语音提示。

2、断开行情服务器

如果您想关闭所有行情接收，可以使用“断开行情”功能。

点击【系统】，选择【断开行情】。或点击金魔方驱动程序界面中的“断开”按钮。

3、单独启动、断开某台行情服务器

当您只想接收股票实时数据时，可以将其他类型服务器断开（如国内期货、股指期货等服务器）。这样可以提高您的软件运行速度。

具体操作如下：

在金魔方驱动程序界面，点击“状态监视”，进入服务器状态监视页面，找到需要启动、关闭的服务器，右键点击出菜单后，选中“启动”或“停止”即可连接或断开该服务器。

4、寻找可良好连接的服务器

当您觉得接收实时行情的速度比较慢时，可以使用驱动程序里面的“测试所有服务器速度”功能，查找出能与您机器连接良好的服务器。

具体操作如下：

在金魔方驱动程序界面，点击“状态监视”，进入服务器状态监视页面，点击右键，会弹出一个菜单，选择“测试所有服务器速度”，就会重新测试所有的服务器跟您的网络连接的速度，用良好、一般、较慢或无法连接表示，以及服务器的连接人数情况，用空闲或较忙表示，可根据测试情况选择连接速度快、空闲的服务器进行连接。

5、代理服务器设置

当您处于有上网限制的网络时，就需要通过代理服务器才能接收到证券的实时行情。如公司内部网络。

具体操作如下：

点击进入“代理设置”对话框，可设置代理服务器，此功能非网络限制用户较少使用。

具体内容需要从您公司的网络管理员获取地址、端口号、用户名、密码。

退出系统

关闭软件时，可以通过以下3种方式做到。

三种方式：
    1、鼠标单击界面右上角“X”关闭按钮；
    2、选择菜单栏“系统”→“退出”；

3、按Alt+F4。


键盘精灵

调出键盘精灵

当您想寻找某个指标、证券、或切换周期时，可以按下键盘上任意一个数字、字母或符号，都会弹出“键盘精灵”。

您可以在这里面输入中英文和数字搜索您想要的东西。

具体操作如下：

键盘精灵操作

可以通过输入代码、名称或名称的汉语拼音首字母来搜索对应的商品（股票、基金、债券、指数等），按enter键进入相关页面。

也可以通过输入指标（如：KDJ）的中英文名称，来利用键盘精灵方便地更换指标窗口里的指标。

还可以当画面快捷键，比如想看“上证A股涨跌幅排名”就可以直接按“61＋enter”。

调出键盘精灵后，可通过键盘上下左右箭头键进行翻页，从而选择所需信息。

键盘精灵快捷码

报价窗口：

00 多图同列

1 交易信息

03 上海指数

04 深证成指

05 切换实时/日线

06 自选股

08 切换周期/板块

30 涨幅排名

31 涨速排名

32 量比排名

30 涨幅排名

31 涨速排名

32 量比排名

33 成交额排名

34 换手率排名

61 上海A股涨幅排名

62 上海B股涨幅排名

63 深圳A股涨幅排名

64 深圳B股涨幅排名

65 A股涨幅排名

66 B股涨幅排名

67 基金涨幅排名

81 上海A股综合排名

82 上海B股综合排名

83 深圳A股综合排名

84 深圳B股综合排名

87 基金综合排名

89 中小企业综合排名

99全屏显示

分析窗口：

0 分笔

1 1分钟

.1 交易信息

2 5分钟

3 15分钟

4 30分钟

5 60分钟

6 日线

7 周线

8 月线

9 年线

19 权息校正

d 多日线（D+天数+回车键），如3日线，在键盘精灵中输入D3回车即可调用到k线图。

m 多分钟线（m+分钟数+回车键），如3分钟线，在键盘精灵中输入M3回车即可调用到k线图。

S 多秒线（s+秒数+回车键），如3秒线，在键盘精灵中输入S3回车即可调用到k线图。

q 多季度线

n 多半年线

J 节气线

温馨提示：

1、多秒线数据是由分笔数据计算而来，所以最多只能显示当天的数据。

2、多分钟线中，能被5整除的时间，由5分钟数据计算而来，不能被5整除的时间，将由1分钟数据计算而来，所以在使用时，数据显示长度将受到这2个周期数据的影响。如果需要较长数据时，建议用“数据下载”功能回补后使用。


工作区

工作区功能的引入，主要是为了满足您有不同的操作配置方案，并能快速切换的需求。

1、软件主窗口左上角区域显示的“国内股票”、“国内期货”、“外盘外汇”等标签即是几个不同的工作区，如下所示，这些工作区是软件预设的工作区，称为系统工作区（该类工作区系统不允许删除）。

2、用户可以新建自己的工作区，称为自定义工作区。用户还可以打开/关闭工作区，可以删除自定义工作区，还可以调整工作区显示的左右顺序或者将工作区从工作区标签区域中拖出来作为一个独立的窗口到拖另一个屏幕中显示。

3、金魔方工作区的特色：

多屏显示工作区：这是金魔方独特的功能。可通过拖放，将当前屏幕中的工作区，移动至其他屏幕中，即可虚拟出一个独立软件界面（其他软件只能拖放窗口，鼠标操作还需要使用主屏幕中的软件菜单，使用相当不方便），而您只需在当前工作区屏幕操作即可。绝对不会因为频繁操作而头晕哦！

自建个性工作区：如果您只跟踪自选的品种，可以新建一个“自选工作区”，可以将自己关心的股票，外汇，期货，股指期货等品种加入，这样下次，只要点击“自选工作区”就能快速进入或切换。别忘记！如果有多屏的话，还可以单独在另一个屏幕显示并操作哦！

下面就让我们来了解更详细一些吧！

新建工作区

点击工作区标签右侧“+”按钮，弹出下拉菜单中选择“新建工作区”，在对话框中键入工作区名称，点击确定即可实现，当前已显示的工作区在下拉菜单中呈灰色不可选状态。

关闭工作区

点击工作区标签右上角“x”关闭按钮，系统工作区隐藏于标签右侧“+”按钮下。

删除工作区

1、系统工作区不可删除，点击关闭按钮只能隐藏于“+”按钮下。

2、 删除自定义工作区：按Ctrl+关闭按钮。

调整工作区位置

1、 左右移动工作区

您想将最后的工作区排在最前面时，可以通过移动工作区功能实现。

体操作如下：

在某个工作区标签上按住鼠标左键然后左右拖曳鼠标，可以看到工作区标签将随着鼠标移动，移动到想要让其显示的位置后松开鼠标，该工作区标签显示的位置就改变了。

2、 将工作区拖出作为独立窗口

如果您在使用多屏幕显示器，可以直接将工作区拖到另一个屏幕中，作为单独窗口显示。

具体操作如下：

在某个工作区标签上按住鼠标左键然后往上或往下拖曳鼠标，该工作区就被拖出作为独立窗口显示了，这个窗口和主窗口拥有同样的菜单，状态栏、导航面板、公式管理面板等，可以很方便地操作。

如果想要把拖出来的工作区放回到主窗口中显示，则在这个工作区标签上按住鼠标左键然后将其拖回主窗口的工作区标签区域中在想要让其显示的位置上松开鼠标即可。

如果在拖出来的工作区独立窗口上直接点击右上角的关闭按钮，则这个工作区会自动回到软件主窗口中隐藏起来，隐藏在工作区标签区域右侧的下拉菜单中。

如果存在工作区独立窗口时点击主窗口右上角的关闭按钮，会自动将一个独立窗口作为主窗口，将之前的主窗口中的工作区隐藏到这个新的主窗口中。


系统

1、连接行情：

此状态为在已断开行情的情况下可选，否则为灰色状态。点击后出现驱动界面，可在—登录信息—中输入用户名、密码；

2、断开行情：

可断开服务器，停止行情接收；

3、保存布局

可以先按照自已的喜好调整好窗口布局（包括工具栏，颜色，分析周期，多图组合等等），然后可以通过这个功能将当前的窗口布局保存成布局文件。

4、调入布局

将布局文件导入系统，选择菜单下列表中的布局文件，导入布局内容。

5、工作区管理：

包含删除当前工作区、新建工作区、新建窗口功能，操作等同在界面上的功能键。

6、板块管理：

为了更方便的管理系统里面的各种分类板块，软件提供了“板块管理”功能。您可以在此面板中，新增、添加、删除自己的板块。

具体操作如下：

板块管理分为二级。第一级为类别项目，包括系统板块、自选股、分类板块等，鼠标双击其中的项目可展开或收拢该项目下的第二级项目。第二级为板块项目。其中系统默认的板块是不可删除和修改的。只有板块名称后有[自]字样的才能修改和删除。

6.1 自建板块

必须选中第一级的类别项目，界面右边的“新建板块”才能操作，否则无法新建。所以首先选中新板块需要放置的第一级项目，然后点击右边的“新建板块”，在弹出框中填入新建板块名称，点击“确定”即会在该类别项目中创建该板块。而该板块显示的名称除您输入的名称外，系统会默认后面加上[自]，代表是您自建的板块，是可以由您自由修改或删除的。

6.2 新建自选板块

与自建板块类似，只是第一级指定在”自选板块”新建，而有所不同的是，新版块名称前必须加上“自选-”,否则系统不会保存您新建的板块。

7、数据管理

当您分析、选股、评测证券的过程中，需要使用更长的数据时，可以通过“数据下载”功能补充。

具体操作如下：

选中数据下载菜单，弹出数据下载界面，界面提供快速下载、超长数据下载两种不同的下载方式。

7.1 快速下载

当您只需要短线选股时，可以使用“快速下载”功能，快速获得近期的数据。

具体操作如下：

该下载方式的特点为，无需您设置下载时段，系统自动将您所缺的数据补齐，满足绝大部分的看盘需要。其主要提供全部的日线数据及日线以下周期的近期数据，如1分钟数据（仅包含最近10天）、5分钟数据（仅包含最近50天）、分笔数据（仅包含当天）。

使用时，首先需登录行情服务器，否则无法下载。然后选中需要下载数据的范围，如深沪股票、商品期货等，再选择需要下载的数据类型，如日线、5分钟或除权数据等，最后，点击“开始下载”，等待系统提示下载完成后即可。

温馨提示：正常情况下使用快速下载，请使用系统默认的下载方式：自动补齐。这样系统会自动判断您需要下载多少数据。

7.2超长数据下载

当您需要较长数据进行策略评测时，建议使用“超长数据下载”功能。

该下载方式的特点为，提供更长时间段的日线以下周期数据，可自定义下载的品种、时间段。主要满足您评测所需要尽量多数据的需求。

单品种超长数据快速下载操作：

在k线图界面下，在空白处右键点击，在弹出的右键菜单中选中“下载更多数据”后，系统会自动切换到“超长数据下载”界面，并自动选取当前画面中的品种，您只需再设置下载的时段和数据周期类型，点击下载即可。

批量数据下载具体操作如下图：

使用时，首先点击“请选择品种”后面的小文件夹图标，在弹出“选择证券”窗口中选择需要下载的品种。

如需多选，可按住键盘左下角的ctrl键，鼠标点击多个品种名称，可见到所点中的品种名称都变蓝色，代表已被选中，最后，点击“确定”按钮，即可多个添加。

如需全选，可先用鼠标点蓝窗口的第一个品种，然后按住键盘左下角的Shift键，再用鼠标点窗口里的最后一个品种，这时，整个窗口的品种都会变成蓝色，代表已全被选中，最后，点击“确定”按钮，即可全部添加。

如添加了您不想要的品种，可通过x按钮进行删除。

选择好品种后，再选择您需要下载的数据类型，（如1分钟。而日线全部数据已在快速下载中提供，所以这里没有日线数据选项），之后，再设置需要数据的时段，最后点击“开始”，直到系统提示完成。

温馨提示：如果感觉下载数据速度慢，不妨在“选择服务器”那里换另一台试试。

8、 复制数据

将当前报价表中数据拷贝到剪贴板，可指定栏目数；

9、 打印

9.1 打印

打印功能为您在纸打印出和屏幕显示一样的图象，系统支持彩色打印。也可将当前显示的内容输出到图形文件。

9.2 打印预览

可在实际打印前在屏幕上观察打印效果，便于调整打印效果。

9.3 打印设置

设置打印机和纸张，并且可以设置打印图形在纸上的位置和大小。

10、图形输出

将当前显示的软件界面内容输出到图形文件，可选择保存路径、图形文件格式，保存像素等；

11、选项

可以设置系统的各种参数。

11.01 外观

用于配置图形分析画面、证券列表窗口的外观。在中间[颜色项目]中列有可设置的项目，如图形背景、列表背景、图形文字、坐标轴、价格线（阳线、阴线、美国线）、指标线，若要改变某项设置，则可以用鼠标点击该项。
    【配色方案】系统提供若干预定义的配色方案供选择。缺省为自定义（指系统正在使用的配色方案），点击下拉按钮将出现更多配色方案，选中某个方案，【图形预览】窗口显示该方案的效果图。
    设置图形字体、画线字体或列表字体选项，可分别用于改变图形文字、画线文字或证券列表文字的字体与字号。

可以按【方案另存为】按钮将自设的方案保存在硬盘。

缺省线宽：调整系统指标线形宽度。

仔细审视【图形预览】，感到满意后，点击【确定】按钮，配色方案即生效。

11.02 参数

自动换页时间（秒）：可对【画面】-【自动翻页】功能的翻页时间进行控制。

预警时间间隔（秒）：可对预警间隔多少时间计算一次进行设定。

指标排序更新时间（秒）：可设定指标排序时的刷新时间。

11.03 选项

报价表高亮显示价格变动：选中后，报价表界面中，只要品种有价格变动，将会以高亮背景显示该价格变动。

列表切换板块时保持排序：选中后，在列表界面中切换到板块列表中，依然按之前列表的顺序排序。

退出软件时提示：选中后，在关闭软件时，系统会提示是否关闭软件。

提示测评或交易状态下不能进行此操作：选中后，在测评或交易状态下，做切换周期、切换品种、切换策略等操作时，会提示“不能进行此操作”。

软件启动后自动运行自动交易：选中后，每次启动软件，都会自动进入自动交易状态。（提示：该功能需保存交易账号和交易密码）

开启智能无人值守模式：选中后，软件如果在运行中非正常退出后，系统会自动拉起软件。（适合自动交易使用）

11.04 图形

多图同列模式：可设置在多图同列状态下，同时显示多少个图。

自动保存指标参数：选中后，系统会将您最后调整过的参数进行保存。

画线自动隐藏：选中后，当关闭画线工具条时，所有画线会自动隐藏。如需调用，打开画线工具条即可。

缺省k线数量：设置后，每次打开k线图，图中会默认显示设定的k线数。

加载k线数量：为了避免k线数量太多导致计算量巨大，可在此项中设置k线图加载的k线数量。

实体阳线：选中后，原空心阳k线变成填充实体阳k线。

画线结束保持该画线状态：选中后，每次选中的画线工具画完结束后无需再选中该画线即可重复使用。

K线末端空余k线数：设置后，最后一根k线将离画面最右方距离N根k线的位置。

切换证券时保持主图叠加：选中后，在切换品种时，原主图叠加的品种走势继续显示。

显示左坐标轴：选中后，画面左侧将增加一个纵坐标轴。

K线图缩小到所有后可继续向左压缩：选中后，K线图缩小到最小后，还能向左压缩。

所有股票的分时图显示红绿柱子：选中后，所有股票的分时图昨收价位置都显示多空红绿柱子。

打印时总打印黑白图像：选中后，每次会自动默认以黑白颜色打印。

指标标题栏换行显示：选中后，指标名称和数值可多行显示。

鼠标滚轮方式：选中切换品种，鼠标滚轮状态下切换品种，选中缩放k线，鼠标滚轮状态下缩放k线。

【细】最新成交在上方：选中后，在信息栏中的明细中，成交明细最顶部最新成交排序。

工作区中非活动窗口隐藏标题栏：在工作区中多窗口排列时，鼠标未选中的窗口不显示顶部的标题栏。

十字光标自动吸附：选中后，鼠标不移动到k线外，十字光标将锁定在k线中央。

11.05 坐标

纵坐标线显示：选中后，在k线图界面中，将会显示纵向坐标虚线。

横坐标线显示：选中后，在k线图界面中，将会显示横向坐标虚线。

纵坐标总是标示最小最大值：选中后，纵坐标总是会显示k线或指标的最大最小值。

百分比坐标对齐方式：左对齐，为坐标数值按左对齐方式显示，右对齐，为坐标数值按右对齐方式显示。

等分坐标几等份：设置后，纵坐标将按以N等份方式显示。

主图坐标仅随k线变动：主图坐标不考虑主图叠加指标值。

实时图采用等分坐标：选中后，分时图中将会采用等分坐标显示。

实时图坐标类型：百分比，以固定百分比坐标显示。最高最低，以当日的最高最低坐标显示。

实时图坐标最小百分比幅度：可设置实时图最小百分比幅度显示。

信息面板k线坐标百分比：选中后，信息面板右下角的k线小图以百分比坐标。

主图坐标坐标显示最新价：选中后在纵坐标轴上最新价以白底高亮显示。

技术分析坐标显示时间滚动条：选中后时间轴将会显示时间滚动条，可通过滚动条左右移动k线图。同时按住右键方式的还将起作用。

11.06 数据

完全点播模式：选中后，只有选中的品种才会有行情，适用于自动交易，减少资源占用。

多秒线：可设置默认显示n秒线。

多分钟线：可设置默认显示n分钟线。

多小时线：可设置默认显示n小时线。

多日线：可设置默认显示n日线。

多周线：可设置默认显示n周线。

多月线：可设置默认显示n月线。

多季线：可设置默认显示n季线。

多年线：可设置默认显示n年线。

11.07 外挂

设置需外挂系统的路径即可共享外挂系统的数据，可设置外挂交易委托、投资管理、资讯浏览、F10资料查阅系统。

自助委托一外挂系统可按F12启动。

自助委托一外挂系统可按ALT+F12启动。

11.08 测评

资金不足时强平：选中后，测评中如出现资金不足情况，系统强行平仓。

忽略下单函数的滑点：选中后，测评中将忽略下单函数里面设置的滑点。

期末持仓强平：选中后，测评中遇到最后还有持仓时，强行平仓。

无风险利率：设置无风险利率的数值。

多少个标准差当做极端交易：设置极端交易的标准差参数。

12、退出

退出本系统。


量化交易

1、智能交易评测

点击该菜单可以打开策略评测系统，支持单策略、多策略智能交易。

2、评测报告

可查看智能交易评测的结果详细分析报告。

3、本地模拟交易

打开本地模拟交易入口，可以在本地使用模拟账户进行自动交易或手工交易。

4、退出本地模拟交易

退出停止在进行中的本地模拟交易。

5、真实交易委托

打开真实交易入口，需要登录真实的账户，做真实的交易。

6、退出真实交易

退出停止真实交易。

7、账户信息

打开显示账户的信息，包括委托、持仓、资金、历史成交、合约配置、追价单等。

8、交易日志

打开显示交易的明细情况，包括账户登录时间、持仓、下单、开仓、平仓事件记录。

9、交易管理

9.1 经纪商管理

可添加或删除系统配置的经纪商网络下单设置。

9.2 查询结算单

可以查询历史结算明细数据。

9.3 交易参数配置

可以修改参议参数设置，如等待撤单时间等。

10、公式日志

是记录策略输出的信息，方便随时监控策略运行状态，输出的内容可以保存为文本文件。

11、全局变量

用于添加、删除全局变量。

12、公式编辑器

打开公示编辑器，用于公式、交易策略的编写及公式编译。

13、账户上传到花生网

可将运行的交易记录包括模拟和真实的交易记录上传到花生网网站进行策略评测。

14、策略上传到花生网

可将策略运行的结果上传的花生网。打开菜单后，如下图提示。

15、启动所有智能交易

启动所有智能交易选中后打开软件后自动进入所有智能交易，便于自动交易时系统崩溃后自动重启软件后自动进入交易状态。

16、无人值守模式

打开无人值守模式时如果程序崩溃退出后能自动打开程序。

17、防止计算机休眠

计算机休眠功能打开时，如果系统处在自动交易状态，计算机休眠会导致交易中断；选中这个后防止计算机进入休眠状态下影响自动交易状态。

18、交易风险控制

设定下单条件及品种限制，以降低交易风险。


查看

1、导航：

当您想在当前工作区打开更多的窗口时，可以通过“导航”窗口实现。

具体操作如下：

“导航栏”位于报价窗口左侧，点击右上角“X”将关闭。

说明：包含“当前工作区窗口”及“自选股”，两种导航：

（1）选择菜单栏“查看”→“导航”；

（2）单击软件左侧，可自动隐藏和打开。

2、公式管理：

当您想查找公式、策略、或与别人分享策略时，可以进入“公式管理”界面进行操作。

具体操作如下：

公式系统，双击下属各功能名称可展开其相应子功能；

（1）在搜索栏中键入所需搜索项，公示系统将自动进行搜索查询

（2）两种打开方式：

A、选择菜单栏“查看”→“公式管理”；

B、单击软件左侧，可自动隐藏和打开。

3、综合排名

点击“综合排行”则打开综合排行榜窗口，显示某个板块中的证券按各种不同的指标排序的情况，同时可以显示9个列表即9个不同指标的排序状态。

点击“选择板块”按钮可以选择想要查看的板块，例如可以选择A股板块，B股板块，上海A股，深圳A股等。

在9个列表中的任意一个列表中点击右键，在弹出的右键菜单中可以对当前这个列表选择指定的排序指标，支持以下这些排序指标：当日涨幅排名、当日跌幅排名、当日振幅排名、当日成交额排名、当日成交量排名、当日换手率排名、当日量比排名、当日委比排名、当日委差排名、外内盘比值排名、外内盘差值排名、涨速正序排名、涨速逆序排名。

对于每个指标排序列表，可以在右键菜单中选择是升序排列还是降序排列。

右键菜单中的“同步锁定”是指选择了“同步锁定”后，在一个列表中选中一个证券，这个证券在其它8个列表中就会被自动选中，方便比较同一个证券按不同的指标排序所处的位置。

右键菜单中的“刷新”选项是用来刷新指标排序。

点击“排名设置”，可以设置：排名数及风格设置。

按上面参数修改后，出来的综合排名榜如下图

4、成交明细

可查看每支证券的每笔成交。在证券的分析画面中，打开菜单出现如下图。

5、分价分量

可查看每支个股每分钟的成交量和价格关系。在证券的分析画面中，打开菜单出现如下图。

6、显示工具栏

在分析图或实时图窗口中，选中此菜单后，显示工具栏内容，否则隐藏工具栏，扩展窗口显示空间，如下图。

7、显示快速切换

在分析图或实时图窗口中，选中此菜单后，显示快速切换条，否则隐藏快速切换条，扩展窗口显示空间，如下图。

8、打开安装目录

打开软件所在的目录。

9、季节分析

在某个证券的分析窗口，打开菜单“查看-季节分析”，可以选择起止年份，查询到某个证券在某年某月的平均涨幅，以及该证券在查询时间段内每个月份的平均涨幅。


工具

1. 条件选股

条件选股就是由用户设定一些条件，例如短期均线上穿长期均线，然后由计算机按照这个条件自动地搜索所有的股票并找出符合条件的股票。该功能可以为用户选出当前行情或历史一段时间满足条件的股票，还可以测试选股条件在历史一段时期的成功率。

2. 预警

提供实时报警功能，在股票满足预定的条件时（例如价格涨幅大于某个百分比），自动进行报警，弥补了盯盘顾不过来的情况。

3. 太阳风暴

太阳风暴与传统分析软件的盯盘、选股功能不同，它以二维的图形化坐标视窗为平台，在一个界面中，能同时盯住全部股票的一举一动，轻松发现盘中异动个股，并且用户可通过观察股票在不同坐标轴组合中所处的位置，寻找离散的股票，选择潜力个股，且能直观判别个股在坐标轴作用下的强弱差别，真正使盯盘、选股变得简单、直接、准确、实用。

4. 自定义数据

自定义数据，可灵活管理、应用各类数据（如发行价、自编公式数值），可通过SELFDATA(S)和SELFSTRING(S)函数在个周期下调用,并可将数据导入导出。

5. 横向统计管理

本软件能对整个市场或某些板块进行横向的统计,从而大大加强了资料的丰富性及实用性,同时用户可通过公式系统里的"ESTDATA(N)"函数在各周期下自由调用.

6. 历史回忆

系统能够存储若干天的实时线及分笔成交数据（可以通过下载数据）,通过历史回忆功能,就可回去查看某个交易日所有证券的交易情况。系统用高亮度色作为背景显示处于回忆状态的数据。

7. 所属板块

它表明该股票按不同分类标准划分，分别属于哪些板块。

8. 计算器

启动WINDOWS的计算机，便于进行数据计算。

9. 记事本

启动WINDOWS的记事本，便于记录文本信息。


窗口

1. 全屏显示

可将窗口内容做全屏显示。

2. 层叠

将打开的多个窗口层叠起来。

3. 平铺

将打开的多个窗口平铺起来。


帮助

1. 语言

选择软件语言，如中文简体、繁体；

2. 金魔方论坛

直接在浏览器打开 金魔方论坛 (花生网论坛)。

3. 关于

关于本软件的名称、版本、所属公司等信息。


添加/关闭报价板块

当您需要同时看多个报价时，可以添加报价板块，而当您觉得画面太多内容，影响看盘时，也可以关闭部分不用的报价板块。

具体操作如下：

1、添加：点击工作区下板块右边的加号，出现所有市场板块、分类板块、自定义板块，点击板块名后，完成报价板块添加，被添加过的板块在菜单里显示名字前有勾。

2、关闭：点击报价板块右侧“X“关闭按钮即可关闭报价板块。


调整报价板块位置

左键按住报价板块进行鼠标拖动即可实现调整报价板块位置。


调整报价表显示栏目

如果您觉得报价表表头的显示栏目不够用，或不是您想要的顺序，可以通过“定制表头栏目”达到您的目的。

调整打开方式：右键点击报价窗口任意品种，在填出菜单里选中“定制表头栏目”；

在“定制表头栏目”子菜单下分“可选栏目”和“当前栏目”，

（1）选中（可多选）“可选栏目”下栏目名称→增加，可将栏目增加至“当前栏目”中；

（2）选中（可多选）“当前栏目”下栏目名称→增加，可将栏目删除至“可选栏目”中；

（3）可对两个栏目中名称进行“上移”或“下移”操作；

（4）最后点击“确定”在报价窗口中即显示出自定义的表头栏目。


调整报价表显示列宽

鼠标指向报价表表头栏目分割线，当鼠标变为红色双向箭头，按住鼠标左键左右拖动即可实现调整报价表显示列宽。


切换报价表显示属性

鼠标点击报价窗口左侧TAB，可现实该报价窗口在“行情、财务”两个不同列表间切换。


选中报价表中的证券

1、左键点击证券，可选中一个证券。

2、按住Shift+左键点击，可选中多个连续证券。

3、按住Ctrl+左键点击，可选中多个不连续证券。

4、右键点击报价窗口，子菜单“选中全部”，选中报价窗口中所有证券。

5、右键点击报价窗口，子菜单“选中当前屏”，选中当前报价窗口中所有证券。


报价表排序/取消排序

（1）右键点击表头栏→升序/降序/取消排序（ESC）。

（2）左键单击任意表头栏目，依次默认排序顺序为降序、升序、取消排序（ESC）。


在报价表中添加/删除标记

如果您想将某个证券标上一个记号，方便自己下次寻找或观察，可以通过“添加标记”功能实现。

具体操作如下：

添加：在报价窗口中右键点击证券（可多选），在菜单中选择“添加标记（可多选）”，子菜单下选择系统默认10种不同标记，可在报价窗口序号列显示标记。

删除：在报价窗口中右键点击证券，在菜单中选择“添加标记（可多选）”，子菜单下选择“取消标记”。


从报价表中加入证券到自选股板块或自定义板块

当您觉得某些品种需要经常关注时，可以添加到板块、或自选股的方式实现。

具体操作如下：

首先新建一个自选股板块或自定义板块，回到报价窗口

1、右键点击某个证券，出现菜单-加入到自选，点击完成操作；
2、右键点击某个证券，出现菜单-加入到板块，点击，再进行板块选择，完成操作。

3、通过选中多个证券后，右键点击其中某一证券，出现菜单-加入到板块，点击，再进行板块选择，完成操作。


复制报价表数据

当您想将报价表中的数据拷贝到excel表格中时，可以使用“复制数据”功能实现。

具体操作如下：

选中若干证券后右键点击报价窗口证券，在菜单中选择“复制数据”，在弹出窗口中输入需要复制的栏目数（默认为当前显示的所有栏目，如果只需复制前7行，可将数字改为7），点击“确定”， 系统将所选证券报价表栏目中的证券数据拷贝到剪贴板。


设置/取消常用板块

如果您经常要查看某些板块，可将其设置为“常用板块”，这样可以通过快捷键快速的调用查看。

具体操作如下：

设置：右键点击报价窗口中任意证券，在菜单中选择“设置常用板块”，系统已将该板块设为常用板块（注：系统最多支持设置9个常用板块，键盘精灵输入51-59可调出板块查看。）

取消：在已设置常用板块的前提下，右键点击报价窗口任意证券，在菜单中选择“取消常用板块”。


使用键盘精灵加入证券到自选股板块或自定义板块

在自选股报价窗口下，右键点击报价窗口任意证券，在菜单中选择“键盘精灵加入证券”，使用键盘精灵输入证券代码然后回车，即可实现将证券加入到自选板块或自定义板块。


调整自选股板块或自定义板块中证券的显示位置

1、在自选股或者自定义板块报价窗口下，左键点击证券进行上下拖动即可实现调整证券的显示位置。

2、在自选股或者自定义板块报价窗口下，左键点击证券在子菜单中选择“置顶显示”即可实现调整证券的显示位置。（注：除显示位置已为第一的证券）


从报价表中打开选中证券的分析窗口

如果您想在报价表中打开某个证券的走势图，有一下几种方式：

1、在报价窗口下左键双击任意股票；

2、 在报价窗口下左键单击任意股票→按下Enter；

3、 在报价窗口下右键点击任意证券→打开，在导航“切换到”则会显示该支证券的分析窗口名称，若以相同方式再打开另一支证券则会覆盖前一支证券；

4、 在报价窗口在右键点击任意证券→打开新窗口，在导航“切换到”则会显示该支证券的分析窗口名称，若以相同的方式再打开另一支证券，则不会覆盖前一支证券，而是再显示一行。


报价表指标排序

指标可在任意报价表中排序，还能在自设指标界面中保存及多次调用，下面我们来看看如何操作。

在自设指标页面中排序操作：

也可对指标进行刷新、另选指标、排序、删除等操作。

在自设指标页面中还可将自设指标表保存、调用。

自设指标报表保存操作如下：

自设指标报表调用操作如下：


K线图/实时图切换

当您需要在k线图切换到实时图时，可以通过以下四种方式实现。

1、点击分析窗口左侧的“技术分析”、“分时走势”，可以切换K线图/实时图。

2、 点击分析窗口上方的周期工具栏“实时”其他周期按钮。

3、按下Enter键或F5即可实现K线图与实时图见的相互切换。

4、菜单-分析窗-实时/日线切换或者分析周期选取切换的周期。


复权

如果您发觉k线图形有较大的跳空缺口，影响分析，可使用“复权”功能恢复成连续的k线图。

具体操作如下：

1、点击工具条复权按钮“权”，可对当前证券进行“向前复权、向后复权、等比复权”，再次点击即取消。

2、右键点击纵坐标，可对当前证券进行“向前复权、向后复权、等比复权”，再次点击即取消。

下面是几种除权属性说明：

向前复权与向后复权

向前复权是在复权时把除权前的价格降低，保持除权后的价格不变；向后复权是在复权时保持除权前的价格不变，而是把除权后的价格提高。一般的复权方式是向前复权，因为这样可以保留现 在的价格，而向后复权方法的优点是以前某一天的数值不会因后来的除权而发生变化。

等比复权

复权处理中保持除权之前的涨跌幅不变。

日间复权

自动回补每日k线之间的跳空缺口，去除应跳空缺口导致指标变形的情况，更利于分析的连续性。


股票叠加(主图叠加)

如果您想将多个股票的k线图叠加在一起分析强弱时，可以使用“股票叠加(主图叠加)”功能实现。

具体操作如下：

在K线图下，点击左上角工具栏“叠”(或打开菜单 画面—主图叠加)，弹出窗口，选择证券，出现提示“是否将主图坐标设置为百分比坐标”，点击“确定”后现在股票K线叠加图，可同时选择 多只证券进行叠加（系统默认最多为6图叠加，并用不同颜色文字区别股票）

快捷方式：键盘敲入证券代码或拼音首字母，激活键盘精灵，确定后同时按CTRL+ENTER键。

要取消某条主图叠加的价格线，可以用鼠标右键点击该线，弹出菜单后，选择“删除主图叠加”即可。


移动画面

当您想直接用鼠标平移整个走势图时，可以使用“移动画面”功能。

具体操作如下：

1、点击工具条“平移图形“按钮，当鼠标变成手形状，将鼠标移至主图画面上即可对主图画面进行上下左右移动。

2、鼠标指向横坐标/纵坐标并进行拖动，即可对主图画面进行上下左右移动。


切换画面分析周期

当您想切换不同周期的走势图时，可以使用以下几种方式实现。

具体操作如下：

1、在分析窗口下回车，将当前显示的证券进行实时/k线切换。

2、右键点击【分析窗口】内k线图位置，弹出菜单－【分析周期】，分析周期有：实时、分笔、1分钟、5分钟、15分钟、30分钟、60分钟、1小时线、4小时线、日、周、月、季度、半年、年 线图、自定义多秒、多分、多时、多日、多月、多季、多年线、农历节气线。

3、用鼠标右键点击主图右下角时间轴与纵坐标交叉的分析周期区域，弹出周期选择菜单后，用左键击取需要的分析周期图。

4、工具条上有分析周期按钮，可以直接点击进行切换。


十字游标

左键双击主图画面，鼠标变成十字形状开启十字游标；再双击一次，关闭十字游标；也可以在主图上双击鼠标左键，切换开启/关闭十字游标。

开启十字游标后，弹出一个数据窗（可最小化隐藏起来，或者随意拖动至合适位置，以免影响看图），显示游标所在位置的详细行情信息，每个指标的对应数值也将显示在指标图的上部。十字游标跟随鼠标移动而移动。
    按〖Home〗、〖End〗、〖→〗、〖←〗，可以启动十字游标并左右移动它，同时可能会弹出一个数据窗，数据窗可最小化隐藏起来，或者随意拖动至合适位置，以免影响看图，数据窗显示游标所在位置的详细行情信息，每个指标的对应数值也将显示在指标图的上部。


添加/删除/最大化副图

如果您想同时使用多个指标分析时，可用以下几种方式添加或删除副图：

1、右键单击分析画面主图或副图，在菜单中选择“添加副图窗口”/“删除副图窗口”，每次可添加或删除一个副图。

2、在菜单“画面-主副图数”的子菜单中直接选择主副图数目。

3、使用快捷键Alt+数字1-9直接选择主图副数目，Alt+1代表只有主图没有副图，Alt+2代表一个主图和一个副图，Alt+3代表一个主图两个副图，依此类推。

打开多个副图时还可以最大化某个副图而其它副图都最小化，要最大化某个副图则在该副图任意位置上双击鼠标即可，要还原最大化的副图则再次在该副图上双击鼠标即可。

温馨提示：

统最多支持打开8个副图和一个主图。


显示/隐藏常用指标工具栏

如果您有几个指标经常会用到，但每次使用时都觉得调用麻烦，可以将这类指标加入到常用指标工具栏中，使用时，只要点击工具栏即可。

体操作如下：

用指标工具栏位于副图窗口下方，可以设置其显示或不显示，在主图上点击右键，选择右键菜单“隐藏常用指标工具栏”可将常用指标工具栏隐藏，再次在主图上点击右键，选择右键菜单 “显 常用指标工具栏”可显示常用指标工具栏。


画线功能

在走势图或指标图上画线可帮助您更好地进行图形分析，其中直线画线工具还提供了非常实用的趋势线预警功能。打开分析窗口，您就能看到系统提供的多种画线工具条。

点击鼠标选择一种工具进行画线，画线一般采用鼠标拖动方式进行，移动鼠标到绘图区，在画线起点按下鼠标左键不放并拖动鼠标到终点位置，此时系统就会跟踪您移动鼠标的过程，自动提供一个反馈图形，有些画线还提供角度的提示（如画直线，速阻线，江恩线等）。当您觉得满意时，放开鼠标左键就可以在屏幕上画出该种线型。由于在绘制过程中有一个反馈过程，所以您可以轻易直观地画出满意的线条。

如果您希望能够得到非常精确的画线及画线参数自定义，希望画线的起点与终点能与股票价格严格对应起来及使用自定义参数，这时您可以使用【画线设置】的功能来实现。方法是用鼠标右键点击此画线，然后在其右键菜单中选“画线设置”。（其中黄金分割线、江恩线、多通道线、波浪预测、百分比线、费氏时间线、费氏圆、多圆弧可独立调整画线参数，黄金分割、黄金分割A、黄金分割B、波浪预测、百分比线、标准差通道中的[画线设置]中可设置是否向左、右延长。）

     画线完成以后，可用鼠标拖动画线的起点或终点，改变画线方向；还可以按住CTRL键，用鼠标拖动画线的定位点(选中画线后显示为小方块），系统的吸附功能能将此线上的小方块自动定位到该K线上的最高或最低点。

画线过程中如需多次重复使用同一种画线方式，可在工具条中先选定【保持画笔】功能，使用时就无需每次都点击工具条。这种模式下，如果要做画线外的其他操作，则要先点击工具条中的小箭头按钮。

    鼠标左键点击击画线，可看到画线起点和终点出现小方块，表示已选中该画线，此时按〖Delete〗键可删除它。也可在右键弹出菜单中选【删除】项删除。如果要删除所有的画线，请在画线工具条点击【删除所有画线】按钮。

鼠标右键点击击画线，在弹出菜单中选“颜色”可改变画线颜色，画线的默认颜色在工具条上【预设颜色】里设置的，使用时先在预设颜色中选中一种色彩，然后再画线，该线的颜色即为在预设颜色中选中的色彩。

   系统会自动保存用户的所有画线，下次进入该图时又会自动显现出来。

显示其它分组画线：

分组画线的概念：在一个窗口上打开的分析图画线，是一组画线；如果在另开一新窗口，再画线，那就有另一组画线；要显示其它分组画线，可以点击这个菜单。

插入画线文字注释：

可以在画线附近或者K线附近写文字说明，点击下图中的A文字，鼠标变成铅笔的图形。

在需要添加文字的位置点击，出现文字的编写窗口，输入内容，再点击确定插入文字内容。

分析图上插入符号：

可以在画线附近或者K线附近写符号图，点击下图中的“符号”，鼠标变成铅笔的图形。

在需要添加符号图片的位置点击，出现符号的选择编辑窗口，再点击确定插入图片符号。

趋势线预警功能：（仅“直线”工具才能使用）

使用“直线”工具在图形中画好直线后，右键点击直线，在弹出菜单中选中“趋势线预警”，即可实现走势上、下穿过该直线时，系统预警提示。设置之后，直线末端会出现一个小喇叭的图标用 以提示与一般直线的区别。


在分析画面上显示、操作公式指标

如果您在k线图界面需要切换不同的指标，请看以下我们的具体操作：

1、切换显示的指标

分析画面主图或副图上切换显示的公式指标可以通过以下几种方式：

（1）点击常用指标工具栏上的指标（如有多个副图则需要先单击选中某个副图才可以在这个副图上显示所点击的指标；主图指标则会自动显示到主图上不需要选中）

（2）通过键盘精灵输入公式指标名称来选择（如有多个副图则需要先单击选中某个副图才可以在这个副图上显示所点击的指标；主图指标则会自动显示到主图上不需要选中）

（3）在主图或副图上点击右键，通过右键菜单“选择公式”来选择想要显示在该图上的公式指标

（4）从公式管理面板上将某个公式拖放到某个主图或副图中

2、叠加显示多个指标

主图或副图中可以叠加显示多个指标，要叠加指标则需要按住Ctrl的同时将想要叠加显示的指标从公式管理面板中拖放到主图或副图中。

3、关闭指标

想要关闭主图或副图上显示的指标，可以通过右键点击主/副图上显示的指标线或者指标名称，然后选择右键菜单“关闭指标”来实现。

4、查看指标用法说明

点击主/副图上显示的指标线或指标名称的右键菜单“指标用法说明”，就会弹出一个对话框显示该指标的用法说明。

5、调整指标参数

点击主/副图上显示的指标线或指标名称的右键菜单“调整指标参数”，就会弹出该指标的参数调整界面，参数调整后画面上显示的指标会即时刷新，还可以把调整后的参数设为默认参数，这样以 后使用该指标时都使用这些参数。

6、修改指标公式

点击主/副图上显示的指标线或指标名称的右键菜单“修改指标公式”，就会打开指标编辑器显示该指标的编辑界面。


切换主图类型

技术分析主图支持以下几种不同类型的画法：蜡烛线、美国线BAR、价位线PRICE、宝塔线TWR、鬼变脸GBL、压缩线CNDEQV，默认是最常用的K线（即蜡烛线），想要切换到其它类型，可以通过选择主图右键菜单“主图类型”的不同的子菜单选项来切换，还可以通过选择菜单“画面-主图类型”中的子菜单选项来切换。

美国线：

价位线：

宝塔线：

鬼变脸：

压缩线：


切换横坐标类型

K线图分析画面的支持以下几种类型的横坐标（即时间坐标）：交易日坐标、自然日坐标、公历时间、农历时间、显示节气月相坐标线功能。想要切换时间坐标类型可以在横坐标轴上点击右键，在弹出的右键菜单选项中勾选不同的时间坐标，也可以通过选择菜单“画面-时间坐标”中的子菜单选项来切换。

自然日坐标：自然日坐标就是日历日连节假日(闭市日）也算进去的，对周期统计和江恩分析法有很大的作用。

节气、月相是一种中国的传统历法，在证券分析中有时也会有神奇的效果，一般用于时间窗口提示。

二十四节气包含：立春、雨水、惊蛰、春分、清明、谷雨、立夏、小满、芒种、夏至、小暑、大暑、立秋、处暑、白露、秋分、寒露、霜降、立冬、小雪、大雪、冬至、小寒、大寒。

月相的变化依次为 新月（初一）→峨眉月→上弦月（初七、初八）→凸月→满月（十五，十六）→凸月→下弦月（二十二、二十三）→峨眉月→新月。

右键点击点击k线图的时间横坐标，显示交易日坐标和自然日坐标，可以任选其中一个进行切换。

该功能的特点是，以日历日的方式显示K线，方便一些周期分析爱好者使用与别不同的周期分析方法。

节气月相坐标

在金魔方中，我们先右键点击k线图的时间横坐标，选择农历时间，才能再选中【显示节气月相坐标】，即可在图表中显示节气月相线坐标，其中红点线代表节气，青点线代表月相。


切换纵坐标类型

K线图分析画面支持以下几种纵坐标（即价格坐标）类型：等差坐标、等比坐标、等分坐标、百分比坐标、黄金分割坐标、普通坐标、对数坐标，可在纵坐标轴上点击右键弹出的菜单中选择切换纵坐标类型，也可以通过选择菜单“画面-主图坐标”中的子菜单选项来切换。

坐标属性说明：

u 普通坐标：坐标刻度之间的间隔距离与价格成正比。例如从10元到100元的距离是从1元到10元的距离的9倍。快捷键 CTRL+N

u 对数坐标：坐标刻度之间的间隔距离与价格的对数成正比。例如从1元到10元的距离和从10元到100元的距离相等。不难看出，对数坐标刻度之间的间隔距离与证券的涨跌幅是成正比例的，价格从从1元到10元涨幅达1000%，从10元到100元的涨幅也是1000%，在坐标上的距离显示是相等的，若两个价格之间的纵向距离是另两个价格之间的纵向距离的两倍，则表示前者涨或跌幅度是后者幅度的两倍，可见对数坐标可以清楚地显示证券的涨跌幅。快捷键 CTRL+L

坐标类型说明：

u 等差坐标：刻度数值线之间的间隔差值相等，是缺省时的坐标。快捷键 CTRL+Q

u 百分比坐标：百分比坐标以画面显示的第一天的开盘价为基准，股价表示为与基准的百分比值，这对于主图叠加有用。快捷键 CTRL+P

u 黄金分割坐标：以画面显示的最高价、最低价为基准，分别显示%分割的数值线，对于分析某波段的压力、支撑价位线特别有用。快捷键 CTRL+H

u 10%等比坐标：10%等比坐标：百分比坐标以画面显示的最后一天的开盘价为基准，显示与基准的10%递增和递减的数值线。快捷键 CTRL+B

u 等比坐标：以画面显示的最高价、最低价为基准，对这个区域三等分，显示分割的数值线，对于分析某波段的压力、支撑价位线有用。

其他切换主图坐标类型的方式：右键点击主图坐标区域待弹出菜单后选择。


主图属性

K线图的更多设置，我们可以在纵坐标的“属性”中设置。

右键点击价格纵坐标，在弹出菜单中选中“属性”，可对k线图进行设置。

坐标轴：

坐标Y轴刻度：

固定最大值：填入具体的数值后，k线图显示的最大价格将限制在您填入的数值内。（提示：高于该数值的k线会无法看见）。

固定最小值：填入具体的数值后，k线图显示的最小价格将限制在您填入的数值内。（提示：低于该数值的k线会无法看见）。

主要单位：纵坐标价格显示间隔。如填入5，纵坐标将会每隔5元显示一个数值。

K线加载范围：

【选项】中设置的加载周期数：填入数值后，将会替换【选项】中设置的加载周期数，如填入0数值，代表加载所有的k线数据（该数值对所有工作区有效）。

加载最近N周期：填入数值后，当前工作区的所有k线图，只加载最近N根k线数据。（该数值仅对当前工作区有效）。

结束日期：该选项需选中【加载最近N周期】才能设置。设置该选项后，k线图将以该结束日期，向前显示【加载最近N周期】里设置的k线根数。如加载最近1000周期，结束日期为2012年10月10日，那么k线图将只显示该日前的1000根k线图。（提示：设置该选项后，将不再显示更新行情。）

最近：可设置只显示最近的N周期数据。如10天，10小时。

起始日期：可设置k线图的任意起始时间。

结束日期：该选项需选中【起始日期】才能设置。设置该选项之后，可在k线图只显示起始日期到结束日期之间的数据。（提示：设置该选项后，将不再显示更新行情。）

交易信号：

显示交易数量：选中后，策略在k线图上会显示交易信号数量。

显示交易价格：选中后，策略在k线图上会显示交易信号位置的价格。

显示交易盈亏：选中后，策略在k线图上会显示每笔交易的盈亏数额。


显示波段高低价

进行图形分析时经常要查看波段高低价，想要显示图形的波段高低价则勾选分析画面主图右键菜单选项 “显示波段高低价”，如不想显示则取消勾选此选项。


反转坐标

图形分析有时需要将图形反转过来，反转图形可通过勾选分析画面主图右键菜单选项 “反转坐标”来实现，反转坐标后纵坐标轴上会显示一个“反”字作为标记。如要取消反转坐标则取消勾选右键菜单选项 “反转坐标”即可。


在分析窗口中添加标记

添加：在分析画面主图上点击右键，点击右键菜单 “添加标记”，在弹出子菜单下选择10种不同标记中任意一个，右侧信息面板上就会显示该标记。

删除：在添加了标记了分析画面主图上点击右键，点击右键菜单“添加标记”，在弹出子菜单中选择“取消标记”，右侧信息面板上显示的标记就被删除了。


从分析界面添加证券到自选股/自定义板块

右键单击分析主图界面，在子菜单中选择“加入到自选”，画面上显示的这个证券就被添加到自选股板块中了。

右键单击分析主图界面，在子菜单中选择“加入到板块”，在弹出的板块管理面板中，选中自定义的目标板块，点击“确定”，画面上显示的这个证券就被添加到自定义板块中了。


在主图画面上叠加最新价线、分价分量、买卖盘

在分析画面上点击右键，选择右键菜单“叠加最新价线”/“叠加分价分量”/“叠加买卖盘”可以分别在画面上叠加最新价线/分价分量图形/买卖盘图形。

注意：分价分量和买卖盘图形只能在分时走势图上叠加。

通过“叠加分价分量”功能，我们可以清楚的看到当前哪个价位累计的成交量最大，从而体现出支撑或压力。而买卖盘的叠加则能看到实盘中，哪些价位买入或卖出的意愿比较强烈。


清除主图叠加

如果您之前在主图上叠加了其他的k线图，可以通过“清除主图叠加”功能清除。

具体操作如下：

右键点击主图画面，在弹出菜单中选择“清除主图叠加”，可将画面上叠加的其它证券的K线图，最新价线，买卖盘，分价分量等一次性全部清除。


副图叠加K线

如果您想观察指标背驰的情况，最好的方法就是在指标上叠加k线图。

具体操作如下：

右键点击副图画面，在菜单中选择“副图叠加K线”，副图上就会叠加显示K线。


从分析窗口中复制K线或指标数据

如果您想将k线数据复制到其他数据表，另外分析，可以使用“复制数据”功能。

具体操作如下：

1、复制K线数据：鼠标放在某根K线上，点击右键，在菜单中选择“复制数据”，这一系列K线的开、高、低、收、量、额这些数据就被复制到剪贴板上了。

2、复制指标数据：鼠标放在要复制指标的上面，点击右键，在菜单中选择“复制数据”，这个指标一系列的指标线数值就被复制到剪贴板上了。


多日实时图

如果您想在实时图上，查看多日的连续走势图，可以如下操作：

在分时走势界面按向下的箭头键可进入多日实时图界面，每按一下向下的箭头键增加一日的实时图，或者点击分时走势图界面右键菜单“多日实时图-增加一日”也可实现，最多可查看10日实时图；

相反，在多日实时图界面每按一下向上的箭头键可减少一日的实时图，或者点击分时走势图界面右键菜单“多日实时图-减少一日”也可实现。

点击分时走势图界面右键菜单“当日实时图”可以直接退出多日实时图界面返回查看当日的实时图。


分析窗口自动翻页

如果您因为浏览多个股票的走势图，感觉翻页很累时，可以使用我们的“自动翻页”功能。

具体操作如下：

点击分析画面中，点击系统菜单“画面”，选择“自动翻页”，即可实现“自动翻页”，再次点击即可停止。


双击历史K线看当日分时

可以通过双击历史K线查看当日的分时图。

操作方法：

1. 在日线图分析窗口中，鼠标双击K线图的空白处，使光标变成十字线。

2. 打开右信息窗口中的“势”。

3. 双击某一天的K线，则在右信息窗口中的“势”图中，可以查看当日的分时图，如下图显示：

注意：

1. 显示的当日分时图涨幅是以当前价位进行计算而得的涨幅，非当日的实际涨幅，但走势是当日一致。

2. 需要显示的当日分时图必须本地有相应的1分钟数据，可以通过长数据下载功能下载历史的一分钟数据，否则只能显示最近10天的对于对应分时图。


多图同列

如果您想在一个画面查看多支股票的走势图时，可以使用“多图同列”功能。

具体操作如下：

1、右键点击副图画面，在菜单中选择“多图同列”（ctrl+M），系统默认为9图组合。

2、菜单→分析窗→多图同列→多图切换。

注：多图同列包含

多股票组合：同时间、同周期、代码相邻的个股K线按照代码顺序排列出来9支证券的行情图

多周期组合：同一支证券9个不同周期的行情图

多日实时组合：同一支证券最近9天的行情图

品种全景组合：同一支证券包括买卖盘口在内的多个周期行情图。

多图同列副图自设指标

首先，进入多图同列的界面，按右键出现菜单，选择公式，选择某个指标，如图：

选择某个指标后，所有的K线图副图指标同步更换为新的指标。如图：


预警

点击功能菜单里的〖工具〗→〖预警〗，如图：

预警窗口由上下两个部分组成,如图

上方框是“预警条件”列表框，显示的是已设定的预警条件的名称及性质；

下方框是“预警记录”列表框，记录着系统历史上发出的预警，包括股票代码、预警条件、预警时间和预警时的价格，当前股价以及与预警时刻比较目前的盈亏情况，最多可保存1024条预警记录。

按“新增条件”或“修改条件”按钮，系统会打开“预警条件设定”对话框。对话框由左右两部分组成，如图：

预警条件列表：以“树状目录”的形式显示可供选择的预警条件，找到作为预警的那个条件，点击它即可，这时发现“预警名称”输入框已显示该条件的名称。你可以在“预警名称”输入框里修改该预警的名称，你可以在该对话框中修改该指标的参数。如图

然后在右边的“监控证券”里面设定监控范围。

单击“加入”按钮，选择想要加入的证券，如图：

按〖清除〗按钮，则会删除对话框里所有的股票。若只想删除几只股票，可以先点击选中它们，然后按〖删除〗即可。

监控板块：打勾选中监控板块左边的小框，即可快速选择各类或各板块的所有证券，如图

输出到板块：把预警得到的证券加入到指定的板块中，你可以进入该板块中进行查看。

打勾选中“输出到板块”左边的小框，然后在右边的下拉菜单里，选择某个你想输出的板块。如图

不启用该预警条件：预警是一个实时监控的行为，要不断消耗系统资源，如果预警条件过多，则会降低预警反应的速度。若不用到某个预警条件，则可以去掉预警条件列表中的打勾选项，将该条件屏蔽掉。如图

预警后保持监控：设置是否需要持续监控的。不选择它，则当某只股票的预警条件满足并发出预警后，系统不再对它实施预警监控；若“打勾”选中它，则系统仍把它保留在监控范围内，继续对它监控，当条件由不满足后变为满足时，预警系统便再次发出预警信号。注意：“勾选”后，可能占有比较多的系统资源。

时段启用：可以设置启用预警监控的时间，例如：设置为开盘时间，即可在开盘的时候监控，其余时间不监控。

发出声音（可指定播放WAVE文件）：打勾选中左边的小框，点击“小方块”按钮，在弹出的对话框里选择WAV的声音文件，当有预警发生时，软件便会播放该WAV的声音文件。

不间断：勾选此项后，无论软件是否接受到新的行情时，预警系统都会进行刷新计算，该选项会占用很大的资源，建议不要使用。


训练模式

在训练模式中，练习模拟操盘可大大提高看盘水平。

在个股K线状态下，点击功能菜单里的〖工具〗→〖训练模式〗，如图：

实用功能：查看历史的行情

选择你想进行模拟的证券（可以是股票或者期货），然后运行模拟训练程序，（例如：选择了龙星化工，这时主图的“时间轴”（横坐标）和“右边交易信息栏”都会变成高亮的颜色。如图（2）：

模拟训练的对话框如下图：

你可以在这里 [image] （图4）设置该模拟证券的日期和时间（时间设置为该市场的开盘时间，如：9：30到11：30）。注意：日期不能为该证券的上市日期之前，否则，将无法运行模拟。

设置日期和时间后，按 [image] （图5）按钮，从左到右分别是快退、后退、快进、前进、自动前进。点击“自动前进”按钮，即可以开始运行模拟的训练，如图（6） [image] ，

再点击一次，便会停止模拟训练。如图（7） [image] 。

其中，如果勾选“按K线步进”时，模拟训练便会自动跳过模拟的“停盘时间”，只模拟开盘时间。

“步长”则是设置每一“单步前进或者后退”的时间周期。例如：如果步长为“1天”，当你单击“单步后退、单步前进”按钮时，主图里的K线会相应地向后或者向前“1天”的周期。

该“步长”是根据分析画面的周期自动设置和周期相适应的步长。改变步长，只需要更改分析画面的时间周期即可。

速度是设置“自动前进”选项的运行速度，单位是：次/分钟，即每分钟显示多少的步长。

在训练模式对话框中有一个时钟，当你运行模拟训练时，时钟会自动地转动，若你设置时间时，该时钟会相应拨到该时间。

设置好以上的参数后，点击“自动前进”按钮，即可观看该证券的历史行情趋势。如图（8）：


太阳风暴

在菜单栏中点击【工具】选择【太阳风暴】，打开【太阳风暴】的对话框，其中，纵坐标、横坐标的分别选择了“涨幅”、“换手”，当前列表选择了“A股板块”，如图

在坐标图里，红色圆圈代表在坐标参数为正数，绿色圆圈代表在坐标参数为负数。

用鼠标双击坐标图上的某个圆圈（个股），即可以显示该个股“圆圈”的名称，并且，软件会直接切换到你刚刚点击的个股的“图像分析界面”。如图

用户可以直接点击“纵”、 “横”的下拉菜单，选择合适的坐标参数，如图

若选择“自设指标”栏目的话，将弹出以下对话框，在对话框里的左边选择指标公式，右边修改指标的参数，例如：将“纵坐标”设置为“MA”“自设指标”。设置完后，点击“确定”即可，如图

系统便会进行计算该指标，如图

计算完后，纵坐标变为“MTM”参数了，如图

当你“勾选”了框时，便会显示你当前在“证券列表”里的个股信息，如图

若不“勾选”“当前列表”时，可以在右边的下拉菜单里，选择某个板块，比如选择“上海A股”，如图

当你“勾选”了“标注股名”时，在右边的下拉菜单里，选择某个板块。如：在标注股名选择“汽车类”，即可在当前板块（如，上海A股）里，标记所有“汽车类”板块里的个股名称，如图

在坐标图上，按住鼠标的左键，框起你感兴趣的个股圆圈，如图

然后，按住鼠标的左键，拖动鼠标，出现一定范围的框，松开左键，便弹出以下对话框，如图

A. 当您选择“放大”选项时，将把您刚才“框起”个股的范围，进行局部放大；点击标题栏上的“取消”按钮，即可取消放大，恢复到原来的显示状态，如图

B. 若选择“加入到板块”，可将把您刚才“框起”个股，加入到指定的板块中，如图

C. 若选择“所属板块分析”，可查看您刚才“框起”来的个股，所属于该板块的选项。


自定义数据管理

自定义数据，可灵活管理、应用各类数据（如发行价、自编公式数值），可通过SELFDATA(S)和SELFSTRING(S)函数在各周期下调用,并可将数据导入导出。

数据属性说明：

单值数据：当对应每只证券只有一个固定的数值时，选用该属性（如发行价等）,也可由指标计算得到，与指标最新值相关联。
单值字符串：当对应每只证券只有一个固定的字符串时，选用该属性。
证券相关序列值：当每只证券跟时间有关的数据时，选用该属性（如自编指标或系统指标数值，如建立扩展数据）。
证券无关序列值：当保存跟证券无关而与时间有关的数值时，选用该属性（如某日公布的经济指数等类似的数据，如建立横向数据）。

以下以制定“浦发银行”（600000）发行价数据为例图示说明：
点击软件功能菜单里的〖工具〗→〖自定义数据管理〗进入操作界面。
步骤（1）：

步骤（2）：

步骤（3）：

通过以上3个步骤，600000的发行价已经输入到自定义数据库中，必须通过系统“扩展函数”调用数据才能以各种方式显示出来。
步骤（4）：、

新建一个“发行价”公式使用扩展函数SELFDATA调用该数据。如下图：

扩展数据归入了自定义数据管理，对应其中的”证券相关序列值“属性。


K线定位

K线定位就是可以将画面快速定位到您希望查看的那根K线位置。

在k线界面中，点击菜单栏中的【画面】－【K线定位】选项，如图。

其中：

左侧：选中后，被定位的k线将会显示在整个k线图左侧位置。

中间：选中后，被定位的k线将会显示在整个k线图中间位置。

右侧：选中后，被定位的k线将会显示在整个k线图右侧位置。


锁定显示时段

将当前画面的K线时间段锁定，翻看其他个股时画面只显示锁定时段的K线。

取消锁定，在右键弹出的菜单选中一次即可。


历史回忆

打开历史回忆

通过超长下载数据后,打开历史回忆功能,就可回去查看某个交易日所有证券的交易情况。系统用高亮度色作为背景显示处于回忆状态的数据。

温馨提示：目前该功能需要先使用超长数据下载功能，将回忆当天的分笔数据下载后才能使用。

回忆前一天

此功能方便您在历史回忆画面里无须再次点击“打开历史回忆”，而直接点该键即可进入回忆当天的前一天回忆。

回忆后一天

此功能方便您在历史回忆画面里无须再次点击“打开历史回忆”，而直接点该键即可进入回忆当天的后一天回忆。

即时/历史切换

此功能方便您在历史回忆画面里直接点该键即可由回忆画面进入最新即时画面，或由最新即时画面进入回忆画面。（需启动历史回忆才显示该键）

关闭历史回忆

此功能键是用于关闭历史回忆功能。（需启动历史回忆才显示该键）


时段统计

时段统计功能是指使用鼠标框定某时段的k线，软件对该时段的数据进行统计显示。统计指定时段开盘、收盘、最高价、最低价、算术均价、加权均价、成交量、成交额、涨跌幅、振幅、换手率、阳量、阴量、阳换手率、阴换手率以及对应时期大盘的涨跌幅和振幅，便于用户分析和掌握阶段时间里股价的综合信息，为决策提供统计依据。

选中后，我们就可以看到该时段的统计信息。

对起止日期进行修改后，统计报表的数据马上随之更新。

温馨提示：除复权时统计的结果有区别，如果是除权后统计的，需要在表头增加显示（除权后）

分时图上的操作

首先，进入某种证券的实时图上，从中找出理想的“形态”，按左键拖动鼠标划出区域，将该形态括起来，在松开左键时，选择【时段分析】选项，如图（3）：

选择时段统计之后，会弹出一个“时段统计”的对话框，点击“时段统计”后，在实时图上，以高亮颜色显示的是刚才所选区域。如图（4）：

对起止时间进行修改后，统计报表的数据马上随之更新。


分析窗口右信息栏

首行证券名称后紧跟的数字表示该证券在证券列表中的排名。比如您在证券列表中进行『涨幅』排序后进入其中某一证券的图形分析，则该数字表示该证券的涨幅排名，上下翻动证券也是按此排名顺序切换的。

作为个股最新行情信息显示时，具体显示内容有委比、委差、三档买卖盘、最新价、涨跌、幅度、总成交手数、现成交手数、平均价、开盘价、最高价、最低价、前收盘、量比、内盘和外盘等证券信息；作为指数显示时将显示最新指数、涨跌、幅度、最高指数、最低指数、成交手数和成交金额等信息。期货品种图形分析右信息栏的〖成〗在分笔成交周期下显示每个成交价的累计开、平仓量。


买卖盘

显示买入、卖出挂单的盘口信息。将鼠标移到买卖盘口上，会显示“买入、卖出、平空、平多”，这是快速下单功能入口，只要用鼠标双击盘口，就能自动进行取价，进入闪电下单界面。


最新行情

显示最新报价、现手、涨跌、均价、涨幅、前收、振幅、今开、总手、最高、总额、最低、换手、量比、分笔、均量、委比、委差、外盘、内盘。


明细

点击“明细”，显示分析窗口中个股或指数、期货的每笔成交明细。


逐笔

显示逐笔行情，只有L2行情才支持显示逐笔行情，如果不是，该窗口中则不会有数据显示。


财务

显示分析窗口中股票公司的最新财务数据。


移动成本

切换交易信息区显示移动成本分布图。

（以黑底默认颜色说明）

移动成本分析图分析在主图区域的不同的价位有多少比例的流通盘股票。在主图（5分钟线以上的分析周期）的右侧从上到下显示了若干根水平线，线条的高度对应左边主图的价格轴价格，线条的颜色反映线条长度代表在这一价位有多少比例的持仓筹码。移动成本分析图分为三类，分别为上市以来的移动成本分布图、N日前（远期）的移动成本分布图、N日内（近期）的移动成本分布图，切换右上部的前三个图标即可查看各图。

开启十字光标，随着游标的移动，分布图随之变动，显示从主图左端开始到游标所处时间之间的持筹成本分布。

各种移动成本分布图

1、上市以来的移动成本分布图

点击右上部的第一个图标，显示上市以来的移动成本分布图。

1）横线有三种颜色，以当前收市价为参考点，靠上面的灰色（背景色不同，具体显示的颜色可能不同）线条表示套牢筹码的分布情况，靠下面的黄色线条表示获利筹码的分布情况，浅蓝色的线条表示50%的成本位置，在此线段上下方各有50%的筹码。浅蓝色的线条段是多空均衡线，当股价在此线段上方是视为市场强市，回调一般在此线附近；反之，当股价在线段下方运行时表示弱市，反弹在此线附近。当天新加入（即最新的价格线）的成本反映在线段头部的小蓝色线。

2）左端的竖线有两种颜色，红色竖线表示在此线段范围内包含了所有90%的筹码分布，竖线段以外的上下方各有5%的筹码分布，蓝色竖线段表示的是70%成本分布范围。多数情况下筹码在两头的数量极少，90%的成本范围体现市场成本分布，70%成本分布范围体现成本的集中度。

2、远期移动成本分布图

点击右上部的第二个图标，显示远期移动成本分布图。比如，可以用不同颜色显示上市到30天前的成本分布、上市到60天前的成本分布、上市到90天前的成本分布，要注意的是，30天前的成本分布包含了60天前的成本分布，因此除了它自身的颜色区域外，还包括60天前的成本分布颜色区域；而60天前的成本分布又包含了90天前的成本分布，如此下去。

3、近期移动成本分布图

点击右上部的第三个图标，显示近期移动成本分布图。比如，可以用不同颜色显示5天前的成本分布、20天前的成本分布、60天前的成本分布，要注意的是，20天的成本分布包含了5天的成本分布，60天的成本分布又包含了20天的成本分布。

u 成本分布图的设置

用鼠标点击成本分布图右上角的工具标志，对移动成本分析图的计算方式、成本线划分精度、近期和远期成本分布图显示的内容和颜色等参数进行设置。

当日成本算法:每日成本算法是一个移动平均过程，公式是，当日成本*（换手率*历史换手衰减系数）+上一日成本分布图*（1-换手率*历史换手衰减系数）。

平均分布：当日换手的证券数在当日的最高价和最低价之间平均分配。

三角形分布：当日换手的证券数在当日的最高价、最低价和平均价之间三角形分配。

历史换手衰减系数:表示历史换手的递减速度，将多少倍数的当日换手率从昨日的成本分布中移走得到当日的成本分布图。

无流通盘数据时用多少天成交量累加

无流通盘数据时用多少天成交量累加替代。

成本分布图线条加粗显示的条件:当筹码很集中时用粗线条表示，所谓筹码很集中意味着90%成本集中度小于某个设定值。

成本线划分精度:设置计算分布时划分上市以来的最高价和最低价之间的间隔，可选择精细计算成本分布精确到1分钱。

成本分布图显示的内容和颜色

设置远期和近期成本分布图显示的分布区数和颜色。

打勾选中分区显示，则显示的分布区不互相重叠。

u 成本分布图下方的数字

第一行：日期。

    第二行：获利比例分布。红框表示获利，绿框表示套牢，框中的数字表示以收市价为参考点,在收市价以下的筹码占总成本的百分比，或有多少获利盘。

    第三行：**元处获利盘**%。此行数值表示将光标移动至任意位置时，在此位置以下的筹码占总数的百分比。您可以通过移动光标来测量任意价位的获利盘比例，比如将光标与分布图中的蓝色横线重合，其显示的获利盘比例应为50%，显示的价格与“平均成本”一致。

    第四行：平均成本，就是蓝色横线处的价格，其含义为将市场所有价位的价格压缩成一个价格时的位置，在平均成本上方有50%的筹码，下方同样有50%的筹码分布。穿透力指该日穿透的筹码与换手率比值。

    第五行：表示以红柱线的中点计算，90%成本的分布状态，对应上图的红色竖线。

第六行：同上，表示70%筹码分布范围，对应上图的蓝色竖线。


指数

在K线图中，点击右信息窗口中的“指”或“大盘”，显示当前品种所在市场的主要指数实时图，如

打开上海A股的某一股票K线，对应的“指”或“大盘”是上证指数的实时图；

打开深圳A股的某一股票K线，对应的“指”或“大盘”是深圳成指的实时图；

打开期货的某一品种K线或实时图时，对应的“指”或“大盘”是该品种主连的实时图；

“指”或“大盘”内容一致，只是在宽度够是显示两个字，否则只显示一个字。


走势

在K线图时可以同时显示实时图；

在实时图是可以显示近期的K线图。


解盘

『解』或者『解盘』， 是指标对应的解盘文字显示内容。

在电脑解盘中看操作提示。

在公式管理器中打开特色指标-MACD实战或鳄鱼线，将指标拉到附图窗口。

对应的解盘文字内容如下图：


策略公式编辑器

“策略公式编辑器”好比是一个工作母床，通过这个工作母床可以制造出所需要的各式各样的零件，同样，在指标、策略分析的工作中，利用编辑器可以编写出相应的策略条件，这一切我们通过“公式编辑器”都可以实现。

最快捷的进入方法是：在分析画面，右键点击指标或策略名称，选中菜单中“修改指标”，即可打开策略公式编辑器。

下面我们来看看他的具体功能吧。


打开/新建指标

1、打开指标

在指标编辑器窗口中点击“文件-打开”菜单，或者点击工具条上的“打开”按钮，或者按快捷键Ctrl+O，都会弹出“打开”窗口让用户选择要打开的指标文件。

支持打开的文件类型是后缀为.ukl的文件，在“打开”窗口中选中一个.ukl文件后点击确定按钮，或者直接在“打开”窗口中双击.ukl文件，就可以在指标编辑器中打开这个指标。

2、新建指标

在指标编辑器窗口中点击“文件-新建”菜单，或者点击工具条上的“新建”按钮，或者按快捷键Ctrl+N，都会自动新建并打开一个新指标的编辑界面。


编辑指标

打开或新建指标后可以对指标进行编辑，以下是编辑界面支持的一些特性：

1、编辑界面上会用蓝色字体突出显示系统的关键字（如close、open等系统函数，and、

if等控制语句），如图3-所示，关键字不能用作变量名和用户的函数名等。

2、支持关键字自动完成功能，如键入字母c后会自动弹出下拉列表显示以c开头的所有关键字。

3、 把鼠标移到关键字上去时会自动弹出关键字的使用说明。

4、支持单行注释和区块注释，单行注释使用“//”，区块注释使用“{ }”

5、支持多窗口复制、剪切、粘贴、全选、撤销、恢复、查找、替换等常用操作。

6、支持代码层次折叠/展开功能。


编译指标

当您写完一个指标或策略时，必须通过“编译”才能正常使用。

具体操作如下：

1、点击菜单“编译-编译当前公式”，或者点击工具条上的“编译当前公式”按钮，或者按快捷键F7，都可以对当前打开的公式指标进行编译。

2、点击点击菜单“编译-编译所有公式”，或者点击工具条上的“编译所有公式”按钮，或者按快捷键Ctrl+F7，都可以对安装目录中“\FML”路径下的所有公式指标一次性全部进行编译。

3、编译通过或失败都会在编译信息面板中有提示，如果是编译失败会提示编译失败的文件及其路径，警告或错误提示信息以及警告或错误所在的行。

4、双击编译当前公式时产生的警告或错误信息可以定位到警告或错误所在的行。


函数字典

当您对函数的用法不清楚时，可以进入“函数字典”查看相关的说明。

具体操作如下：

在“公式系统”二级子菜单下，右键点击任意指标，在菜单中选择“编辑公式”，窗口左边部分即为函数字典，点击函数前方“+“或双击可展开子菜单，再次单击函数即会显示出该函数的语法及用法。而再次双击可将该函数自动复制到编辑窗口中。

函数智能模糊搜索：当您有思路，但不知道使用什么函数实现时，函数智能模糊搜索能快速指引您。


菜单

在“公式系统”下，右键点击任意指标，在菜单中选择“编辑公式”，菜单位于标题栏下方，包含：

文件：文件的常规操作，例如：保存、新建、另存为等。

编辑： 对文字进行编辑，例如：复制、粘贴、剪切等。

编译：编辑当前公式、编辑所有公式。

显示：置顶模式、全屏模式、便签模式、公式面板、字典面板、搜索面板、编译信息面板、公式参数精灵面板。

窗口：显示编辑器当前公式名称。

帮助：显示帮助文档。


工具条

位于菜单栏下方，为常用操作：编译当前公式、编译所有公式、新建、打开、保存、关闭、全部关闭、立即打印、剪贴、复制、粘贴、撤销、恢复、查找、替换、放大、缩小、自动换行、显示缩进参考线。


公式参数精灵面板

按F9,或者打开菜单：显示—公式参数精灵面板，出现下图界面。

此功能主要作用：便于对公式编辑中的常规操作如参数设置、设定是否主图叠加、主图、是否显示坐标线、用法注释、函数插入等通过可视化窗口进行操作，而不用把这些常规功能实现都在公式内容中的编写，提供公式编写的效率及简易。


导航面板

导航面板主要是配置当前工作区内的各种窗口。其中每个工作区默认自带自选股窗口（不可删除）。


切换到

在该区域内，可以看到当前工作区有哪些类型的窗口。如报价表、分析、浏览器窗口。通过“+”按钮可添加窗口至当前工作区，通过“x”按钮可删除当前工作区不需要的窗口。

点击该列表，可在右边调用出对应的窗口。


自选股

显示自选股板块所有证券。双击某个证券进入该证券的分析画面。

切换自选股版块，如已创建过多个自选股板块，可通过点击自选股板块右边的下拉箭头切换到其他自选股板块。


公式管理面板

公式管理面板将所有指标、选股、交易系统、策略公式分门别类，便于用户查找和进行“增、删、修改”等操作。


公式搜索

当您需要寻找某个公式编辑时，可以使用公式搜索功能查找。

具体操作如下：

在搜索栏中键入所需搜索项，公式系统将自动进行搜索查询，在搜索结果中右键点击所需公式名称，在菜单中选择“编辑公式”，则会打开公式编辑器，窗口右边部分显示该函数的语法及用法。


切换公式分类显示

当您想在公式管理树中只显示您的自编指标时，可以使用“切换公式分类显示”功能实现。

具体操作如下：

右键点击公式树一、二级菜单，在弹出菜单中，可以设置公式按不同的分类方式显示。

分类指标：公式树以第一二级分类目录的方式显示。

全部指标：公式树以第一级目录的方式显示全部指标。

自编指标：公式树只显示您编写的指标。

常用指标：公式数只显示您设为常用的指标。


公式树展开/折叠

公式树三种打开方式：

1、点击菜单【查看】--【公式管理】，弹出“公式管理树”；

2、点击屏幕最左边，弹出“公式管理树”；

3、点击工作区tab最前面小图标，弹出“公式管理树”。

展开/折叠：

1、 右键点击“公式系统”，菜单中选择“完全展开/完全折叠”即可实现。

2、 双击公式名称，即可展开公式树，再次双击则完全折叠。

3、 点击公式名称前“+”，可展开公式树，展开公式树后再次点击名称前“—”，可完全折叠。


刷新公式树

右键点击“公式管理面板”，菜单中选择“刷新公式树”即可实现。


新建/重命名/删除文件夹

新建：展开公式，在三级子菜单中右键点击任意指标名称，菜单中选择“新建公式”，在弹出的“新建公式”对话框中键入“新建公式名称”，点击“确定”即可实现。

重命名：展开公式，在三级子菜单中右键点击任意指标名称，菜单中选择“编辑公式”，在公式编辑器中右键点击公式名称，在子菜单中选择“当前文件重命名”即可实现。

删除：展开公式，在三级子菜单中右键点击任意指标名称，菜单中选择“编辑公式”，在公式编辑器中右键点击公式名称，在子菜单中选择“删除当前文件”即可实现。


新建/编辑/删除公式

展开公式，在二、三级子菜单中右键点击任意公式名称，菜单中选择“新建/编辑/删除公式”即可实现。


设置/取消常用公式

展开公式在二、三级子菜单中右键点击任意公式名称，菜单中选择“设为常用”即可实现，设为常用的指标显示为红色以区分其它的公式。


转移公式

当您想将一些公式移到另一个分类中时，可以用“转移公式”功能实现。

具体操作如下：

展开公式，在三级子菜单中右键点击任意公式名称，在子菜单中选择“转移到”，系统会自动弹出“转移到公式组”对话框，选择需要转移到的公式组名称，点击“确定”即可将该公式转移到指定的公式组中，该公式原来所在的公式组则自动将公式名称删除。


查看公式用法说明

如果您想了解指标的使用方法，可以通过“用法说明”菜单获得。

具体操作如下：

展开指标，在二、三级子菜单中右键点击任意公式名称，菜单中选择“用法说明”就会弹出显示该公式用法说明的对话框。


设置指标默认参数

展开指标，在二、三级子菜单中右键点击任意公式名称，菜单中选择“调整指标参数”，设置指标参数后点击“设为默认参数”→“确定”即可实现。


条件选股

在股票市场上的股票那么多，我们怎样才能选出想要买的个股呢，利用本软件中强大功能的“条件选股”就可以解决这个问题了。

条件选股简单的说，就是由用户设定一些条件，（例如短期均线上穿长期均线）然后由计算机按照这个条件自动地搜索所有的股票并找出符合条件的股票。该功能可以为用户选出当前行情或以前某个时间段的满足条件的股票。

指标系统选股中您可由技术指标线、条件选股、K线模式、及它们的组合来做条件选股。

技术指标选股

选中某个技术指标，公式树右边出现若干个输入框，分别是该指标公式相应的参数设置、选股的分析周期以及指标线满足的条件，设置好选股条件，就可进行选股了。

条件选股

选中某个条件选股指标，右边出现该选股条件满足的要求，可改变公式中的参数、分析周期。

K 线模式选股

选中某个K线模式指标，右边出现该K线模式的计算参数（有些K线模式没有参数）、选股的分析周期，可改变公式中的参数、分析周期。选定后可以执行选股。

组合条件选股

将两个或以上的指标公式按照一定的方式设置为“组合条件”即可选股。

下面我们来看看如何进入条件选股界面：

1、展开指标，在二、三级子菜单中右键点击任意公式名称，菜单中选择“条件选股”。2、按F7快捷键打开条件选股窗口。

3、点击主菜单“工具-条件选股”则打开条件选股窗口，条件选股窗口的左侧部分是所

有公式的列表。

打开条件选股界面后，在公式列表中点击选中一个公式，在条件选股窗口右侧就会显示这个公式的参数（如果有参数的话）

根据需要设定好参数，对于技术指标选股需设定公式指标的条件，即某指标线，大于/等于/小于/介于/上穿/下破/维持/保持某个值或某些值，如指标线BBI介于3到5，然后根据自身需要和所用公式的限制选择分析周期，如选择日线

设置好指标条件和分析周期之后点击“执行选股”按钮即可开始按默认的选股范围（默认选股范围是A股板块）、选股方式（默认选股方式是最新行情选股）进行选股。

选股过程会出现进度条指示选股进度，会显示选股范围的证券总数，及时刷新显示选中的证券数目和选股耗时，选股过程中“执行选股”按钮会变成“中止选股”。

点击“中止选股”按钮可中止正在进行的选股，再次点击“执行选股”则重新开始选股，选股结束后会自动跳转到默认设置的选股结果输出板块（默认的选股结果输出板块是条件选股板块）显示选出的证券列表。

想要改变选股范围、选股方式或者选股输出板块，则点击条件选股窗口中的“高级”按钮，可将本来隐藏的一些设置界面展开来进行设置。

勾选当前报价表则将选股范围设置为当前激活的报价表。

取消勾选当前报价表，点击“改变范围”按钮，然后可以在弹出的窗口中选择板块，可以通过在“快速定位板块”输入板块的名称来快速找到想找的板块（输入板块名称后会自动高亮显示名称匹配的板块），板块可以进行多选。

选股的时候默认将停牌的证券排除在选股范围之外，如果想让选股范围包含停牌的证券，则勾选“停牌证券”。

选股方式默认是用最新行情选股，如果想要进行历史时段则勾选“历史时间段选股”，然后根据需要设置时间范围。

选股结果输出到板块时默认是用覆盖的形式输出，每次都会覆盖掉上次的选股结果，可以通过勾选“追加方式”设置为用追加的方式输出，即在上次选股的结果中添加新选出的证券。

如果想要改变选股结果输出板块则点击“选择板块”按钮，然后在弹出的板块选择对话框中选择一个板块，这里只可以选择自选股板块或者自定义的分类板块，不能选择“只读”的系统板块。

如果对于单纯的技术指标选股还不清楚，那么下面我们就用一个kdj指标金叉实例来说明：

1、在选股界面左边，先找到kdj技术指标；

2、然后在右边的“满足条件”设置框里面，进行参数设置，如果无需改变参数，可以直接跳过这步。如图

3、这一步对于指标选股非常重要，就是要设置我们的选股条件。如我们要设置kdj金叉，（金叉就是指标的k线上穿d线）如下图：

4、设置好以上内容后，点击【执行选股】即可。

u 组合条件选股

在条件选股窗口中还可以设置保存组合条件并进行组合条件选股。在条件选股窗口公式列表中选中一个公式，在条件选股窗口右侧设置好公式的参数及指标条件并选择好分析周期，然后点击“加入”按钮，所选的公式就会显示在组合条件显示框中， 用同样的方法可以加入多个公式到组合条件显示框中。

如果想要删除组合条件显示框中的公式则先选中组合条件显示框中想要删除的公式，然后点击删除按钮即可。组合条件要用的公式都选择好列在组合条件显示框中之后，通过点击“与”或者“或”按钮来选择这些条件的组合方式（选择“与”是代表所选的这些公式条件都要满足才算满足条件，选择“或”是代表所选的这些公式条件只要满足其中一个即算满足条件），然后点击“保存”按钮，此时要输入组合条件的名称然后点击确定按钮才能保存，保存之后在条件选股窗口左侧公式列表中就会显示这个组合条件，选中这个组合条件，然后根据需要设置好选股范围、选股方式然后点击“执行选股”按钮即可进行组合条件的选股。

示例:

假设想从深沪两市的A股中选出同时满足“MTM” 60分钟和“MACD”日线选股条件的股票。操作如下:

1、在条件组合窗口输入组合条件名称后按[新增条件]按扭，弹出选择指标窗口（指标系统->技术指标->趋向指标->MTM）

2、选中MTM，画面出现MTM参数框,可选参数；类似地将“MACD ”也加入到条件列表中； 现在条件列表框内已有“MACD”和“MTM　”两个条件。可根据组合条件选[条件相与]或[条件相或]；输入名称后，按[确定]即完成组合条件的创建。

3、在左侧公式列表的“组合条件”分类中即可找到刚才创建的组合名称，左键点击该名称，使其变为蓝色后，最后点击“执行选股”即可选找出我们所需要的结果。

特别指出是，组合条件选股提供给用户将不同分析周期的选股条件组合在一起的功能。


指标排序

指标可在任意报价表中排序，还能在自设指标界面中保存及多次调用，下面我们来看看如何操作。

在任意报价表界面中，右键点击表头栏目，可弹出选择排序指标菜单。

其中：

另选指标：选中该项，会将您选中的排序公式替换当前列的表头栏目。

插入指标：选中该项，会在当前列左边新增一列显示排序公式结果。

选中后，系统会提示是否需要下载数据。

进入指标选择界面：

设置好后点击确定后进行排序。

在行情报价表内排过序的公式，将保存在【自设指标】报表中，方便下次使用。


导入/导出公式

我们可以在【公式管理面板】中，右键选择其中任何一个公式或分类，在弹出菜单中，就会弹出【导入公式】和【导出公式】。


智能交易类指标的历史模拟信号模式

在分析窗口中, 选取智能交易系统的指标，将其拖到到K线图上出现，如下界面内容

策略设置界面：

策略设置—属性：

其中初始资金可手工设定，默认为100万；

手续费按合约价值的千分之几或者指定按每口/每股多少元计算；

滑价 跳，为确保成交，设定向不利方向下单滑价，价格变动最小单位参考合约配置；

公式计算需引用之前最大周期数，是指公式计算时最少需要多少根K线的数据量运算才开始产生交易信号；

交易方向：可以只做多、只做空、双向交易；

默认下单量：

1. 指定口数/股数

2. 指定固定资金量

3. 权益百分比：权益是指市值，包含可使用资金+持仓；设置目的在于可根据当前可使用资金(因收益而浮动)的比例自动调整下单量；例如初始资金为100万，按权益百分比20%，可以下某个品种5口，当盈利到400万后就可以下同样品种20口。

舍去至 的倍数，是指按权益百分比下单时，计算的下单量可能有小数点或者奇数等情况，例如舍去至1的倍数时，假使计算的下单量为2.04口，那实际的下单为2口。

存为缺省：选中了，则下次加载策略时的默认设置为当前设置参数；

重设：恢复为最原始的设置参数；

策略设置—自动交易：

委托单需人工确认：实盘交易过程中，产生下单信号后系统发出下单提示，需人工确认后才实际下单；否则由系统自动下单；

语音警报文件：可选取音频文件，当系统下单成功，如开仓或平仓是播放指定的音频；

语音： 下单成功时播放软件自带的语音提示；

仓位同步：实盘仓位与虚盘同步有三个选项

1. 总是同步 原在虚盘中开仓未平仓的持仓同步到实盘，策略仍会对该持仓做平仓；

2. 下次持仓方向改变时同步 进入实盘后，首先不同步虚盘中的仓位；如策略产生新的下单信号时，判断新的开仓方向，如与虚盘中未平仓的持仓同向，则不同步虚盘中的持仓，取消虚盘中未平仓的仓位；否则同步虚盘中的持仓，并将此平仓，再根据策略信号开仓；

3. 价格优于虚盘均价或在STOP滑价内同步 进入实盘后，当策略产生新的下单指令，开仓价格如比虚盘中最后开仓价格的有优势，则取消虚盘中的持仓，以新价格进行开仓。或者STOP滑价内进行同步。

交易指令的滑价参数为0时，以委托价加减 跳下单

STOP单或滑价参数为-1时，以市价加减 跳下单

转换未成交的开仓单为市价单于N秒后： 开仓指令发出后可能只成交了下单量中的一部分，对于没成交的部分以市价单继续开仓；

转换未成交的平仓单为市价于N秒后： 平仓指令发出后可能只成交了下单量中的一部分，对于没成交的部分以市价单继续平仓；

部分成交的平仓单自动转为市价单： 开仓指令发出后部分成交没成交时，没成交的部分以市价单继续开仓；

部分成交的评价单自动转为市价单： 平仓指令发出后部分成交没成交时，没成交的部分以市价单继续平仓；

日收盘交易在收市前 60 秒下单：

1.公式中如设定了 SetExitOnClose （不过夜的持仓单），盘中如果没有平仓，设定收盘前多少秒以市价单下单平仓；

2. 对设定过 OT_close参数的下单命令，设定收盘前多少秒以市价单下单开仓；

选择交易账户：默认为当前账户

修改公式参数

点击 确定后，智能交易指标在历史K线图上模拟了发出的买卖信号。

K线图右上角的笑脸表示正在运行交易策略，点击该笑脸变成哭脸则停止交易策略的运行。运行实时交易策略时需要登录交易账 户。

K线图上显示开仓、平仓信息，K线上向右的三角形指示开仓位置，向左的三角形指示平仓位置，开仓和平仓之间有虚线相连表示开平仓的对应关系，其中连线显示蓝色代表该笔交易亏损，显示粉红色代表该笔交易盈利。同时可在纵坐标右键菜单中的属性，对交易信号显示的信息进行设置，如显示手数、盈亏金额、交易价格。

把鼠标移到虚线上会弹出显示开仓单号、开仓类型、开仓价格、平仓单号、平仓类型、平仓价格的提示框。

还可通过右键菜单跳到第一个交易的(home键)、跳到最后一个交易点(end键)、只显示真实交易点、只显示虚拟交易点、显示所有交易点。

鼠标右键策略名称，弹出右菜单，可以重新进行策略设置，移除策略即是关闭策略，修改公式对公式内容进行调整，导出公式将公式导出文件；可打开两个测试报告，方便对比查看，如下。


测评设置

金魔方评测平台最大程度模拟真实交易的情形，帮助你对它们进行试炼，直观地、值得信赖地挑选出在真实市场能够稳健获利的策略。

u 最高精细到分笔级别的行情，真实地模拟行情的生长。

u 忠实地反映整个交易过程。包括期间仓位和资金的变化。

u 多角度全方位显微镜般细致入微的评测指标全面检视策略表现。

u 立体多维方式呈现参数变化带来的绩效表化。帮助你找到即使将来市道发生变化，也能很好适应的表现均衡的策略。

u 推进分析。用其中一段数据优化出来的参数，放到另一段乃至另外几段数据上进行评测。如果它们都表现优秀，那么将来的真实交易，将会只是另一个“新的段”，有很大的机会象之前几段一样表现优秀。

u 用本地的，按照你的意愿设置了模拟佣金、保证金比例等等交易参数的，逼近真实的模拟交易所，进行实时的模拟交易。

点击主菜单【量化交易】-【智能交易测评】进入以下界面

右侧按钮的作用解释：

清空列表：清空已选择的策略；

添加：添加新的策略，评测系统支持多策略，可添加多个策略，策略左边选择框选上时表示该策略将在评测时运行；

复制、删除：用于复制产生策略、删除列表中策略。

全选、反选：用于全选策略、取消所有策略的选择。

上下箭头：用于移动对策略的选择焦点；

展开：用于是否显示策略的详细信息还是只显示标题；

从工作区导入：用于将在当前工作区运行的所有策略导入到评测系统中。（推荐方式。可快速将需测评策略公式、测评品种、测评周期等设置导入到评测系统中，无需重新设置）

评测设置左侧各选项及内容解释：

选择测试时段：可以设置评测的起止时间段；

时间段内只取最近N根K线：可只最最近的一段K线进行评测，如最近500根；

导入数据： 系统支持从文件中导入导出证券的历史数据；同数据的导入导出功能；

数据下载： 直接打开数据下载的界面，策略中的品种默认选中；

可视化：选中后，在策略运行过程中，可以看到K线在逐根前行，K线上显示相应由策略产生的买卖点信号。

创新新窗口：选中时，运行策略在新的窗口进行，之前跑过策略窗口保留，便于比较多个运行策略的结果；不选则始终在同一个窗口运行策略；

速度：可调整运行策略的速度；移动MIN和MAX之前的浮标改变运行速度快慢；

保存设置：将当前的评测设置保存到设置文件。

设置另存为：将当前的评测设置保存为指定路径下的XML文件。

加载设置：将XML文件的设置信息导入到当前评测设置中。

下面我们来一边解释，一边实操演示如何对一个策略进行完整的测评操作。

第一步：点击“量化交易-智能交易评测”，进入评测系统，如下图界面

第二步：添加测评-点击添加，如下图：

添加策略的品种：在品种下方-双击『双击这里设置』，

打开“设置品种”界面，点击“选择品种”选择某个市场中的证券，如下图，完成黄金主连的添加。

其中

u 手续费：包含固定部分，按量或按额的变动部分手续费。

u 保证金：包含固定部分，按量或按额的变动部分。

u 独立资金，初始额：账号初始资金额度。

u 滑价：即每次成交不利方向滑移多少个最小变动单位。

u 开仓类型：允许开多仓和空仓、只允许开多仓、只允许开空仓，是否不能平今仓。

第三步：添加策略的公式：在公式下方-双击『双击这里设置』，如下图：

选择公式脚本—SAR抛物线转向智能交易系统。

其中：

u 默认下单量：1. 每次N口/ 股：指定下单口数或股数

2. 每次N元：指定下单固定资金量

3. 每次N%：是指市值的%，包含可使用资金+持仓；设置目的在于可根据当前可使用资金(因收益而浮动)的比例自动调整下单量；例如初始资金为100万，按权益百分比20%，可以下某个品种5口，当盈利到400万后就可以下同样品种20口。

u 公式计算至少需要多少周期：是指公式计算时最少需要多少根K线的数据量运算才开始产生交易信号；

u 应用于所有公式：选中后以上设置可以运用到所有公式，而无需再次设置。

完成设置一个策略后，结果如下图图3.10.6-5，品种下显示选择的品种及其数据情况，公式下显示选择的公式及运行周期和运行模式。

第四步：现在将策略及其参数设置进行优化参数的策略评测。

首先需开启参数优化功能。

设置好后，点击【开始】按钮，程序经过运行后，列表中显示不同参数策略运行的结果。

温馨提示：如果您设置参数的最小最大值数值差距很大，计算的时间就会很长，而如果您将步长设置的很少，也将会产生很大的计算量。

查看有优化结果中列表形式的内容，可以点击表头按表头显示内容进行排序，方便找到最佳的运行结果；

优化结果中的三维形式，是所有参数(参数以x、y、z轴对应不同参数值)组合的策略运行效果3D图，其中：

颜色越深，表示策略的获利越大；浅绿色的是亏损的策略；

右边的X、Y方向可以选择对应不同的参数，另一个参数指定不同的数值，以显示不同的效果图；

Z方向可以选择不同的优化目标，如盈利因子，净利润等等；

鼠标点击3D移动，可以从不同方向查看效果图；

旋转方向：可选择绕X、Y、Z轴、原点旋转；

模型样式：线框模型、表面模型，显示不同的3D效果图

输出TS格式文件：可将评测结果输出到TXT文件；

看策略3D效果图的要点：好的策略应该是3D图表面相对平整，高原平坦而非山峦跌宕起伏过于激烈的策略。参数的选取倾向于比较平坦的获利区域，以求策略取得平稳的复利效果。

在列表中双击其中一行参数策略，可以运行策略对应的参数，并查询其运行的结果，现选择排行中净利润最大的策略，双击后出现该策略运行的结果，其中

图为其累计交易盈亏资产曲线图，走势图显示资产的变化情况；

图为策略的交易明细，显示该策略整个运行过程中的交易明细情况，包括每一单的单号、所平单号、类型、状态、品种、仓位号、开仓平仓时间、价格、盈亏情况等等数据。

评测报告分为策略分析、交易分析、时段分析三部分，如图

总体概述：

评测分析可参考报告中各个图表包括：收益风险分析、时间仓位分析、资产曲线、资产及水下(回撤)曲线、资产升水及回撤曲线、资产升水及回撤幅度曲线

交易分析可参考报告中各个图表包括：交易明细、交易总体分析、极端交易、最大浮盈浮亏、累计交易盈亏资产曲线、平仓交易余额曲线及回撤、平仓盈亏散点图、有效盈亏率散点图、平仓盈利分布图。

至此已经完成一个策略的评测过程。

第五步：如果测评没有任何结果，可查看【运行日志】，里面包括用户自定义输出的信息和系统内部信息（如公式运行错误信息），日志内容包括时间、公式名称、输出信息。如有余额不足提示，所以策略应资金不足导致后面没有交易信息。


测评报告

在研发交易策略时，我们需要通过一系列可量化的统计指标度量、分析、评判交易状况的“好”“坏”，将这些统计指标组织成图表形成分析报告，以期全面、量化、直观地对交易进行评测或跟踪，最终实现保全资本，持续稳健地达成盈利目标。测评报告即由各种表格和图形组成，表格可显示各项精确量化的统计指标值，图形直观，便于观察，包括折线图、面积图、柱形图、散点图、饼图等。

在研发策略时，通过分析测评报告，可以发现问题，改进、优化、直至调试出可行的策略；或者根据这些指标筛选符合自己偏好使得更易坚持的策略；或者研发B策略（B商品）去对冲A策略(A商品)的劣势；或者评判策略适用于哪些类型市场状况，扬长避短......等等，这就要求测评报告能够全面细致地从各个角度对交易状况进行考察。金魔方提供了非常详尽的、全方位的各项统计指标和图表，能够像显微镜那样满足用户的需求。

对实盘交易也可生成相似的测评报告，通过这些统计指标分析评估交易绩效，选用能弥补不足的商品、策略，或者有针对性地提升交易技巧。

善用测评报告，才能评估策略的好坏、评估能否用于真实交易，因此，我们先讲解它所揭示的各种统计指标和图表。


策略分析

u 总体概要

净利润：统计期内交易产生的净利润，净利润=总盈利-总亏损，这是不可忽视的考察收益情况的第一指标，但单纯看净利润的数额不能客观评判整个绩效状况。

总盈利（毛利）：每笔盈利的交易实现的盈利总和，若把投资看做是商业活动，这个数额就是总收入。

总亏损（毛损）：每笔亏损的交易实现的亏损总和，若把投资看做是商业活动，这个数额就是总支出，设法减少亏损就能增加净利润。把交易亏损看成是做生意的成本支出，也更能坦然接受亏损交易，想想，开个公司每天都有支出，好比每天都有亏损交易，输得起的交易者才能成为赢家。

盈利因子(毛利/毛损) ：总盈利/总亏损，也称为盈利比。它表示每亏损（支出）1元能获取多少元的盈利（收入）。这个比率说明投资效率，当然是越大越好。

收益率%：净利润/期初资产×100%，假设在统计期没有追加或减少资金。

年化收益率%：几何平均的年复合收益率（年复利、CAR、CAGR）。

最大资产回撤：逐根K线计算资产极高值出现后到极低值的最大回撤（缩水）金额，若资产值创新高，则重新计算，从该点再计算下一次最大回撤，该值就是其中最大值的那次回撤。可以从详细资产曲线的阶段高峰到阶段低谷查看该值变化。通过这个统计值，可以检视自己在这样的交易数量下能忍受多大的回撤金额。它与最大资产回撤幅度是衡量风险的重要指标，固定交易量看这个指标，随资产变动调整调整交易量则看最大资产回撤幅度。

净利润/最大资产回撤：又称恢复因子，在统计期内获得利润与承受风险的比率。这是考察风险与回报关系的重要指标。

最大资产回撤幅度：以百分比计量回撤幅度而不是回撤金额，计算方法与最大资产回撤相似。强平、爆仓风险来自于这个回撤幅度。通过这个统计值，可以检视自己在心理、资金上能忍受多大的资产回撤幅度。

这个幅度可认为是对风险最重要的衡量工具，通过考察长期的、跨越不同市场状况的资产回撤情况，可以对交易中发生的所有负面结果及其相关影响有个充分的了解。

年化收益率/最大资产回撤幅度：又称MAR比率，这是最常用的风报比指标。考察让资产平均每年增值的幅度与需承受的最大资产回撤幅度的关系。

交易次数：交易总次（笔）数，分批开仓后一次平仓，一次开仓后分批平仓，都会拆成一一对应的交易量相同的多次交易。这个指标可以评估交易的频率，由于每次交易是要付出交易成本的，这个数据也和佣金、滑价等交易费用支出相关，过于频繁的交易，其成本可能吃掉可以取得的利润。用分批开平仓的技巧可以减小风险，也可用于调整胜率、盈亏比。

盈利交易次数：盈利交易是指开平仓差价产生的毛利减去开平仓交易成本（包括佣金、滑价、息差等）依然有利润的交易。

亏损交易次数：亏损交易是指平仓后产生亏损的交易。盈利交易次数与亏损交易次数之和可能小于总交易次数，其差值为盈利为0的打平交易次数。

胜率%：胜率% = 盈利交易次数/交易次数*100%，盈利交易次数所占的百分比，也称为正确率或赢亏率。胜率低于50%未必是亏损系统，只要每次交易的平均盈利比平均亏损足够大。一般未经过特别过滤的趋势跟随型或突破型策略，其长期的胜率低于40%。而均值回归型策略其胜率容易达到50%以上，但如果不控制好每次交易的亏损，很高的胜率也未必是盈利的系统。设置止赢位、止损位对改变胜率和盈亏比有极大影响。通常来说，投资者尤其是新手偏好高胜率的交易，胜率太低会影响心态，导致无法长期坚持执行，所以，策略组合最好能牺牲些盈亏比换来胜率大于50%，好比薄利多销而不求暴利，在实战中心理上也比较容易接受。

平均盈亏：每次交易的盈亏额的平均值，也称为预期盈利、期望收益。对于每次交易固定数量或金额的系统（统计期内价格波幅不大的可固定数量，反之应固定金额），看预期收益比较有意义。如果策略测试时佣金和滑价设置为0，那么这个值应大于这些实际交易时可能产生的交易成本才是可盈利的策略。

平均盈亏=净利润/交易次数=每笔交易的期望收益=平均盈利×胜率-平均亏损×（1-胜率）

平均盈利：盈利的交易每次平仓实现盈利额的平均值，平均盈利=总盈利（毛利）/盈利交易次数。

平均亏损：亏损的交易每次平仓实现亏损额的平均值，平均盈利=总亏损（毛损）/亏损交易次数。

盈亏比：平均盈利/平均亏损，趋势交易追求高盈亏比，用多次小的试错成本换来一次大的盈利。不同风格的交易策略，或偏好高胜率，或偏好高盈亏比，长线趋势型系统，其盈亏比高，短线交易系统，盈亏比相对较低。

最大单次盈利：盈利交易中最大一次的盈利，若最大单次盈利与平均盈利差距过大，则应视为偶然事件。

最大单次亏损：亏损交易中最大一次的亏损，若最大单次亏损与平均亏损差距过大，应检查系统的风险控制能力，可以考虑设置止损位，以防御突发状况造成的重大亏损。

最大连续盈利次数：盈利有时有集中的现象，策略适应此阶段的走势形态。也许可以考虑在连续盈利接近最大连盈次数时，开始减轻每次交易投入的资金。

最大连续亏损次数：亏损有时有集中的现象，策略不适应此阶段的波动，心理上能否承受如此多次的试错？也许可以考虑在连续亏损最大次数时，逐步增大资金投入。

平均持仓周期：持仓周期/交易次数，考察策略偏长线或是短线

平均盈利周期：盈利交易持仓周期/盈利交易次数，考察盈利交易是否需要耐心持有

平均亏损周期：亏损交易持仓周期/亏损交易次数，考察亏损交易是否及时平仓

u 风险分析（过度冒险是自寻死路，但是不敢冒一定的风险就会失去很多机会，评估风险并以此改进风险管理技术有助于树立信心和耐心，实现预期目标）

去离群总盈利：去除离群盈利交易产生的总盈利，离群盈利交易是指单次盈利在n倍标准。

去离群总亏损：去除离群亏损交易产生的总亏损，离群亏损交易是指单次亏损在n倍标准差之外的亏损，如果去离群总亏损与总亏损差距过大，说明大部分亏损来自于突发的重大亏损，则策略需要增强防御这类情况的能力。

期末持仓盈亏：统计期末有持仓时的浮动盈亏，若没有未平仓头寸，显示N/A

持有收益：统计期初不用资金杠杆全额开仓，到期末实现的盈利或亏损，其收益率即等于期末价格变动的幅度。比如10万初始资金，商品期末价格上涨了200%，则多头持有收益为20万，空头持有收益为-20万，不必考虑是否支持保证金交易、资金杠杆是多少。不能简单地以净利润与该收益作比较判定策略好坏，因为还需要比较资产最大回撤和收益标准差这类风险度量，如果在风险报酬比率上优于简单开仓持有，则是好的策略。

佣金合计：包括经纪商手续费、交易所手续费、股票托管费等交易费用

滑价合计：历史回测测试时假设的滑价，或者实际交易中滑价导致的交易成本。

最大单次盈利/总盈利：若该值较高，即最大单次盈利在总盈利中的比重过大，则说明系统实际盈利能力和稳定性不高。

最大单次亏损/总亏损：若该值较高，这次最大亏损是否是这个策略的“黑天鹅”。

净利润/最大单次亏损：该值越高越好。

回归年化收益率：对资产曲线按月（年、周）计算线性回归后的年复合收益率，对统计的起止日期相对不敏感。

月化收益率：月复合收益率（月复利）。

月平均收益（30天/月）：净利润/统计期间月数。

月收益标准差：每个月净利润的标准差。

月收益率标准差：统计每月资产收益率的标准差，标准差越小表示资产曲线越平滑。

最大资产回撤：逐根K线计算资产极高值出现后到极低值的最大回撤（缩水）金额，若资产值创新高，则重新计算，从该点再计算下一次最大回撤，该值就是其中最大值的那次回撤。可以从详细资产曲线的阶段高峰到阶段低谷查看该值变化。在这样的交易数量下能忍受多大的回撤金额。

最大资产回撤发生期：从资产高峰到低谷的起止日期。

最大资产回撤幅度：以百分比计量回撤幅度而不是回撤金额，其余与最大资产回撤相同。强平、爆仓风险来自于这个回撤幅度。心理、资金上能忍受多大的资产回撤幅度。

这个幅度可认为是对风险最重要的衡量工具，通过考察长期的、跨越不同市场状况的资产回撤情况，可以对交易中发生的所有负面结果及其相关影响有个充分的了解。

最大资产回撤幅度发生期：最大资产回撤幅度发生的起止日期。

最长资产回撤持续时间（天）：从资产极高值到创新高所经过的最长时间，衡量的是恢复速度，即一段损失期后需多长时间资产额才能重新站上新的高点。这个期间未必是最大资产回撤或回撤幅度发生的期间。

通常投资市场都是快跌慢涨，包括资产曲线。假如初始资本是100万元，回撤50%，那就只剩50万元，要恢复到100万元，需要获利100%，显然这更大可能是需要更长的时间，难度也更大。所以，首要任务是保存资本，再图盈利。

对于那些需要从业绩增量中获得报酬的基金管理者，当资产回撤达到一定程度，如果想尽快收回损失，相应的恢复过程就需要及时增加资本投入，伴随而来的财务压力可能使基金管理者变得不耐烦并想努力尽快捞回损失而采取激进措施，但很可能会发现自己掉进了一个更深的洞，进而威胁整个交易计划的生存。所以，把一定的资产回撤作为降低风险的基础是风险管理计划的重要组成部分。例如，在交易计划之初就确立资产回撤达到10%时就将仓位降低50%，首先，这将大大有助于减少资产进一步回撤的程度，其次，从长期来看会更有信心承担未来可能发生的更大的风险。

最大浮动亏损：有持仓时的最大浮动亏损金额，浮动亏损可能对投资者心理造成较大冲击，在期货这种运用资金杠杆的情况下，会导致可用金减少，直接影响保证金水平，甚至带来穿仓风险，被强行平仓甚至直接爆仓，这个指标可以帮助头寸管理和设定机动的最大亏损止损位。

最大浮动亏损幅度：有持仓时的最大浮动亏损幅度，以百分比考察浮动亏损，统计期间价格幅度变化很大时，用百分比有可比性。对于短期或固定金额开仓，数额指标比较直观，但对长期的或持仓量变化大的，应该检视幅度指标。

最大平仓交易回撤：逐笔计算平仓交易时的资产的极高值出现后的最大亏损金额，若平仓交易时的资产值创新高，则重新计算，从该点再计算下一次最大回撤，该值就是其中最大值的那次回撤。可以从平仓交易资产曲线的阶段高峰到阶段低谷查看该值变化。

最大平仓交易回撤发生期：平仓交易时从资产高峰到低谷的起止日期。

最大平仓交易回撤幅度：以百分比计量回撤幅度而不是回撤金额，其余与最大平仓交易回撤相同。

最大平仓交易回撤幅度发生期：以百分比计量回撤幅度而不是回撤金额，其余与最大平仓交易回撤相同。

净利润/最大资产回撤：以百分比计量回撤幅度而不是回撤金额，其余与最大平仓交易回撤相同。

净利润/最大平仓交易回撤：以百分比计量回撤幅度而不是回撤金额，其余与最大平仓交易回撤相同。

年化收益率/最大资产回撤幅度：以百分比计量回撤幅度而不是回撤金额，其余与最大平仓交易回撤相同。

有效年化收益率/最大资产回撤幅度：大于2为好。

年化收益率/25%的最大资产回撤幅度的平均值：分母以最大的25%的资产回撤幅度的平均值作为风险。

ULCER指数：用于计算Ulcer绩效指数，以资产回撤的平均化作为风险度量

Ulcer =sqrt((R1^2+ R2^2+......+ Rn^2)/n)

R1、R2...... Rn为第1、第2......第n个资产回撤幅度。

R平方：资产曲线与基准指数的相关系数的平方*100，反映基准指数（大盘）的波动对收益表现的影响，该值用于度量策略的系统风险，或者说是系统风险在总风险中所占的比重。例如指数ETF对标的指数的R平方接近于100。

夏普指数：经风险调整后的绩效指标，用于衡量投资的有效回报。

夏普指数=（月化收益率-无风险月利率）/月收益率标准差 SR=(MR-RFR)/SD

无风险利率（RiskFreeReturn RFR）一般为银行定存利率或短期国债的月收益率，在【选项】中设置。

时间跨度很长的可以用年化收益率和无风险年利率计算。夏普指数大于1为好，大于2很好，若为负值，表示承受风险但回报率反而不如存银行。

Ulcer绩效指数：以夏普指数相似，但以资产回撤作为风险衡量

UPI=（年化收益率-无风险年利率）/ Ulcer

以Ulcer指数代替夏普计算公式中的分母。

稳健风报比：回归年化收益率/长度调整平均最大回撤

长度调整平均最大回撤＝最大5次回撤幅度的平均值×这5次回撤期的平均天数/365，从回撤幅度和持续时间这两个角度来度量风险。

飞狐评分：该分值综合衡量盈利能力、资金占用率（平均仓位）、最大风险和长期稳定性。同样的年化收益率，若仓位越大，表示投入资金越多，分数越低；若回撤越大，表示爆仓风险越大，则分数越低；标准差越小，统计时间越长，稳定性越好，则分数越高。

分值 =年化收益率/平均仓位×(1 + 最大资产回撤比例) ×（1-月收益标准差*3）×交易月数^（1/3）

这个算法对开始运行不久（1年之内）取得较好收益的策略评分偏高。

例如,年化收益率 30%,平均仓位30%,最大资产回撤比例 -15%，月收益标准差3%，交易期长达125个月的策略，其分数为:

(30 / 0.3)*(1 - 0.15)*（1-0.03*3）* 125^（1/3） = 100 * 0.85 * 0.91*5 = 386.75

对于亏损系统，不计交易月数，为了让回撤比例越大，稳定性越差，负值越大，算式为

分值 =年化收益率/平均仓位×(1 + 最大资产回撤比例的绝对值) ×（1+月收益标准差*3）

例如,年化收益率 -30%,其余数据与上述相同，则分数为:

(-30 / 0.3)*(1 + 0.15) *（1+0.03*3） = -100 * 1.15 *1.09= -125.35

u 时间仓位分析

总交易时间：有足够历史数据可让策略产生交易信号的期间，不一定等同测试期间。

持仓时间（天）：有持仓的天数总计。

持仓时间%：有持仓的天数总计。

最大空仓时间（天）：这个空仓时间长可能意味着必须有足够耐心等待下一次交易。

总交易月数：总交易期间换算成月数量。

盈利月数：交易期资产增值的月数量。

资产增值天数：统计当天收盘比前一天资产增值的天数。

资产减值天数：统计当天收盘比前一天资产减值的天数。

获利日占比：资产增值天数/总交易时间*100%。

最大浮盈日期：最大浮盈的具体日期。

最大浮亏日期：最大浮亏的具体日期。

平均持仓周期：持仓周期/交易次数，考察策略偏长线或是短线。

平均盈利周期：盈利交易持仓周期/盈利交易次数，考察盈利交易是否需要耐心持有。

平均亏损周期：亏损交易持仓周期/亏损交易次数，考察亏损交易是否及时平仓。

最大持仓数量：统计历史上曾经的最大的持仓合约数。

最大占用资金：统计历史上最大投入的资金额，开仓到最大仓位时投入的资金。

最小账户资金：最大资产回撤+占用的保证金。

平均仓位：对每根K线取样计算持仓占用的资金/资产的百分比平均值，仓位意味着风险敞口，该百分比越高，表示资产暴露给市场波动风险的程度越高，也表示在市场上投入资金量越大，机会成本越大，没有更多的资金投入其他地方。

u 资金曲线

资产曲线是每天对应的资产连线，它有三条线，红线表示表现资产的潜在高点，绿线表示资产的潜在低点，黑线是平仓后才把平仓盈亏计入资产（余额）的曲线。显然，多头持仓的资产高点以持仓期间每日的最高价计算，资产低点以最低价计算，因尚未平仓，浮动盈亏不计入资产余额，所以持仓期间黑线是水平线，空头持仓则反之。如果某段时期没有持仓，则三条线都是数值一样的水平连线。

附图占用保证金曲线，代表对应当时占用了多少保证金。

双击鼠标出现十字光标可查看各点数值。

u 资产及水下（回撤）曲线图

资产曲线是每天对应的资产连线，它有三条线，红线表示表现资产的潜在高点，绿线表示资产的潜在低点，黑线是平仓后才把平仓盈亏计入资产（余额）的曲线。显然，多头持仓的资产高点以持仓期间每日的最高价计算，资产低点以最低价计算，因尚未平仓，浮动盈亏不计入资产余额，所以持仓期间黑线是水平线，空头持仓则反之。如果某段时期没有持仓，则三条线都是数值一样的水平连线。

资产回撤曲线是资产从潜在高点回撤到潜在低点的金额，其最大值即【总体概要表】中的“最大资产回撤”，固定数量交易用该曲线评估风险。

资产回撤幅度曲线是资产从潜在高点回撤到潜在低点的幅度，其最大值即【总体概要表】中的“最大资产回撤幅度”，随资金变动调整交易数量的用该曲线评估风险。

双击鼠标出现十字光标可查看各点数值。

u 资产升水及回撤曲线图

资产升水曲线表示表现资产的潜在高点的数值连线。

资产回撤曲线是资产从潜在高点回撤到潜在低点的金额，其最大值即【总体概要表】中的“最大资产回撤”，固定数量交易用该曲线评估风险。

u 资产升水及回撤幅度曲线图

资产升水曲线表示表现资产的潜在高点的幅度连线。

资产回撤幅度曲线是资产从潜在高点回撤到潜在低点的幅度，其最大值即【总体概要表】中的“最大资产回撤幅度”，随资金变动调整交易数量的用该曲线评估风险。

双击鼠标出现十字光标可查看各点数值。


交易分析

u 交易明细

【交易明细】表，它的每一行们与主图上的交易箭头是对应的，其表头的部分项目解释如下：

交易指令：交易指令函数中指定的开仓名或平仓名，若未指定，系统会根据指令类型自动填充；

盈亏%：盈亏金额/开仓市值*100%，开仓市值=开仓价*合约乘数*交易量；

有效盈亏：盈亏金额/开仓占用保证金*100%

滑价成本：策略设置中所设置的滑点折算成金额，在计算盈亏时扣除。需注意的是，对滑价成本的处理与手续费相似，并不影响信号的开平仓价格；

最佳平仓价：多头持仓期间的最高价或空头持仓期间的最低价；

最差平仓价：多头持仓期间的最低价或空头持仓期间的最高价；

最大浮盈：持仓期间最大的浮动盈利，此时的市场价即是最佳平仓价；

最大浮亏：持仓期间最大的浮动亏损，此时的市场价即是最差平仓价；

开仓效率：表示在开平仓之间的行情中开仓的位置，例如，持仓期间行情最高最低价范围为100点，做多开仓价在最低点，则开仓效率为100%；

多头开仓效率=（最高价-开仓价）/（最高价-最低价）

空头开仓效率=（开仓价-最低价）/（最高价-最低价）

平仓效率：表示在开平仓之间的行情中平仓的位置，例如，行情范围100点，做多平仓价在最高点，则平仓效率为100%；

多头平仓效率=（平仓价-最低价）/（最高价-最低价）

空头平仓效率=（最高价-平仓价）/（最高价-最低价）

交易效率：表示在开平仓之间的行情中吃到的区间，例如，行情范围100点，盈利80点，则交易效率为80%

多头交易效率=（平仓价-开仓价）/(最高价-最低价)

空头交易效率=（开仓价-平仓价）/(最高价-最低价)

【交易明细】是原始的交易数据，只有这些数据难以对交易状况有整体的认识，需要对这些数据进行统计，形成各项指标值，我们把最基本最重要的统计指标提炼出来，形成【总体概要】表。

u 交易总体分析

盈亏中值：盈亏中值（中位数）就是一半次数的交易的盈亏比它大，另一半次数的盈亏比它小，在完全对称分布中，均值和中值是相同或几乎相同的。如果平均盈亏大大超过盈亏中值，则很可能是由于少数赚钱最多的交易大大提高了均值水平。反之，如果盈亏中值明显高于平均盈亏，那很可能是由于有一些重大亏损。

最大单次盈利/总盈利：若该值较高，即最大单次盈利在总盈利中的比重过大，则说明系统的盈利很大程度是靠某次暴利，其实际盈利能力和稳定性不高。

最大单次亏损/总亏损：若该值较高，这次最大亏损是否是这个策略的“黑天鹅”。

净利润/最大单次亏损：该值越高越好。

最佳10%交易盈利/净利润：按盈利水平排在前10%的交易实现的盈亏占净利润的比例，该比值度量了盈利的集中度。如果该值等于100%，说明前10%的交易赚取了所有的净利润，而余下的90%的交易仅仅实现盈亏平衡。但是，从这个数据不能指望通过减少这些不盈利的交易来提高效益，因为那90%的交易是整个交易成功不可或缺的部分。对于一个趋势跟随策略来说，保存资本让顶级的交易机会真正发挥作用是非常重要的。

最差10%交易亏损/净利润：按盈利水平排在最后10%的交易实现的亏损占净利润的比例，对于一个中长线策略来说，这个亏损值不应该夺去排前10%的交易所获得的核心利润，健全的风险控制是做到这一点的关键。

最大连续盈利额：最大的连续盈利实现的盈利额，不一定是最大连续盈利次数那一系列交易产生的。

最大连续亏损额：最大的连续亏损实现的亏损额，不一定是最大连续亏损次数那一系列交易产生的。

最大连续盈利率：最大的连续盈利实现的盈利率，不一定是最大连续盈利次数那一系列交易或者最大连续盈利额那一系列交易产生的。

最大连续亏损率：最大的连续亏损实现的亏损率，不一定是最大连续亏损次数那一系列交易或者最大连续亏损额那一系列交易产生的。

u 离群交易

【离群交易】表，统计、考察非常态交易的状况。

统计所指的离群点是远离一般水平的极端大值和极端小值，离群交易即发生在常态盈利或亏损之外的交易，计算时把不在常态范围（n倍标准差）内的交易归入离群交易。人类活动的结果往往导致“厚尾分布”而不是正态分布，金融数据表现出尖峰厚尾的特征，具体来说就是离群交易数量偏多，比如，正态分布上百年难遇1次的事件现实中十年遇到2次。

盈亏的标准差：平均盈亏的标准差

最大偏移/标准差：最大单次盈利或最大单次亏损与标准差的比值

离群交易数量：离群交易次数

离群交易盈亏：离群交易的盈亏之和

在【选项】->【测评】页面中，可设置“几个标准差外算作离群交易”。

u 最大浮盈浮亏

最大值：所有平仓交易的浮盈/浮亏中的最大值。

发生日期：浮盈/浮亏出现最大值的日期。

最大值%：所有平仓交易的浮盈/浮亏幅度中的最大值。

平均值：所有平仓交易的浮盈/浮亏的平均值。

平均值%：所有平仓交易的浮盈/浮亏幅度的平均值。

标准差：所有平仓交易的浮盈/浮亏的标准差。

平均值+N倍标准差：平均盈亏+盈亏的标准差。

平均值-N倍标准差：平均盈亏-盈亏的标准差。

u 平仓收益曲线

该图是累积平仓盈亏的连线，体现了每次交易的累积平仓收益。横坐标为交易序号，表示第几次交易，曲线上的红色点表示累积收益创新高，绿色点表示累积收益创新低。

u 平仓收益曲线与回撤图

该图是累积平仓盈亏的连线，体现了每次交易的累积平仓收益。横坐标为交易序号，表示第几次交易，曲线上的红色点表示累积收益创新高，绿色点表示累积收益创新低。

平仓收益回撤曲线是平仓收益从高点回撤到低点的金额，其最大值即【收益风险分析表】中的“最大平仓交易回撤”，显然，它小于“最大资产回撤”，固定数量交易用该曲线评估风险。

平仓收益回撤幅度曲线是平仓收益从高点回撤到低点的幅度，其最大值即【收益风险分析表】中的“最大平仓交易回撤幅度”，显然，它小于“最大资产回撤幅度”，随资金变动调整交易数量的用该曲线评估风险。

双击鼠标出现十字光标可查看各点数值。

u 多头平仓收益曲线与回撤图

该图是累积多头平仓盈亏的连线，体现了每次多头交易的累积平仓收益。横坐标为交易序号，表示第几次交易，曲线上的红色点表示累积收益创新高，绿色点表示累积收益创新低。

多头平仓收益回撤曲线是多头平仓收益从高点回撤到低点的金额，其最大值即【收益风险分析表】中的“多头最大平仓交易回撤”，显然，它小于“最大资产回撤”，固定数量交易用该曲线评估风险。

多头平仓收益回撤幅度曲线是多头平仓收益从高点回撤到低点的幅度，其最大值即【收益风险分析表】中的“多头最大平仓交易回撤幅度”，显然，它小于“最大资产回撤幅度”，随资金变动调整交易数量的用该曲线评估风险。

u 空头平仓收益曲线与回撤图

该图是累积空头平仓盈亏的连线，体现了每次空头交易的累积平仓收益。横坐标为交易序号，表示第几次交易，曲线上的红色点表示累积收益创新高，绿色点表示累积收益创新低。

空头平仓收益回撤曲线是空头平仓收益从高点回撤到低点的金额，其最大值即【收益风险分析表】中的“空头最大平仓交易回撤”，显然，它小于“最大资产回撤”，固定数量交易用该曲线评估风险。

空头平仓收益回撤幅度曲线是空头平仓收益从高点回撤到低点的幅度，其最大值即【收益风险分析表】中的“空头最大平仓交易回撤幅度”，显然，它小于“最大资产回撤幅度”，随资金变动调整交易数量的用该曲线评估风险。

u 平仓盈亏散点图

该图是所有交易的平仓盈亏的分布。横坐标为交易序号，表示第几次交易的平仓盈亏。黑色水平线是总体的平均盈亏，红色水平线是所有盈利交易的平均盈利，绿色水平线是所有亏损交易的平均亏损。红色点表示若干倍标准差外的离群盈利交易，绿色点表示若干倍标准差外的离群亏损交易

u 有效平仓盈亏率散点图

有效平仓盈亏率=平仓盈亏/实际占用保证金。用于观察每笔交易的盈亏占实际动用资金的收益率。

u 最大浮盈散点图

横坐标是交易序号，每个点表示该笔交易的最大浮盈，水平线是最大浮盈的平均值。

u 最大浮盈-平仓盈亏柱状图

横坐标是交易序号，每个柱的高点都在0线之上，是该笔交易的最大浮盈，低点是该笔交易的平仓盈亏，柱形高度表示最大浮盈与平仓盈亏间的差距。红色表示该笔交易是盈利的，绿色表示该笔交易是亏损的。

u 最大浮盈-平仓盈亏散点图

该图描绘了每笔交易的盈亏与最大浮动盈利间的关系。

纵坐标是平仓盈亏的绝对值。红色表示盈利交易，绿色表示亏损交易。

u 最大浮亏散点图

横坐标是交易序号，每个点表示该笔交易的最大浮亏，水平线是最大浮亏的平均值。

双击鼠标出现十字光标可查看各点数值。

u 最大浮亏-平仓盈亏柱状图

横坐标是交易序号，每个柱的低点都在0线之下，是该笔交易的最大浮亏，高点是该笔交易的平仓盈亏，柱形高度表示最大浮亏与平仓盈亏间的差距。红色表示该笔交易是盈利的，绿色表示该笔交易是亏损的。

双击鼠标出现十字光标可查看各点数值。

u 最大浮亏-平仓盈亏散点图

横坐标是交易序号，每个点表示该笔交易的最大浮亏，水平线是最大浮亏的平均值。

双击鼠标出现十字光标可查看各点数值。

u 平仓盈亏分布图

柱线表示某个平仓盈亏幅度小区间的交易次数，观察上图，虽然亏损交易的总次数大于盈利交易的总次数，但盈利幅度大于亏损幅度，总体依然是盈利的。该图叠加了中心值为平均盈亏的正态分布曲线，便于对比。

双击鼠标出现十字光标可查看各点数值。


时段分析

u 月绩效分析表

测试期内所有相同月份交易绩效的统计。

如上图，是2005-2012年的月绩效统计，3、7、9月份的绩效如此不堪，可考虑这几个月份减小投入资金或不做交易。4、10月份的绩效惊人，可考虑这几个月份加大投入。

u 月度分析

与【月绩效分析表】不同，该表是测试期内每个自然月的交易绩效的统计。

u 年度分析

测试期内每个自然年的交易绩效的统计。

u 月净值收益与回撤柱形图

实心柱高度表示该月资产净值的盈亏，0线上的虚线柱高度表示该月的最大浮盈，0线下的虚线柱高度表示该月的最大浮亏。

固定数量交易看金额图，随资金变动调整交易数量的看幅度图。

u 月净值收益与回撤幅度柱形图

实心柱高度表示该月资产净值的盈亏幅度，0线上的虚线柱高度表示该月的最大浮盈幅度，0线下的虚线柱高度表示该月的最大浮亏幅度。

固定数量交易看金额图，随资金变动调整交易数量的看幅度图。

u 月平仓收益与回撤柱形图

实心柱高度表示该月平仓收益，0线上的虚线柱高度表示该月的最大平仓盈利，0线下的虚线柱高度表示该月的最大平仓亏损。若该月无平仓交易则无柱线。

固定数量交易看金额图，随资金变动调整交易数量的看幅度图。

双击鼠标出现十字光标可查看各月数值。

u 月平仓收益与回撤幅度柱形图

实心柱高度表示该月平仓收益幅度，0线上的虚线柱高度表示该月的最大平仓盈利幅度，0线下的虚线柱高度表示该月的最大平仓亏损幅度。若该月无平仓交易则无柱线。

固定数量交易看金额图，随资金变动调整交易数量的看幅度图。

双击鼠标出现十字光标可查看各月数值。


策略上传到花生网

策略上传到花生网，可将本地策略运行的结果上传到花生网展示或自己查看。

策略评测完成后，在评测报告的界面上，点击右键，出现菜单“上传数据”。

上传设置如下·：

点击“上传”，可将策略及评测结果上传到花生网。

说明：上传设置，设置上传的账号(该账号为花生网账号)，首次使用需要做设置。

如没有上传账号，请点击“注册账号”到花生网注册。

温馨提示：设置完成后，请别忘记保存设置，以便以后使用。


本地模拟交易平台

目前支持国内期货CTP交易通道。并将陆续与合作伙伴开通股票交易通道。

平台的设计目标：

1. 交易结果是确定的。

2. 交易表现是稳定的。

3. 交易过程是快速的。

4. 交易过程的监控是直观的。


本地模拟交易 登入/注销

打开菜单“量化交易-本地模拟交易”会弹出本地模拟交易登录界面，如下图

输入客户号、密码，点击登录。清空数据库：选项如果勾上则清除本地原有的交易记录。

如无本地模拟交易账号，可以点击“注册本地模拟账号”进行注册。

输入用户名、密码，提交，完成资金账户的注册。

自动化交易在金魔方中相当简单，只需将智能交易系统（仅该类指标才能程式化交易）放在主图上，在登陆交易账号的状态下，打开交易开关，即可进行自动化交易。

可能大家会问怎么做神奇的多策略组合交易？其实也很简单，只需将一个品种打开多个图形，再将策略拖放至各个图形上即可做到多策略自动交易。

温馨提示：

1、在自动交易状态下，k线图上将锁定不能做切换，如果需要看其他，建议多打开一个窗口，如必须在原窗口下切换，需关闭交易开关才能操作。

2、由于每个策略具有单独的ID号，其中人工单也属于一个单独的ID号，所以人工单需要平仓时，必须人工操作平仓。

设置好后，我们就可以享受自动交易带来的愉悦了，当然您的智能策略能盈利是最关键的。

当您还没有形成成熟的策略之前，可以检验一下自己的手工操作方式，使用手工下单模拟。

手工下单也不复杂，请看下图

在弹出下单界面中，设置好您要使用的交易类型，您要做空请点击【卖出】，您要做多请点击【买入】，系统就会将您的委托进入模拟交易所队列中。

点击委托页面，可查看与委托相关的信息，并可快速撤单和全部撤单。

点击持仓页面，可查看自己持有什么品种，多少仓位，并可快速平仓。

以上基本涵盖了模拟交易的主要操作部分，大家赶紧来试试吧！

退出本地模拟交易，点击菜单“量化交易-退出本地模拟交易”。


真实交易委托 登入/注销

点击主菜单“量化交易-真实交易委托”会弹出登录界面，选择好经纪商，然后输入在对应经纪商处开户时取得的客户号和密码即可登录。

如果想要用代理服务器，则先在登录界面切换到“代理服务器设置”标签进行代理服务器的设置，选择好代理服务器的种类之后输入可用的代理服务器的IP地址和端口，输入用户ID和口令，然后点击“保存设置”，设置好代理服务器之后切换回“登录信息”标签，选择好经纪商，然后输入在对应经纪商处开户时取得的客户号和密码即可登录。

登录时可选择是否记住客户号，如选择记住客户号则下次登录时就不需再次输入客户号；还可以选择是否清空数据库，如选择清空数据库则会清除保留在本地数据库的所有信息，然后从服务器上同步回所有的信息，但要注意的是清空数据库之后一些只保存在本地数据库没有保存在服务器上的信息就没有了，比如追价单。

登录正在进行的过程中点击登录界面上的“取消”按钮则会取消登录。

登录成功后若想注销登录，点击主菜单“量化交易-退出真实交易”即可。


交易管理-经纪商设置

点击菜单“量化交易-交易管理-经纪商管理”打开经纪商管理设置窗口，如图所示

温馨提示：地址栏中必须加入tcp://这个前缀，否则无法正常登陆。

添加后重启程序，进入应该就可以看到新加入的经纪商了。注意新加入的经纪商不一定就在列表前面，如果没有看到，可以拉动滚动条看是否在下面。

这时候就可以选择您需要的经纪商，输入客户号和密码后，可以登录交易服务器了

温馨提示：

如果有用户发现自己的经纪商不在当前的经纪商列表中，请把具体的经纪商信息（包括经纪商名称，经纪商ID和交易服务器列表）发送给我们统一添加，我们会在下一次升级的时候统一升级经纪商列表，如果没有把经纪商列信息发送给我们，可能升级的时候需要先备份一下您的经纪商列表文件（程序安装目录\trade\Broker.xml）,等升级完成后再还原回来，否则可能会被覆盖。


程式化交易

程式化交易是指通过运行公式指标自动进行的交易，具体策略编写可参考公式编辑器中的“字典”查看每个函数的用法。

1、如何自动交易？（程式化交易下单）

程式化交易在金魔方中相当简单，只需将智能交易系统（仅该类指标才能程式化交易）放在主图上，在登陆交易账号的状态下，打开交易开关，即可进行自动化交易。

可能大家会问怎么做神奇的多策略组合交易？其实也很简单，只需将一个品种打开多个图形，再将策略拖放至各个图形上即可做到多策略自动交易。

温馨提示：

1、 在自动交易状态下，k线图上将锁定不能做切换，如果需要看其他，建议多打开一个窗口，如必须在原窗口下切换，需关闭交易开关才能操作。

2、由于每个策略具有单独的ID号，其中人工单也属于一个单独的ID号，所以人工单需要平仓时，必须人工操作平仓。


手工下单

1、 开仓

双击分析窗口界面信息面板上面的买卖盘，或者点击主窗口状态栏上的“买”按钮，或者点击“量化交易-本地模拟交易”、或者点击“量化交易-真实交易委托”，都能打开手工下单界面，下单界面默认选取当前画面上的品种。和程式化交易开仓类型一样，手工开仓时交易类型也可以选择市价单、限价单或追价单，交易方向也可以选择是买入（开多）还是卖出（开空）；下单时可以设置止盈/止损价，也可以不设置，填0即为不设置。

手工开仓-市价单，下单不需输入交易价位，输入手数，根据需要设置止盈止损价，然后直接点击买入或者卖出按钮即可，买入的委托报单价格自动设为最新的卖一价，卖出的委托报单价格自动设为最新的买一价。

手工开仓-限价单，下单需要选择方向“开多”或者“开空”，需要输入价位、手数，根据需要设置止盈止损价、委托单有效期（“截至期日”），然后点击“下单”按钮。

手工开仓-追价单，和限价单一样，下单需要选择方向“开多”或者“开空”，需要输入价位、手数，根据需要设置止盈止损价、委托单有效期（“截至期日”），然后点击“下单”按钮。

2、 撤单

在“委托”界面可以对未成交还在队列中的委托单进行手工撤单：双击想要对其撤单的委托单所在的行，然后会弹出撤单确认对话框，点击“是”进行确认即可快速撤单，通过右键菜单“撤单”也可以实现对选中的委托单进行撤单；还可以通过右键菜单“撤掉所有单”一次性撤掉所有未成交还在队列中的委托单。在追价单界面，也可以用同样的方法对显示在追价单界面的委托单进行撤单。

3、 平仓

双击“持仓”界面，任意一个仓位所在的行（除“止盈价”或“止损价”这两列以外），就会弹出该仓位的手工平仓界面，手工平仓可以像开仓一样选择市价单、限价单或者追价单这几种交易类型。

市价单平仓界面如图所示，输入手数，然后点击平仓按钮即可。

限价单平仓界面如图所示，输入手数、价位，根据需要选择“截至期日”，然后点击下单按钮。

追价单平仓界面如图所示，输入手数、价位，根据需要选择“截至期日”，然后点击下单按钮。

4、 修改止盈止损价

双击“持仓”界面任意一个仓位的止盈价或止损价，就会弹出该仓位的止盈止损价修改界面，如图所示，可以同时修改止损价和止盈价，也可以只修改止损价或止盈价，输入想要修改的止损/止盈价的价位，不需修改的则不需要输入保持原先的值，然后点击修改定单按钮即可。


委托

委托界面显示已经发送到交易所的委托单的相关信息，包括策略单号、券商单号、成交单号、品种、操作状态、执行状态、开平、多空、类型、委托价、委托量、成交量、未成交量、委托时间、成交时间、账户、策略号，如图所示

其中，

“操作状态”是指客户端对委托报单的处理状态，包括“已经提交”、“报单已经拒绝”等。

“执行状态”是交易所返回的对该委托单的处理状态，包括“撤单”、“部分成交余单撤单”、“全部成交”、“未成交还在队列中”等。

“开平”包括平今、平昨、开仓。

“多空”表示多空方向，包括“买入”“卖出”。

“类型”表示委托单类型，包括“限价”“市价”。

“策略号”是下单时定义的用来识别区别不同策略的编号；手工单比较特殊，将其策略号固定为-1。


资金

资金界面显示交易账户的资金相关的信息，包括“动态权益”“可用保证金”“可取资金”“冻结资金”“占用保证金”“币种”。如图所示


持仓

持仓界面列表显示当前账户下面不同策略的所有的持仓，列表内容包括品种、昨/今仓、方向（买入或卖出）、持仓量、可用量（可用量=持仓量-冻结量）、冻结量（已经发送相关平仓指令到交易所但暂未成交的量）、成本、最新价、浮动盈亏、止损价、止盈价、账户、策略号，如图所示

鼠标点击任意一个持仓所在的行可以打开这个持仓的品种的分析画面。


历史成交

历史成交界面列表显示程式化交易的历史记录（手动交易的记录不会在此显示），列表内容包括平仓单号、开仓单号、平仓类型、品种代码、开仓时间、开仓价格、平仓价格、平仓量，如图所示


合约配置

合约配置界面列出了交易系统支持的各个合约品种相关的配置信息，方便查看，包括品种代码、合约、合约名、交易所（合约所属交易所）、合约乘数、最小价格变动单位、品种类型、最后日期（合约交割日期）、多头保证金率、空头保证金率、开仓手续费、平仓手续费、平今手续费、开仓手续费率、平仓手续费率、平今手续费率，如图所示


追价单

委托单界面列表显示保存在本地尚未发送到交易所的委托单，包括尚未被触发的追价单和委托价格超出当前涨跌停范围的限价单，列表内容包括策略单号、品种、状态、执行状态、开平、多空、类型、委托价、委托量、委托时间、账户、策略号，如图所示


账户上传到花生网

金魔方软件通过登录期货CTP账号，可查询到您以往的真实交易记录，也能将您在金魔方的本地模拟交易记录，可通过上传功能将记录上传到花生网，供您分析自己的交易情况。

您还可通过对花生网账户进行设置，选择将记录公开分享或是仅限自己查看。

操作说明：

1、 先登录CTP账户或本地模拟账户，才能对记录进行上传，点击金魔方中的“量化交易”菜单登陆账户。

温馨提示： ①、登录CTP账户后出现上图提示则表明已取回并匹配所有交易记录，这时才可以开始上传记录（请确保有交易过，否则上传没有数据）。

②、登录本地模拟账户，只需当登录窗口消失后，即可开始上传记录（请确保有交易过，否则上传没有数据）。

2、 登录账户后，点击菜单“量化交易-账户上传到花生网”或点击交易平台上的“上传账户数据”按钮，如图所示:

3、 首次使用账户上传时，账户列表为空，需要点击“上传设置“进行设置，如图：

4、 设置如下图:

5、输入花生网账号、密码：该账号为花生网注册账号，如无账号则点击-注册账户，在弹出的花生网网页中进行注册。

首次使用“资金账号”和“别名”都为空，需要点击界面右边的“添加账号”。

添加账号：资金账号为本地模拟账号或者真实账号，需输入资金账户及别名，其中资金账户是用户在上传时选择的账户名。

别名主要是为了方便花生网分类管理，一个资金账号只可对应一个别名，但在设置之前需到花生网—“我的花生地”中添加对应的账户。

6、花生网该账户名对应的就是上传设置里的别名，如下图：

7、上传记录

设置完成后，选择需要上传的账户，然后点击上传，即可将交易记录上传至花生网，时间需要大约1分钟左右，再次登录花生网可查询到评测结果。


快捷键列表
F2 切换到行情报价表（如果当前为行情报价表，则不起作用）
F4 大盘指数切换 (只在图形窗口中起作用)
F5 分时线、日线切换 (只在图形窗口中起作用) 点数图中切换周期
F7 条件选股
F8 周期切换 (在图形窗口中起作用)
F11 交易

Tab 切换窗口

Alt＋F4 退出软件

Ctrl＋M 启动／停止多图同列 (只在图形窗口中起作用)
Ctrl＋N 添加窗口
Ctrl＋O 弹出选项对话框
Ctrl＋P 打印设置
Ctrl＋S 输出图形（类似屏幕截图，可直接存成bmp/gif文件）

Ctrl＋Delete 删除所有交易指示（只在图形窗口中起作用)
Ctrl＋PgDn 自动换页/停止换页

Shift＋P 切换/取消鼠标在主图上平移画面功能（只在图形窗口起作用）
Shift＋U 全屏/窗口模式切换

Alt＋1 只显示主图 (只在图形窗口中起作用)
Alt＋2 显示主图和一个副图 (只在图形窗口中起作用)
Alt＋3 显示主图和两个副图 (只在图形窗口中起作用)
Alt＋4 显示主图和三个副图 (只在图形窗口中起作用)
Alt＋5 显示主图和四个副图 (只在图形窗口中起作用)
Alt＋6 显示主图和五个副图 (只在图形窗口中起作用)
Alt＋7 显示主图和六个副图 (只在图形窗口中起作用)
Alt＋8 显示主图和七个副图 (只在图形窗口中起作用)
Alt＋9 显示主图和八个副图 (只在图形窗口中起作用)

在图形分析窗口可用以下快捷键切换分析周期：
0 分笔成交
1 1 分钟线
2 5 分钟线
3 15分钟线
4 30分钟线
5 60分钟线
6 日线
7 周线
8 月线
9 年线
D 多日线（用户自定周期）

选择主图K线模式可有以下几种快捷方式：
K 蜡烛线
BAR 美国线
PRICE 价位线
TWR 宝塔线
GBL 鬼变脸
CNDEQV 压缩线

↑ K线柱体放宽
↓ K线柱体缩窄
← 十字光标线向左移动
→ 十字光标线向右移动
Home 十字光标线向左移动到当前画面的最左边一条K线
End 十字光标线向右移动到当前画面的最右边一条K线
Ctrl＋← K线向左移动
Ctrl＋→ K线向右移动
Ctrl＋Home K线向左移动到最头
Ctrl＋End K线向右移动到最尾
Ctrl＋↑ 当前活动副图切换到上一个副图
Ctrl＋↓ 当前活动副图切换到下一个副图
PageUp 上一券种
PageDown 下一券种
直接键入代码 如:600839回车，即切换到四川长虹
直接键入技术指标名称 如：MACD 即切换到MACD指标

图形分析中[回车]键切换实时/历史走势（切换到上次显示的周期，不一定是日线）

键盘精灵快捷键：

报价窗口：

00 多图同列

1 交易信息

03 上海指数

04 深证成指

05 切换实时/日线

06 自选股

08 切换周期/板块

30 涨幅排名

31 涨速排名

32 量比排名

30 涨幅排名

31 涨速排名

32 量比排名

33 成交额排名

34 换手率排名

61 上海A股涨幅排名

62 上海B股涨幅排名

63 深圳A股涨幅排名

64 深圳B股涨幅排名

65 A股涨幅排名

66 B股涨幅排名

67 基金涨幅排名

84 深圳B股综合排名

87 基金综合排名

89 中小企业综合排名

99全屏显示

分析窗口：

.1 交易信息

0 1分钟

1 5分钟

1 15分钟

4 30分钟

5 60分钟

6 日线

7 周线

8 月线

9 年线

19 权息校正

d 多日线（具体多少日由系统选项多日线的天数设置而定）

m 多分钟线（具体多少分钟由系统选项多分钟线的分钟数设置而定）

S 多秒线（具体多少秒由系统选项多秒线的秒数设置而定）

q 多季度线

n 多半年线

J 节气线

[.1] 显示/隐藏右侧交易信息；（图形分析）

[.10] 为“取消标记”[.11][.12][.13]... [.19]分别或“品种标记1-9”。


直线

Ø 直线的画法

单击鼠标左键，选取一点作为趋势线的起点，移动鼠标在分析图中选取直线的终点，点击鼠标左键便可生成直线。

Ø 工具说明

技术分析的一个重要论点就是：价格沿趋势变动。历史图表也表明，几乎所有中期的（甚至是长期的）价格变动都差不多沿着一条直线进行。有效的趋势线应由二个以上的支撑点（下跌时）或阻力点（上升时）连接而成。

注：直线一般是高点和高点的连线，或者是低点和低点的连线。但低点（高点）和高点（低点）的连线在判断 股价的趋势时，也能发挥很大作用，这条线用来作为重要的支撑（压力）线有时还是十分有效的。

Ø 研判方法

如果价格处于上升趋势或下跌趋势中，说明价格正加速前进，处于明显的多头或空头市场中，否则认为市场处于无势可言的状况，即"盘整态"。

一条斜线（趋势线）会把K线图分成两部分，线的上方被视为多头区域，线的下方被视为空头区域，斜线斜率的大小反应了趋势变动速度的大小。趋势线的"角度"，即每天上涨或下跌的幅度，实际上是一种"速度"的表现，所以，45度角的趋势线一般称为"定速线"；如果行情既非强势也非弱势，趋势线变成接近于水平，说明行情处于无方向的盘整期。

1、有效的趋势线是价格回调或反弹时重要的支撑线或阻力线。趋势线为什么有如此大的作用，可能的原因有：（1）股市中一种趋势一旦确立，一般很难改变。（2）趋势线有时也是市场信心和心理成本的象征，如果股价突破了趋势线，很容易造成多方或空方的崩溃，所以，所谓"市场主力"就会刻意维持股价沿趋势线运动。

2、价格一旦突破趋势线，则是重要的趋势反转信号，应注意买入或卖出。越重要越有效的趋势线被突破，其转势的信号越强烈。被突破的趋势线原来所起的支撑和压力作用，现在将相互交换角度。即原来是支撑线的，现在将起压力作用，原来是压力线的现在将起支撑作用。

注：这种方法在实际操作中，确实既简单又有效，趋势代表价格的前进方向，正常情况下，价格应该持续顺着趋势的轨迹前进，有时，价格会忽而朝趋势线的左方偏离，忽而朝右方偏离，这就形成了价格与趋势线的"乖离"，这种乖离的研判方法，与移动平均线"乖离"的研判方法类似，因为趋势线和移动平均线均表示股价落在"线"附近的概率较大，因而这些线对价格有一定的"吸引力"，移动平均线表示目前大多数人的持仓成本，趋势线表示价格前进的方向。因而，在移动平均线和趋势线周围，会不断出现价格的涨落，当价格距离趋势线超过一定距离时，便会受吸引力的牵制，而逐步向趋势线靠拢，反之，当价格接近趋势线时，又会逐步偏离趋势线而产生乖离,我们可以通过比较历史数据乖离的大小来判断现在价格是否即将进行修正。


水平线

Ø 水平线的画法

选取一点作为水平线的起点，单击鼠标左键便可形成一条水平线。

Ø 工具说明

水平线用来标示不同的水准。特别是用来标示支撑和压力位。支撑位是指当价格受买方(多头)控制时，阻止其下跌的水准。压力位则相反，当价格受卖方 (空头) 控制时，抑制其进一步上涨的水准。

Ø 研判方法

支撑和压力线会阻止或暂时阻止股价向一个方向继续运动。我们知道股价的变动是有趋势的，要维持这种趋势，保持原来的变动方向，就必须冲破阻止其继续向前的障碍。比如说，要维持下跌行情，就必须突破支撑线的干扰，创造出新的低点；要维持上升行情，就必须突破上升的压力线的干扰，创造出新的高点。同时，支撑线和压力线又有彻底阻止股价按原方向变动的可能。当一个趋势终结了，它就不可能创出新的低点和新的高点，这样支撑线和压力线就显得异常重要，是取得巨大利益的地方，

1、上升趋势中，如果未创新高，即未突破压力线，我们可以说这个上升趋势已经处在关键位置，如果往后的股价又向下突破了这个上升趋势的支撑线，一个趋势转折重要信号就产生了，通常这意味着，这一轮上升趋势已经结束，下一步的走向是下跌的过程。同样，下降趋势中，如果末创新低，即末突破支撑线，这个下降趋势就已经处于关键位置，如果下一步股价向上突破了这个下降趋势的压力线，这就发出了这个下降趋势将要结束的强烈的信号，股价的下一步将是上升的趋势。

2、支撑和压力地位可以相互转换。一个支撑如果被突破，那么这个支撑将成为压力；同理，一个压力被突破，这个压力将成为支撑。这说明支撑和压力的角度不是一成不变的，而是可以改变的，条件是它被有效的足够强大的股价变动突破。


线段

Ø 线段的画法

单击鼠标左键，选取一点做为线段的起点，移动鼠标在分析图中选取线段的终点，点击鼠标左键便可生成线段，线段的距离就是起点到终点的距离。

Ø 工具说明

线段工具的用法与趋势线、支撑线和压力线相同，不同之处是线段的距离是一定的。


矩形

Ø 矩形的画法

单击鼠标左键，选取一点作为矩形起点，移动鼠标，窗口中的矩形大小会随之改变，将鼠标放至适当位置，单击左键即可生成相应的矩形，矩形的大小是由以选取的两点为端点的对角线长度和角度决定。

Ø 工具说明

矩形又称箱体，就是把股价的高点做顶,低点做底,在一个涨跌的周期里画成一个方形的箱。

Ø 研判方法

股票在运行过程中，形成了一定的价格区域.即股价是在一定的范围内波动，这样就形成一个股价运行的箱体。当股价滑落到箱体的底部时会受到买盘的支撑，当股价上升到箱体的顶部时会受到卖盘的压力。一旦股价有效突破原箱体的顶部或底部，股价就会进入一个新的箱体里运行，原箱体的顶部或底部将成为重要的支撑位和压力位。

1、箱体整理指股票在箱体内运动时，在触到顶部区(或箱体的高位区)附近即回落，触到底部区(或箱体的底位区)附近即反弹。箱体整理说明多空双方力量均衡，两方都在找突破方向，此时大部分股票走势向上向下突破都没有定论,但有些股票走势在突破前还是有迹可寻的。

2、股价收盘有效突破箱顶，意味着原先的强阻力变成了强支撑，而股价必然向上进入上升周期。只要技术指标盘中不即时显示箱顶标志，增加持仓应该是个不错的选择，尤其当股价升势明显时。同理，当上升中的股价出现箱顶标志后开始出现下跌，以后很可能会下跌或整理一段较长的时间，将时间或精力耗在其中是件不明智的事情。突破(跌破)强阻力(支撑)必然上涨(下跌)寻强阻力(支撑),突破上箱底进入上箱寻顶,跌破下箱顶进入下箱寻底。


三角形

Ø 三角形的画法

单击鼠标左键，选取一点作为三角形的起点，移动鼠标至第二点再单击鼠标左键选中，在第三点处单击鼠标左键即可完成一个三角形。

Ø 工具说明

三角形形态的特点是：价格波动的幅度从左至右逐步减小，多空双方的防线逐步靠近，直至双方接火，形成价格的突破。根据具体情况，三角形形态又分为上升三角形、下降三角形和正三角形等。

Ø 研判方法

1、上升三角形，其趋势为上升势态，多方占优，空方较弱，多方的强大买盘逐步将价格的底部抬高，而空方能量不足，只是在一水平颈线位做抵抗。

（1）从Ｋ线图中可绘制低点与低点相连，出现由左至右上方倾斜的支撑线，而高点与高点相连，基本呈水平位置。

（2）在上升三角形形态内的成交量也是从左至右呈递减状态，但当它向上突破水平颈线时的那一刻，必须要有大成交量的配合，否则成交量太小的话，价格将会出现盘整的格局，从图形上走出失效形态。如果在上升三角形形态内的成交量呈不规则分布，则维持盘整的机率要大。

（3）由于上升三角形属于强势整理，价格的底部在逐步抬高，多头买盘踊跃，上升三角形突破成功的话，突破位为最佳买点，后市则会有一波不俗的涨幅。如果上升三角形突破失败的话，则会承接形态内的强势整理而出现矩形整理，形成头部形态的机率也不会太大。

2、下降三角形，买卖双方力量却与上升三角形所显示的情形相反。

（1）空方力量不断地增强抛售压力，股价还没回升到上次高点便抛出，而多方坚守着某一价格的防线，使股价每回落到该水平便获得支撑。

（2）当购买的实力消耗尽时，卖出的力量把水平的需求线支撑力击破，形成一个短期卖出信号。

（3）“下降三角”往下跌破，不必大量的成交量来说明，一般在跌破后数天，成交会呈现增加的趋势，这一点与“上升三角形”不同。在向下跌破后，有时可能会出现假性回升，回升将会受阻于“下降三角”的底线水平之下。

3、正三角形（又称对称三角形），在其水平出现了徘徊争持的局面，每一次短期回升的高点都较上次为低，但与此同时，新的短期回落，其低点都上次为高，而成交量在这期间呈现下降的倾向。

（1）图形上将高点和低点，分别以直线连接起来，就可以画出一个上下相称的三角形状，而这两条线最终会相交于一点。

（2）成交量在对称三角形成的过程中不断减少。一般情形之下， “对称三角”的徘徊调整后，会继续原来的趋势移动。

（3）行情必须往其中一方明显突破后，才可以采取相应的买卖行动。如果往上冲阻力（必须得到大量成交量增加的配合），就是一个短期买入信号。反之若是往下跌破（在低成交量之下跌破），便是一个短期卖出信号。


平行线

Ø 平行线的画法

三点确定平行线，前两点确定平行线的斜率，第三点到前两点确定的直线的距离决定平行线间的具体。

Ø 工具说明

1、等距水平平行线定义

等距水平平行线是在由达韦斯•尼古拉所创立的"股票箱理论"的基础上演变而来(其基本原理、作图方法和研判要点与"股票箱理论"基本相同，)，它是"股票箱理论"应用中的一种"特例"：

（1）所画出的全部平行线均为水平平行线。而"股票箱"所画出的平行线既可以是水平平行线，更多的则是带有倾斜角度的平行线。因此，等距水平平行线主要是用于价格(包括指数)在作水平横向波动阶段的分析与研判，以及价格突破"旧箱"的上(或下)边线之后波动空间(长度)的量度。

（2）一般而言，在"标准坐标"(又称"算术等距刻度坐标")中使用"等距水平平行线"效果较好。但不排除在少数情况下，在"半对数坐标"(又称"半对数刻度坐标")中使用"等距水平平行线"，也可能会有较好的分析和预测效果。

（3）实证表明，价格波动的内在规律与波动力度并非千篇一律。在部分股票(而非全部股票)或部分股票的某一个波动阶段的分析中，适用于在"标准坐标"之下使用"等距水平平行线"来预测与量度，表明这一阶段波动的力度比较符合线性增长(变动速率)的特征。其直观的现象就是这一波动阶段中上升或下跌的力度均较为温和，不及呈对数增长波动(变动速率)的力度来得凌厉。

4、画"股票箱"时需要选择三个点，而在画"等距水平平行线"时只需要选定两个点：一个上边线的点和一个下边线的点，操作时相当便捷。


江恩线

Ø 江恩线的画法

单击鼠标左键，选取一点作为起点，移动鼠标，再选取一点作为甘氏线的终点，单击鼠标左键便可生成江恩线。

Ø 工具说明

江恩线(Gann line)分上升甘氏线和下降江恩线两种，是由William D．Gann创立的一套独特的理论。Gann是一位具有传奇色彩的股票技术分析大师。江恩线就是他将百分比原理和几何角度原理结合起来的产物。江恩线是从一个点出发，依一定的角度，向后画出的多条直线，所以江恩线又称为角度线。

图为-个江恩线各个角度的直线图。

图中的每条直线都有一定的角度，这些角度的得到都与百分比线中的那些数字有关。每个角度的正切或余切 分别等于百分比数中的某个分数(或者说是百分数)。

江恩线中的每条直线都有支撑和压力的功能，但这里面最重要的是45度线、63.75度线和26.25度线。这三条直线分别对应百分比线中的50%，62.5%和37.5%百分比线。其余的角度虽然在价格的波动中也能起一些支撑和压力作用，但重要性都不大，都很容易被突破。

Ø 研判方法

第一步：确定起始点，被选择的点同大多数别的选点方法一样，一定是显著的高点和低点，如果刚被选中的点马上被创新的高点和低点取代，则江恩线的选择也随之变更。下图中我们选择了2002年1月29日的最低点为起始点。

第二步：确定起始点后，再找角度(即45度线)，如果起始点是高点，则应画下降甘氏线；反之，如果起始点是低点，则应画上升江恩线。这些线将在未来起支撑和压力作用。

例： 鼠标画法：移动鼠标到被选为起始点的2002年1月29日的最低点，移动鼠标找角度(2002年月22日的最高点)即可。


速阻线

Ø 速阻线的画法

单击鼠标左键，选取一点作为起点，移动鼠标，再选取一点作为速阻线的终点，单击鼠标左键便可生成速阻线。

Ø 工具说明

速阻线是一种将趋势线和百分比回撤融为一体的新技巧，是埃德森•古尔德开创的，实质上也属于趋势线三分 法的具体应用。速阻线测绘的是趋势上升或下降的速率（或者说是趋势的速度）。

Ø 研判方法

1、如果上升趋势正处于调整之中，那么速阻线向下折返的余地通常是到上方的速度线（2/3速阻线）为止；如果它又被超越了，那么价格还将跌到下方的速度线（1/3速阻线）；如果下方的速度线也跌破了，那么价格就可能一路而下，直至原趋势的起点的水平。在下降趋势中，下放的速度线如果被突破，那么价格很可能上冲到上方速度线处。要是后者也失守，那就意味着价格将会涨到原趋势的起点的水平。

正如所有的趋势线一样，速度线一旦被突破，角色也会反串。这样，在上升趋势的调整过程中，如果上面的线（2/3线）被突破，价格则跌到1/3线，再从后者上面反弹。这时候，上面的线已演变成阻挡障碍了。仅当上面这条线被重新穿回，那么价格才可能向原高点挑战。同样的道理在下降趋势中也成立。

2、第一步：确定起始点，被选择的点同大多数别的选点方法一样，一定是显著的高点和低点，如果刚被选中的点马上被创新的高点和低点取代，则速阻线的选择也随之变更。下图中我们选择了2002年1月29日的最低点为起始点。

第二步：确定起始点后，再找角度，如果起始点是高点，则应画下降速阻线；反之，如果起始点是低点，则应画上升速阻线。

例： 鼠标画法：移动鼠标到被选为起始点的2002年1月29日的最底点，移动鼠标找角度即可。


黄金分割线

Ø 黄金分割的画法

单击鼠标左键，选取一点作为起点，移动鼠标，再选取一点作为黄金分割线的终点，单击鼠标左键便可生成黄金分割线。

Ø 工具说明

黄金分割率(0.382，0.618)是一组自然和谐的比率，应用在技术分析上，当价格调整时，0.382，0.618作为回调或反弹的关键位，准确度较高，与波浪理论有异曲同工之处。此工具提供8个比率点位，分别是0.191、0.382、0.5、0.618、0.809、1.382、1.618、2.618。

Ø 研判方法

（1）、0.382和0.618是反映了股市变化的重要转折点。当股价涨势趋近或达到38.2%和61.8%时，反跌很可能出现。反之，当股价跌势趋近或38.2%和61.8%时，反弹的可能性很大。

（2）、 当股价上升时，可按黄金率算出上升的空间价位。一般预计股价上升能力与反转价位点的数字是0.191、0.382、0.618、0.809和1。当股价涨幅超过1倍时，反跌点数字为1.91、1.382、1.618、1.809和2，依次类推。

（3）、反之，当上升行情结束，下跌行情开始时，上述数字仍然可以预计反弹的不同价位。


百分比线

Ø 百分比线的画法

单击鼠标左键，选取一点作为起点，移动鼠标，再选取一点作为百分比线的终点，单击鼠标左键便可生成百分比线。

Ø 工具说明

百分比线是将一定的价格空间分为8等分，1/8，2/8，3/8，4/8，5/8，6/8，7/8，8/8，另外又以3为分母，分成1/3和2/3。综合上述空间，以百分比来表示。用来描述一些重要的支撑、阻力位。此工具默认显示2/8、4/8、6/8三个等分点的线。

Ø 研判方法

1、百分比线考虑问题的出发点是人们的心理因素和一些整数的分界点。当股价持续向上，涨到一定程度，肯定会遇到压力，遇到压力后，就要向下间撤，回撤的位置很重要。黄金分割提供了几个价位，百分比线也提供了几个价位。以这次上涨开始的最低点和开始向下回撤的最高点两者之间的差，分别乘上几个特别的百分比数，就可以得到未来支撑位可能出现的位置。设低点是10元，高点是22元。这些百分比数一共10个，它们是: 0.125 0.25 0.375 0.5 0.625 0.75 1 0.33 0.67 。

2、这里的百分比线中，0.33、0.67这二条线最为重要。在很大程度上，回撤到是人们的一种心理倾向。


波浪尺

Ø 波浪尺的画法

上涨趋势浪，单击鼠标左键，选取最低点作为起点，移动鼠标再选取一个高点作为第二点，再在回调波的低点处单击鼠标左键作为第三点，上涨波浪尺便可生成。

下跌趋势浪，单击鼠标左键，选取最高点作为起点，移动鼠标再选取一个低点作为第二点，再在回调波的高点处单击鼠标左键作为第三点，下跌波浪尺便可生成。

Ø 工具说明

波浪尺是运用黄金分割法于艾略特波浪理论，具体应用是将黄金分割比例来单独测量某个波浪的上下起伏幅度。

如图：上涨趋势，A为起点，B为第二个点，C为第三个点，以A、B点之间的距离用黄金分割法分别计算出0.382、0.5、0.618、1、1.382、1.5、1.618、2的份数，在C点的基础上加上上面计算的份数，即形成预测以后波浪的波动幅度的波浪尺。下跌趋势同理。


弧线

Ø 弧线的画法

单击鼠标左键，选取一点（应为显著的高点和低点）作为起点，如果刚被选中的点马上被创新的高点和低点取代，则起始点的选择也随之变更。确定起始点后，再找第二点即弧线的圆心，也应选择市场重要的顶点和底点。

Ø 工具说明

菲波纳奇弧线体现了时间因素。这也是一种回撤测算技术，其构造方法与阻速线的类似。首先在图上找出上下两个极端的点（通常是市场的重要顶点和底点），然后以第二个点为圆心，按照菲波纳奇参数，38.2%，50%，61.8%，从两点之间的垂直线段上截得三个半径，分别画出三条弧线。这三条弧线从时间和价格两方面标识了可能出现支撑或阻挡的位置。


斐波那契周期数

Ø 斐波那契周期数的画法

单击鼠标左键，选取斐波那契周期数的起点，便可以生成。

Ø 工具说明

斐波纳切周期线：从重要的市场顶部或底部起向未来数算，得出的时间目标。其中的垂直线分别标志着未来第1、第2、第3、第5、第8、第13、第21、第34、第55及第89个交易周期的位置。这些周期可能意味着市场的重要转折点。


线性回归带、回归通道

Ø 线性回归带的画法

单击鼠标左键，选取一点作为起点周期，移动鼠标再选取终点周期，便可生成线性回归带、回归通道。

Ø 工具说明

线性回归、线形回归带及线形回归通道：线性回归、线性回归带及线性回归通道是根据数学上线性回归的原理来确定一定时间内的价格走势。线性回归将一定时间内的股价走势线性回归，然后来确定这一段时间内的总体走势；线性回归带是根据这一段时间内的最高、最低价画出线性回归的平行通道线；回归通道是线性回归带的延长。
    回归通道由五个部分构成：
    1、中间的这条线叫回归线，也是通道的主轴线。回归线是通过对股价作线性回归分析统计而形成的，它是一种有别于传统线型的趋势线，最接近于股价趋势的真实内涵。
    2、回归线上方的平行线叫通道上轨线。
    3、回归线下方的平行线叫通道下轨线。
    4、通道的实线部分叫回归确认带，即是回归确认的长度，也是进行回归分析起点终点的距离。
    5、通道的虚线部分叫回归预测带，就是回归通道所预测股票未来走势区间。股票的未来走势将在回归预测带中形成技术判断。

Ø 研判方法

1.用趋势线原理确定回归线；

2.用主要趋势形成的时间跨度确定回归确定带的长度；

3.回归确认带的长度一经确定不可轻易改变；

4.当趋势线明显改变是修正回归线，并用重新确定的回归线重新确定回归确认带的长度；

5.股价突破通道上轨时将冲高回落；

6.股价回落至回归线时将获得支撑而反弹；

7.股价跌破回归线时是卖出信号；

8.股价跌破通道下轨时是止损信号；

9.回归通道对上升第二浪有更强的预测作用。


等周期线

Ø 等周期线的画法

单击鼠标左键，选取周期线的起点，移动鼠标再选取周期线的终点，便可生成一组垂直平行的周期线，周期线间的距离（即周期数）由起点和终点之间的周期数决定。

Ø 工具说明

此工具遵循循环周期理论，画出相等时间间隔的许多垂直线。通常地，单位时间间隔相对应一个周期。

Ø 研判方法

周期线可以提醒交易者，当价格波动至周期线附近时，正处于上升行情的，应留意价格可能形成的高点；正处于下跌行情的，应留意价格可能形成的低点。但它们不一定形成头部或者底部，可能仅仅是一处回档或反弹幅度稍大的转折点而已。


量度目标

Ø 量度目标的画法

单击鼠标左键，选取目标价格的起点，移动鼠标，选取目标价格的终点，便可以生成距离相等的一组横向平行线。

Ø 工具说明

此工具画出相等价位间隔的许多水平平行线。通常地，单位间隔相对应一个价格变动幅度。可以用来度量价格形态的目标价格。


测评报告

测评报告界面是以表格和图形的形式，从各种不同的角度来分析测评结果。包括策略分析、交易和时间分析三部分。

策略分析包括总体概要、时间分析、仓位分析、收益分析、风险分析、风险报酬比例这几个表格和资产曲线、资产及水下（回撤）曲线、资产升水及回撤曲线、资产升水及回撤（%）这几个图形。

1、策略分析

u 总体概要

净利润：统计期内交易产生的净利润，总盈利-总亏损，这是不可忽视的考察收益情况的第一指标，但单纯看净利润的数额不能客观评判整个绩效状况。

总盈利（毛利）：每笔盈利交易实现的盈利总和，总收入

总亏损（毛损）：每笔亏损交易实现的亏损总和，若把投资看做是商业活动，这个数额就是总支出，设法减少亏损就能增加净利润。

盈利因子(毛利/毛损) ：总盈利/总亏损，也称为盈利比。每亏损（支出）1元能获取多少元的盈利（收入），把交易亏损看成是做生意的成本支出，也更能坦然接受亏损交易，想想，开个公司每天都有支出，好比每天都有亏损交易。这个比率说明投资效率，当然是越大越好。

去极端总盈利：去除极端盈利交易产生的盈利，极端盈利交易是指盈利在3倍标准差之外的盈利，如果去极端总盈利与总盈利差距过大，说明大部分盈利来自于非常态的收益，则根据策略的风格，或者说明实现的净利润不太可靠，或者说明不可错过任何一次交易。

去极端总亏损：去除极端亏损交易产生的亏损，极端亏损交易是指亏损在3倍标准差之外的亏损，如果去极端总亏损与总亏损差距过大，说明大部分亏损来自于突发的重大亏损，则策略需要增强防御这类情况的能力

期末持仓盈亏：统计期末有持仓时的浮动盈亏，若没有未平仓头寸，显示N/A

持有收益：统计期初不用资金杠杆全额开仓，到期末实现的盈利或亏损，其收益率即等于期末价格变动的幅度。比如10万初始资金，商品期末价格上涨了200%，则多头持有收益为20万，空头持有收益为-20万，不必考虑是否支持保证金交易、资金杠杆是多少。不能简单地以净利润与该收益作比较判定策略好坏，因为还需要比较资产最大回撤和收益标准差这类风险度量，如果在风险报酬比率上优于简单开仓持有，则是好的策略。

月平均收益：净利润/统计期间月数

月收益标准差：每个月净利润的标准差

佣金合计：包括经纪商手续费、交易所手续费、股票托管费等交易费用

u 时间分析（从时间角度对策略进行评估）

总交易月数：总交易期间换算成月数量

盈利月数：交易期资产增值的月数量

总交易时间（天）：有足够历史数据可让策略产生交易信号的期间，不一定等同测试期间

持仓时间（天）：有持仓的天数总计

持仓时间 %：持仓时间/总交易时间*100% 有持仓时间占得比例越小，说明策略在市场上投入资金越少，机会成本越小，就有更多的资金投入其他地方

资产增值天数：统计当天收盘比前一天资产增值的天数

资产减值天数：统计当天收盘比前一天资产减值的天数

获利日占比（增值时间 %）：资产增值天数/总交易时间*100%

最大空仓时间（天）：这个空仓时间长可能意味着必须有足够耐心等待下一次交易

最大浮动盈利日期：持仓浮动盈利最大的日期，检视是什么仓位和走势产生的

最大浮动亏损日期：持仓浮动亏损最大的日期，检视是什么仓位和走势产生的

u 仓位分析（仓位意味着风险敞口和资金效率）

最大持仓数量 ：统计历史上曾经的最大的持仓合约数

最大占用资金：统计历史上最大投入的资金额，开仓到最大仓位时投入的资金

最小账户资金：最大资产回撤+占用的保证金

平均仓位%：对每根K线取样计算持仓占用的资金/资产的百分比平均值，仓位意味着风险敞口，该百分比越高，表示资产暴露给市场波动风险的程度越高，也表示在市场上投入资金量越大，机会成本越大，没有更多的资金投入其他地方

u 收益分析（收益率的几何平均值，复利的威力，月收益6%=年收益101%=十年1088倍）

收益率%：净利润/初始资金×100%，在统计期没有追加或减少资金

年化收益率%：几何平均的年复合收益率（年复利、CAR、CAGR）

（（期末资产-期初资产）^（1/x）-1）×100% ； x为统计期年数

月化收益率%：月复合收益率（月复利）

有效收益率%：按持仓占用资金计算的收益率，收益率%/平均仓位%

有效年化收益率%：按持仓占用资金计算的年复合收益率，年化收益率%/平均仓位%

回归年化收益率%：对资产曲线按月（年、周）计算线性回归后的年复合收益率，对统计的起止日期相对不敏感

u 风险分析（过度冒险是自寻死路，但是不敢冒一定的风险就会失去很多机会，评估风险并以此改进风险管理技术有助于树立信心和耐心，实现预期目标）

最大浮动亏损：有持仓时的最大浮动亏损金额，浮动亏损可能对投资者心理造成较大冲击，在期货这种运用资金杠杆的情况下，会导致可用金减少，直接影响保证金水平，甚至带来穿仓风险，被强行平仓甚至直接爆仓，这个指标可以帮助头寸管理和设定机动的最大亏损止损位

最大浮动亏损幅度：有持仓时的最大浮动亏损幅度，以百分比考察浮动亏损，统计期间价格幅度变化很大时，用百分比有可比性。对于短期或固定金额开仓，数额指标比较直观，但对长期的或持仓量变化大的，应该检视幅度指标

最大平仓交易回撤：逐笔计算平仓交易时的资产的极高值出现后的最大亏损金额，若平仓交易时的资产值创新高，则重新计算，从该点再计算下一次最大回撤，该值就是其中最大值的那次回撤。可以从平仓交易资产曲线的阶段高峰到阶段低谷查看该值变化。

最大平仓交易回撤幅度：以百分比计量回撤幅度而不是回撤金额，其余与最大平仓交易回撤相同。

最大平仓交易回撤发生期：平仓交易时从资产高峰到低谷的起止日期

最大资产回撤：逐根K线计算资产极高值出现后到极低值的最大回撤（缩水）金额，若资产值创新高，则重新计算，从该点再计算下一次最大回撤，该值就是其中最大值的那次回撤。可以从详细资产曲线的阶段高峰到阶段低谷查看该值变化。在这样的交易数量下能忍受多大的回撤金额。

最大资产回撤幅度：以百分比计量回撤幅度而不是回撤金额，其余与最大资产回撤相同。强平、爆仓风险来自于这个回撤幅度。心理、资金上能忍受多大的资产回撤幅度。

这个幅度可认为是对风险最重要的衡量工具，通过考察长期的、跨越不同市场状况的资产回撤情况，可以对交易中发生的所有负面结果及其相关影响有个充分的了解。

最大资产回撤发生期：从资产高峰到低谷的起止日期

最长资产回撤持续时间（天）：从资产极高值到创新高所经过的最长时间，衡量的是恢复速度，即一段损失期后需多长时间资产额才能重新站上新的高点。这个期间未必是最大资产回撤或回撤幅度发生的期间。

通常投资市场都是快跌慢涨，包括资产曲线。假如初始资本是100万元，回撤50%，那就只剩50万元，要恢复到100万元，需要获利100%，显然这更大可能是需要更长的时间，难度也更大。所以，首要任务是保存资本，再图盈利。

对于那些需要从业绩增量中获得报酬的基金管理者，当资产回撤达到一定程度，如果想尽快收回损失，相应的恢复过程就需要及时增加资本投入，伴随而来的财务压力可能使基金管理者变得不耐烦并想努力尽快捞回损失而采取激进措施，但很可能会发现自己掉进了一个更深的洞，进而威胁整个交易计划的生存。所以，把一定的资产回撤作为降低风险的基础是风险管理计划的重要组成部分。例如，在交易计划之初就确立资产回撤达到10%时就将仓位降低50%，首先，这将大大有助于减少资产进一步回撤的程度，其次，从长期来看会更有信心承担未来可能发生的更大的风险。

月收益率标准差：统计每月资产收益率的标准差，标准差越小表示资产曲线越平滑

Ulcer指数：用于计算Ulcer绩效指数，以资产回撤的平均化作为风险度量

Ulcer =sqrt((R1^2+ R2^2+......+ Rn^2)/n)

R1、R2...... Rn为第1、第2......第n个资产回撤幅度

R平方：资产曲线与基准指数的相关系数的平方*100，反映基准指数（大盘）的波动对收益表现的影响，该值用于度量策略的系统风险，或者说是系统风险在总风险中所占的比重。例如指数ETF对标的指数的R平方接近于100

u 风险报酬比例（衡量潜在收益所蕴含的风险，所谓风险回报比率（简称风报比）就是指这类比率。算式一般都为收益/风险，收益和风险各有各的算法。这些比率都是越高越好。）

净利润/最大资产回撤：又称恢复因子，在统计期内承受风险与获得利润的比率

净利润/最大平仓交易回撤：在统计期内承受风险与获得利润的比率

年化收益率/最大资产回撤幅度：又称MAR比率，大于2为好

有效年化收益率/最大资产回撤幅度：大于2为好

年化收益率/25%的最大资产回撤幅度的平均值: 分母以最大的25%的资产回撤幅度的平均值作为风险。

夏普指数：经风险调整后的绩效指标，用于衡量投资的有效回报。

夏普指数=（月化收益率-无风险月利率）/月收益率标准差 SR=(MR-RFR)/SD

无风险利率（RiskFreeReturn RFR）一般为银行定存利率或短期国债的月收益率，在【选项】中设置。

时间跨度很长的可以用年化收益率和无风险年利率计算。夏普指数大于1为好，大于2很好，若为负值，表示承受风险但回报率反而不如存银行。

Ulcer绩效指数：以夏普指数相似，但以资产回撤作为风险衡量

UPI=（年化收益率-无风险年利率）/ Ulcer

以Ulcer指数代替夏普计算公式中的分母

风报比：月化收益率/月收益率标准差 或者 年化收益率/年收益率标准差

稳健风报比：回归年化收益率/长度调整平均最大回撤

长度调整平均最大回撤＝最大5次回撤幅度的平均值×这5次回撤期的平均天数/365，从回撤幅度和持续时间这两个角度来度量风险

飞狐评分：该分值综合衡量盈利能力、资金占用率（平均仓位）、最大风险和长期稳定性。同样的年化收益率，若仓位越大，表示投入资金越多，分数越低；若回撤越大，表示爆仓风险越大，则分数越低；标准差越小，统计时间越长，稳定性越好，则分数越高。

分值 =年化收益率/平均仓位×(1 + 最大资产回撤比例) ×（1-月收益标准差*3）×交易月数^（1/3）

这个算法对开始运行不久（1年之内）取得较好收益的策略评分偏高。

例如,年化收益率 30%,平均仓位30%,最大资产回撤比例 -15%，月收益标准差3%，交易期长达125个月的策略，其分数为:

(30 / 0.3)*(1 - 0.15)*（1-0.03*3）* 125^（1/3） = 100 * 0.85 * 0.91*5 = 386.75

对于亏损系统，不计交易月数，为了让回撤比例越大，稳定性越差，负值越大，算式为

分值 =年化收益率/平均仓位×(1 + 最大资产回撤比例的绝对值) ×（1+月收益标准差*3）

例如,年化收益率 -30%,其余数据与上述相同，则分数为:

(-30 / 0.3)*(1 + 0.15) *（1+0.03*3） = -100 * 1.15 *1.09= -125.35

资产曲线

画出每根K线对应的资产连线，表现资产的潜在高点和低点，如果没有持仓，则水平连线

叠加余额曲线，余额曲线用阶梯形连线

资产及水下（回撤）曲线

包括资产高点、资产低点、余额、资产回撤金额、资产回撤幅度这几条曲线

资产升水及回撤曲线

显示资产升水与回撤金额的对比。短期看金额，长期看幅度。

资产升水及回撤（%）

显示资产升水与回撤幅度的对比。短期看金额，长期看幅度。

优化结果：

根据提供的参数包括：资金余额、净利润、收益风险比、盈利因子、年化收益率、最大资产回撤幅度、胜率、盈亏比、交易次数、最大资产回撤、夏普指数、总盈利、总亏损、盈利次数、亏损次数、最大连续盈利次数、最大连续亏损字数、最大单次盈利、最大单次亏损、平均盈利、平均亏损、平均盈利周期、平均亏损周期、自定义评价公式，由系统自行随机设定参数组合，形成各个组合的测评结果。

列表显示各种参数组成的测评结果，列的标题包括参数组合的名称（名称带有各个参数值）、序号、以及所有的参数名。

每一行显示对应的测试结果，可双击列名进行结果排序。

双击其中一行，即可对某个参数组合进行测评，并显示相应的结果。

参数优化3D展示形式：

2、交易分析

交易明细：按每次交易（每次平仓算一次交易，每次平仓可能对应一次或多次开仓）列出交易明细，包括交易序号，品种名称，委托序号，交易类型，交易指令（多策略组合测试时策略名/PosID对应的Comments），交易时间（佣金 + 息差），数量（开/平仓量），价格（开/平仓价格），每个开仓对应的最佳和最差平仓价（对应最大浮盈/最大浮亏的价格），每次交易的交易成本、盈亏额和盈亏百分比（相对于开仓时资产的盈亏幅度，为方便计算，盈亏额/（平仓时资产-盈亏额）*100%）、累计盈亏额和盈亏百分比（累计盈亏/（平仓时资产-盈亏额）*100%）、浮盈、浮亏，每次交易后的资金余额（初始资金+累计盈亏），每次交易的有效盈亏百分比（该笔盈亏/开仓投入资金*100%）、持仓周期、每周期平均盈利

交易总体分析

交易次数：交易总次（笔）数，每一次平仓算完成一次（笔）交易，这次平仓可能对应多于一次的开仓，或者还有持仓未完全平完。这个指标可以评估交易的频率，由于每次交易是要付出交易成本的，这个数据也和佣金、滑价等交易费用支出相关，过于频繁的交易其成本可能吃掉可以取得的利润。

盈利交易次数：开平仓差价产生的毛利减去开平仓交易成本（包括佣金、滑价）依然有利润的交易次数。

亏损交易次数：利润为0的也算作亏损交易，因为持仓占用资金是付出了机会成本，这样就不需要另外统计打平交易。

胜率：盈利交易次数所占的百分比，也称为正确率或赢亏率。胜率低于50%未必是亏损系统，只要每次交易的平均盈利比平均亏损足够大。一般未经过特别过滤的趋势型或突破型系统，其长期的胜率低于50%。而均值回归型系统其胜率容易达到50%以上，但如果不控制好每次交易的亏损，很高的胜率也未必是盈利的系统。设置止赢位、止损位对改变胜率和盈亏比有极大影响。通常来说，投资者尤其是新手偏好高胜率的交易，胜率太低会影响心态，导致无法长期坚持执行，所以，策略组合最好能牺牲些盈亏比换来胜率大于50%，好比薄利多销而不求暴利，在实战中心理上也比较容易接受。

胜率% = 盈利交易次数/交易次数*100%

平均盈亏：每次交易的盈亏额的平均值，也称为预期盈利、期望收益。对于每次交易固定数量或金额的系统（统计期内价格波幅不大的可固定数量，反之应固定金额），看做预期收益比较有意义。如果策略测试时佣金和滑价设置为0，那么这个值应该大于这些实际交易时可能产生的交易成本。

平均盈亏=净利润/交易次数

每笔交易的期望收益=平均盈利×胜率-平均亏损×（1-胜率）

显然，平均盈亏=期望收益

盈亏中值：盈亏中值（中位数）就是一半次数的交易的盈亏它大，另一半次数的盈亏比它小，在完全对称分布中，均值和中值是相同或几乎相同的。如果平均盈亏大大超过盈亏中值，则很可能是由于少数赚钱最多的交易大大提高了均值水平。反之，如果盈亏中值明显高于平均盈亏，那很可能是由于有一些重大亏损。

平均盈利：盈利的交易每次平仓实现盈利额的平均值

平均盈利=总盈利（毛利）/盈利交易次数

平均亏损：亏损的交易每次平仓实现亏损额的平均值

平均盈利=总亏损（毛损）/亏损交易次数

盈亏比：平均盈利/平均亏损，趋势交易追求高盈亏比，用多次小的试错成本换来一次大的暴利。不同风格的交易策略，或偏好高胜率，或偏好高盈亏比，趋势型系统，其盈亏比高。回归型系统，其盈亏比低。设置止赢位、止损位对改变胜率和盈亏比有极大影响，及时平仓不能盈利的头寸有助于提高盈亏比。

最大单次盈利：盈利交易中最大一次的盈利，若最大单次盈利与平均盈利差距过大，则应视为偶然事件。

最大单次亏损：亏损交易中最大一次的亏损，若最大单次亏损与平均亏损差距过大，应检查系统的风险控制能力，以防御突发状况造成的重大亏损。

最大单次盈利/总盈利：若该值较高，即最大单次盈利在总盈利中的比重过大，则说明系统实际盈利能力和稳定性不高。

最大单次亏损/总亏损：若该值较高，这次最大亏损是否是这个策略的“黑天鹅”

净利润/最大单次亏损：该值越高越好

最佳10%交易盈利/净利润：按盈利水平排在前10%的交易实现的盈亏占净利润的比例，该比值度量了盈利的集中度。如果该值等于100%，说明前10%的交易赚取了所有的净利润，而余下的90%的交易仅仅实现盈亏平衡。但是，从这个数据不能指望通过减少这些不盈利的交易来提高效益，因为那90%的交易是整个交易成功不可或缺的部分。对于一个趋势跟随策略来说，保存资本让顶级的交易机会真正发挥作用是非常重要的。

最差10%交易亏损/净利润：按盈利水平排在最后10%的交易实现的亏损占净利润的比例，对于一个中长线策略来说，这个亏损值不应该夺去排前10%的交易所获得的核心利润，健全的风险控制是做到这一点的关键。

最大连续盈利次数：盈利有时有集中的现象，策略适应此阶段的走势形态。也许可以考虑在连续盈利接近最大连盈次数时，开始减轻每次交易投入的资金。

最大连续亏损次数：亏损有时有集中的现象，策略不适应此阶段的波动，心理上能否承受如此多次的试错？也许可以考虑在连续亏损最大次数时，逐步增大资金投入。

最大连续盈利额：最大的连续盈利实现的盈利额，不一定是最大连续盈利次数那一系列交易产生的

最大连续亏损额：最大的连续亏损实现的亏损额，不一定是最大连续亏损次数那一系列交易产生的

最大连续盈利率：最大的连续盈利实现的盈利率，不一定是最大连续盈利次数那一系列交易或者最大连续盈利额那一系列交易产生的

最大连续亏损率：最大的连续亏损实现的亏损率，不一定是最大连续亏损次数那一系列交易或者最大连续亏损额那一系列交易产生的

极端交易（统计发生在常态盈利或亏损之外的极端交易的数量和金额，极端交易是指不在常态范围（3倍标准差）内的交易。人类活动的结果往往导致“厚尾分布”而不是正态分布，金融数据表现出尖峰厚尾的特征，具体来说就是极端交易数量偏多，比如，正态分布百年难遇1次的事件现实中十年遇到2次。）

平均盈亏：所有交易（每次平仓算一次交易）的盈亏金额的平均值

盈亏的标准差：所有交易（每次平仓算一次交易）的盈亏金额的标准差

平均盈亏+1倍标准差：平均盈亏+盈亏的标准差

平均盈亏-1倍标准差：平均盈亏-盈亏的标准差

最大偏移/标准差：与其平均值相差最大的盈亏金额/盈亏的标准差

极端交易数量：盈亏金额超过其3倍标准差的交易次数

极端交易盈亏：盈亏金额超过其3倍标准差的交易产生的盈亏金额总和

最大浮动盈亏（浮盈浮亏对持仓心理造成较大冲击，可接受的浮盈浮亏状况对长期坚持很重要）

最大值：所有平仓交易的浮盈/浮亏中的最大值

发生日期：浮盈/浮亏出现最大值的日期

最大值%：所有平仓交易的浮盈/浮亏幅度中的最大值

平均值：所有平仓交易的浮盈/浮亏的平均值

平均值%：所有平仓交易的浮盈/浮亏幅度的平均值

标准差：所有平仓交易的浮盈/浮亏的标准差

平均值+1倍标准差：平均值+标准差

平均值-1倍标准差：平均值-标准差

累计交易盈亏资产曲线

扣减初始资产，用累积平仓盈亏的连线，体现了每次交易的累积平仓收益。横轴为交易序号，绿色点表示创新高

平仓交易余额曲线及回撤

显示平仓交易的资产（余额）、资产回撤金额、资产回撤幅度3条曲线

平仓盈亏散点图

所有交易的平仓盈亏分布。横坐标为交易序号。已经有平均盈亏水平线，再加上平均盈利水平线、平均亏损水平线

有效盈亏率散点图

纵轴为收益率（%），每笔交易盈亏相对于投入资金的收益率

平仓盈利分布图

显示平仓盈利柱形图，叠加正态分布曲线